Click here to buy the full 141-page “Take Control of iWeb: iLife ’08 Edition” for only $10!
# TABLE OF CONTENTS

**READ ME FIRST  4**  
Updates ......................................................................................... 4  
Basics .......................................................................................... 4  
What’s New in Version 1.1 ............................................................ 5  

**INTRODUCTION  7**  
**QUICK START TO MAKING A SITE IN iWEB  8**  
**WHAT’S NEW IN iWEB 2  10**  
**A BRIEF HISTORY OF WEB SITES  11**  

**INSTALL iWEB  15**  
Run the Installer ........................................................................ 15  
Make Sure You Have the Latest Version ....................................... 17  

**CREATE YOUR FIRST SITE  18**  
Create a Domain File ................................................................. 18  
Choose a Template ..................................................................... 20  
Choose a Page Type .................................................................... 25  
Name Your Site ......................................................................... 28  
Name Your Home Page .............................................................. 29  
Edit the Headline ....................................................................... 31  
Change the Picture ..................................................................... 31  
Edit the Heading & Body Text ..................................................... 34  
Add Special Elements ................................................................ 36  
Change the Page Size & Background Color .................................... 37  
Make Your About Me Page .......................................................... 37  

**PUBLISH YOUR SITE  41**  
Decide Where to Publish Your Site ............................................... 41  
Publish to MobileMe ................................................................... 42  
Publish to a Personal Domain on MobileMe ............................... 44  
Publish to Other Servers ............................................................ 47  

**WORK WITH TEXT  50**  
Make Text Sparkle ..................................................................... 50  
Create Web Hyperlinks ............................................................... 57  
Create Other Link Types ............................................................. 60  

**SHAPES, LAYERS & MASKS  63**  
Shapes ...................................................................................... 63  
Layers ....................................................................................... 67  
Masks ....................................................................................... 69
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>PUBLISH A BLOG</td>
<td>72</td>
</tr>
<tr>
<td>PUBLISH A PODCAST</td>
<td>78</td>
</tr>
<tr>
<td>Create a Podcast Section</td>
<td>79</td>
</tr>
<tr>
<td>Add an Episode</td>
<td>82</td>
</tr>
<tr>
<td>Submit a Podcast to the iTunes Store</td>
<td>86</td>
</tr>
<tr>
<td>ADD PHOTOS</td>
<td>89</td>
</tr>
<tr>
<td>Create a Photo Page</td>
<td>89</td>
</tr>
<tr>
<td>Enhanced vs. Regular Slideshows</td>
<td>93</td>
</tr>
<tr>
<td>Set Up a My Albums Page</td>
<td>94</td>
</tr>
<tr>
<td>Export Photos from iPhoto to iWeb</td>
<td>96</td>
</tr>
<tr>
<td>Work with Web Galleries</td>
<td>97</td>
</tr>
<tr>
<td>ENHANCE PHOTOS</td>
<td>98</td>
</tr>
<tr>
<td>The Fine Points of Formatting Photos</td>
<td>98</td>
</tr>
<tr>
<td>Instant Alpha</td>
<td>101</td>
</tr>
<tr>
<td>Accelerate Picture Downloads</td>
<td>102</td>
</tr>
<tr>
<td>Create Picture Hyperlinks</td>
<td>105</td>
</tr>
<tr>
<td>Make an Image Map</td>
<td>106</td>
</tr>
<tr>
<td>CREATE AN ONLINE MOVIE THEATER</td>
<td>107</td>
</tr>
<tr>
<td>Add a Video from iMovie</td>
<td>107</td>
</tr>
<tr>
<td>Add a Video from YouTube</td>
<td>109</td>
</tr>
<tr>
<td>MAKE MONEY, ADD FORMS &amp; MORE</td>
<td>111</td>
</tr>
<tr>
<td>Add Google AdSense Ads</td>
<td>111</td>
</tr>
<tr>
<td>Add Google Maps</td>
<td>114</td>
</tr>
<tr>
<td>Run an Online Store</td>
<td>115</td>
</tr>
<tr>
<td>Add a Form</td>
<td>121</td>
</tr>
<tr>
<td>Increase Traffic</td>
<td>126</td>
</tr>
<tr>
<td>MANAGE MULTIPLE iWEB SITES</td>
<td>127</td>
</tr>
<tr>
<td>LEARN MORE &amp; DO MORE</td>
<td>129</td>
</tr>
<tr>
<td>APPENDIX A: WEB HOSTING</td>
<td>130</td>
</tr>
<tr>
<td>APPENDIX B: ADD A TWITTER FEED</td>
<td>134</td>
</tr>
<tr>
<td>ABOUT THIS BOOK</td>
<td>138</td>
</tr>
<tr>
<td>About the Author</td>
<td>138</td>
</tr>
<tr>
<td>Author’s Acknowledgements</td>
<td>138</td>
</tr>
<tr>
<td>Shameless Plugs</td>
<td>139</td>
</tr>
<tr>
<td>About the Publisher</td>
<td>139</td>
</tr>
<tr>
<td>Production Credits</td>
<td>139</td>
</tr>
</tbody>
</table>
Welcome to Take Control of iWeb: iLife ’08 Edition, version 1.1, published in February 2009 by TidBITS Publishing Inc.

This book puts you in control of creating and publishing professional-looking Web sites using iWeb, Web design software from Apple Inc. This book was written by Steve Sande, edited by Karen Anderson and Tonya Engst, and published by TidBITS Publishing Inc.

Copyright © 2009, Steve Sande. All rights reserved.

If you have the PDF version of this title, please note that if you want to share it with a friend, we ask that you do so as you would a physical book: “lend” it for a quick look, but ask your friend to buy a new copy to read it more carefully or to keep it for reference. You can click here to give your friend a discount coupon. Discounted classroom and Mac user group copies are also available.

Updates
We may offer free minor updates to this book. To read any available new information, click the Check for Updates link on the cover, or click here. On the resulting Web page, you can also sign up to be notified of major updates via email. If you have a version of this book where the Check for Updates link doesn’t work, contact us at tc-comments@tidbits.com to obtain the PDF.

Basics
In reading this book, you may get stuck if you don’t know certain basic facts about iWeb or if you don’t understand Take Control syntax for things like working with menus or finding items in the Finder. Please note the following:

• **Path syntax:** I occasionally use a *path* to show the location of a file or folder in your file system. Path text is formatted in special type. For example, iLife ’08 installs its component applications, such as iWeb, in the Applications folder. The path to iWeb is: /Applications/iWeb.

  The slash at the start of the path tells you to start from the root level of the disk. You will also see paths that begin with ~ (tilde), which is a shortcut for any user’s home directory. For example, if
a person with the user name `andrea` wants to create a new iWeb domain file in a folder called Web Sites in her Documents folder, she would create the domain file in her `~/Documents/Web Sites` folder, which is another way of writing `/Users/andrea/Documents/Web Sites`.

- **Menus:** When I describe choosing a command from a menu in the menu bar, I use an abbreviated description. For example, the abbreviated description for the menu command that saves a file from iWeb is “File > Save.”

- **Toolbar:** I refer to the iWeb toolbar (shown below this paragraph), throughout this book. You can find it at the bottom of the iWeb window, or—if you prefer to use menus or keyboard shortcuts, check out Table 1, next page, which maps the toolbar buttons to menu commands and keyboard shortcuts.

![iWeb Toolbar](image)

### What’s New in Version 1.1

Whether you’re a new reader or have been along for the iWeb ride since the first edition of this book, some recent changes to the world of Apple and the Internet are discussed in detail in this new version:

- **.Mac becomes MobileMe:** As part of the overall effort to support wireless synchronization of calendars, contacts, and other information, Apple has changed the name and features of .Mac. The new online product, designed to be attractive to owners of Windows and Linux PCs as well, is called MobileMe.

  Like .Mac, MobileMe is available for $99 per year. The subscription now provides 20 GB (twice the previous amount) of combined email and file storage and 200 GB of monthly data transfer, meaning that it’s now feasible to host podcasts, video, and large photo libraries on your iWeb site.

- **Add a Twitter feed to your iWeb site:** Twitter is the new social networking phenomenon that you use by writing 140-character (or less) “tweets” about what you’re currently doing. In Appendix B: Add a Twitter Feed (p. 134), you can learn how to add a Twitter feed to your iWeb site showing your most recent tweets.
<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Menu Equivalent</th>
<th>Keyboard Equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>File &gt; New Site</td>
<td>Shift-Command-N</td>
</tr>
<tr>
<td></td>
<td>Insert &gt; Text Box</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Insert &gt; Shape &gt; [list of shapes]</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Insert menu</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Arrange &gt; Bring Forward</td>
<td>Option-Shift-Command-F</td>
</tr>
<tr>
<td></td>
<td>Arrange &gt; Send Backward</td>
<td>Option-Shift-Command-B</td>
</tr>
<tr>
<td></td>
<td>Format &gt; Unmask</td>
<td>Shift-Command-M</td>
</tr>
<tr>
<td></td>
<td>Arrange &gt; Rotate Counter Clockwise</td>
<td>Command-R</td>
</tr>
<tr>
<td></td>
<td>View &gt; Show / Hide Media Browser</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>View &gt; Show / Hide Adjust Image</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>View &gt; Show / Hide Inspector</td>
<td>Option-Command-I</td>
</tr>
<tr>
<td></td>
<td>View &gt; Show / Hide Colors</td>
<td>Shift-Command-C</td>
</tr>
<tr>
<td></td>
<td>Format &gt; Font &gt; Show / Hide Fonts</td>
<td>Command-T</td>
</tr>
</tbody>
</table>

Click here to buy the full 141-page “Take Control of iWeb: iLife ’08 Edition” for only $10!
INTRODUCTION

In January 2006, Apple CEO Steve Jobs announced iWeb, a new Web site design and publishing tool in iLife ’06. I know all too well how difficult it is to make a great-looking Web site and create a blog, because I’ve struggled with the complexities of RSS feeds and searched to find a way to easily publish photo galleries and podcasts. Watching Jobs simply click and drag his way through the creation of a professional-looking Web site in a few minutes during a keynote address was certainly an eye-opener, so I purchased iLife ’06 and began playing with iWeb. The result of my play was the first edition of this book.

Fast-forward to August 2007 and another announcement from Steve Jobs—the release of iLife ’08, including a new version of iWeb. What impresses me most about iWeb 2 is how Apple’s developers improved on the original by adding capabilities that previously required extensive workarounds—see What’s New in iWeb 2 (p. 10) for more details on the new features.

In this book, I take you on a journey of discovery. I briefly explore the past so you can see what a powerful tool iWeb is, and then you can follow me as I build a Web site step by step. You can visit my iWeb site at http://www.tcoiweb.com/, and then read about how I used iWeb to create what you’re viewing.

If you’ve never made a Web site before, you’ll be thrilled with how easily you can organize your thoughts and have iWeb turn them into a beautiful work of art. Experienced Web designers will be happy with how iWeb works with the rest of the iLife suite to create vibrant Web sites full of text, sound, video, and photography.

Let’s get started!
QUICK START TO MAKING A SITE IN iWEB

Although you can read this book sequentially, you may wish to use this page to set a custom path through the topics that I cover. You can click the blue links to jump quickly to a particular section.

Learn what’s new in iWeb 2:
• Find out how the changes in iWeb 2 and the capabilities of MobileMe combine to help you create Web sites that are more compelling and powerful that those you could create in iWeb 1; see What’s New in iWeb 2 (p. 10).

Start your site:
• For historical context, read A Brief History of Web Sites (p. 11). Then, if you haven’t already, Install iWeb (p. 15).

• Start a new site! Learn how to Create Your First Site (p. 18).

• Get the scoop on Editing One Site on Two Macs (p. 40).

• Ready to take your site live? In Publish Your Site (p. 41), you’ll find out how to publish to MobileMe and to other servers. Appendix A: Web Hosting (p. 130) provides more detail about hosting your site on a server that is not MobileMe.

Add links & media:
• Learn about making links in Create Web Hyperlinks (p. 57) and Create Other Link Types (p. 60).

• If image-based links are more your fancy, find more info in Create Picture Hyperlinks (p. 105) and Make an Image Map (p. 106).

• Turn your thoughts into bits with Publish a Blog (p. 72).

• Take your radio or TV show online with Publish a Podcast (p. 78).

• Add Photos to your site, and learn about Photo pages, My Albums pages, and Web galleries (p. 89).

• Use iWeb to Create an Online Movie Theater (p. 107).

Go beyond the limits:
• Learn how to Make Text Sparkle (p. 50) and discover the fabulous effects you can create with Shapes, Layers & Masks (p. 63).
• **Add Special Elements** (p. 36) to count visitors and provide information.

• See **Enhance Photos** (p. 98) to add cool effects—like **Instant Alpha** (p. 101)—to your photos, plus get advice on how to **Accelerate Picture Downloads** (p. 102).

• **Add Google Maps** to give your readers directions with the Google Map Web Widget (p. 114).

• Get an example of adding HTML code to your Web page in **Add a Video from YouTube** (p. 109).

• Get social with your iWeb site. Read **Appendix B: Add a Twitter Feed** (p. 134).

• Looking for extra income? **Add Google AdSense Ads** (p. 111), get ideas for how to **Run an Online Store** (p. 115), and **Increase Traffic** to your site (p. 126).

• **Add a Form** to your site in order to capture information from visitors (p. 121).

• **Manage Multiple iWeb Sites** using separate domain files (p. 127).
WHAT’S NEW IN iWEB 2

Let’s start by looking at what’s new or different in iWeb 2:

• **MobileMe improvements:** Apple has updated the MobileMe service to make it more useful to iWeb users. For instance, you can now Publish to a Personal Domain on MobileMe (p. 44).

  Apple has also increased the amount of disk storage and the monthly bandwidth allowance, so even large and heavily visited Web sites can exist on a MobileMe account. However, the MobileMe terms and conditions still prohibit the use of MobileMe-hosted sites for ecommerce. Note that MobileMe was renamed MobileMe on July 9, 2008 (it was formerly called .Mac).

• **Web widgets:** With a new feature called HTML Snippets, you can add things like news headlines, live webcam feeds, YouTube videos, and stock tickers to your Web site. For examples, see Add a Video from YouTube (p. 109), Add a Form (p. 121), and Appendix B: Add a Twitter Feed (p. 134).

• **Google integration:** Apple and Google have been getting cozy lately, and the integration of Google AdSense and Google Maps into iWeb 2 is a perfect example of the level of cooperation between the two companies:

  ◦ The Google AdSense widget enables you to Add Google AdSense Ads to your Web pages (p. 111).

  ◦ The Google Maps widget provides a way to Add Google Maps to your Web content with one click (p. 114).

• **New templates and theme switching:** Apple has created 8 new themes for iWeb 2, bringing the total to 26. When you Choose a Template for your Web site, consider a new iWeb theme to give your site a makeover (p. 20).

• **Instant Alpha:** A powerful new photo editing tool, Instant Alpha, removes background clutter from photos you use in iWeb sites, giving the images a more professional appearance (p. 101).

• **Improved integration with iPhoto:** Through enhanced Photo pages, Web galleries, and My Album pages, iWeb 2 makes it easier than ever to Add Photos (p. 89) to a Web site.
LIKE MANY LONG-TIME MAC GEEKS, I STARTED USING THE INTERNET PRIOR TO THE INTRODUCTION OF THE WORLD WIDE WEB (IN MY CASE, THANKS TO ADAM ENGST’S INTERNET STARTER KIT FOR MACINTOSH). FOR THE MOST PART, EARLY INTERNET APPLICATIONS PROVIDED A TEXT-BASED WAY TO INTERACT ON THE INTERNET. SOME OF THE EARLY INTERNET APPLICATIONS WERE CONFUSING TO USE (GOPHER, FOR EXAMPLE) AND HAVE DISAPPEARED, BUT OTHER TOOLS, LIKE CLIENTS FOR FTP (FILE TRANSFER PROTOCOL), ARE STILL USED.


THE LANGUAGE OF THE WEB IS HTML (HYPERTEXT MARKUP LANGUAGE). CREATED BY TIM BERNERS-LEE AS PART OF HIS ORIGINAL SPECIFICATION FOR THE WORLD WIDE WEB, HTML IS A SET OF TEXT INSTRUCTIONS DESIGNED TO TELL A WEB BROWSER, LIKE SAFARI OR FIREFOX, WHERE TO PLACE TEXT, PICTURES, LINKS, AND OTHER FEATURES ON A WEB PAGE. (FIND OUT MORE ABOUT TIM BERNERS-LEE AT HTTP://EN.WIKIPEDIA.ORG/WIKI/TIM_BERNERS-LEE.)

I WAS SO EXCITED BY THE INVENTION OF THE WORLD WIDE WEB AND HTML, THAT I ALMOST IMMEDIATELY DOWNLOADED THE ORIGINAL NCSA MOSAIC WEB BROWSER, VISITED THE FEW SITES THAT WERE AVAILABLE, AND MADE MY OWN WEB SITE. WHAT TOOL DID I USE TO SET UP MY ORIGINAL SITE? SIMPLETEXT. THAT’S RIGHT—THE SAME TOOL WE STILL USE TO READ THOSE UBQUITOUS READ ME FILES THAT SEEM TO COME WITH EVERY NEW PIECE OF SOFTWARE, ALTHOUGH IT’S NOW CALLED TEXTEDIT.

SIMPLETEXT WAS A GOOD TOOL FOR DEVELOPING WEB SITES IN THOSE DAYS. MOST SITES CONSISTED OF A LOT OF TEXT, HYPERLINKS TO OTHER SITES, AND HAD ONLY A FEW GRAPHICS SINCE MOST OF US WERE USING SLOW, DIAL-UP MODEMS TO ACCESS THE INTERNET. WE WOULD TYPE THE HTML INTO A TEXT DOCUMENT AND THEN VIEW THE MORE GRAPHICAL RESULT IN A WEB BROWSER.
**Install iWeb**

To install iLife ’08, your Macintosh must meet or exceed the following minimum requirements:

- A Mac with a Power PC G4, PowerPC G5, or Intel processor, and at least 512 MB of memory (1 GB or higher is recommended). iWeb is a *Universal* application (so it runs on Power PC- and Intel-based Macs), and it operates much faster on the Intel-based machines.

- DVD drive (SuperDrive or Combo Drive).

- At least 3 GB of available disk space if you want to install all of the iLife ’08 software.

- Mac OS X Tiger 10.4.9 or later, including Mac OS X Leopard 10.5.

- QuickTime 7.2 or later. iLife ’08 installs this on your Macintosh if it’s not currently installed.

If your Mac does meet the requirements, grab your iLife ’08 disc and follow the directions in this section to install the software, make sure you have the latest version, and launch the software.

**Run the Installer**

Before you install iWeb (or any software), I recommend that you quit any applications that are already running. Also, I suggest that you temporarily disable antivirus software like McAfee, Norton Antivirus, or ClamXav to avoid possible conflicts with the installer. Remember to practice safe computing and turn your antivirus protection back on once the installation is completed.

If you’ve installed other Mac software, you already know how to install iLife ’08: Open the box, remove the installation DVD, and place it in the Combo Drive or SuperDrive in your Macintosh. Soon the drive begins to whir and the DVD contents appear on the screen ([Figure 2](#)). Double-click the iLife ’08 icon to launch the installer.
CREATE YOUR FIRST SITE

In this section, I walk you through the basic steps for doing Web publishing in iWeb. You can follow along as I create a site, which I’ve put on the Web—at http://www.tcoiweb.com/—so you can see it in action. You may wish to create a similar sample site, so you can get some practice. Alternately, you can skim this section to quickly find information about a particular topic.

Create a Domain File
What’s a domain? Generally, a domain name identifies a computer or computers on the Internet. For instance tidbits.com is the domain name used for the Mac news site TidBITS. However, the relationship between iWeb Domains and Internet domains is tenuous, and it’s probably best not to try to think of them as being analogous.

An iWeb Domain file contains the materials that make up an iWeb site—the HTML code, Cascading Style Sheets, images, sound files, and movies.

TIP MORE ABOUT DOMAIN FILES
You can find out how to work with one Domain file on multiple Macs in the sidebar Editing One Site on Two Macs, at the end of this section. And, if you want to make more than one Web site in iWeb and thus to have multiple Domain files, see Manage Multiple iWeb Sites (near the end of the book).

When you first launch iWeb, it may automatically create a new Domain file or it may ask you to locate one or create a new one. Let’s look at each of those scenarios:

- First launch ever: When you first launch iWeb on your Mac, iWeb creates a new Domain file for you and it greets you with a Welcome to iWeb ’08 dialog (Figure 4). Click the OK button, and you’ll be asked to Choose a Template.
PUBLISH YOUR SITE

In this section, I help you figure out where to publish your site (MobileMe or somewhere else) and give you the necessary steps.

Decide Where to Publish Your Site

A Web site is nothing if the rest of the world can’t see it. To publish your site so others can view it, you must copy its files to a Web server, a computer running Web-serving software that knows how to communicate with Web browsers. Usually, a Web server has an always-on connection to the Internet and—ideally—it is situated in a place where power outages, drive failures, and other problems are unlikely to occur. A service that provides you with space on a Web server, and takes care of all the maintenance and technical details of running a Web server is called a Web host.

From the perspective of an iWeb user, you have three main choices for your Web host, which I present here in what I consider the most likely option to the least likely:

• **Use MobileMe:** Apple has made Web publishing easy by integrating iWeb with MobileMe. A site published to MobileMe can be open for the world to see, or it can be password protected for privacy. The URL to your Web site can either begin with www.mac.com, or you can host a personal domain (a registered domain name that you control) on MobileMe. One downside of publishing to MobileMe is that Apple doesn’t allow commercial activity on Web sites hosted there (see the Warning in Run an Online Store to read the rules about commercial activity).

Available for $99.95 per year, MobileMe provides 10 GB of disk storage, an email address, and many other features. To join, visit your local Apple Store or see http://www.me.com/. (Joe Kissell’s *Take Control of MobileMe* is a valuable source of information on how to make the most of MobileMe.)

**NOTE** Amazon often sells MobileMe packages at a substantial discount.

• **Use a third-party Web host:** Many iWeb users already have Web hosting as part of the service from their Internet Service Provider (ISP), and some may own or share a Web server. You
WORK WITH TEXT

Even if you include fancy graphics or podcasts on your Web site, the text is the heart of your site and is worthy of your attention. In this section, I cover a grab bag of techniques that all relate to working with text: improving its look, avoiding issues with high-ASCII characters, and creating hyperlinks.

Make Text Sparkle

iWeb’s professionally developed templates are nice, but you may want to customize the look of your text, perhaps in order to make your page stand out more. Although I don’t want to overdo it, I’d like to add pizzazz to my example pages by modifying text colors and styles, and applying effects such as opacity and rotation.

Fonts

If you have a special headline that needs to stand out, consider using a different font. Yes, I know I told you earlier not to use too many different fonts, and that basic rule still applies. However, judicious use of a special font can definitely change the way your Web page looks. As an example, I decided to change the title text “About this site” to make it look friendlier and stand out a bit. I selected the text by double-clicking it, and then clicked the Fonts button on the toolbar. Playing with the Font panel for a while, I found a font (Bernard MT Condensed) that gave me the look I wanted.

Size

Size matters when it comes to text on Web pages. Headlines and titles should be larger than body text. To change text size without using the Font panel, select the text and press Command-Minus to make the text smaller or Command-Plus to make the text larger. There’s also a slider in the Font panel you can use to resize text on the fly.

Color

Adding color is an easy and usually unobtrusive way to customize the text on your Web site. I recommend using a consistent color theme throughout your site—choose colors that go well together.

Click here to buy the full 141-page “Take Control of iWeb: iLife ’08 Edition” for only $10!
In this section, I talk about three powerful iWeb features—Shapes, Layers, and Masks. I touched on the topic of layers with respect to text objects in *Work with Text*, but there’s more to the story.

**Shapes**

In iWeb, *shapes* are exactly what the name implies, pre-drawn shapes that you use to add excitement to your Web site. These include lines, arrows, circles, stars, rectangles, polygons, and even a comic speech balloon. Shapes can behave in three different ways on your page:

- **Inline**: If you insert a shape just after clicking in a text block, when a text cursor is flashing, the shape goes in the text as an inline graphic, meaning it behaves just like a regular character.

- **Wrapped**: You can change an inline graphic so that text in its paragraph wraps around it.

- **Fixed-object**: You can drag the object around freely on the page and place it where you like. Text does not wrap around it. (See *Fixed-object shapes*, ahead two pages.)

**Inline & wrapped shapes**

Follow along with me as I add an inline shape: First, I set the insertion point by clicking in the text where I want the shape to go. Next, I choose a circle from the Shapes pop-up menu on the toolbar. A circle surrounded by handles appears (Figure 36).

![Figure 36](image)

Inserting this shape changed the spacing between two paragraphs of my text and, frankly, I don’t like the way it looks. That can be fixed with word wrapping.

I don’t like the way the shape looks, since it’s creating too much space above my paragraph. So, I keep the shape selected, open the Inspector, click the Text button, and click the Wrap button. I check
**Publish a Blog**

_Blog_ is a contraction of _Web log_, describing a Web site on which a writer, or group of writers, posts items on a regular basis focusing on a specific subject. The items typically include text, images, and links to other Web sites or Internet resources. Blogs display content in reverse chronological order, with the latest entries at the top.

Although we didn’t call them blogs in the early days, blogs have been on the Web all along. Blogging took off in 2001 with the emergence of Blogger and other free Web-based blogging services that made it easy to add new blog entries and keep old entries organized. Blogging has become a popular means of communication and has been adopted by the mainstream media, although it is primarily known as an alternative media capable of affecting worldwide opinion.

iWeb’s Blog page type provides most of the elements of a classic blog:

- An overview page, with excerpts of the most recent posts listed in reverse chronological order
- Detailed blog entries on their own pages
- An archive of past entries that your readers can visit
- Comments with attachments (when the Web site is published to MobileMe)
- A tool for searching iWeb blogs (MobileMe only)

In this section, I show you how to be an iWeb blogger. I’m a bloggy kind of guy, so I want to add a blog to the example Web site:

1. **Add the Blog pages:** Choose File > New Page (Command-N) or click the + button below the Sidebar. Select the Blog page type for the template you’re using, and then click Choose.

   A _Blog_ item appears in the Sidebar, heading a category that includes _Entries_ and _Archive_. The _Entries_ item opens in the Webpage canvas area (Figure 47), in case you want to make a new entry right away.
What’s the fastest-growing new media on the planet? Podcasts. *Podcasts*, online radio shows, are consumed whenever, wherever, and however the listener desires. A typical podcast has three features:

• It has a number of episodes, all dealing with a particular subject.

• Listeners can subscribe to a podcast using *podcatcher* software like iTunes or Juice. By subscribing to a podcast, listeners will receive the latest episode automatically.

• Listeners can enjoy a podcast on a mobile device, such as an iPod, iPhone or other MP3 player.

Hundreds of thousands of podcasts are available today on almost any conceivable topic from “A Bluegrass and Old Time Radio Show” to “Zolfo Springs, Florida Weather.”

Podcasts can go beyond the audio to include video, at which point, we call them *video podcasts*, or *vodcasts*. Video podcasts won’t necessarily appeal to people who like to listen while they do something else, but they do have advantages:

• It’s easier to demonstrate devices or processes when you can show your audience what you’re talking about instead of describing it.

• The combination of sight and sound is much more engaging than audio alone. Would you rather see bright blue water, sparkling sand, and swaying palm trees in a travel podcast, or only hear the podcaster describing them?

As an owner of iLife ’08, you have three powerful integrated tools at your disposal for recording, editing, and publishing podcasts—GarageBand, iMovie 7, and iWeb 2. GarageBand has special podcast tools, including automatic *ducking* (turning down the volume of music when narration begins) and adding iTunes enhancements (such as chapters). iMovie 7 is the video podcast equivalent of GarageBand, and it can transfer your video masterpiece into a Web-friendly, low-bandwidth version that plays nicely in a Web browser or on an iPod.
ADD PHOTOS

Digital photos are great! It’s so easy to take pictures with your digital camera and transfer them to your Mac, then retouch and categorize them in iPhoto. With iWeb, it’s straightforward to add a gallery to your Web site so visitors can read about a vacation trip and then view pictures from the trip in an animated slideshow.

Of course, you can insert a single photograph anywhere in your site, but iWeb also provides a few special options:

- **Photo pages:** These pages are set up to display as many as 300 photos on a page. If you publish to MobileMe, they also offer a nice slideshow option.

- **My Album pages:** New in iWeb 2, these Web pages organize multiple iPhoto albums on a single page. Once you Set Up a My Albums Page, viewers of the page can click an iPhoto album’s thumbnail-style cover image to open a Photo page showing its contents.

- **Web galleries:** New in iLife ’08, you can Work with Web Galleries in iPhoto and publish them to your MobileMe account. Web galleries have a number of nice features for fun and easy viewing of photos, and you can put an animated, clickable, thumbnail-style image leading to a gallery on any page in iWeb.

Tip: More Info on Photos Ahead
For advice on making your photos faster to download for people viewing your site, enhancing their appearance using tools in iWeb, or for details on making them into clickable links, see the next section, Enhance Photos.

Create a Photo Page
iWeb has a special, attractive page type—the Photo page—specifically for publishing your pictures on your Web site. iWeb even provides a slideshow feature to show your pictures in sequential order.
**ENHANCE PHOTOS**

iWeb 2 gives you the power to do more with your online photos. In this section, I describe how to create interesting effects, frames, and shadows, and even how to use my favorite new iWeb 2 tool—Instant Alpha, which eliminates cluttered backgrounds in photos. I also cover editing photos so that they load faster (see Accelerate Picture Downloads), how to turn almost any picture into a clickable hyperlink (see Create Picture Hyperlinks), and how to Make an Image Map.

**The Fine Points of Formatting Photos**

Here are my favorite tips for formatting photos in iWeb:

- **Removing, adding, or changing reflections**: Some iWeb templates automatically place a reflection under large pictures on certain pages. You can add, remove, or change reflections on almost any picture through the Graphic Inspector: select the picture, open the Graphic Inspector, and configure the “Reflection” checkbox and slider. Reflections cannot be added to photos that represent iPhoto Web galleries.

  Reflections aren’t always appropriate. I like them under large single photos on a page, but they seem distracting and unnecessary on pages with a lot of text or multiple photos. I tried reflections under the photos on the Examples page of my Web site and didn’t like them (Figure 62).

  ![Figure 62](image)

  Photos on a Web page without (left) and with (right) a reflection. Should you use a reflection? You make the call. In this case, I found the reflection distracting, so I removed it.

- **Adding, removing, or changing shadows**: You can make photos appear to float over a Web page by adding a shadow. I find shadows less distracting than reflections, and they can add depth
CREATE AN ONLINE MOVIE THEATER

Digital video is becoming much easier to produce, thanks to better camcorders and software like iMovie 7. You can share your digital videos with your Web site visitors by converting the videos to a Web-friendly, low-bandwidth format, then exporting them to iWeb. The process is extremely easy, once you’ve created the digital video. You can also embed a YouTube video right on your Web page; iWeb’s new HTML Snippet command makes it easy.

Add a Video from iMovie

Once you’ve shared a movie from iMovie to Apple’s Media Browser, you can easily import it into other applications that use the Media Browser, including iWeb.

Here’s how to put your movie in the Media Browser and include it on an iWeb page:

1. With your edited movie selected in iMovie 7, choose Share > Media Browser.

   A dialog appears, asking you to select the format(s) for exporting your movies (Figure 67).

   ![Figure 67](image)

   Sharing to the Media Browser makes your movie available to any application that uses the Media Browser. In this example, I chose to export to a file viewable on iPhones and computers, as well as compatible with MobileMe and YouTube.
A Web site can be a drain on your wallet, especially if it grows so popular that you’re charged for bandwidth and space usage overages. Wouldn’t it be nice if you could at least recoup part of the cost of running your Web site? Perhaps you have a great new product or service that you want to sell online. With iWeb and a little ingenuity, you can start selling your goods to the world.

Perhaps you’d like to add a form to your site, either to gather names or to conduct a survey. Or, maybe you’d like to add a map? I cover these options and more in this section.

**Add Google AdSense Ads**

In the previous edition of this book I described how you could join an affiliate program (Amazon Associates) that lets you put ads on your Web pages. There was only one problem with this; you couldn’t use the affiliate links if you were using MobileMe (.Mac). Since that time, Apple has become a close partner with Google and added the capability to place Google AdSense ads on any Web site you create with iWeb, including those hosted on MobileMe. What’s even better is how easy it is to insert AdSense advertisements on your Web pages.

To begin choose File > Set Up Google AdSense. Now enter your email address to create a new account (Figure 69), and click Submit to begin the process. (Of course, if you already are a member, click the I Already Have an Account button.)
MANAGE MULTIPLE iWEB SITES

Once you’re familiar with iWeb, you may want to have multiple sites. For example, perhaps you want to have your own site and a Web site for a school or church group, or for different clients. You can create multiple Web sites in iWeb and publish them to your MobileMe account all at once, but if you’re not using MobileMe or wish to have the second site on another Web server, you need to create separate Domain files, a feature that Apple added in iWeb 1.1.

If you currently have all your Web sites in a single Domain file and want to split them out to separate Domain files, follow these steps:

1. In the Finder, create a separate folder for each of your Web sites.

   For example, I created a folder in my Documents folder and named it Websites, and then made six new folders within it (Figure 78).

   ![Figure 78](image)
   
   Finally, I can store my Web sites in my Documents folder, which is where I think they should be.

Click here to buy the full 141-page “Take Control of iWeb: iLife ’08 Edition” for only $10!
LEARN MORE & DO MORE

Continue your journey with iWeb by learning more about MobileMe, podcasting, and Web design. The publications, Web sites, and products listed here are some of my favorites.

Take Control ebooks:

• *Take Control of MobileMe* by Joe Kissell (TidBITS Publishing, $10)
• *Take Control of Podcasting on the Mac*, by Andy Affleck (TidBITS Publishing, $10)
• *Take Control of Your Domain Names*, by Glenn Fleishman (TidBITS Publishing, $10)

Books:

• *The Non-Designers Web Book*, by Robin Williams & John Tollett, (Peachpit Press, $34.99)
• *Web Design Garage*, by Marc Campbell (Prentice Hall, $34.99)

Web sites:

• Apple’s iWeb Forum
  http://discussions.apple.com/forum.jspa?forumID=1193
• Vincent Flanders’s *Web Pages That Suck*
  http://www.webpagesthatsuck.com/

Click here to buy the full 141-page “Take Control of iWeb: iLife ’08 Edition” for only $10!
APPENDIX A: WEB HOSTING

The topic of hosting an iWeb site on a server that isn’t run by MobileMe could rightfully fill another book. However, it wouldn’t be fair to you to talk about setting up your own Web site without at least touching on the subject, so this appendix gives an overview of how to host your site someplace other than MobileMe.

To host your Web site elsewhere than MobileMe, follow these steps:

1. Decide at what Web location your site will be reachable. Web-hosting companies typically offer you one or more of the following choices for the start of a URL:

   - **A special path at the hosting company from a domain they control:** This is common because it requires the least effort by the hosting company. The pattern is usually `http://www.example.com/username/` or `http://www.example.com/~username/`.

   - **A subdomain at the hosting company:** A subdomain prepends a name to the front of a domain name; for instance, I host Web sites on my Podbus.com hosting service with URLs like `http://mytestsite.podbus.com/`.

     If you go with either of the above two options, skip to Step 5.

   - **Your own domain:** Many hosting companies are happy to create a virtual Web server for you at a domain name you choose and register through them or a third party. A virtual Web server resides on the same computer as dozens or even tens of thousands of other Web sites, but only responds when its name is “called” by a browser. For example, my Podbus.com servers host a Web site whose URL is `http://stmatthew-elca.org/`. This type of hosting is usually slightly more expensive than using a path or a subdomain.

     **Allow for transfer time!** If you already own a domain you want to use, but you don’t want to work with the existing firms that handle your domain and Web hosting, allow a few days to transfer your files or registration to new hosts.
APPENDIX B: ADD A TWITTER FEED

Do you tweet? No, I’m not asking if you think you’re a bird, but if you are a member of Twitter.

Twitter (http://www.twitter.com/) is a social networking service based on the idea of answering the question “What are you doing?” with frequent 140-or-less character posts to the world at large and your followers in particular. It has become wildly popular, with many Web sites, news organizations, celebrities, and even the Take Control series (http://www.twitter.com/takecontrol/) having Twitter accounts that you can follow.

If your friends or Web site visitors don’t have Twitter accounts, they can still follow your daily antics if you add a Twitter feed to your iWeb site. What’s a Twitter feed? It’s a listing of your most recent tweets in reverse chronological order—kind of a mini-blog. Figure 79 shows a Twitter feed on an iWeb page.

The Twitter feed JavaScript adds your latest tweets in reverse chronological order, along with when they were posted. A small addition to the script posts a message if Twitter is slow in responding, so your readers know that the tweets are loading, albeit slowly.

To add the Twitter feed, use the HTML Snippet Web Widget to add to your iWeb page a script written in JavaScript—a programming language popular with Web developers—by developer Remy Sharp (http://remysharp.com/) and made available under an MIT License.
ABOUT THIS BOOK

Thank you for purchasing this Take Control book. We hope you find it both useful and enjoyable to read. We welcome your comments at tc-comments@tidbits.com. Keep reading in this section to learn more about the author, the Take Control series, and the publisher.

About the Author

Steve Sande embraces change. After gathering his Bachelor of Science in Civil Engineering and MBA from the University of Colorado, he worked as an engineer until falling in love with the Mac in late 1984. He started a new life as an IT manager and unofficial Mac evangelist, at one point managing a team supporting over 1,200 Macs.

In late 2004, Steve embarked on a new career as a certified Mac consultant. When he’s not haunting the local Apple Stores, working with clients, or writing ebooks, he loves to cook, go geocaching, sing, ride his recumbent bicycle, collect and create art, and attend classical music concerts (despite the picture, Steve doesn’t like most country music). He’s also an instructor for ASPE Technology facilitating Business Analysis classes (http://www.aspetech.com/). Since the spring of 2008, he’s been blogging professionally on The Unofficial Apple Weblog (http://tuaw.com/). You can follow Steve on Twitter (http://www.twitter.com/stevensande/).

Steve lives in Highlands Ranch, Colorado, with Barb—his wife of 29 years, who really is a rocket scientist—and his tortoiseshell cat, Ruby.

Author’s Acknowledgements

I’d like to thank several people for their support during the creation of this book:

• Barb Sande, my wonderful wife, for putting up with me typing away on my computer at all hours of the day.

• Tonya Engst, for being such an unbelievably patient, hard working, and understanding editor-in-chief.

Click here to buy the full 141-page “Take Control of iWeb: iLife ’08 Edition” for only $10!
• **Karen Anderson**, for taking on the daunting task of editing this book and being patient with a person who is notoriously slow at creating updates.

• **Remy Sharp**, for his wonderful Twitter feed JavaScript.

• **Tom Gewecke**, for his outstanding work in the iWeb Forum on the Apple Support Web site and assistance with previous versions of this book.

### Shameless Plugs

If you’re a Mac user who lives nowhere near an Apple Store, and you need some help or training, my Mac consulting firm, [Raven Solutions, LLC](http://www.ravensolutions.com), offers remote online support services. When I’m not available, one of my team of Apple certified consultants can help out.

I also run a Web and podcast hosting company called [Podbus.com](http://www.podbus.com). Our rates are low, our service is great, and we offer a money-back satisfaction guarantee ([http://www.podbus.com/](http://www.podbus.com/)).

### About the Publisher

Publishers Adam and Tonya Engst have been creating Mac-related content since they started the online newsletter *TidBITS*, in 1990. In *TidBITS*, you can find the latest Macintosh news, plus read reviews, opinions, and more ([http://www.tidbits.com/](http://www.tidbits.com/)).

Adam and Tonya are known in the Mac world as writers, editors, and speakers. They are also parents to Tristan, who thinks ebooks about clipper ships and castles would be cool.

### Production Credits

Link-making AppleScript: Matt Neuburg  
List macros: Sharon Zardetto  
Take Control logo: Jeff Tolbert  
Editor: Karen Anderson  
Editor in Chief: Tonya Engst  
Publisher: Adam Engst  
Twitter feed test assistant: Amelia Sauter

Click here to buy the full 141-page “Take Control of iWeb: iLife ’08 Edition” for only $10!
TAKE CONTROL books help readers regain a measure of control in an oftentimes out-of-control universe. Take Control books also streamline the publication process so that information about quickly changing technical topics can be published while it’s still relevant and accurate.

The electronic version of this book does not use copy protection because copy protection makes life harder for everyone. So we ask a favor of our readers. If you want to share your copy of this ebook with a friend, please do so as you would a physical book, meaning that if your friend uses it regularly, he or she should buy a copy. Your support makes it possible for future Take Control ebooks to hit the Internet long before you’d find the same info in a printed book. Plus, if you buy the ebook, you’re entitled to any free updates that become available.

Although the author and TidBITS Publishing Inc. have made a reasonable effort to ensure the accuracy of the information herein, they assume no responsibility for errors or omissions. The information in this book is distributed “As Is,” without warranty of any kind. Neither TidBITS Publishing Inc. nor the author shall be liable to any person or entity for any special, indirect, incidental, or consequential damages, including without limitation lost revenues or lost profits, that may result (or that are alleged to result) from the use of these materials. In other words, use this information at your own risk.

Many of the designations used to distinguish products and services are claimed as trademarks or service marks. Any trademarks, service marks, product names, or named features that appear in this title are assumed to be the property of their respective owners. All product names and services are used in an editorial fashion only, with no intention of infringement of the trademark. No such use, or the use of any trade name, is meant to convey endorsement or other affiliation with this title.

This title is an independent publication, and it has not been authorized, sponsored, or in any way otherwise approved by Apple Inc. Because of the nature of this title, it uses terms that are trademarks or registered trademarks of Apple Inc.; to view a complete list of the trademarks and of the registered trademarks of Apple Inc., visit http://www.apple.com/legal/trademark/appletmplist.html.
Now that you’ve seen this ebook, you know the Take Control ebooks have a great onscreen layout, clickable links, and real-world info that puts you in control. Click any book image below or visit our Web store to add to your ebook collection!

**Take Control of MobileMe**
by Joe Kissell

Apple’s MobileMe service provides oodles of features, but are you making the most of your membership?

$10

**Take Control of Your iPhone**
by Ted Landau

Avoid trouble, solve problems, discover hidden tricks, and use your iPhone like a pro.

$15

**Macworld Total Leopard Superguide**
by Breen, Dalrymple, Engst, et al.

Become more productive in Leopard with detailed advice in this savvy compendium from the experts at Macworld!

$12.95

**Take Control of Customizing Leopard**
by Matt Neuburg

Find real-world advice in this road map to customizing Leopard, including new features, such as Time Machine, Stacks, and Spaces.

$10

**Take Control of Buying a Mac**
by Adam Engst

Save money, avoid stress, and buy exactly the right Macintosh for you with this must-read guide from Mac guru Adam Engst!

$10

---

**More Titles!**

Delve into even more topics, including:

- Running your Mac—upgrading the OS, backups and maintenance, permissions, fonts, accounts, and sharing files.
- Buying a new Mac.
- More topics—AirPort and Wi-Fi security, iPhone, troubleshooting, spam, email, Windows on a Mac, switching to a Mac, and more.

Click here to buy the full 141-page “Take Control of iWeb: iLife ’08 Edition” for only $10!