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Read Me First
Welcome to Take Control of Using Mountain Lion, version 1.2,
published in April 2013 by TidBITS Publishing Inc. This book was
written by Matt Neuburg and edited by Tonya Engst.
This book gives you a hands-on guided tour OS X 10.8 Mountain
Lion, focusing on new features while reminding you of important
older options, and describing the adjustments, tweaks, and
customizations you can and should make in the System, the Finder,
and more.
Please note that if you want to share this ebook with a friend, we
ask that you do so as you would a physical book: “lend” it for a quick
look, but ask your friend to buy a new copy to read it more carefully
or to keep it for reference. Discounted classroom and Mac user
group copies are also available.
Copyright © 2013, Matt Neuburg. All rights reserved.

Updates and More
You can access extras related to this book on the Web (use the link
in Ebook Extras, near the end; it’s available only to purchasers). On
the ebook’s Take Control Extras page, you can:
• Download any available new version of the ebook for free, or buy
any subsequent edition at a discount.
• Download various formats, including PDF, EPUB, and—usually—
Mobipocket. (Learn about reading this ebook on handheld devices
at http://www.takecontrolbooks.com/device-advice.)
• Read postings to the ebook’s blog. These may include new tips or
information, as well as links to author interviews. At the top of the
blog, you can also see any update plans for the ebook.
If you bought this ebook from the Take Control Web site, it has been
added to your account, where you can download it in other formats
and access any future updates. However, if you bought this ebook
elsewhere, you can add it to your account manually; see Ebook Extras.
5
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Basics
In reading this book, you may get stuck if you don’t understand a
few basic aspects of using the Mac, or you don’t understand the way
I describe things like working with menus, preferences, and windows,
or finding items in the Finder or using keyboard shortcuts.

Menus
When I describe choosing a command from a menu in the menu
bar at the top of your Mac’s screen, I use an abbreviated description.
For example, my description for the menu command that creates a
new default window in the Finder is “File > New Finder Window.”
Contextual Menus
In the old days, I would have said that a contextual menu appears
after you hold down the Control key while clicking something that
has a contextual menu, such as an icon in the Finder. Now, however,
there are many ways to open a contextual menu. You can Controlclick, but if your mouse can right click, or if you use a trackpad or
other means of opening a contextual menu, you should feel free to
use the method you prefer—read Trick Out Your Mouse or Trackpad.

Keyboard Shortcuts and Modifier Keys
I talk quite a lot in this book about using keyboard shortcuts to tell
Mountain Lion what to do. A keyboard shortcut is a combination of
keys that you press in place of using the mouse or trackpad to run a
command. For example, to close a Finder window, you could click the
red Close
button at its upper left; or, you could choose File > Close
Window. But notice on the File menu, to the right of “Close Window”,
that the text reads ⌘W. The menu is telling you that you can also close
the window by pressing the ⌘ key on your keyboard (adjacent to the
Space bar) and the W key at the same time. Your Mac is full of
shortcuts like this, some noted on the menus, and some listed in
System Preferences.
Modifier keys are used in keyboard shortcuts (otherwise your Mac
would think you were typing regular text). These are keys such as
⌘ (Command), Option, Control, and Shift. Refer to Modify Your
Modifiers to see the symbols and names for common modifier keys.
6
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Note: The term trigger sometimes comes up in this context, too. A
trigger is anything that invokes a command. It could be a keyboard
shortcut, but it could also be a gesture on a trackpad or Magic Mouse.
It could even be a modifier key with a gesture!

Preferences
When I say “preference pane,” especially when I speak of “the so-andso preference pane,” I’m referring to a pane in the System Preferences
application. To start System Preferences, choose System Preferences
from the Apple menu (or click its icon in the Dock, if it’s there).
You access a particular preference pane by way of its icon, or the View
menu. For example, to see “the Displays preference pane,” you would
launch System Preferences and then click the Displays icon or choose
View > Displays. (To see the icons if they aren’t visible, choose View >
Show All Preferences.)
On the other hand, talk of preferences for a particular application
has to do with the window you see when you choose AppName >
Preferences (where AppName is the name of the application). So, for
example, when I say, “set the Finder preferences not to show All My
Files in the sidebar,” I’m telling you to bring the Finder to the front,
and then choose Finder > Preferences and do something in the window
that appears.
Note: You can learn more about System Preferences in Straighten
Out Your System Preferences.

Panes and Views
What’s in a window can change depending on what button you press.
So there needs to be terminology describing the changeable portion of
a window. I call the highest region of changeability in a window (often
the entire content of the window) a “pane”; smaller areas within a pane
that can change, I call a “view.”
For example, as I just mentioned, when you start System Preferences,
you can then choose from the View menu to see a particular preference
pane, such as Displays or Energy Saver. Those, then, are panes.
Similarly, in the Finder preferences window, you can click a toolbar
item, such as General or Labels, to change the entire content of the
window; so I’ll speak of “the General pane” or “the Labels pane.”
7
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Smaller regions whose content changes when you click a button—the
sort of area that often used to be called “tabs”—are what I call “views”
in this book. So, for example, to see “the Color view of the Displays
preference pane,” you would launch System Preferences and then
switch to the Displays pane, and then click Color to see the Color view
within the Displays pane.

Paths and the Invisible Library
I occasionally use a path to specify the location of a file or folder
in your file system. Path text is formatted in a colorful font. For
example, Mountain Lion stores most utilities, such as Terminal
and Disk Utility, in the Utilities folder; the path to Terminal is /
Applications/Utilities/Terminal.
The slash at the start of the path tells you to start from the root (top)
level of the disk. You will also encounter paths that begin with ~ (tilde),
which is a shortcut for any user’s home folder. For example, if someone
with the username joe wants to install fonts that only he can access, he
would install them in his ~/Library/Fonts folder, which is just another
way of writing /Users/joe/Library/Fonts.
Tip: The Library folder mentioned in the previous paragraph, found
at ~/Library, is normally invisible in Mountain Lion. To see it, hold
down the Option key and choose Go > Library in the Finder. For
instructions on how to make this folder permanently visible, read
Adam Engst’s TidBITS article at http://tidbits.com/article/12306. The
advice in the article’s subsection “Accessing the Library Folder in Lion”
works equally well in Mountain Lion.

Aliases
An alias is the Mac OS X way to point to a file or folder that lives
somewhere else. It’s almost as if the item were in two places at once.
For example, if the book you’re writing lives at ~/Documents/Important/
MyBook.pages, you could put an alias to that file on the desktop, at ~/
Desktop/MyBook.pages. That way, the desktop alias reminds you to work
on your book, and when you open the alias from the desktop, what
opens is the real file inside ~/Documents/Important/.

8
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To make an alias, select the original file or folder and choose File >
Make Alias. If you move or rename the real file or folder, any aliases
pointing to it continue to work correctly. If you move or rename an
alias, it continues to work correctly. If you delete an alias, the real file
is unaffected.

What’s New in This Edition
Take Control of Using Mountain Lion is the sixth edition of an ebook
I originally wrote in 2003, then called Take Control of Customizing
Panther. Fast-forward to 2012, and although Take Control of Using
Mountain Lion still covers customization, it also looks more fully at
understanding and using this newest iteration of Mac OS X.
If you’ve been reading this ebook through its previous incarnations,
or feel that you already know a great deal about previous Big Cat
versions of Mac OS X, take note of the important Know What’s New
chapter, a few pages ahead; it summarizes new goodies, methods of
working, and other changes in 10.8 Mountain Lion, and helps you
locate the related new info in this book.
You might be familiar with Lion, in which case Mountain Lion will
appear to you as a readily usable minor update, or you might be a
Leopard or Snow Leopard user making the big jump past Lion to
Mountain Lion, which means you need to know what’s new in both
Lion and Mountain Lion. For this reason, I’ve structured this ebook
similarly to the previous edition, Take Control of Using Lion, and
I’ve called out features that are new either in Lion or in Mountain Lion.
Note: You won’t get the full Mountain Lion experience unless you use
finger gestures with a trackpad or a similar modern mousing device.
Although this ebook will work nicely for you no matter what your
input device, I wholeheartedly describe finger gestures for trackpads
(and Apple’s Magic Mouse) throughout.

Like previous editions of this ebook, this one is sold with a companion
ebook with the word Upgrading in its title, intended to be read before
this one. You certainly don’t need Take Control of Upgrading to
Mountain Lion to use this book, and if you’ve already been using
Mountain Lion for a while you likely don’t need it at all. However,
many people do buy these two books together.
9
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What’s New in Version 1.2
Several changes near the beginning of the Start Saving chapter
have corrected information (because the existing explanation was
incomplete) or expanded advice (because Apple made an important
change in Mountain Lion 10.8.2). In particular, read the sidebar Is
Quitting the Same as Closing? and the emphasized text “What happens
to the original document?”.
Other modifications that might interest you are these:
• Directions for another way to toggle whether notification alerts and
banners appear: Option-click the Notification Center
icon at
the far right of the menu bar. (See Set Up Notifications, just above
the figure.)
• Adjustments in the last few paragraphs of Get Ready for Resume,
including new emphasized text with advice about unsticking an
application that won’t launch because of a conflict between what
it wants to do and what Resume wants it to do.
• More detailed information about how to dictate: in particular, I’ve
added a link to Apple’s recently released list of dictation commands
(look near the end of Talk to Type).
• A technique for permanently displaying the Save As command on
the File menu of a modern document model application (see the last
set of steps in Consider Application Shortcuts).
• Because DejaMenu is no longer readily available, the sidebar An
Alternative Solution now recommends MenuPop. MenuPop can
“pop” up the commands on the menu bar at the pointer’s location,
so it’s especially helpful if you have a big monitor—or more than
one monitor.
• A pointer to Display Menu, a free utility that returns the function of
the traditional Displays status menu to Mountain Lion (read the last
paragraph in Mirror Video).

10
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Introduction
If working with computers teaches us anything, it’s that things change.
Change is exciting! So I’m sure you’re excited about the prospect of
OS X 10.8 Mountain Lion. Mountain Lion, to make a sweeping
generalization, is a better 10.7 Lion. It has some completely new
features, such as the Notification Center and the availability of iCloud
in Open and Save dialogs, along with various small tweaks, such as
the way certain System Preference panes have been reorganized. But
it inherits most of its look and feel from Lion, including Lion’s eyecatching animations and its ways of drawing windows styles and
interface widgets. Mountain Lion also improves certain features
introduced in Lion; for example, Auto Save is much friendlier than
in Lion, with new options and menu items that make it easier to use
and understand.
My goal in this book, as in my previous Take Control introductions
to new systems, is to make you productive. Your computer isn’t a mere
interface display; it’s a tool for getting things done. Now that you’ve
upgraded to Mountain Lion, that tool might feel unwieldy at first. I
want to get you past that feeling as fast as possible. You don’t just want
to look at Mountain Lion; you want to use it. And you certainly don’t
want it to use you; you don’t want what’s new and unfamiliar to keep
you from getting back to work comfortably and quickly.
That’s what this book is for. What options, settings, choices do you
need to tackle, what new techniques and possibilities, what ways of
thinking and working and understanding do you need to know about,
in order to start using Mountain Lion comfortably and efficiently, so
you can stop gaping at your computer and get back to using it? This
book will show you.
Since I don’t know what system version you were using previously,
and because Mountain Lion is so closely related to Lion, I emphasize
in this ebook not only new Mountain Lion features but also aspects
of Mountain Lion that were new in Lion. I hope that this will help all
readers, of whatever background, to become familiar with Mountain
Lion quickly and easily.

11
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Mountain Lion Quick Start
This book describes many areas of 10.8 Mountain Lion worth
exploring and understanding, some of which will be more
immediately important to you than others. Naturally, I think
that sooner or later you should read this entire book, but I also
understand that you’re eager to get working with Mountain Lion
and that you might want to know what’s most important to know
and do right now, and come back to the rest of the book later.
If you’ve just installed Mountain Lion, immediately
improve your experience:
1. Suspend Spotlight: To do so, use the Spotlight system preference
pane. In the Privacy view, click the plus
button, choose your
computer name from the Open dialog’s sidebar, and click Choose.
(If you have multiple volumes, do this repeatedly until all disks and
volumes are listed under “Prevent Spotlight from searching these
locations.”) This will stop your disk from thrashing and free up
your computer’s attention. You can later (like, before going to bed)
remove from the Privacy list any disks you want Spotlight to index.
2. Suspend automatic updates: To do so, use the Software Update
system preference pane; for now, uncheck everything. You’ll turn
automatic updates back on later, or you’ll click Check Now, to
update manually, because you definitely want any available updates.
At the very beginning, though, you don’t want downloads
happening automatically in the background; you want your
computer’s undivided attention.
Tip: If you have Take Control of Upgrading to Mountain Lion, follow
all the instructions in “Perform Post-installation Tasks” there, too. (If
you don’t have it, don’t worry.)

If you installed Mountain Lion long ago, or with the above
two items taken care of, now you can:
• Straighten Out Your System Preferences—you’ll be using them a lot,
especially at first.
• The Dock is always present (or would like to be), so set it up the way
you want it: Dominate the Dock.
12
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• Make sure you can see clearly. At the very least:
‣ If text on the screen isn’t easy on your eyes, Smooth Your Text.
‣ If the cursor is hard for you to see, you might prefer to increase
its size: Grow the Cursor.
‣ If the menu bar is hard to see because the color of the desktop
background bleeds through, Make the Menu Bar Opaque.
• Decide how you want scrollbars to work. Read Survey Your
Scrollbars.
Explore new features of Mountain Lion:
There’s a lot to know about what’s new in Mountain Lion! Read Know
What’s New. Many changes listed in that chapter aren’t mentioned
elsewhere in this book. Then follow the links there to learn about and
explore new Mountain Lion features. In particular:
• Some applications save automatically as you work. That’s right:
you’re about to Stop Saving. Lion users, take note! The Auto Save
interface in Mountain Lion is changed (for the better) from Lion.
• Enjoy Mountain Lion’s new iCloud integration: read Configure the
Cloud and Store Files in the Cloud.
• Meet Mountain Lion’s new Notification Center; it’s time to Notice
Notifications.
• Be a Great Dictator! Use your voice to make words appear in a
document: Talk to Type.
• Find out about new tighter security: Guard the Gates.
• Are you a Dashboard user? If so, be aware of its Mountain Lion
makeover: Dominate Dashboard.
• Mountain Lion adds new AirPlay options for streaming audio and
video from your Mac. Read Activate AirPlay to learn more.
Review—or learn for the first time—features that were new
in 10.7 Lion:
• Start with Lion windows, which have some new behaviors:
‣ Resizing windows works in a new way, and so does customizing
a window’s toolbar. Read Resize Efficiently, Lose the Lozenge.
13
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‣ Prepare to have windows reappear when you launch an
application or restart the computer: Get Ready for Resume.
‣ What’s that double-arrow at the top right of the window? It’s
so you can Make Full-Screen Windows.
• Now you’re ready to Meet Mission Control and Manage Spaces.
(Lion users, there’s a new Mission Control configuration checkbox
in Mountain Lion that might make your life easier, so don’t miss it.)
As time permits, read the rest of Wash Your Windows.
• Curious about Launchpad? Time to Adopt a Launcher.
• Get acquainted, or reacquainted, with the Finder, Spotlight, and
Open and Save dialogs, all of which are chock full of new tweaks
and behaviors: read Handle the Hierarchy.
• If you have a Magic Mouse, a Magic Trackpad, or a modern
Mac laptop, Mountain Lion is a gesture-based world; get acquainted
with those gestures by reading Trick Out Your Mouse or Trackpad.
Do these things as needed and when time permits:
• Tweak keyboard shortcuts and keyboard behavior to match your
needs and habits; read the rest of Master the Mouse, Control the
Keyboard.
• If colors seem washed out or unsatisfactory, Calibrate Your Screen.
For more seeing tricks, survey the rest of Ease Your Eyeballs.
• Simplify your font access and make your Mac run leaner and
meaner; read Fix Your Fonts.
• Meet the spelling correction interface and discover a new way to
enter accented characters: Tackle Your Text.
• Make effective use of the icons at the right end of your menu bar;
read Customize Status Menus.
• Make various additional small customizations; read Explore
Miscellaneous Features.
• Be ready to continue exploring customizations; read Keep Using
Mountain Lion.
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Know What’s New
Lion and Mountain Lion present many interesting changes and
innovations that you’ll want to take account of as you adjust your
work habits to fit the new environment. Lion, in particular, presents
many radical changes from earlier systems; Mountain Lion has
some new features, but mostly it keeps or refines what it inherits
from Lion. This chapter lists both innovations that were introduced
in Mountain Lion and those that were introduced earlier, in Lion.
For some of these innovations, I refer you to later chapters for more
detailed discussion; but for others, this chapter is the only place
where I discuss them. So be sure to read this chapter to get an idea
of what to expect. (If you don’t understand all the terminology,
don’t worry—the important points are discussed later in the book.)

Notifications
New in Mountain Lion, the Notification Center allows applications
to post floating alerts telling you when things happen, such as a mail
message arriving or a calendar event coming up.
As in iOS, you can swipe to summon a view of stored recent alerts.
The Notification Center
icon takes its place at the right end of the
menu bar, and causes the Notification Center to appear at the right of
the screen; notifications are configured through the Notifications pane
of System Preferences, which behaves much like Notifications in the
iOS Settings app. Read Notice Notifications.
Note: iOS is the operating system that runs on Apple’s iPhone, iPad,
and iPod touch handheld devices.

Auto Save
Starting in Lion, applications may opt to save documents automatically
as you work, and allow you to review and revert to earlier versions of
a document, similar to Time Machine. If you haven’t been using Lion
already, you’ll find that this represents a wholesale change in how
15
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Straighten Out Your
System Preferences
Throughout this book, I’ll be advising you to make (or consider
making) some adjustments in your System Preferences. One of the
first things to do in a clean Mountain Lion installation is to make
sure you can navigate System Preferences easily.
To start System Preferences, choose System Preferences from the
Apple menu (or click its icon in the Dock, if it’s there).
The default arrangement of preference pane icons in the main System
Preferences window is by category (Personal, Hardware, Internet &
Wireless, and System). Perhaps this arrangement is to your taste, but
it certainly isn’t to mine, because what I know isn’t a preference pane’s
category, but its name! Therefore, I like to see these icons arranged
alphabetically by the name of the preference pane. To obtain that
arrangement (Figure 4), start up System Preferences and choose
View > Organize Alphabetically.

Figure 4: The main pane of System Preferences, with its icons
arranged alphabetically.
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Dominate the Dock
The Dock is a major component of the Mac OS X interface. Using
a computer whose Dock isn’t how you want it is annoying. It makes
sense to become familiar with the Dock early on, and to know how
you can modify its appearance and behavior.
Different users use the Dock in different ways. My Mom likes to see
the Dock all the time, and she likes it to be filled with the icons for
the applications she uses most often (because otherwise she has
trouble launching an application). I like the Dock hidden by default,
freeing up valuable screen real estate, and I like it to contain only
icons for applications that are currently running. Our approaches
to the Dock are diametrically opposed, but they are both legitimate.
Your goal should be to make the Dock work the way you want it to.

How the Dock Works
The Dock displays (reading roughly from left to right):
• Application icons: These may be running applications (which
appear automatically) or pointers to applications that are not
running.
• A divider: Drag this line (Figure 6) to resize the Dock. Summon
the divider’s contextual menu to bring up a menu with quick access
to some of the settings in the Dock preference pane and a command
for opening the Dock preference pane.

Figure 6: The right end of the Dock. Things to notice:
• The divider.
• The “light” under LaunchBar’s icon (meaning that it’s running).
• Mountain Lion’s new, less glassy Dock appearance.
• The Downloads folder progress bar, new in Mountain Lion.
29
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Guard the Gates
Perhaps you’ve already heard the hype: Mountain Lion has a new
security feature called Gatekeeper, intended to reduce your Mac’s
vulnerability to malicious attacks. Which is scarier, the possibility
of attacks or Gatekeeper itself? What should you do to configure
your Mac in order to keep it safe? Will you be able to run all your
favorite applications, or will Gatekeeper lock them out somehow?
Don’t worry. The only thing you have to fear is fear itself. You
can and should make a simple initial security setting—in fact, the
default setting is probably the right one for you—and then you can
forget all about Gatekeeper. Mountain Lion makes security easy
and transparent; there are some new dialogs that you might see
once in a while, and there’s one important new trick for launching
an application that I’ll explain in a moment.

Understand Sandboxing and Code Signing
To understand what Apple has done about security in Mountain Lion,
you need to know about two simple concepts:
• Sandboxing: An application can optionally elect to be sandboxed.
This means, in effect, that the application will confine its activities
to certain behaviors and to a restricted region of your hard disk.
So even if some malicious attacker managed to inject code into a
sandboxed application, it wouldn’t be able to do very much damage,
because the application can’t go beyond its sandboxed limitations.
For example, imagine a malicious virus that tries to take over
the brain of an application and save evil files in crucial places
on your hard disk. If the application is sandboxed so that it can’t
save files except in a few specific folders, the malicious virus will
be foiled. Similarly, suppose the malicious virus wants to make
the application “phone home,” sending messages over the Internet
about what you’re doing. If the application is sandboxed so that it
can’t access the network, the virus won’t be able to do that.
Sandboxing rules can also prevent an application from accessing
hardware, such as a microphone or camera.
35
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Configure the Cloud
The “cloud” is a major buzzword in the news these days, but all
it really means is the Internet. When data is “stored in the cloud,”
this just means it is kept on a computer that isn’t your computer.
Instead, it’s kept on a computer that’s visible across the Internet.
The reason for storing data “in the cloud” is that the cloud—the
Internet—is available from any computer (or mobile device, such as
a smartphone or iPad). In this sense, data “in the cloud” is available
anywhere—indeed, Apple refers to its cloud technology internally
as “ubiquity.”
Apple’s system-level access to cloud-based data storage is through
iCloud, introduced on iOS devices in iOS 5, and on the desktop in
Lion 10.7.2. What is iCloud, and should you use it? And what new
iCloud developments does Mountain Lion bring? That’s what this
chapter is about.

Why Use iCloud?
When you set up your newly installed Mountain Lion system, you
passed through a screen offering to let you sign in to your iCloud
account, or to create an iCloud account if you didn’t have one. Did
you? If you have just one computer, and you don’t have any iOS
devices, you might not find any advantage in using iCloud (though
in a moment I’ll describe a scenario where you might). But if you have
multiple computers or any iOS devices, you should seriously consider
using iCloud if you’re not using it already.
Take me, for instance. I have two computers, one in the office and
one in the living room. And I have three iOS devices: an iPhone,
an iPad, and an iPod touch. Before iCloud, making my calendar and
contacts information the same on all these devices, though possible,
was kind of a nightmare. With iCloud, however, my calendar and
contacts information is the same on all these devices, automatically,
all the time.
If I need to add an event to my calendar, it doesn’t matter which
computer or iOS device I’m using! I can enter the event then and
there, on any device. Any time one of these devices can see the Internet
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Notice Notifications
Mountain Lion introduces a new system-level way for applications
to post alerts without interrupting your work, letting you know that
something has happened or is about to happen. These alerts are
called notifications, and they are stored and managed through the
Notification Center.

Understand Notifications
If you’ve ever seen an alert message from iCal appear on your screen,
or if you’ve installed Growl (http://growl.info/) and seen it put up
a message from an application, you know what a notification is and
why it’s useful:
• A full-fledged alert dialog in an application is heavyweight; it
requires that the application be brought to the front, and it may
not be possible to work with that application until you explicitly
dismiss the alert.
• In contrast, a notification is lightweight; it can appear in front
of everything on screen even if the application that sends it isn’t
frontmost or even visible, and it doesn’t interrupt what you’re
doing, get in your way, or prevent you from continuing to work.
Mountain Lion’s new Notification Center provides a centralized
system-based locus for notifications. It provides a way for any
application to post a notification, and it gives you a single built-in
place to view and manage notifications.
In Mountain Lion, you can view notifications in two ways:
• Banners and alerts: An application may spontaneously post
a banner or an alert as a small rectangle at the top right of your
screen. The difference between a banner and an alert is that a
banner appears fleetingly and vanishes automatically, while an
alert, though it isn’t modal and doesn’t prevent you from working,
won’t go away until you click in it (Figure 13).
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Wash Your Windows
Here’s a news flash from the Department of Unintended
Consequences: windows are great, but they’re also a problem.
As soon as you have more than a few windows open at once, it’s
clear that those windows are like automobiles, and your monitor
is like a Los Angeles freeway—it’s overcrowded, and no matter
how much you widen it, it’s still going to be overcrowded. This
is particularly a problem for an operating system like Mac OS X,
where the windows of different applications can become
intermingled. Finding the window you want can be like searching,
amid the distracting red herrings, for the Purloined Letter: you
might not be able to see it even if it’s in plain sight.
Each new major version of Mac OS X seems to take yet another
stab at helping you deal with windows. Lion was no exception; it
brought far-ranging changes throughout the spectrum of window
management. You’ll want to be clear on how to work with windows
in Mountain Lion:
• When it comes to working with an individual window, Lion
changed the way scrollbars and window resizing operates, and
I discuss those topics first in the chapter ahead.
• Lion introduced the Resume feature, which causes windows
you were working with to reappear each time you launch an
application; you’ll want to get your head around this in Get
Ready for Resume.
• To handle all the windows that are open on your Mac at once,
you’ll want to Meet Mission Control and consider the ideas in
Manage Spaces.
• Lion also added a way to eliminate distractions with full-screen
windows, and I discuss that in Make Full-Screen Windows.
• This chapter also discusses how to Dominate Dashboard and
offers some thoughts on the need to Consider Third-Party
Window Management.
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Handle the Hierarchy
Your hard disk holds programs (applications) that you want
to use and documents that you want to read or edit. They live
somewhere—but where? To get anything done, you must be able
to find your files, whether these are applications or documents.
There are two main ways of locating files on a Mac, which you can
think of as polar opposites of one another:
• The folder hierarchy: Every file is in a folder, every folder
is in a folder, and so on, upward, until we reach the top level,
called a volume: this is usually your hard disk, or a partition
of your hard disk. So, to reach any file or folder, you can traverse
that same path downward: starting at some high level, such as
a volume or your Home folder, you enter a folder, then a folder
within that, and so forth, until you reach whatever you’re after.
Configure a Finder Window (just ahead) covers the basics, and
later topics in the chapter go beyond the basics. If you are new
to Mountain Lion and iCloud, be sure to read Store Files in the
iCloud.
• Jumping: Navigating the folder hierarchy can be tedious.
Besides, the hierarchy works like a filing cabinet, whereas your
mind may not; and to locate something this way, you must know
the sequence of folders containing it, which isn’t always the case.
You need to slice through the hierarchy and jump directly to a
file or folder—so let’s call this way of locating things jumping.
If you need to quickly jump to a file, skip ahead to Jump with
Spotlight or Remember about Recent Documents, and to jump
to an application so you can run it, read Adopt a Launcher.

Configure a Finder Window
Browsing your folder hierarchy starts with a Finder window. With a
Finder window, you can navigate to any file on any mounted volume.
You can open multiple Finder windows simultaneously and navigate to
different places in them (or even get multiple views of the same place).
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Stop Saving
Many applications display and allow you to edit the contents of
files that belong to you. Such files are called documents, and these
are document-based applications; the main signs of a documentbased application are that its primary windows represent files
and that it lets you edit the contents of those files. (For example,
TextEdit and Preview are document-based applications; Safari is
not, even though its windows are sort of like documents, because
its windows don’t represent editable files belonging to you.)
Starting in Lion, some document-based applications began
participating in a new mode of being that Apple calls the modern
document model. Such applications support the system-level Auto
Save feature. These applications no longer require that you save
a document as you edit it; instead, the document is saved
automatically. Although this feature is not a new concept—many
Mac applications have had it as an option for years—this behavior
may mean a new way of working for you on your Mac.
In Mountain Lion, Apple has responded to complaints about this
feature by restoring some menu items that it had removed in Lion,
by adding some new menu items to make certain actions more
convenient, and by giving you an option to change the behavior
of the interface in a way that may prove more congenial. Naturally
you’re going to want to know about these changes.
In this chapter, I begin by discussing how to tell if an application
uses the modern document model, along with a key checkbox in
System Preferences. Then I explain how to Work with Documents
in this model. I finish with a look at Versions, which can help you
undo edits in a more nuanced way than what was previously
available without the modern document model (see Handle Regret).

Meet the Modern Document Model
Apple’s new modern document model is an opt-in technology: you
don’t get any choice whether to opt in, but an application’s developer
does. A developer must rewrite the application for Lion or Mountain
Lion, electing to use the modern document model; otherwise, the
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Master the Mouse,
Control the Keyboard
Advanced as it is, Mountain Lion can’t read your mind. The main
way to get anything done on your Mac is still by manipulating the
mouse or trackpad and by pressing keys. Therefore you owe it to
yourself to give a little thought to what these input devices do.
You can make a number of customizations regarding how the
Mac responds to your clicks, gestures, and keypresses. Individually,
each of these customizations may seem small, but considering how
much time you’ll spend mousing and typing, they can add up to the
difference between annoyance (or even wrist pain) and nimbleness.
In addition to using the keyboard and mouse or trackpad, a few
valiant pioneers have long made use of speech recognition—you
talk, the computer types. Starting in Mountain Lion, if you have an
Internet connection, you too can get your feet wet with basic speech
recognition; it’s built in to Mountain Lion, and you can use it in any
application. I discuss that in Talk to Type, later in this chapter.

Trick Out Your Mouse or Trackpad
Your input device may respond to various gestures, and you may be
able to customize some of those responses. Depending on what input
device you have, look in the Mouse system preference pane or the
Trackpad system preference pane. In this discussion, I concentrate on
the Magic Mouse, the trackpad on a relatively new portable, and the
Magic Trackpad.
How new is my portable? A portable is “new” if it has a large
multi-touch glass trackpad and no separate button.
The Mouse and Trackpad preference panes, when you have one of
these devices connected, are divided into separate views. Within each
view are effects your gestures can have; in each case, you can elect to
disable the effect, and in some cases you have a choice of gestures for
causing an effect. A helpful movie illustrates a gesture as you hover
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Fix Your Fonts
Font management has always been a problem on the Mac, and
fonts remain a rocky area of OS X. Once you have more than a few
fonts, the mere act of choosing a font in an application becomes a
trial, because the list of available fonts is so long. Font versioning,
especially when different fonts have the same name, is a
troublesome business. And a surprisingly high percentage of
crashes and other strange phenomena experienced by Mac users are
due to font problems, such as conflicts between fonts, or fonts that
are in some way badly structured.
For these reasons, it’s good to take control of your fonts. Read this
chapter to implement font management that will make your Mac
quicker and nimbler by putting unneeded fonts out of sight—until
you do need them.
At the end of this chapter, you’ll learn about Mountain Lion’s
Restore Standard Fonts command, a rarely used feature that you
might need some day.

Know Why Font Management Is Needed
The biggest problem with fonts in Mac OS X is that they are literally
all over the place. There isn’t just one Fonts folder you can peek into
and say “These are my fonts.” Fonts load automatically into the system
and become available for use in applications if they are in any of (at
least) three places:
•

/System/Library/Fonts

•

/Library/Fonts

•

~/Library/Fonts

So just seeing what fonts you have is a pain in the Finder. And even
when you know a font file’s name, that doesn’t mean you know all
about it:
• A font file is like an image file: its name is just a label; what you
want to know is what a font face looks like.
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Tackle Your Text
Unless you use your Mac primarily for surfing the Web or for
creating graphics, sooner or later you’re going to press a key on
your keyboard, and a text character is going to appear on your
screen. It sounds simple, but behind the scenes a lot of incredibly
sophisticated stuff is happening as the mighty Mac OS X text engine
swings into action.
You’ll want to examine the text engine and Set Up Text Behavior,
and become acquainted with Mountain Lion’s interface for
correcting your spelling. Then you should Understand the Input
Menu so that you can enter interesting text characters.

Set Up Text Behavior
To explore Mountain Lion’s text engine, you need to work in two places
at once. First, bring up the Language & Text preference pane, and
switch to the Text view. Second, launch TextEdit, because unlike many
other word processors and text processors it’s a kind of unmediated
showcase for Mountain Lion’s built-in text engine features. (Mail is
another application that uses the text features we’ll be discussing here,
but TextEdit is simpler to use for exploratory purposes.)
So, you’ll customize system-level settings in the Text view of the
Language & Text preference pane, and you’ll experiment with the text
engine in action in TextEdit.

Text Substitutions
In the Text view of the Language & Text preference pane, the Symbol
and Text Substitution table is a list of changes that the text engine can
make for you automatically as you type. For example, you type (c) and
the text engine can automatically change it to the copyright symbol ©.
Don’t worry, you can turn off text substitutions: In an
application that is text substitution–savvy like TextEdit, you can turn
off text substitutions if you don’t like them. Plus, if an unwanted text
substitution occurs, you can always undo it with Edit > Undo.
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Ease Your Eyeballs
A common complaint about using computers is an inability to see
comfortably. You sit at the computer for long stretches of time; you
read text on the screen; you peer at minute details. You deserve as
pleasant a viewing experience as you can possibly get. Mountain
Lion gives you many ways to improve the way your monitor
portrays the computer’s world.

Calibrate Your Screen
When you first install Mountain Lion, the default screen calibration
may give your screen a pale, washed-out appearance, making icons
difficult to distinguish and text difficult to read.
If you don’t like, or have doubts about, the way your screen looks,
go to the Color view of the Displays system preference pane and
experiment with different display profiles, if there are multiple profiles
listed. For example, my Hewlett-Packard monitor comes with a display
profile, which Mountain Lion used automatically; but I found by
experimentation that I preferred Apple’s Generic RGB Profile.
Resolution matters too: Take a quick look at the Display view of
the Displays system preference pane. You may be offered a choice of
resolutions here. In most cases, you’ll see a “Best for display” radio
button, and this really will be the best. But if you click “Scaled” you’ll
see a choice of alternative resolutions you can try. Scaled resolutions
generally don’t look as good—except with Apple’s new Retina display
laptop, where they are excellent.
If no display profile proves satisfactory, you can make your own
custom display profile. To do so, you’ll calibrate the display manually.
Follow these steps:
1. Wait until a time of day, and be in a location and under lighting
conditions, where you commonly use your computer. Your
perception of the screen is greatly affected by the incident and
ambient light. Position yourself where the screen is at its best
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Customize Status Menus
Status menus (also called status items, status icons, menu extras,
or menu bar extras) are the icons that appear at the right end of
your menu bar. (This area is technically called the system status
bar.) Status menus can be a convenience or a waste of valuable
menu bar space, depending on your needs, your monitor size, and
what you had for breakfast. In any case, controlling which status
menus appear is a customization you can and should perform.
Unfortunately, the tools for status menu management are scattered
all over your Mac. This chapter will help you find most of them.

Show Status Menus
How do status menus come into being? There are various ways.
Some status menus are there by virtue of being enabled in System
Preferences. Some are put there by some application, either through
its preferences or because the application is running (Figure 69).

Figure 69: The system status bar shown above has three groups
of icons:
• Starting from the left, the first two status menus come from thirdparty utilities—respectively, the applications FastScripts and
Dropbox.
• Then come status menus placed by various built-in System
Preference panes and utilities—Accessibility, Time Machine,
Bluetooth, Network (Wi-Fi), Eject, Language & Text (Input menu),
Sound, Date & Time, and Users & Groups (Fast User Switching).
menu and the Notification
• At the far right are the Spotlight
button, which are not really status menus.
Center
Tip: An application’s menus can crowd out status menus on a small
screen. There are some utility applications with no menus of their
own; switch to such an application and now there’s nothing to crowd
out your status menus, so you can see them all! An example is
Menuola (http://www.geocom.co.nz/programs, donationware).
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Explore Miscellaneous
Features
This chapter shines a light into some further corners of Mountain
Lion’s world. It takes the form of a list of additional miscellaneous
features that you should not neglect in your eagerness to get on with
using Mountain Lion.

Activate AirPlay
Apple’s AirPlay technology (formerly called AirTunes) has allowed
you to stream audio wirelessly from a Mac to an AirPlay-compatible
device for quite some time. For example, instead of outputting music
from iTunes to speakers built into or attached to your Mac, you could
choose an AirPlay device as an output destination for iTunes. This
device could be, for example, an AirPlay-compatible speaker or an
AirPort Express connected to your stereo system.
Note: Because my editor Tonya Engst has a Mac that supports video
mirroring, and I don’t, she was nominated as official Guest Author for
this topic. Take it away, Tonya!

Stream Audio
New in Mountain Lion, you can stream all your Mac’s audio, not just
audio from an AirPlay-savvy audio application. To set this up, first
make sure your Mac is connected to a wireless network that also has
an AirPlay device connected to it. Now:
1. Open the Sound system preference pane, and click the Output
button.
In the Output view, you should see any devices that are currently
available for sound output, including any AirPlay devices. In
Figure 70 you can see both an Apple TV and an AirPort Express
(called TidBITS Express), along with some non-AirPlay options.
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Keep Using Mountain Lion
There’s lots more to explore and learn about Mountain Lion.
This book can’t cover everything; if it tried to, it would become
too long and boring. You’re ready to start using Mountain Lion
and get serious work done, but you should also continue the process
of getting acquainted with Mountain Lion’s world. Keep your eyes
open and you’ll find plenty of new features and options.
This book has pointed out Mountain Lion features that are particularly
important or difficult to find, but many others remain, and you should
still search them out and tweak Mountain Lion so that it’s the way you
like it. For example, this book hasn’t talked about setting your Mac’s
sound volume, or specifying its Beep sound.
One wise move is to take some time, after the excitement of meeting
Mountain Lion has subsided, to march through every view of every
pane of System Preferences. Look at your options, and make sure
things are set up the way you like them.
Similarly, as you start up an application, take a moment to examine
its preferences and see what new features and options are available
to you. For example, in Safari, there’s the Reading List feature; take
time to explore it and think about whether it’s something you’ll want
to use. Similarly, do you like tabbed Web browsing? When you click
a link to open a page in a new tab, do you want holding the Shift key to
mean “open the page in the background” or “open the page and switch
to that tab right now”? This book hasn’t talked about how you set up
Safari’s preferences. But those are still things you should do.
Finally, if you think a particularly important aspect of Mountain Lion
has been omitted from this book, email us and let us know. Maybe
we’ll include it in a future update. Many of our ideas about what our
readers find significant have come from our readers themselves.
Tip: To munch on the full smörgåsbord of what Mountain Lion has
on offer that’s new, read http://www.apple.com/macosx/whats-new/
features.html.
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About This Book
Thank you for buying this Take Control book. We hope you find it
both useful and enjoyable to read. We welcome your comments at
tc-comments@tidbits.com.

Ebook Extras
You can access extras related to this ebook on the Web. Once you’re
on the ebook’s Take Control Extras page, you can:
• Download any available new version of the ebook for free, or buy
a subsequent edition at a discount.
• Download various formats, including PDF, EPUB, and—usually—
Mobipocket. (Learn about reading this ebook on handheld devices
at http://www.takecontrolbooks.com/device-advice.)
• Read postings to the ebook’s blog. These may include new
information and tips, as well as links to author interviews. At the
top of the blog, you can also see any update plans for the ebook.
If you bought this ebook from the Take Control Web site, it has been
automatically added to your account, where you can download it in
other formats and access any future updates. However, if you bought
this ebook elsewhere, you can add it to your account manually:
• If you already have a Take Control account, log in to your account,
and then click the “access extras…” link above.
• If you don’t have a Take Control account, first make one by
following the directions that appear when you click the “access
extras…” link above. Then, once you are logged in to your new
account, add your ebook by clicking the “access extras…” link a
second time.
Note: If you try the directions above and find that the device you’re
reading on is incompatible with the Take Control Web site, contact us
at tc-comments@tidbits.com.
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