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Read Me First
Welcome to Take Control of Safari 6, version 1.0, published in
October 2012, by TidBITS Publishing Inc. This book was written
by Sharon Zardetto and edited by Tonya Engst.
This book shows you how to make the most of Safari 6, a deceptively
powerful Web browser with features you may have never even tried.
If you want to share this ebook with a friend, we ask that you do
so as you would with a physical book: “lend” it for a quick look,
but ask your friend to buy a copy for careful reading or reference.
Discounted classroom and Mac user group copies are available.
Copyright © 2012, Sharon Zardetto. All rights reserved.

Updates and More
You can access extras related to this ebook on the Web (use the link
in Ebook Extras, near the end; it’s available only to purchasers). On
the ebook’s Take Control Extras page, you can:
• Download any available new version of the ebook for free, or buy
any subsequent edition at a discount.
• Download various formats, including PDF, EPUB, and—usually—
Mobipocket. (Learn about reading this ebook on handheld devices
at http://www.takecontrolbooks.com/device-advice.)
• Read postings to the ebook’s blog. These may include new tips or
information, as well as links to author interviews. At the top of the
blog, you can also see any update plans for the ebook.
If you bought this ebook from the Take Control Web site, it has been
added to your account, where you can download it in other formats
and access any future updates. However, if you bought this ebook
elsewhere, you can add it to your account manually; see Ebook Extras.
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Basics
There are some basics you need to know to make your reading
experience smoother:
• Menu references: The shorthand description for referring to
choosing something from a menu is, for example, File > Open.
For menu commands that toggle between wordings based on
circumstances, I often use something like this: “View > Show/Hide
Tab Bar.”
• Mac OS X versions: I usually refer to the current and recent Mac
systems by both their cat monikers and numbers—“10.8 Mountain
Lion” or “10.7 Lion.” To see what system you’re running, choose
Apple  > About This Mac.
• Path names: The route you take to a file on your hard drive,
whether by looking through columns in a window or by doubleclicking your way through folders, is the file’s path, and there’s
a standard “syntax” for describing these paths. The disk’s name
is always the first thing in a path; we assume the disk is always
there, so we don’t include its name, but we do preserve the slash
that would separate it from the next item. So, HardDrive/System/
Library becomes /System/Library.
A path to something in a user’s home directory starts with the
drive’s name, followed by Users and then the user’s name. The
standard convention, however, replaces those first three items
with ~ (tilde), so HardDrive/Users/Miriam/Library becomes simply
~/Library. (You’ve probably noticed by now that path text is
formatted in special type.)
• System Preferences: To work with System Preferences, choose
Apple  > System Preferences and, in the window that opens,
click the icon for the settings you want to adjust. I describe this
procedure simply as, for example, “Open the Parental Controls
preference pane” or “In System Preferences, open Parental
Controls.”
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• Safari Preferences: Applications have their own preferences,
separate from System Preferences. In Safari, choose Safari >
Preferences (Command-Comma), then access a specific type of
preference—such as General or Bookmarks—by clicking its icon
at the top of the Preferences window. I usually refer to a Safari
preference pane as, for instance, “Safari’s General preferences”
or “the Bookmarks pane of Safari’s preferences.”
• Contextual menus: When I refer to accessing a contextual
menu, I usually write “Control-click [whatever] for the contextual
menu …”. This is a little ironic since I never Control-click—my main
computer is a laptop, and I use a two-finger tap for a contextual
menu. You might do the same, or you may be using a mouse that’s
set to open a contextual menu with a right-click. Whenever you read
“Control-click” or “right-click,” use your favorite method to open a
contextual menu.
• Gestures: I often mention two-finger (and sometimes threefinger) swipes, and even pinching and two-finger double-tapping,
as a way of, for instance, scrolling pages, looking through Tab
View, accessing Mission Control, or zooming. This assumes you’re
using the common defaults for those gestures. Yours may be set
differently in System Preferences, including (but, as the lawyers say,
“not limited to”):
‣ The Trackpad pane: Scroll & Zoom and More Gestures views
‣ The Mission Control pane
‣ The Mouse pane

What’s New in This Edition
This ebook is effectively the third edition of an ebook that I’ve been
writing about Safari, beginning with Safari 4, continuing with Safari 5,
and now focusing on Safari 6.
Out with the old, in with the new! That about sums it up. I’ve deleted
obsolete material (RIP, RSS!) and added coverage about new features
in Safari (see What’s New in Safari 6). In addition, I’ve tweaked some
general information that’s system-specific, since we’re two systems
7
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(10.7 Lion and 10.8 Mountain Lion) beyond what was current for
the last edition of this book. So for instance, using the new-in-Lion
Mission Control/Application Windows (Switch Windows) and fullscreen mode (Hide Windows with Full-Screen Mode) to control Safari
window clutter get their due. Also, the concept of mailing Web links or
pages, and how Safari coordinates with Apple Mail isn’t new, but there
is a new way to access the options as well as new ways to format the
information you send, as described in Email Links or Page Content.
Some things are new to this edition that aren’t new to Safari 6 because
of the leapfrogging nature of app updates and book updates:
• The Reading List, which was added to Safari 5.1, is new to this book
because it came out after the Safari 5 edition did. (But the feature
was considerably updated for Safari 6, so make sure you read all
about it, in Work with the Reading List.)
• Now that extensions are not the Brand New Thing, it’s easier to poll
experts about the ones they recommend, which is just what I did,
and I’ve added the list for your convenience. I put special notices,
like the one below, throughout the book wherever I discuss a feature
(or lack thereof) that a specific extension addresses, linking it to the
fuller description in Recommended Extensions, where you’ll find
links to downloadable versions.
Extension alert! Full descriptions are in Recommended Extensions.
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Introduction
Why do you need a book about Safari? You’ve probably been using
Safari for quite a while, and you’re doing just fine.
But you don’t have to settle for “fine.” In all likelihood, Safari does
far more than you’ve been asking it to, and those things you have
been doing with it you can do more quickly, elegantly, and efficiently
when you know Safari’s ins and outs. I can vouch for that because back
when Safari 4’s beta version was released, I vowed to finally, finally,
explore Safari thoroughly, in order to find the best way to organize
bookmarks, learn about tab options instead of using them solely in
the most obvious way—oh, and deal with the pesky issue of having
dismissed the offer to save a password for a site and never again being
asked to do so. Ever since then, I jump on Safari’s newest releases to
explore its changes.
Because I devote so much time to this, you don’t have to. You won’t
have to learn bits and pieces from various sources, experiment on
your own, or click your way through the not-exceptionally-helpful
Help system to put together disconnected bits of information.
No matter how you use Safari—for lightweight general surfing or
middleweight targeted browsing with (a probably disorganized pile
of) bookmarks—this book will take you to the heavyweight division,
with toned tabs, a buffed bookmarks bar, ad-free main-article reading,
read-it-later-offline storage, and more.

9
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Safari 6 Quick Start
The material in this book is the least linear of any Mac book I’ve
ever written: there are few interdependencies among the topics,
so you can start with any one that piques your interest or is likely
to answer the burning questions you have about using Safari—
whether they’re of long-standing duration or specifically about
Safari 6. Luckily, ebook links lend themselves to just that sort
of approach!
On the other hand, if you don’t want to accidentally miss anything,
just follow the advice given to Alice: “Begin at the beginning and go
on till you come to the end: then stop.”
Upgrade to Safari 6 if you have 10.7 Lion:
• Safari 6 is automatically installed with 10.8 Mountain Lion, but is
also available—sans a few features—for Lion systems. Choose Apple
 > Software Update if you haven’t upgraded yet.
Check out Safari’s new features:
• If you want to hit the highlights of new features, use the links in
What’s New in Safari 6.
Customize your experience:
• From top (the toolbar) to bottom (the status bar), you can tweak
Safari’s looks and basic behavior—see Customize Your Safari
Environment.
• For more advanced customization, find out how to Organize the
Bookmarks Bar and how to Expand Safari’s Capabilities with
Extensions.
• If you’re setting up Safari for a child, you can set limits with
parental controls, as described in A Different Kind of Careful
Browsing.
• Set your Safari preferences. Its various preference panes are
covered in their topic areas, such as:
‣ Set Your Tab Preferences
‣ Override Window-Opening Links
10
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‣ Set Your Bookmark Preferences
‣ Define Your History Range
‣ Turn On AutoFill Sources
‣ Set the Download Preferences
Learn key browsing techniques:
• You know the basics, but you can learn their details in:
‣ Navigate to and within Web Pages
‣ Track Your Downloads
‣ Use AutoFill for Forms and Passwords
• See how you can read an “article” without ads distracting you
or having to click from one page to the next when it’s split across
several pages in Tune Out Page Clutter with Reader.
• Juggle multiple sites with finesse by learning how to Tame Multiple
Pages with Window Tabs.
• Learn about the different ways you can go back to previously visited
Web sites in Manage Your Top Sites, Set Up and Use Bookmarks,
and Retrace Your Steps through History.
• Read how you can store a Web page for later reading, offline, in
Work with the Reading List.
• Protect your privacy: Store and Edit Your Passwords, and learn
about Stealth Browsing and how to Erase Your Tracks with the
Reset Command.
• Optimize your search techniques in various areas with:
‣ Search the Web
‣ Search within a Page
‣ Search Your History and Bookmarks

11
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What’s New in Safari 6
Safari 6, released with OS X 10.8 Mountain Lion, is another step
in the evolution of Apple’s browser. No, it’s not revolutionary by
any means, but there are convenient, welcome improvements. In
this chapter, I first list what’s new in Safari 6, and then I note which
of the new features you won’t find if you’re still running 10.7 Lion.
Here are the new features in Safari 6, and where they’re explained:
• The former “smart address field” is now exceptionally clever, and
works as a combined address and search field, as described in Use
the Address Field to Load a Page.
• The Tab View lets you peruse all of a window’s open tabs without
having to move from tab to tab.
• Work with the Reading List to read Web pages offline.
• Share from the Share Button to put email, messaging, tweeting, and
more at your fingertips.
• When more Web sites get up to speed with this HTML5 feature,
you’ll be able to Handle Web-Page Notifications.
• Use iCloud Tabs to pick up where you left off on another computer
or device with the syncing of left-open tabs.
• There’s a new Safari preference pane that lets you Store and Edit
Your Passwords.
But, Apple giveth and Apple taketh away: RSS feeds are no longer
available, and sorely missed.
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What’s Not New in Safari 6 in Lion
The version of Safari 6 that’s available for 10.7 Lion is missing some
features that are in the Mountain Lion version (most are dependent
on Mountain Lion features):
✦ Notifications.
✦ iCloud Tabs: These are a special syncing convenience that lets
you see what tabs you left open on one computer or mobile device
when you’re using one of your other ones.
✦ Tab View.
✦ Share button: The soon-to-be (if not already) ubiquitous Share
button came to Mountain Lion from iOS. It’s not available
in Lion, but some of its commands (it sports a drop-down menu)
are available elsewhere. Not, however, the Message, Twitter, and
Facebook commands, since those connect to Mountain Lion’s
innards.
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Click here to buy the full 143-page “Take Control of Safari 6” for only $10!

Customize Your
Safari Environment
From top (the toolbar and bookmarks bar) to bottom (the status
bar), and several things in between (such as starting pages), you
have some choices as to how Safari’s window looks and behaves.
In this chapter, I show you the most important ways to customize
Safari when you start using it. I cover many other customization
options throughout this ebook.

Do Basic Setup for the “Bars”
The top of the Safari window has, directly beneath its title bar, the
toolbar, tabs (in the “tab bar”), and the bookmarks bar; at the bottom
of the window is the lowly status bar (Figure 1).

Figure 1: The top “bars” don’t look like separate entities, but
different areas provide different functionality. From top to bottom:
the title bar, the toolbar, the bookmarks bar, the tab bar, and the
status bar.
14
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Tune Out Page
Clutter with Reader
Reader was my favorite new feature in Safari 5, and it’s still
something I use frequently. It lets you easily read the main text
on a page by consigning surrounding text, buttons, menus and—
especially and—ads to a darkened oblivion behind a special reading
window. The window uses an easy-to-read font with good line
spacing, no matter what fonts the page’s designer chose to impress
you. As an extra bonus, Reader grabs all the text of an “article” into
a single reading window, even when it’s spread across several Web
pages. It’s perfect for not only reading, but also for printing or
emailing.

Learn Reader Basics
Before you learn how to use Reader, you should understand that it
doesn’t work on every Web page. The page must have what can be
considered a main “article,” something that’s identified by Safari as
such, based on the page’s code and the length of the text. (There’s no
code that’s specific to Reader; it looks at the standard HTML coding
of a page.) So, if you go to something like the home page of Wikipedia
(http://en.wikipedia.org/wiki/Main_Page) or the New York Times
(http://www.nytimes.com/), you won’t be able to use Reader, because
those pages are a conglomerate of short pieces, none of which qualify
as a main article. But, as soon as you click a link to read one of the
story blurbs on the top page, you can use Reader.
How can you tell when Reader’s available? The Reader button that’s
embedded in the address field turns blue to show that it’s active
(Figure 19).
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Manage Your Top Sites
Safari is Big Brother-ish in a good way: it keeps track of where
you’ve been, and how often and how recently you’ve been there.
It then cleverly compiles an easily scanned Top Sites collection
of thumbnails stripped of such distractions as sign-in pages and
multiple pages from the same site.

View Your Top Sites
See your Top Sites by choosing History > Show Top Sites (CommandOption-1) or by clicking the Top Sites
button in the toolbar or
bookmarks bar. The sites are displayed in a curved gallery of
thumbnails (Figure 16).

Figure 16: The Top Sites view. A blue frame surrounds the
thumbnail you’re pointing to (third row, middle). The Edit button lets
you manipulate the thumbnails, and the Search History field is best
ignored in favor of searching your history in the Bookmarks window.
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Navigate to and
within Web Pages
The journey may be the reward in life, but when you’re browsing
the Web, it’s the destination that counts. In this chapter, I explain
how to get there quickly and move among various “theres” with a
minimum of effort.

Use the Address Field to Load a Page
Safari’s original address field became the “smart address field” in
Safari 5 because you could type only part of a URL (Universal Resource
Locator, a Web site “address”) and get it auto-completed based on
what was in your history and bookmarks collection.
In Safari 6, it functions as a combined address and search field and is
called … the address and search field. But I’ll continue on a friendly,
first-name basis and call it simply the “address field.”
The address field can jump to a conclusion if you type part of a page’s:
• URL: A URL is a page’s address, such as:
http://www.takecontrolbooks.com/spotlight

You don’t have to type the http://www. prefix, or even start with
the domain name for Safari to suggest a match. Typing apple could
suggest apple.com and applepie.com, as well as fruitpies.com/
apple.
• Title: This is what appears in the Safari window’s title bar, based
on the Web designer’s name for the page. The page at http://www.
takecontrolbooks.com/spotlight, for instance, has the title “Learn
easy and sophisticated ways to search your Mac with Take Control
of Spotlight for Finding Anything on Your Mac.”
• Bookmark name: If you’ve saved a bookmark for a page and
given it a name instead of its default URL, the name is also a
candidate for the address field.
25
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Wrangle Windows
Whether you open new windows with a press of Command-N or by
employing some of the fancy options for clicking links described in
the previous chapter, it’s easy to get buried in windows when you’re
working in Safari for more than, say, three minutes. There are lots
of tools at your fingertips for managing a mess, such as Mission
Control, full-screen mode, and even that old standby, the Minimize
command.
(If you want help managing tabs within windows, see the next
chapter, Tame Multiple Pages with Tabs.)

Switch Windows
The three basic ways to move from one Safari window to another are
common to most Mac apps:
• Click: Click on any part of a non-active window.
• Use a keyboard shortcut: Command-~ (tilde, at the upper left
of the keyboard) and Command-Shift-~ take you to the previous
and next Safari windows.
• Choose from a menu: Use the list in the Window menu (a tabbed
window is named by its frontmost tab).
The more sophisticated ways are common to most Mac apps, but they
involve the Mission Control and Application Windows features
introduced in 10.7 Lion:
• Mission Control: A basic way to access Mission Control is to click
its icon in the Dock (but see the sidebar just ahead for other ways
to open it). Whether you’re in Safari or another app with Safari
running in the background, going to Mission Control provides an
overview of everything that’s going on. Miniatures of your windows
will be grouped around the Safari icon, and clicking on one sends
you back to Safari with that window in the front.
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Tame Multiple Pages
with Tabs
Window tabs are possibly the best thing since sliced bread. Come
to think of it, they’re sort of like sliced window.
Tabs let you keep multiple Web pages open in a single window;
this is especially useful on a laptop with limited screen real estate,
but it keeps window-juggling to a minimum on any screen. And tabs
provide a convenient organizational tool: you can, for instance, have
several windows open, each with a subset of related Web pages in
tabs, when you’re researching a topic—whether the topic is global
warming or which wireless Bluetooth speaker you’re thinking of
ordering from Amazon.

Set Your Tab Preferences
Whether you’ve been using tabs all along, or are about to explore
their usefulness, set up your tab preferences. If you have no personal
preferences, start with my recommendations:
1. Choose Safari > Preferences and click Tabs.
2. From the Open Pages in Tabs Instead of Windows pop-up menu,
choose Automatically. This option is detailed in Override WindowOpening Links, ahead in this chapter.
3. Select the Command-Click Opens a Link in a New Tab checkbox.
Enter the twenty-first century if you’ve been delayed; this is the
standard for opening tabs. (See Tabs, Tabs, Everywhere to learn
how this setting affects more than just links.)
4. Uncheck When a New Tab or Window Opens, Make It Active. One
of the advantages of tabs is that you can Command-click a dozen
links on the page you’re reading, to line up a bunch of tabbed pages
that you can then read without having to move back and forth
between the main page and its linked pages. You can do the same
thing with opening new windows, sending them behind the current
41
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Handle Web-Page
Notifications
Notifications is one of the interface concepts that has come to
10.8 Mountain Lion from iOS. The Mac is now infused with
notifications from Mail, Twitter, Reminders, and more—including
Safari 6. If you’ve already used Notifications, you know how handy
(and/or annoying) they can be. In Safari, you can easily manage
the annoying part, leaving only the handy part.
“Notifications,” also called Server-Sent Events by the cognoscenti,
is a relatively new aspect of the HTML5 standard, and, as such,
there aren’t a lot of sites that utilize the feature at this point.
Consider this chapter a get-acquainted introduction.

About Notifications …
You don’t have to worry about being bombarded by unwanted Web
page notifications. For a site to send you a notification:
• It must ask you to allow notifications from the page (Figure 21).
Standards call for your actually clicking a button to get the request,
so you shouldn’t get an annoying pop-up asking for permission.
• You must agree to receive notifications from the page; you can
easily rescind the permission at any time.
• You must go to the Web site for a notification to be pushed to you.

Figure 21: A notification request shows up in a slide-out dialog in
response to your clicking a Request button on a page.
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Work with the
Reading List
The Reading List was introduced in Safari 5.1—too late for the
last edition of this book, but well before the introduction of Safari 6.
In Safari 6, however, it evolved into what it should have been all
along—a way to store not just pointers to pages, but the page
contents as well so you can read them later, when you’re offline.
Maybe your “check out this page” obligations are piling up: a few
links in email messages, some in your Twitter feed, others that you’ve
collected from pages that you’ve had time to peruse—and you have
a half-zillion tabs waiting for your attention, littering your windows.
Or perhaps you’re heading somewhere (like an airplane) where you
won’t have a connection but have some research to do across a dozen
Web sites. Either way, it’s the Reading List to the rescue (Figure 24)!

Figure 24: Unread items in the list are in black type, while items
you’ve already read are gray; use the All and Unread buttons to filter
the list. The Close button appears whenever you hover over an item
in the list.
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Share from the
Share Button
Fresh from its successful performance in iOS, the Share
button
has migrated to many aspects of Mountain Lion, including Safari 6.
Its menu is a shortcut to sharing the current Web page through
various routes.
The Share button is available only in the Mountain Lion version of
Safari 6, although some of its commands (the ones not dependent
on Mountain Lion built-in features) are available to Lion users
through regular menus and other buttons.

The Share Menu
The Share
button’s menu (Figure 26) includes six commands, two
of which stretch the meaning of “share” beyond its breaking point.

Figure 26: The Share button’s menu.

If you’re running Lion, you won’t have a Share button, or the ability to
share to Messages, Twitter, or Facebook, but you have alternatives for
the first three commands:
• Add to Reading List: Flip back to the previous chapter, Work
with the Reading List, to learn all about this feature. Alternatives
(and the only options for Lion users) are choosing Bookmarks >
71
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Set Up and
Use Bookmarks
Bookmarks are, at heart, simple things: pointers to pages you
want to revisit. But their flexibility—the different ways you can
store and access them, how they interact with tabs—make them
far from simple tools.
For years, I kept very few bookmarks on my bookmarks bar, and
most of the rest in what amounted to a big pile (nothing in folders
or subfolders), with little or no renaming of my bookmarks from
their default, often long-winded, titles. I bookmarked a lot of sites,
yet rarely used the bookmarks to go back to them because the lack
of organization made it too much of a bother—I wound up googling
to find them again.
Once I started exploring bookmark options and discovered their
versatility and power, however, I was converted—and I’ve been
proselytizing ever since. Knowing how convenient bookmarks
have made my browsing has encouraged me to become, and stay,
organized—a philosophy I have yet to apply to my closets. Naming
a bookmark and putting it in a folder when I first save it became
second nature to me in a very short time. (I still have a catch-all
bookmark folder for when I’m in a hurry or don’t know exactly
where I want to put something—just as I have a junk drawer in the
kitchen. And in the dining room. And in almost every other room.)

Set Your Bookmark Preferences
The Safari Preferences window has an entire pane devoted to
Bookmarks (Figure 29).
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Retrace Your Steps
through History
You certainly don’t remember all the places you’ve been on the
Web. But Safari does, and it provides a myriad of ways for you to
return to almost any site you’ve ever visited. Maybe you want to
return to page that you clicked away from ten links ago (and then
jump back to that tenth page); perhaps you want to return to a blog
you read last month but didn’t bookmark for easy reference. Or
maybe you just closed a multi-tabbed window and want it all back.
Safari can help you with those situations, and others.
Your overall browsing history is tracked by a series of bookmarks—
one for every page you view (yes, every page, not every site!). These
history bookmarks are divided into subsets for each day and are
available from the History menu and its submenus, as well as from
within the Bookmarks window through the History collection. (There’s
also a more ephemeral, and very convenient, history recorded for each
window and tab you work in; see View Recent Pages.)
History bookmarks? What’s the difference between the bookmarks
you create and history bookmarks? Just that you create your own
bookmarks for pages to which you’d like to return, and put them in
various easy-to-access places, while Safari automatically bookmarks
every single page you visit and puts them in the History collection.

Define Your History Range
Set the limit for how long your history lasts with the Remove History
Items pop-up menu in the General pane of Safari Preferences
(Figure 37). In the absence of any choice between the too-short onemonth option and the perhaps too-long one-year option—four to six
months would feel about right!—I suggest you choose After One Year.
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Stealth Browsing
Maybe you’re at your desk during a coffee break and, in fear of
being downsized, you start surfing some job sites. Maybe you and
your spouse share a computer without separate accounts and you’re
researching a super-special anniversary present. Maybe you realize
you’re leaving an easy-to-follow trail, so you choose History > Clear
History to erase your footprints. Not enough! Not nearly enough.
Like sloughed-off, DNA-laden skin cells at a crime scene, browsing
leaves telltale signs of your presence in ways that probably don’t
occur to you. A savvy snoop can check all sorts of Safari detritus,
such as its cache files and cookies, and even its collection of “Web
site icons ” (Safari’s nomenclature for favicons, the little icons
in front of a URL in the address field). Your Top Sites view and
the Web search field drop-down can give you away, the Downloads
list displays recent downloads, and the AutoFill pane in Safari
Preferences displays a non-protected list of your user names for
various sites. (I’m talking about privacy here, but those user names,
and the AutoFill function, present security issues as well.)
In this chapter, I tell you how you can keep your browsing history
secret with details on private browsing, handling your cookies, and
resetting Safari.

Secret Surfing
If you’re merely going down a temporary path that you want to keep
private, and not worried about the rest of your browsing history,
choose Safari > Private Browsing. Safari will suffer amnesia until you
turn off the privacy setting: your history isn’t tracked, new AutoFill
information isn’t stored, searches aren’t added to the Web search field
drop-down, downloads aren’t added to the list, and tabs are not sent
to iCloud. Although changes to existing cookies are discarded as soon
as you exit private browsing mode, any new cookies created while
you browse remain. If you “leave” private mode by crashing, however,
Safari won’t have a chance to clean up the cookie changes and you
might want to attend to that yourself (see “C Is for Cookie,” next).
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Know Your Search Options
Safari offers three distinct types of searching: across the seemingly
boundless Web, within the currently displayed Web page, and
through the titles and content of the pages in your history and
bookmarks collections. In fact, when you type something in Safari
6’s new unified address and search field, its drop-down menu
provides suggestions in all three areas.

Search the Web
When it comes to searching across the vastness of the Web, Safari
is merely a conduit to the mighty search engines Google, Yahoo, and
Bing (okay, some are mightier than others). So, the first thing to do is
choose your favorite:
1. Open Safari’s General preferences.
2. Choose something from the Default Search Engine pop-up menu.
Set Your Web-Search Preferences
Safari’s search field is wired directly to each search engine, so set
your search preferences at each site:
✦ http://www.bing.com/preferences.aspx
✦ http://www.search.yahoo.com/preferences/preferences
✦ http://www.google.com/preferences
Extension Alert! Google Search Cleanup gets rid of advertising and
text-menu clutter from the Google results screen.

When you start typing in the new combined address/search field,
Safari gets to work looking everywhere—your history, your
bookmarks, the current page, and even with the search engine of your
choice. It then presents a little of everything in its drop-down menu.
If there’s a Top Hit from your history or bookmarks, it gets pride of
place in the menu, but suggestions for possible search terms get more
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Use AutoFill for
Forms and Passwords
Safari’s AutoFill feature helps fill in the blanks on Web pages—
for forms and even user name and password information. It uses
information from the sources you’ve allowed, and it can fill in fields
on a Web page one at a time or in one fell swoop.

Turn On AutoFill Sources
Safari can gather form-filling information from three sources, but you
have to tell it which ones it’s allowed to use:
1. Open Safari Preferences and click AutoFill (Figure 44).

Figure 44: The Edit buttons in AutoFill are somewhat misleading:
only the first lets you edit information, by opening your card in
Contacts (or Lion’s Address Book). The other two open lists for which
your only editing option is deleting entries.

2. For the most complete AutoFill behavior, check all the choices:
‣ Using Info from My Contacts Card: Your card can store the
frequently asked-for basics of name, address, phone, and email.
This card should have been automatically created as part of your
Mac OS X setup. You can find it in Contacts (or Address Book)
by choosing Card > Go to My Card. If you don’t have an official
card, create or go to your existing card, and choose Card > Make
This My Card to identify it as yours.
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Track Your Downloads
Most of us don’t give a second thought to downloads: click a link,
download, perhaps the download auto-opens, and we move on. A
little attention to the details, however, never hurts—and might help.

Set the Download Preferences
There are three download-related items in the General pane of Safari
Preferences (Figure 47).

Figure 47: Default (and also the recommended) settings for
download-related items in Safari Preferences.

These options are best left at their defaults:
• Save downloaded files to: The default Downloads folder is the
logical place; the only reason to change the download location is to
prevent the commingling of Web downloads and email attachments
from Apple Mail, both of which use this folder as a default—but I
recommend changing Mail’s download folder instead. (Do you think
of email attachments as “downloads”?)
Tip: Keep your Downloads folder in the Dock. It bounces once when
a download is complete—a nice little alert—and you can sort the
folder’s contents by Date Added to get to the latest download quickly:
Control-click the Downloads icon in the Dock icon and choose Date
Added.)
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Expand Safari’s
Capabilities
with Extensions
Extensions are small programs that extend Safari’s functionality
by adding missing features or improving existing ones. The addition
could be as tiny as adding a button to the toolbar that takes you
directly to a weather report for your area. Or, it could be much
larger, and more useful: blocking annoying ads from appearing,
letting you navigate from one link to another on a page using just
the keyboard, providing previews of Web pages on a Google results
page, or adding an entire bar at the top of the Safari window to
display a news feed or Twitter messages.
Apple’s Extensions Gallery is the official hub for Safari extensions,
but others are available directly from developers.

Install Extensions
You can download and install extensions both from Apple’s Extensions
Gallery and from developers’ Web sites. What’s the difference? A layer
of security. Extensions in the Gallery get a signed digital certificate
from Apple, which ensures that any updates come from the original
developer. Also, through a practice called “sandboxing,” Gallery
extensions are designed so that they can interact only with Safari,
and can’t talk to your operating system or secretly give information
to Web sites (some extensions are supposed to provide Web sites with
information—but not secretly).
Safari’s extensions capability is turned on by default, but to make sure
you have it turned on:
1. In Safari, choose Safari > Preferences and click the Extensions
button.
2. At the upper right, click to toggle on Extensions, if necessary.
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Appendix A: Create a WebClip Widget
If you use Dashboard a lot, you’ll find it convenient to have a Web
page snippet, or “clip,” as a widget for quick reference, whether it’s
tomorrow’s weather, today’s stocks, or a joke-of-the-day.
(Don’t use Dashboard? Don’t know what it is? It’s an application,
on your Dock by default but also in your Applications folder,
that displays a bunch of tiny applications, called widgets, that do
everything from tracking the weather to checking what’s in your
local movie theaters to tracking the stock market to—of course—
playing games.)
To create a widget from part of a Web page:
1. Go to the Web page you want to clip.
2. Choose File > Open in Dashboard, or click the Open in Dashboard
button if it’s on your toolbar.
3. The Web page dims and a large bright patch follows your cursor
around (Figure 55).
4. Move the cursor to the spot on the page that you want to clip; the
bright rectangle resizes to fit each article as you pass over it.
Not everything can be clipped: “Clippability” depends on the
Web page design; the rectangle resizes itself only over clippable
articles or graphics.
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About This Book
Thank you for purchasing this Take Control book. We hope you find
it both useful and enjoyable to read. We welcome your comments at
tc-comments@tidbits.com.

Ebook Extras
You can access extras related to this ebook on the Web. Once you’re
on the ebook’s Take Control Extras page, you can:
• Download any available new version of the ebook for free, or buy
subsequent edition at a discount.
• Download various formats, including PDF, EPUB, and—usually—
Mobipocket. (Learn about reading this ebook on handheld devices
at http://www.takecontrolbooks.com/device-advice.)
• Read postings to the ebook’s blog. These may include new
information and tips, as well as links to author interviews. At the
top of the blog, you can also see any update plans for the ebook.
If you bought this ebook from the Take Control Web site, it has been
automatically added to your account, where you can download it in
other formats and access any future updates. However, if you bought
this ebook elsewhere, you can add it to your account manually:
• If you already have a Take Control account, log in to your account,
and then click the “access extras …” link above.
• If you don’t have a Take Control account, first make one by
following the directions that appear when you click the “access
extras …” link above. Then, once you are logged in to your new
account, add your ebook by clicking the “access extras …” link a
second time.
Note: If you try the directions above and find that the device you’re
reading on is incompatible with the Take Control Web site, contact us
at tc-comments@tidbits.com.
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About the Author
It’s hard to believe that I’ve been writing about computers since before
the Mac was born. There were personal computers before the Mac??
Ah, yes, my first: the Timex-Sinclair with its 2K of RAM (that’s not a
typo, and it was a thrill when the 16K RAM pack became available) and
cassette-tape storage. Good old days? Not by a long shot!
But I’ve been writing about the Mac since it arrived on the scene—
many hundreds of print articles, twenty or so (paper) books, and now
electronic-based dissemination of Mac info—and haven’t tired of it
yet (and I tend to become bored rather easily). We generally have
about three times as many computers in the house as people, along
with such necessities as a Time Capsule, an iPad, iPod touches, and
soon another iPhone.
In addition to a university-professor husband whose Macophilia rivals
my own, I have two grown sons occasionally back in the all-too-briefly
emptied nest due to the vicissitudes of the economy and job market—
once they somehow coordinated moving back the exact same week. We
live in New Jersey, just a few miles outside of Manhattan (a statement
I add for the comfort of my New-York-born-and-raised husband—and
you should understand that when we say “New York” around here, it
means New York City, not the state).

Author’s Acknowledgments
If I say “thanks, as usual” that doesn’t diminish the gratitude. So,
thanks, as usual, to Tonya Engst for her direction and editing. And her
friendship.
Thanks also to Michael E. Cohen—I don’t know what the E stands for
(Editor?)—for his round of editing on the first edition of this book. I
hope he enjoyed the collaboration as much as I did. (How can you not
love an editor who muses in a margin note: I wonder if the One Ring
was Sauron’s horcrux?)
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Featured Titles
Click any book title below or visit our Web catalog to add more
ebooks to your Take Control collection!
Take Control of Apple Mail in Mountain Lion (Joe Kissell) Learn
the basics and go under the hood with Apple’s Mail application in
OS X 10.8.
Take Control of iCloud (Joe Kissell): Understand the many features,
get set up properly, and enjoy iCloud!
Take Control of Making Music with GarageBand ’11 (Jeff Tolbert):
Combine your creativity with GarageBand’s editing and mixing
techniques to compose tunes that please the ear!
Take Control of Maintaining Your Mac (Joe Kissell): Find a
commonsense approach to avoiding problems and ensuring that your
Mac runs at peak performance.
Take Control of Making Music with GarageBand ’11 (Jeff Tolbert):
Combine your creativity with GarageBand’s editing and mixing
techniques to compose tunes that please the ear!
Take Control of Recording with GarageBand ’11 (Jeff Tolbert): Create
musical compositions with vocals, drums, guitars, and even the kitchen
sink!
Take Control of Scrivener 2 (Kirk McElhearn): Write your screenplay,
novel, or dissertation with the author-focused features in Scrivener!
Take Control of Spotlight for Finding Anything on Your Mac (Sharon
Zardetto): Whether by mouse or menu, or by typing a complex query,
you’ll learn how to find your files, contacts, images, and much more.
Take Control of Using Mountain Lion (Matt Neuburg): Chockablock
with core concepts and insider tips on customizing and navigating in
10.8 Mountain Lion.
Take Control of the Mac Command Line with Terminal (Joe Kissell):
Learn the basics of the Unix command line that underlies Mac OS X,
and get comfortable and confident when working in Terminal.
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