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Read Me First 
This ebook was published in November 2018 by alt concepts inc. It was 
written by Jason Snell and edited by Scholle McFarland. 

This book helps you get started with Apple’s Photos app for macOS 
and iOS. It focuses on importing libraries from older apps, managing 
your media inside Photos, and using Photos to edit and share your 
media with friends, relatives, and the world at large. 

Take Control of Photos, version 1.0 

Copyright © 2018, The Incomparable Inc. All rights reserved. 

Updates and More
 

You can access extras related to this ebook on the web (use the link 
in Ebook Extras, near the end; it’s available only to purchasers). On 
the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
any subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. You may find new tips or information, as 
well as a link to an author interview. 

If you bought this ebook from the Take Control website, it has been 
added to your account, where you can download it in other formats 
and access any future updates. However, if you bought this ebook 
elsewhere, you can add it to your account manually; see Ebook Extras. 
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Basics
 

To review background information that might help you understand 
this book better, such as finding System Preferences and working with 
files in the Finder, I recommend reading Tonya Engst’s ebook Take 
Control of Mac Basics. 
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Introduction 
In 2002, Apple introduced iPhoto as a way for us to save our photos on 
our Macs inside a “digital shoebox.” At the time, I’d owned a digital 
camera for three months, and had only a few hundred digital images. 
Over the years, as my photo library grew, Apple revised iPhoto, always 
trying to stay in front of the onslaught of thousands of digital photos 
accumulated over a lifetime—at least the lifetime of my two children. 

By 2014, enough was more than enough. Apple decided it needed to 
start from scratch and ditch iPhoto and replace it with a single applica-
tion, which would be called—in the prosaic style favored by Apple for 
its iOS apps—Photos. This would allow Apple to unify (more or less) 
the photography apps it was creating for both macOS and iOS. 

In this book, I’ll describe how to perform essential tasks with Photos— 
in both macOS and iOS. Apple deploys some of the most powerful 
functionality it has developed—including its iCloud servers and its 
machine-learning technology—in the service of making your photo 
library more accessible and discoverable. 

My daughter, whose birth was the motivator for my very first digital-
camera purchase, is about to graduate from high school. Her entire life 
has been chronicled with digital photos—tens of thousands of them at 
this point. That catalog, which spent time in several photography apps 
including iPhoto, now resides in my iCloud Photos, accessed via 
Photos on macOS and iOS. Photography is how we preserve the images 
of our lives; it’s important that we understand the software that allows 
us to organize, view, and share those images. That’s what you’ll learn 
with this book. 

The version of the book you are reading has been updated to reflect the 
changes in Photos version 4.0, which was released along with macOS 
10.13 Mojave and iOS 12 in September 2018. You can find an overview 
of the changes by reading What’s New in Photos. 

Thanks for joining me on this journey. Let’s get started! 

7
 

Click here to buy the full 156-page “Take Control of Photos” for only $14.99!

https://www.takecontrolbooks.com/cart?add-to-cart=1247


         
       

              
   

  
           

       

          
            

  
         

    
         

   

        
           

         
            

           
    

 
          

         
  
           
         

     

Photos Quick Start 
This book explores Apple’s Photos app (in both macOS and iOS) by 
walking you through the most essential photo-management and 
editing tasks. You can read the chapters in any order. Click any link to 
jump to a topic. 

Find out what’s new: 
•	 Discover what you have to look forward to with Photos in 10.14 

Mojave and iOS 12 in What’s New in Photos. 

•	 If you’re just now switching to Photos from Apple’s venerable 
iPhoto app, you can get a rundown of the differences in Switch from 
iPhoto. 

Import and manage photos: 
•	 Photos for macOS and iOS can import files directly from your 

camera or memory card. Read Import Your Files into Photos. 
•	 You can switch between libraries to keep collections separate. See 

Manage Multiple Photos Libraries. 

Get organized: 
•	 Apple includes machine-learning technology in Photos that allows 

the app to identify objects, animals, and faces. Read Use Search to 
Find Your Photos to take advantage of this exciting feature. 

•	 Want to quickly round up all the photos of your kids taken with 
your DSLR within the last year? Take advantage of your valuable 
metadata in Define Smart Albums. 

Perfect your photos: 
•	 Give photos a little extra “pop” in macOS or iOS by cropping, 

applying filters, and fixing red-eye and rotation problems. See Make 
Quick Photo Fixes. 

•	 Learn how to Make Edits to Your Photos by removing unwanted 
details and applying adjustments, as well as editing with external 
apps like Photoshop if you prefer. 
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Explore your collection: 
•	 Remember Christmas 3 years ago? Photos does. Peruse Photos-

generated collections of your photos, including a map of locations, 
associated people, and (in Photos for iOS) a customizable movie. 
Check out Unearth Old Photos for much more. 

•	 Get a handle on how Apple automatically identifies the people in 
your photos, as well as how to put names to faces in Find and Name 
People. 

Connect with other devices: 
•	 Thanks to the cloud, you can access your entire Photos library from 

any device you own. But you’ll need to change the way you think 
about managing your photos to make it work. Read Sync with 
iCloud Using Photos. 

•	 Admire your favorite photos on your big-screen TV when you View 
Photos on Apple TV. 

Show off your photos: 
•	 Don’t let your photos stay locked up on your Mac. Learn the easiest 

ways to Share Your Photos with others using social media and 
more. 

•	 If your desired method of sharing your photos involves getting them 
out of Photos, try Export and Resize Images. 

•	 Turn a special event’s photos into a beautiful movie with its own 
soundtrack. See Make Slideshows in Photos. 

•	 For all the convenience of digital photos, there’s still nothing quite 
like holding an image of loved ones in your hands. Discover how to 
use new third-party extension apps to design printed calendars and 
books. See Build Books and Calendars. 
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What’s New in Photos 
In macOS Mojave and iOS 12, Photos has grown and changed. Here 
are the highlights of the biggest changes in the new versions of Photos. 

Changes in Photos for iOS
 

Apple actually made some nice changes to Photos in iOS 12, revamping 
parts of its interface and upgrading search features: 

•	 In iOS, Photos has gained the capability to search for multiple items 
at once, which makes it much easier to zero in on exactly the photo 
you’re looking for. See Use Search to Find Your Photos. 

•	 A new For You tab provides a single place to see recently shared 
photos, memories, effect suggestions, and more. See Navigate 
Photos for iOS. 

•	 The Import tab has been given a major update. See Import to iOS. 

Changes in Photos for Mac
 

The Mac version of Photos didn’t quite take macOS Mojave off, but its 
changes have been minimal: 

•	 Keyboard shortcuts have been changed. See Navigate the Photos 
Interface. 

•	 Perhaps most notable are the features that have been removed— 
those for making calendars, books, and other printed materials. 
However, several companies have released extensions for Photos 
that offer comparable functionality. See Build Books and Calendars. 

10
 

Click here to buy the full 156-page “Take Control of Photos” for only $14.99!

https://www.takecontrolbooks.com/cart?add-to-cart=1247


            
            

              
            

             
     

             
           

            
         

          
          

           
           

         
  

            
          

         
        

             
            

          
          

 

Switch from iPhoto 
It’s been several years since Apple officially declared iPhoto a dead app 
and replaced it with Photos, but for some of us the migration from 
iPhoto to Photos has been a slow one. Photo libraries may be the most 
precious troves of data on our computers, and the prospect of moving 
them to a new app—one that abandons some of the concepts of the 
current app, no less—can be daunting. 

The truth is, in most ways, Photos is just an expanded and updated 
version of iPhoto with a new name. A few organizational features have 
been lost, the interface is more refined, deep connections to iCloud and 
Apple’s machine-learning technology have been added, and the app 
feels faster. Photos can import your iPhoto library (see Import from 
iPhoto into Photos). iPhoto’s star ratings have been demoted to key-
word status, flagged items are now Favorites, and iPhoto Events are 
now just another kind of photo album. Photos also offers numerous 
improvements to iPhoto, including expanded editing tools and direct 
integration with iCloud. 

With a little time, iPhoto users should be able to settle in comfortably. 
In this chapter, I’ll show you how to make the switch. 

Tip: For a closer look at the pros and cons of switching, see Rob 
Griffiths’ article “An in-depth look at moving from iPhoto to Photos.” 

Import from iPhoto into Photos
 

If Photos is the spiritual successor to iPhoto, it’s only right that Photos 
can import your iPhoto library, and do so while keeping it intact—more 
or less (Figure 1). Because the features of Photos don’t align precisely 
with those in iPhoto, some information from iPhoto ends up in unex-
pected locations. 
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Figure 1: An iPhoto library (left) migrates to Photos (right). 

You’ll need to get used to the changes in Photos—and be prepared to 
change your approach to organizing your media—but Apple has 
worked to make the migration process as painless as possible. 

Don’t Use iCloud (Yet!) 
On first launch, Photos asks if you’d like to use iCloud Photos. I 
recommend that you decline for now, and read the Sync with iCloud 
Using Photos chapter before committing. 

Don’t worry—it’s quite easy to turn on iCloud Photos at any time. 

Import Automatically 
The first time you launch Photos, it searches your system for iPhoto 
and Aperture libraries. If only one library fits the bill, it imports that 
library. Otherwise, it opens the Choose Library dialog (see Manage 
Multiple Photos Libraries). Choose a library from the list, and Photos 
prepares the library for import. 
In some cases, macOS may import your iPhoto library before you ever 
open Photos. Don’t worry—iPhoto will warn you if this has happened, 
and you can delete that unedited Photos library and re-import from 
iPhoto at any time without penalty. 
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Import Your Files into 
Photos 

While iCloud can automatically add all the photos you take on your iOS 
devices to Photos on the Mac (see Sync with iCloud Using Photos), the 
traditional way of adding items to a Photos library is by connecting a 
device or memory card directly (Figure 4). 

Figure 4: When you attach a camera or insert a memory card, 
Photos displays its contents in the Import pane. 

Tip: See Import to iOS if you want to move your images directly onto 
an iOS device. For information about importing an entire library into 
Photos, see Import from iPhoto into Photos. 

First, you’ll need to decide whether to import photos directly into 
Photos from your camera (either via USB or by inserting a memory 
card) or to first import them using Apple’s Image Capture app and 
then add them to Photos. If you plan to modify your images in some 
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way before Photos ingests them, or if you’d prefer to manually manage 
where your files are stored, use the second approach. 

Import from a Camera
 

If you’re shooting photos (or capturing video) with a standalone 
camera, or with an iOS device that isn’t syncing with iCloud, you’ll get 
your files into Photos by attaching the device or its memory card to 
your Mac. 

When you attach a device that your Mac registers as one containing 
photos and/or videos, your device appears automatically in the Devices 
section of the sidebar. 

Skip Photos Already in Your Library 
When you attach a device, Photos scans its contents and compares 
them to its current library. If Photos finds the same images in both 
places, it collects these items at the very top of the Import pane, 
marked as Already Imported (Figure 5). Below that, it shows photos 
that aren’t yet in the library, labeled as New Items. 

Figure 5: Photos points out items you’ve already imported into its 
library. 

18
 

Click here to buy the full 156-page “Take Control of Photos” for only $14.99!

https://www.takecontrolbooks.com/cart?add-to-cart=1247


 

            
          

           
   

    
 

    
        

 

         

      

    

       

  

       

         

Manage Multiple Photos 
Libraries 

Most people will probably use a single library with Photos. But if you 
want to keep strict separation between different media collections, it’s 
easy to create multiple libraries in Photos on the Mac and switch 
between them (Figure 15). 

Figure 15: Two different Photos libraries, with entirely different sets 
of media. 

Reasons to Have Many Libraries 
There are plenty of scenarios that might lead you to want more than 
one library: 

✦ Create one for each client, if you’re a freelance photographer. 

✦ Keep your work photos separate from the family stuff. 

✦ Let your kids mess with their photos without trashing your library. 

✦ Separate the files you want to sync to iCloud from ones you don’t. 

Add a New Library
 

Here’s how to create a new Photos library: 

1. Hold down the Option key as you open Photos. 
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2. In the Choose Library dialog that appears (Figure 16), click the 
Create New button. 

Figure 16: Hold down Option while opening Photos to see the
 
Choose Library dialog.
 

Photos asks you to choose where on your Mac’s drive you want to save 
the new library file. 

Switch Between Libraries
 

Hold down the Option key as you open Photos. In the Choose Library 
dialog, do one of the following: 

•	 If one of the listed libraries is the one you want to open, select it and 
click the Choose Library button. 

•	 To open a Photos library that isn’t listed, click Other Library. 

Note: The Choose Library dialog lists any importable library it can
 

find—the app actually searches your Mac for any Photos libraries as 

well as not-yet-imported Aperture and iPhoto libraries.
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Navigate the Photos 
Interface 

The macOS Photos interface (Figure 19) is a study in minimalism: 
most of the action takes place in a single window, which you navigate 
through by clicking on items in the sidebar. (Of course, that approach 
doesn’t quite translate to the iOS version—see Navigate Photos for 
iOS.) 

Figure 19: The main Photos interface features a sidebar on the left; 
clicking in the Photos view brings up a tab bar at the top of the 
window. 

If you make the window very narrow, the sidebar vanishes and you 
have to navigate entirely from the menu bar. I don’t recommend it. 
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A Quick View of Selections 
In the top right corner of the Photos window, you’ll see text indicating 
how many items are currently selected. You can drag the thumbnail 
image to the right of the text as a proxy of the entire selection, 
whether it’s into a different app or just into a photo album. 

Just below the selection indicator is a filter interface; click the text 
next to Showing and you can quickly filter the view to show only 
favorites, edited images, photos, or videos. 

Browse Your Library
 

The most important part of the Photos app is probably the Library 
section of the sidebar, most especially the Photos section, which lets 
you browse every media file in your library. 

When Photos is selected, you’ll see four buttons at the top of the 
screen. Each of these corresponds to a different view of the photo 
library, moving from the most granular to the broadest overview. 
Photos displays your entire library; Moments displays the library 
separated into different sections based on time and location; Collec-
tions summarizes multiple-day events; and Years zooms way back to 
let you browse your collection quickly by year. 

Scrub Through Your Photos 
In the Collections and Years views, Photos shows your library in 
collages of tiny thumbnails. You can click and drag over the 
thumbnails to see a larger version of each image as you move over it 
(Figure 20). Release the button and Photos opens the image you were 
viewing in the main window. 
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Manage Your Photos 
Apple knows most of us don’t have a lot of time to organize our photo 
libraries. Even though Photos deeply analyzes each image to figure out 
its contents, it still can’t divine everything about a photo—at least, not 
yet. That’s why Photos also contains a set of simple organizational 
tools that let you embed additional meaning into the images you’ve 
captured. 

Play Favorites
 

Some of us like to precisely quantify things. I knew a kid in high school 
who actually rated every movie he watched on a five-star system. (He 
grew up to be a movie critic—true story!) But most of us can’t be 
bothered with complex ratings systems, so Photos uses a simpler 
approach: Favorites. 

In thumbnail views, all your Favorites appear with little white hearts in 
their bottom-left corner (Figure 30). Awwww. (There’s even a subtle 
drop shadow, so if that corner of your photo is white, you can still see 
the heart.) 

Figure 30: Find the fave: it’s the one with the white heart in the 
bottom-left corner. 

Click Favorites in the sidebar and you’ll see just your very best shots, 
as judged by you (Figure 31)! 
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Figure 31: If I had a favorite view of my photos, it would probably 
be quite similar to the Favorites view. 

Make a Favorite on the Mac 
There are plenty of ways to mark a photo as a Favorite: 

• Select an image and then click the heart icon located toward the 
right side of the toolbar (Figure 32). 

Figure 32: Show your love with the heart icon. 

• Select an image and press the Period (.) key. 

• Hover your pointer over the image and click the heart that appears 

• Select an image and choose Image > Add to Favorites. 

• In the Info window (press ⌘-I), click the heart in the upper-
right corner. 

Make a Favorite in iOS 
Unfortunately, Photos for iOS doesn’t really let you do much in the way 
of adding more information to your photos. You can’t even add key-
words. You can create albums (see Make Albums in Photos) and you 
can mark items as Favorites. 

To favorite a photo, tap its thumbnail to view it full-screen and then 
tap the heart icon in the toolbar. (If the heart is filled in, the image 
is a favorite. You can un-favorite the photo by tapping it again.) 
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Find and Name People 
Photos performs 11 billion computations on every photo to analyze its 
contents for faces, scenes, and objects. But while Photos is good at 
recognizing faces, it’s terrible at putting names to those faces. Unless 
you’ve been diligent about adding everyone whose picture you take to 
the Contacts app (complete with a picture that Photos can use to 
identify them), you’ll need to do some work in the People view (Figure 
36), located in the Library section of the sidebar, to teach Photos who’s 
who. 

Figure 36: The People view is a catalog of familiar faces, and it’s 
where you teach Photos who is who. 

Find All Photos for a Person
 

The People view contains all the faces Photos has identified and 
connected to a name. If you want to find photos of a specific person, 
this is the place to go—just double-click an item to see all the photos 
that Photos has matched to that face. 

Having your photos tagged based on who’s in them is a great organiza-
tional tool. For example, when it’s time to find photos of my family for 
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our holiday cards and annual calendars, I use a smart album that 
displays photos containing all four of our faces (see Define Smart 
Albums). It’s sobering to discover that in a full year, you were pho-
tographed with your family fewer than ten times. 

Fix Your Face 
If you don’t like the picture that represents you (or someone else) in 
the People view, you can fix that: 

1. Double-click the face. 

2. Scroll down and find a better picture. 

3. Control-click the image and choose Make Key Photo.
 

Photos reassigns the default image.
 

Name and Merge People
 

Apple’s face recognition engine is really good at finding faces. Once it 
had done its job on my 79,000-image library, it had found 1,000 
different faces and plopped them into my People window. Of course, it 
doesn’t know who most of those people are, and you’ll find that the 
same people will be listed multiple times. It takes a little work to get 
your People list in order, though every move you make helps the face 
recognition engine learn and improve so that it’s better at matching 
other faces across all your devices. 

To associate a name with an unnamed face in the People view, move 
the pointer over any unnamed face and click Name. Then begin to type 
that person’s name. 

As you type, a pop-up menu suggests people Photos already knows 
about via its own catalog of faces or your Contacts app (Figure 37). If 
one of those is the person you’re looking for, select it. Otherwise, just 
type the person’s name and press Return. 
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Use Search to Find Your 
Photos 

All the images in your Photos libraries are scanned millions of times 
with machine-learning algorithms to identify faces, as well as more 
than 4,000 different scenes or objects (see Find and Name People for 
more on face-detection). This makes the Search feature in Photos 
incredibly powerful. Want to find a photo featuring a dog? Just type 
dog in the search box. The automatically generated Dog category will 
provide you with possibilities (Figure 41). And that’s just the begin-
ning. 

Figure 41: Photos can do tricks like identify dogs in photos. (No-
body’s perfect, though—it also found a few cats.) 

The Search Box Is Your Friend
 

Some people use search boxes habitually. Others see them as a last 
resort. If you’re in the latter camp, you need to break from tradition 
when you use Photos. The Search feature in Photos is terrific. You can 
quickly search keywords (Figure 42), titles, or descriptions. Enter a 
year, or a month and a year, and you see all the photos taken during 
that time. 
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Figure 42: Type the name of a location (here, the island of Kauai) 
to see all the pictures you took there. 

I rely on the Search feature for navigating my library of more than 
70,000 photos, and I highly recommend it. When in doubt, use the 
search box! 

On the Mac, if you don’t see the search box in the upper-right corner, 
back out to a broader viewing level, such as the main level of an album. 

In iOS, if you don’t see the search box, make sure you are in the main 
level of Photos, Memories, or Albums and tap the Search icon. 

Quickly Jump to Dates 
Type a month and year combination to quickly see all photos taken
 

on that date. So, for example, I enter August 2004 to see all the
 

images from the month my son was born.
 

Experience Rich Search Results in iOS 
In iOS 12, Photos takes a step forward when compared to macOS 
Mojave. Search results on iOS are incredibly rich. When you search for 
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Unearth Old Photos 
The Memories view in macOS (Figure 49) and the For You tab on iOS 
present you with collections of photos and videos based on times, 
place, or theme, so you don’t have to do the work to gather everything 
together. 

Figure 49: The Memories pane shows collections of images and 
videos that Photos thinks you might like. 

The Memories view is located under Library in the macOS sidebar and 
on the For You tab in iOS, and contains a scrollable list of rectangles 
labeled with what they contain. Memories are organized automatically 
by Photos based on a few different concepts: the recent past (“Best of 
Last Month”), this same time in a previous year (“On This Day”), 
locations (“Kauai”), and even themes (“In Nature”). It may seem a bit 
scattershot, but the idea is to help rediscover photos that you’d never 
otherwise revisit. 
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To begin reliving a Memory, double-click any item in the Memories 
pane. 

What’s In a Memory?
 

Every Memory begins with a large header image and text describing 
the Memory. In iOS, this is actually a video you can edit. (See Edit a 
Memory Video, later in this chapter.) 

Below this is an automatically generated summary of what Photos 
considers the “best” images from this Memory. Click Show All to see all 
the photos and videos that are a part of the Memory. 

A Memory page can also feature groups and people who appear togeth-
er in this Memory (Figure 50), a map of locations represented within 
the Memory, and related Memories. 

Figure 50: A Memory also displays people and groups, a map of 
locations, and related Memories. 
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Make Albums in Photos 
Just because Apple has put effort into automatically organizing your 
photos doesn’t mean you can’t do it yourself if you prefer. After all, 
there’s only so much nuance a computer can bring to organizing our 
photo libraries. You can create your own collections of items in the 
Albums section (Figure 53). 

Figure 53: Click the Media Types or My Albums folders for a view of 
all the items contained inside. 

This chapter begins by looking at albums in macOS, and ends with a 
discussion of how to Use Albums in Photos for iOS. 

Find Your Albums
 

At the top of the Albums section, you’ll find a folder called Media 
Types, which filters all your items down into media with special 
attributes, such as selfies, panoramas, portrait mode, live photos, 
videos, screenshots, GIFs, and bursts. 
There’s also a My Albums folder, where you’ll find all the albums 
you’ve created, manually or via smart albums (see Define Smart 
Albums). 
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Make a New Album
 

To create a new album, choose File > New Album (⌘-N). If you didn’t 
select anything, the album will be empty. Otherwise, you get a new 
album made from the photos you’ve selected. 

Sorting Your Albums 
Organize your albums by selecting an album and dragging it into 
place in the sidebar. Alternatively, choose View > Sort and select an 
item, like By Name or By Newest First, from the submenu. 

You can also sort the photos contained in albums; see the sidebar
 

Sorting Photos in Albums, later in this chapter.
 

Add Photos to an Album
 

Unless you’re very lucky and select just the right images for your 
album the first time, you’ll probably want to add items to your album 
afterward. Here’s how: 

•	 Add photos to an album by dropping them over the album in the 
sidebar. 

•	 Select items in Photos and choose Image > Add To and pick an 
album (Figure 54). (If you’ve recently created an album, you can 
press ⌘-Control-A to add the photos directly there.) 
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Sync with iCloud Using 
Photos 

While Photos works fine as a standalone image library, it’s built to 
connect with Apple’s online service, iCloud. With iCloud Photos, all 
your devices can view items stored in a single online library—and add 
new items to it, giving you access to every item in your media collec-
tion from any device (Figure 62). 

Figure 62: Check the iCloud Photos box in Photos > Preferences > 
iCloud to sync with iCloud. 

Uploading your library to iCloud adds convenience and a measure of 
safety to your photo collection, but there are numerous complications 
to this process, too. 

The Cost of Cloud Storage 
As of this writing, every Apple ID comes with 5 GB of free iCloud 
storage. 50 GB of iCloud space (including not just your photos but 
your iOS backups and iCloud Drive files) costs $0.99 per month, 
200 GB costs $2.99 per month, and 2 TB costs $9.99 per month (To 
check the latest pricing and rates for different countries, see Apple’s 
iCloud storage plans and pricing page.) 

At the high end, that’s a better deal than Google Drive or Dropbox, 
which charge $9.99 and $8.25 respectively per month for 1 TB. But 
Amazon now offers unlimited photo storage free for Prime members, 
and Google Photos offers free unlimited storage space—so long as 
your photos are limited to 16 megapixels and your video files to 
1080p. 
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Set a System Photo Library
 

iCloud syncing will work only with a single library on your Mac, which 
Apple refers to as the System Photo Library. It’s generally the first 
library that you opened when you started Photos. You can have as 
many libraries as you like (see Manage Multiple Photos Libraries), but 
only one can sync to iCloud. 

To change the System Photo Library: 

1.	 Hold down the Option key and launch Photos. 
2.	 Select the library that you want to sync via iCloud, and click Choose 

Library. 
3.	 Choose Photos > Preferences > General. 
4.	 Click the Use as System Photo Library button (Figure 63). 

Figure 63: Click Use as System Photo Library to make your current-
ly open library iCloud eligible. 

Turn On iCloud Syncing 
iCloud syncing is an all-or-nothing proposition. To turn it on, choose 
Photos > Preferences > iCloud and select the checkbox next to iCloud 
Photos. Photos immediately begins uploading the entire contents 
of your library to iCloud. 

Choose to Keep Local Copies 
I have 14 years of digital-camera files in my photo collection, so many 
that I use an external drive to store them. (The drives inside my com-
puters aren’t big enough!) 
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Make Quick Photo Fixes 
Photos has a bunch of simple tools that can improve your images 
quickly and without a lot of fuss. A few don’t even require you to enter 
image-editing mode. In this chapter, I focus on these “quick-fix” 
options. For more advanced editing, see the next chapter, Make Edits 
to Your Photos. If you’re working in iOS, see Process Photos in iOS, at 
the end of this chapter. 

Edit without Fear 
You can always go back to your original image: click the Revert to 
Original button in the toolbar or choose Image > Revert to Original. 
This feature is also available in the Edit pane. Photos always stores a 
copy of your original image. 

Edit Without Editing
 

Two of the quick-editing features in Photos are so quick, they don’t 
even require you to enter editing mode. These items appear on the 
toolbar in the top right of the Photos window. Rotation is accessible at 
all times, and Auto Enhance is accessible after you double-click on any 
photo. 

Use Auto Enhance 
While Photos gives you lots of tools to tweak your images very 
carefully, it also offers a sophisticated auto-enhance feature, which you 
can activate by pressing ⌘-E or (after having double-clicked the 
photo) clicking the Enhance icon in the toolbar. When you Enhance 
an image, Photos analyzes it and makes its best guess about the proper 
levels, color, and more. 

Since it’s operated by a computer and not a human, the Enhance icon 
won’t solve every problem. Sometimes it will make your photo look 
worse, and other times it can be a bit too timid (Figure 67). But it’s 
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always worth a try if you’re not confident using the more advanced 
features under the Adjust icon. 

Figure 67: The Enhance feature tries to improve your photo, but 
usually doesn’t overdo it. (Here, the right image is enhanced; the left 
is the original.) 

Rotate Photos 
Sometimes photos are oriented in the wrong direction—usually 
because they were taken with an older camera without an 
accelerometer or because you held the camera in such a way that it got 
confused about which end was up. The Rotate icon lets you quickly 
fix this by rotating your image in 90º increments (counterclockwise by 
default, clockwise if you hold down the Option key). You can also 
rotate counterclockwise by pressing ⌘-R, or ⌘-Option-R for 
clockwise). 

For a finer increment of rotation, try the Crop feature’s Auto button, 
described next. 

Make Quick Fixes in Edit Mode
 

Some other quick-fix features require you to enter Edit mode, which 
provides you with dozens of tools to modify your images. To enter Edit 
mode, select an image and press ⌘-Return. (If you’re already viewing 
a single image, you can either press ⌘-Return or click the Edit button 
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Make Edits to Your Photos 
Basic adjustments of the kind I described in the previous chapter, 
Make Quick Photo Fixes, are often all you need to make your photos 
come to life. But sometimes you need to take total control over the 
situation. 

Select an image and press ⌘-Return (or if you’re viewing a single 
image, click the Edit button in the top right) to enter Edit mode, then 
click to switch to the Adjust tab. Along the right side you’ll see 
numerous tools you can use to make your images look their best 
(Figure 75). 

Figure 75: Exterminate all your images’ flaws with the Adjust tab of 
the Edit view. 

If you’ll be editing in iOS, read this entire chapter to learn the lay of the 
land and then see Add Adjustments in iOS and Extensions for iOS for 
iOS-specific details. 
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Adjust Your Photos
 

Down the right side of the Photos window you’ll see 13 different 
adjustment controls. When you hover over them, you’ll see that many 
offer an Auto button to automatically apply basic adjustments, as well 
as an undo arrow . Click the disclosure triangle to the left of any 
item to see the controls that live underneath (Figure 76). 

Figure 76: Many adjustment options have a primary control (visible 
once you click the disclosure triangle) made up of component options 
you can display by clicking another triangle. 

Many, but not all, of the adjustment controls offer an interface where 
you drag a control across a horizontal bar. The center position general-
ly means no effect is applied, while dragging to the right or left applies 
an effect positively or negatively. For example, as you slide the Color 
control to the right, your image will become increasingly saturated. If 
you slide it to the left, the color will gradually drain away. 

Rely on Non-Destructive Editing 
An important thing to understand about using Adjustments is that 
everything you do is non-destructive. 

In macOS, every adjustment can be turned on and off at any time by 
clicking the checkmark icon. (A checkmark means the adjustment 
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Share Your Photos 
What good are photos if you can’t share them with friends? Tradition-
ally, sharing photos meant sending prints or making albums. You can 
still do that—see Build Books and Calendars—but sometimes you want 
sharing to be more immediate. iCloud Photo Sharing lets you share an 
entire album that others can update and comment on (see Share Using 
iCloud). And if your desired sharing method requires that you get your 
photos out of Photos, you can do that too (see Export and Resize 
Images). At the end of the chapter, I discuss how to Share from iOS. 

Use the Share Menu
 

One way to share images with other apps and macOS system features 
is to use the Share menu in Photos for macOS. Select a photo, and then 
choose File > Share, control-click an image and choose Share (Figure 
84) from the contextual menu, or select a photo and click the Share 
icon in the toolbar. 

Figure 84: Access the Share menu by Control-clicking a photo. 
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Tip: Mojave removes integration with social media services like 
Facebook, Flickr, LinkedIn, Twitter, and Vimeo, which means you 
can’t share directly with those services from Photos on your Mac 
anymore. 

Transfer a Photo 
Some options in the Share menu directly transfer a photo to another 
person or a privately shared area: 

•	 iCloud Photo Sharing: If you have this feature turned on, click 
here to add a photo to any of your shared albums. (See Share Using 
iCloud, later in this chapter.) Images shared using this feature are 
reduced to 2048 pixels on the longest edge. 

•	 AirDrop: Quickly transfer a photo to another device—Mac or iOS— 
using Apple’s AirDrop technology. 

•	 Messages: Send a photo directly to one of your contacts via the 
Messages app (Figure 85)—all without ever leaving Photos. 

Figure 85: You can send an iMessage to someone without even 
leaving the Photos app. 
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View Photos on Apple TV 
Your living room is a natural place to share photos, and your big high-
definition TV set can be an excellent canvas. If you have a fourth-
generation Apple TV or Apple TV 4K connected to your set, you can 
view your iCloud Photos, as well as Albums and Memories, in the 
Apple TV Photos app (Figure 96). 

Figure 96: The Apple TV Photos app gives you access to your iCloud 
Photos library, Memories, and albums. 

Don’t Use iCloud Photos? 
Photos for Apple TV is really designed for iCloud Photos. If you just 
want to share photos from your Mac to your Apple TV, you can use 
Home Sharing on your Mac and the Computers app on your Apple TV. 
(See Photos and Older Apple TVs for info on Home Sharing.) 

Scroll Through Photos
 

The Photos app on the Apple TV is designed to show off your photos 
and videos, not to let you make edits. The Photos pane displays the 
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entire contents of your iCloud Photos Library separated into Moments, 
with the newest on top. 

To view an image full screen, select the photo with the Siri Remote and 
click. From this view, you can swipe left and right to move to the next 
and previous photos in your library. 

Tip: The Apple TV can play back the video version of a live photo. 

Swipe up to display the date and time the photo was taken (Figure 
97). Swipe back down to zoom back to full size. 

Figure 97: Swipe up on a selected photo to see the date and time 
the photo was taken. 

Note: Photos not showing? Your teen’s photos showing instead of 
yours? Read Use iCloud Photos on the Apple TV for help. 

View Memories 
All your Memories are viewable in the Memories pane (Figure 98). 
You scroll through them from left to right. Click a selected Memory to 
open that collection. 
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Make Slideshows in 
Photos 

I can’t go to a school function without seeing at least one slideshow. 
Photos provides seven different slideshow themes (Figure 100), and 
if you’re the type who wants your slideshows just so, you have a lot of 
power to control exactly how yours behave. 

Figure 100: The Vintage Prints theme may be my favorite of the 
Photos slideshow themes. 

This chapter begins by talking about the slideshow options in Photos 
for macOS; for iOS information, read Make Slideshows in iOS, at the 
end of the chapter. 

Create a Slideshow
 

To create a Slideshow select photos and choose File > Create > 
Slideshow > Photos. Give your slideshow a name, and click OK. A new 
entry appears in the My Projects section of the sidebar. 
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In the slideshow editor that opens, you can organize the images, 
choose a theme and music, and determine how long your slideshow 
lasts, as I describe next. 

Choose a Theme 
Click the Theme Picker icon at the right and then click a theme 
name. You can re-order the images in all themes by dragging their 
thumbnails around in the strip at the bottom of the window—drag the 
rule above the thumbnails up a bit if they’re too small (Figure 101). 

Figure 101: Choose a theme from the list at right. You can drag 
around the small images at the bottom of the screen to re-order the 
Slideshow. 
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Build Books and Calendars 
For many years, Apple let you use iPhoto and then Photos to create 
designs with your photos, upload those designs to Apple’s servers, and 
then take delivery of custom-printed objects in a few days’ time. My 
family created annual calendars and books. These physical products 
are great ways to keep our photos in view throughout the year, even 
when we aren’t staring at a device. 
Unfortunately, Apple has decided to get out of the business of produc-
ing books and calendars. Instead, it’s allowed third-party services to 
create special apps and make them available for download in the Mac 
App Store. These free apps allow you to create projects based on your 
Photos library and order them from right within Photos. It’s a new 
approach, but there are a lot of encouraging signs. 
Here, then, are various ways to get your photos out of your library and 
into the real world. 

Design Books with Mimeo and Motif 

As of this writing (in late 2018), there are two apps that really excel at 
letting you build paper books and calendars within Photos: Mimeo 
Photos and Motif, both free. I’ll describe the process of building books 
in both of them below. 

Build with Mimeo Photos 
I’ve been very impressed with Mimeo Photos (Figure 109). In gener-
al, I found it to be a suitable replacement for Apple’s own book-build-
ing tool, with some features that surpass the ones that Apple previous-
ly offered. 
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Figure 109: Mimeo Photos lets you build books within Photos, and 
offers some features that Apple’s implementation never did. 

To create a project using Mimeo Photos, first download the app from 
the App Store. After you launch the app and give it permission to 
access your photos, you can start a new project by selecting images or 
choosing an album in Photos and then selecting File > Create > Book > 
Mimeo Photos. 

Choose the type of book you’d like to create (Mimeo offers six styles of 
hard- and softcover books). Click Create, select a theme, and Mimeo 
generates an automatic layout based on the images you add to the 
project. Though, I found myself deleting all those pages and then 
slowly building my own. 

In the sidebar on the right side of the window, click Layout to view all 
the optional layouts for a page (Figure 110). Mimeo provides dozens 
of layout designs based on how many photos you want on a page or 
spread. 
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About This Book 
We hope that you found this book both useful and enjoyable to read. 
We welcome your comments and questions in individual chapters. You 
can also send us email. 

Ebook Extras
 

You can access extras related to this ebook on the web. Once you’re 
on the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
a subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. You may find new tips or information, as 
well as a link to an author interview. 

•	 Find out if we have any update plans for the ebook. 

If you bought this ebook from the Take Control website, it has been 
automatically added to your account, where you can download it in 
other formats and access any future updates. However, if you bought 
this ebook elsewhere, you can add it to your account manually: 

•	 If you already have a Take Control account, log in to your account, 
and then click the “access extras…” link above. 

•	 If you don’t have a Take Control account, first make one by follow-
ing the directions that appear when you click the “access extras…” 
link above. Then, once you are logged in to your new account, add 
your ebook by clicking the “access extras…” link a second time. 

Note: If you try these directions and find that your device is incom-
patible with the Take Control website, contact us. 
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