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Read Me First 
Welcome to Take Control of Numbers, Third Edition, version 3.0, 
published in September 2021 by alt concepts inc. This book was 
written by Sharon Zardetto and edited by Michael E. Cohen. 

Want to get more out of Apple’s Numbers app? This book’s for you! 
You’ll learn everything from the basic interface to the construction of 
intricate formulas; how to shuffle data around, and sort and filter it 
simply or with complex rules; and how to create tables and charts. 

If you want to share this ebook with a friend, we ask that you do so 
as you would with a physical book: “lend” it for a quick look, but ask 
your friend to buy a copy for careful reading or reference. Discounted 
classroom and Mac user group copies are available. 

Copyright © 2021, Sharon Zardetto. All rights reserved. 

Updates and More
 

You can access extras related to this ebook on the web (use the link 
in Ebook Extras, near the end—it’s available to only purchasers). On 
the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
any subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

If you bought this ebook from the Take Control website, it has been 
added to your account, where you can download it in other formats 
and access any future updates. However, if you bought this ebook 
elsewhere, you can add it to your account manually (see Ebook Extras). 
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What’s New in the Third Edition
 

Sometimes it’s difficult to keep up with Apple’s app updates. Within 
days of the original release of the second edition of this book, for 
instance, Numbers jumped from version 4.3 to 5.0, which we were able 
to accommodate with a swift update.Then there were minor Numbers 
updates for “stability and performance improvements,” tweaks to 
existing features, and the addition of minor but convenient features. 
Numbers 5.3 presented some changes and soon begat Numbers 6.0. 
Then, suddenly, version 10.x appeared, with quite a few changes— 
although not quite worthy of such a version-number jump. It was 
however, worthy of a new edition of this book—and while I was work-
ing on it, Numbers was updated again, so you’re reading Take Control 
of Numbers, Third Edition, which was written for Numbers 11.x. 

The major additions to this book since the last version are: 

• How to Use Titles and Captions on nearly everything. 

• An exploration of the color well used for assigning colors to 
almost anything in Numbers; it includes how to make pastel shades 
and add your own colors to its popover (Consider Color). 

•	 Coverage of the new, easier and yet more powerful table-sorting 
options (Sort with the Organize Inspector). 

These are a few of the smaller helpful additions: 

• Meet the new and improved version of The Template Chooser. 

• Add a color to your background when you Colorize a Sheet. 

•	 Make a handy floating palette of the options in the Format 
inspector’s Arrange section: see the end of The Sidebar and Inspec-
tors. 

• Learn how to Use the Smart-View Strip (and why you’d want to). 
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Introduction 
Let me ask you some questions: 

•	 Are you new to spreadsheet applications? 

•	 Are you new to Numbers, or to its latest version (11.1 as I write 
this)? 

•	 Have you had time to only skim the surface of Numbers and want to 
be more proficient? 

•	 Are your formula-building skills pretty much limited to SUM and 
AVERAGE but you want more from your data? 

•	 Do you want to alleviate the black-and-white tedium of most 
spreadsheets by using color for table lines, cell backgrounds, cell 
contents—and more? 

•	 Would you like to create templates for tables you design so you 
don’t have to start from scratch every time? 

•	 Would you like table cells to “recognize” the type of data you’ve 
entered and automatically format it so that, for instance, you can 
type 123 and get $1.23? 

•	 Do you want to transform your data into expressive charts? 

At the risk of sounding like an infomercial: If you answered “yes” to 
any of these questions, this book is for you. If you have other ques-
tions, this book is for you. If you don’t even know what questions to 
ask, this book is for you. 
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Numbers Quick Start 
Beginning at the beginning is not always what a reader needs. 
Here are some areas that you might want to get to out of the order 
in which they’re presented in the book. 

Get started: 
•	 Read in-depth coverage of Numbers’ basics in Learn Terminology 

and the Interface, Work with Sheets and Templates, Learn Table 
Basics, and Master Cell Basics. 

•	 If you’re new to spreadsheets in general, also check Learn Table 
Anatomy, read Cell Referencing, and Learn Data Entry Basics. 

•	 If you’re new to Numbers, but comfortable with spreadsheets, you’ll 
find these topics especially helpful: Work with Sheets and Tem-
plates, The Template Chooser, and Use Pop-Up and Contextual 
Table Menus. And you’ll love learning how to Analyze Data with 
Categories. 

Work more efficiently: 
•	 Customize Your Environment. 

•	 Keep your frequently used document setups instantly available: Use 
Built-In and Custom Templates. 

•	 Speed Data Entry with Autocomplete and Speed Data Entry with 
Autofill when you can. Use Special Data-Input Options (Create 
Checkboxes, Use Star Ratings, Build Pop-Up Menus) and Define 
Sliders and Steppers wherever you can. And Use the Smart-View 
Strip to quickly enter common functions. 

•	 Don’t waste time recreating formatting combinations: make Custom 
Templates for documents, Use Table Styles, and Use Paragraph and 
Character Styles. 
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•	 Color permeates everything in Numbers, including, now, the sheet 
background, so Consider Color, see how to Colorize a Sheet and 
learn about The Accent Color and The Color Well. 

Learn about formulas and functions: 
•	 If you’re new(ish) to spreadsheets, you should Master Cell Basics, 

Learn Formula-Building Basics, Cell References, and Understand 
Functions and Arguments. 

•	 Learn how to Work in the Formula Editor and then Explore the 
Functions Browser. 

•	 If you know basic formula and function usage, and want to broaden 
your knowledge, read Nested Functions and Master IF Statements 
and Logical Operators. 

When looks matter: 
•	 A table can look both businesslike and friendly when you know your 

formatting options. See Apply Table Formats, Apply Basic Cell 
Formats, Review Standard Data Formats, and Create a Custom Data 
Format. 

•	 Standardize the look of components in tables and sheets with styles: 
Read Use Table Styles, Use Paragraph and Character Styles, List 
Styles, and the chart style information in the The Chart Tab topic. 

•	 Keep things shipshape on a sheet by using Rulers and Ruler Guides 
and learning how to Work on the Arrange Tab. 

•	 Add graphical elements to a sheet as described in Work with Shapes 
and Images and create free-standing labels using Text Boxes. 

Visualize data with charts: 
•	 Get the basics in Learn Chart Parts and Terminology, and then learn 

how to Create a Chart. 

•	 Work with special chart options: Design 3D Charts, Make Interac-
tive Charts. 
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Get more information out of your information: 
•	 Look at data in a whole new way: Make Interactive Charts. 

•	 Look at data in a whole new light: Analyze Data with Categories. 

•	 Add extra statistical data (that doesn’t even appear in your table) to 
a chart with Reference Lines. 

Work with other people: 
•	 When “other people” are Numbers users, learn to Share a Numbers 

Document and Add Comments for more explicit instructions. When 
they are not, learn how to Import, Export, and Share Files. 
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About Numbers 
This chapter describes how to download Numbers (it’s free!) and stay 
updated, helps you Learn Terminology and the Interface, and explains 
how to Customize Your Environment to suit your particular needs. 

If you don’t already have Numbers, the question is: Why not? It’s been 
a free download since mid-2017 (along with Apple’s other productivity 
apps, Pages and Keynote). 

To download Numbers, go to the Apple Store (choose Apple  > App 
Store) and sign in. Start typing numbers in the Search field, click 
Numbers when it shows up in the drop-down list and click the Open 
“button” (it’s just a blue word). 

To check for Numbers updates, go to the App Store and click Updates 
in the sidebar or choose Store > Updates. 
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Learn Terminology and the 
Interface 

Because an app’s terminology is inseparable from its interface, we take 
a quick look at both in this section. After pinning down the terms table 
and sheet, we’ll explore The Sidebar and Inspectors, and then I’ll show 
you how to Customize Your Environment by setting preferences and 
modifying the Numbers toolbar. Next, we’ll Consider Color and how 
it’s used with various Numbers elements. Finally, you’ll learn how to 
Use Titles and Captions and Use the Smart-View Strip. 

Tables and Sheets
 

Numbers is not your [insert ancestor]’s spreadsheet program. Origi-
nally, a spreadsheet was a document with a grid of rows and columns 
to hold numbers and the results of mathematically manipulating them. 
While Numbers uses “spreadsheet” to refer to its documents, that 
spreadsheet can have multiple sheets, accessed by tabs in the window. 
And a sheet can hold multiple items, including text blocks, charts, 
pictures, and even video. Want a grid for number manipulation? Put a 
table on your sheet. 

The Sidebar and Inspectors
 

The sidebar is a major interface element in Numbers. It’s a panel at the 
right of the window, whose content changes based on what you’re 
doing, or what you’ve selected, in the document. It most often displays 
one of two inspectors: Format and Organize. Each has multiple tabs 
for setting options that can change based on the current selection on 
the sheet. Some tabs have further divisions, accessed by buttons, like 
Style and Layout in Figure 1. 
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Figure 1: Left, the Format inspector’s four tabs; the text tab has 
two panes. Right, the Organize inspector’s three tabs. 

To view an inspector, click the Format or Organize button at the 
far right of the toolbar, or select from the View > Inspector submenu. 
(To dismiss the sidebar and reclaim some screen real estate, click the 
currently active inspector’s button. 

Apple sometimes refers to the sidebar generically as “the inspector,” 
especially in commands like “Show/Hide Inspector,” but in practice, 
you’ll find it’s easy to understand what’s being referenced. 

Note: The sidebar also displays options for controlling other spread-
sheet procedures, such as arranging and aligning objects on a sheet, 
advanced column sorting, and, most importantly, printing. 

You’ll become dependent on the sidebar, and it will be a love/hate 
relationship. On a laptop, it takes up about twenty percent of the 
screen width; on a big screen, it can be a very long trip for the cursor to 
get there. There’s a partial solution for this—and by “partial,” I mean 
that it works for only the Format inspector’s Arrange tab—but it’s 
not nothing. Choose View > Show Arrange Tools for a floating palette 
of the Format inspector’s Arrange Tab (Figure 2). 
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Work with Sheets and 
Templates 

You can’t do anything in Numbers without working on a sheet—the 
blank canvas on which you place Numbers’ raison d’être: tables and 
their related charts (as well as fancier elements). After we look at 
colorizing a sheet’s background, I’ll show you how to create, name, and 
delete sheets, and how to use their tabs to manipulate multiple sheets 
in a document. Tabbed and Merged Windows describes a different 
kind of tab structure, one that makes juggling multiple open windows a 
thing of the past. Zooming In and Out explains how to get anything 
from a bird’s-eye view to an extreme closeup of your sheet. Finally, I 
show you how to Use Built-In and Custom Templates. 

Colorize a Sheet
 

One of Numbers’ new features is the ability to assign a background 
color to a sheet. A pastel colorized background could be easier on your 
eyes than bright white. Or you might find it convenient to color-code a 
background to track how far along you are in data-collecting, or to 
signify which group of colleagues is supposed to be looped in regarding 
data changes. 

Start by clicking an empty spot on the sheet to deselect everything else. 
Go to the Format inspector; because the sheet was selected by that 
click, the inspector displays its Sheet pane. Click the color well 
and choose a color. You’ll probably want a pastel-ish shade rather than 
an intense one: see the tip about pastels in Consider Color. 

When you apply color to a sheet, the color shows through objects like 
tables and charts (and even the center of a donut chart) which you 
probably assumed were white areas, but they were actually “empty.” 
Use a white (or other color) fill for table cells, and white backgrounds 
for other objects to keep the sheet from showing through. 
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Manage Sheets and Sheet Tabs
 

A Numbers document can have more than one sheet. Each one gets a 
tab immediately beneath the toolbar; click a tab to display its sheet. 
Each tab has a menu (Figure 11): point to the tab and click the menu 
arrow that appears, or Control-click anywhere on the tab. The menu 
lists all the tables and charts on the sheet, in order of creation, and 
provides handy sheet-related commands. 

Figure 11: A sheet’s pop-up menu. 

When you select an object from the menu, the window displays it, 
scrolling if necessary. You can use any sheet’s pop-up menu, not just 
the active one. So, for instance, you can delete any sheet at any time. 

Here’s what else you can do with the sheet tabs: 

•	 Add a sheet: Click the Add button on the far left or choose 
Insert > Sheet. 

•	 Rename a sheet: Double-click its tab to select the name for 
editing. (It doesn’t have to be the current sheet, and you don’t have 
to click the text.) 

Note: A new sheet starts with an empty table, which uses the first of 
the table styles included in the document (see Use Table Styles). 
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Learn Table Basics 
Tables are the sine qua non of spreadsheet applications, so it’s impor-
tant that you understand the basics of table handling. In this chapter, I 
start with nomenclature for the parts of a table, and then cover how to 
Create and Control Tables. After describing how to Use Pop-Up and 
Contextual Table Menus and Title and Caption Tables, I show you how 
to Manipulate Rows and Columns, which covers important skills such 
as inserting, deleting, resizing, and hiding them. 

Learn Table Anatomy
 

Apple has long been allergic to naming smaller interface elements, but 
we need names in order to talk about the features, so I’ve fabricated 
some for our mutual convenience (Figure 14). Note that in the cur-
rent version of Numbers, a table has both a title (formerly called a 
“name”) and a caption. 

Figure 14: I use this terminology to refer to table elements. 

Note: The color used for the various handles is the accent color 
chosen in the System Preferences General pane. 
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Recognize Table States
 

A table exists in one of four states, although you can’t identify the 
current state until you click the table (which might change its state). 
What difference does a state make? If you press Delete when a table is 
active, you delete the contents of the current cell, while pressing Delete 
when the table is selected deletes the table itself. 

In two of the four states, tables display their Row/Column bars and 
table buttons; I’ve marked those with a with a little table button icon in 
Figure 15. 

Figure 15: The four table states. In the active and selected states, a 
table displays its table button and its Row and Column bars (not 
shown here). 

A table is active when one or more of its cells are selected. When 
nothing in a table is selected, it’s inactive, and its handles, bars, and 
buttons disappear. Press Command-Return to change an active table 
to a selected state, which provides white resize handles at the bottom-
right corner and the bottom and right midpoints. 

Using the Arrange > Lock command on a selected table glues it to a 
spot on the sheet and prevents any changes to data. (The little x’s at its 
corners and around its perimeter don’t show until you select it.) 
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Master Cell Basics 
You’ll spend lots of time selecting cells and moving around in tables, so 
knowing how to select and Move Between Cells, and Move Within a 
Block of Cells saves a lot of time. This chapter also covers how to Move 
a Cell or Its Data and Merge and Unmerge Cells (and explains what 
happens to their data when you do either). 

Cell Referencing
 

You’ve probably already realized that a single cell is named, bingo-like, 
for its column and row: B2, E6, and so on. A selection of multiple cells, 
referred to variously as a block, range, or array, is named for its top-
left and bottom-right cells, with a colon between: B5:D10, for instance. 

When you refer to a cell in another table on the same sheet, you can 
refer to it by its row/column position: Budget Auto. For cells in a table 
on another sheet, first identify the table or sheet followed by a double 
colon and then the position reference: Summary by Category::Budget 
Auto. You won’t be typing all that: you’ll be building a formula in the 
Formula Editor, and clicking the target cell will enter its “name.” 

Select Cells
 

To select a cell, just click it. (Selecting its contents takes another click; 
read Learn Data Entry Basics). Once selected, a cell is ready for action: 
type something and it goes in the cell, paste something and it goes in 
the cell (if it can), press Delete and the cell contents disappear. 

To select more than one cell: 

•	 Drag: Drag across contiguous cells (in any direction, including 
diagonally) to select them. 
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•	 Shift-click: When some cell(s) are already selected, Shift-clicking 
adds cells to the selection—but what you wind up with depends on 
where you start. When you drag-select a block of cells, everything is 
calculated from the cell that you click first. Drag-select the block 
A1:A3 starting in A1, Shift-click in A4, and you get A1:A4 selected, as 
you’d expect. But selecting A1:A3 by dragging up from A3, and then 
Shift-clicking in A4 leaves only A3:A4 selected: A3 is the initial cell, 
and the Shift-click selects from that cell to the Shift-click spot 
(Figure 27). 

Figure 27: Altering a selection with a Shift-click in A4. Left: Initial 
selection dragged from A1 to A3. Right: Initial selection dragged from 
A3 to A1. 

•	 ⌘-click: ⌘-click a cell to add it to or remove it from a selection; an 
addition doesn’t have to be contiguous with the current selection. 

•	 Drag handles: Drag a white selection handle to enlarge or shrink 
a selection horizontally or vertically. 

•	 Add Shift: Alter a selection by adding Shift to any keyboard 
option that moves you from one cell to another (except for Tab and 
Return, which reverse direction when you add the Shift key). So, 
with the selection A1:A3 made by dragging from A1 to A3: 

‣	 Pressing Shift-↓ adds A4, the cell beneath the selection. If you 
started with a two-column selection, Shift-↓ would add the two 
cells beneath that selection. 

‣	 Pressing Shift-→ adds B1:B3 because it selects cells in the next 
column that are adjacent to the already selected cells. 

‣	 Pressing ⌘-Shift-→ selects to the ends of the rows. 
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Use Table Formats and 
Styles 

Numbers offers many options for table formatting that can make a 
table easy to read—or turn it into an abomination to behold. When 
it comes to avoiding the latter, my advice is: Practice restraint! 

Just below, I describe table formatting options that you can use to 
standardize the look of your tables and make them easy to scan for 
specific data. With formatting skills under your belt, you can Use Table 
Styles to apply your perfect combo of formats to other tables, and 
Reorganize Styles to keep your most-used ones readily at hand. 

Apply Table Formats
 

The four formatting choices that affect an entire table—gridlines, 
outlines for the table and title, alternating row color, and overall text-
size re-sizing—are all accessible in the Format inspector’s Table tab. 
You can apply these to any active or selected table, or to multiple 
selected tables: 

•	 Gridlines: Almost every table starts with cells delineated by gray 
gridlines. They can be switched on and off separately for body rows 
and columns, row and column headers, and footers (Figure 36). 

Figure 36: The gridline buttons. Left: Horizontal and vertical lines 
for body cells. Right: Header columns, header rows, and footer rows. 

If you apply Cell Borders and later remove them, the gridlines 
beneath are likely to be gone too. Getting them back is easy but not 
obvious: select the area, go to the inspector’s Cell tab, click the 
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appropriate gridline pattern from the Border choices, and choose 
Default Style from the Border Styles pop-up menu. 

•	 Table and title outline: In the Table Outline section, choose a 
line style from the pop-up menu, select a color, and set a line thick-
ness; add the same outline to the table’s title by checking “Outline 
Table Title” (Figure 37). (Default Table Style sets the outline back 
to what’s defined in the table’s style.) 

Figure 37: Use the Format inspector’s Table tab to create a 
custom table outline and to turn the table title outline on or off. 

•	 Alternating row color: To make a table more readable, shade 
alternate rows: check Alternating Row Color in the Table tab, and 
then choose from the color well . Shading doesn’t have to be 
subtle shades of gray—other colors can be subtle, too. 

•	 Proportional text re-sizing: If the text in a selected or active 
table has more than one font size, you can proportionately resize all 
the text by clicking the small or large Table Font Size  button. 

In a selected (not active) table, you can use the shortcuts for 
Format > Font > Bigger and Format > Font > Smaller: ⌘-= (be-
cause of the plus sign on that key) and ⌘-- (that’s not a typo—it’s 
the ⌘ key and the minus sign). This approach is particularly useful 
when you Resize a Table by its handles, a method that doesn’t affect 
text size. 
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Learn About Cell Formats 
“Format” is a nebulous word when it comes to table cells because it can 
refer to different things. A cell’s format defines its look, such as its 
background fill and border color and thickness. A cell’s format also 
describes how its data should look—such as whether there are dollar 
signs on numbers. 

In this chapter, I cover the details of basic cell formats—background 
fills and borders—and demystify the sometimes puzzling interaction 
between Cell Borders and gridlines. I also explain one of my (and soon 
to be one of your) favorite features in Use Conditional Highlighting, 
which explains how to apply cell formatting that changes based on a 
cell’s content. 

Apply Basic Cell Formats
 

You can use cell borders and fills to subtly define areas of your table, or 
to make it look like Times Square at night (which can be a thrill in real 
life, but in a spreadsheet…). 

Cell Borders 
Most tables start with staid gray gridlines, but you can draw attention 
to specific areas of a table using cell borders, which trump the gridlines 
wherever they’re used. You design and apply borders with the controls 
on the Format inspector’s Cell tab (Figure 40). 

Figure 40: Border controls on the Cell tab: border patterns, menus 
for border and line styles, a color well, and stroke setting. 
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To apply borders to cells, select the target area and then click a pattern 
in the Format inspector to define which lines in the selection are to be 
formatted (Figure 41). 

Figure 41: Border-pattern choices and the results when a six-cell 
block is selected: Outline, All Borders, Inside Borders, and Middle 
Borders (which can be vertical). 

Next, select from the Border Styles pop-up menu (Figure 42). 

Figure 42: The Border Styles menu. 

Finally, pick a border color from the color well , which displays 
choices from the document’s color palette, and then set its border’s 
stroke (thickness) by typing a number in the field or clicking the up/ 
down arrow controls next to it. 

How manually applied borders and a table’s gridlines interact is not 
obvious, but it’s logical, and not difficult to work with. 

Although cell borders that you apply manually override gridlines, those 
can be restored easily because Numbers tracks them separately. If you 
apply borders to cells in a table, they replace the table’s default grid-
lines for those cells. If you turn off the table’s gridlines, the borders 
remain, as shown in Figure 43. 
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Control Data Input 
Put data in a cell? Sure, just click in a cell and type—what else is there 
to know? You can learn about options for entering data, and the many 
different types of data that Numbers recognizes and can handle auto-
matically, as described in Understand Automatic Data Formats, and 
how to Control Text Wrap in Cells when your cell runneth over. 

And then there’s letting Numbers do more of the work for you: Speed 
Data Entry with Autocomplete and Speed Data Entry with Autofill. You 
can also do more than just a plain ol’ copy and paste: Explore Copy and 
Paste Options shows you how to copy and paste within and between 
tables, and leave a cell’s data behind if you want to copy only its 
formatting to paste in another cell. 

Learn Data Entry Basics
 

To enter data in an empty cell, just click and type: you don’t have to 
click the cell a second time to get a blinking text cursor. 

If there’s something in a selected cell, you can delete it by pressing 
Delete, or replace it by typing. To edit its contents, click to select the 
cell and click again to place the blinking text cursor (or double-click at 
the spot you want to edit to both select the cell and place the cursor). 

Each cell is like a teeny-tiny word processor: when you’re editing a 
cell’s contents, for instance, you can double-click a word to select it or 
drag across characters to select them. 

You must let Numbers know that you’ve finished typing before 
it can use your input to calculate formulas or do its auto-formatting 
tricks. Going to another cell takes care of that, but if you want to see 
formula results, or have auto-formatting applied before you leave the 
cell, press ⌘-Return to deselect the contents. 
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To erase all data from a cell, select the cell and press Delete. This works 
for a selected range of cells, too: you can clear multiple cells with a 
single keypress. (Text or data formatting applied to the cell remains.) 

Graphics Are Not Data 
It seems that you can put an image in a cell: with an image on the
 

clipboard, select a cell and choose Edit > Paste, and a tiny version of
 
the image winds up in the cell. But it’s just background, like cell
 
color, so the cell’s data appears on top of it.
 

It’s not obvious how to get rid of a background image in a cell—
 

unless you remember that it’s just a cell format at that point: select 

the cell and, in the Format 
 inspector’s Cell tab, choose No Fill. 

Understand Automatic Data Formats
 

In cells that have the default Automatic data format set on the Format 
inspector’s Cell tab, Numbers recognizes these data types: 

•	 Numbers: When you finish entering a number, it’s right-aligned in 
the cell to reassure you that it’s been recognized as such. 

•	 Text: Text is anything that doesn’t qualify as any of the other data 
types, so it includes pure text as well as mixtures of text, numbers, 
and/or symbols. Text is automatically left-aligned in a cell. 

•	 Dates and Times: You can’t have a date without a time, or a time 
without a date: input one, and Numbers includes the other, al-
though whether it’s displayed depends on the cell’s formatting): 

‣	 Date: Enter 5/23 and weekday, 5/23/[current year] 12:00:00 AM 
is stored. 

‣ Time: Enter 12:27, and [current date] 12:27:00 PM is stored. 

‣	 Month name: A full date (the first of the month, with the
 
current year) and 12:00 AM is stored.
 

To see the stored data behind the display in a cell, check the smart-
view strip (see Use the Smart-View Strip) at the bottom of the 
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Learn About Data Formats 
Numbers lets you control two kinds of data formatting. There’s the 
data type: an entry of 3:02 could be a time, or a duration of 3 hours 
and 2 minutes, but formatting it specifically as a time or duration 
keeps things clear. And then there’s the data’s appearance: you type 2, 
but it could be displayed as 2.0 or 200%; or a date could show as 
December 10, 2001 or 12/10/01 or the European 10 December 2001. 

In this chapter, I describe the standard data formats that Numbers 
recognizes and then show you how to Create a Custom Data Format for 
numbers and text, including how to use Alternative Formats with 
Rules to change a cell’s formatting based on the data in it. 

Review Standard Data Formats
 

Use the Data Format pop-up menu on the Format inspector’s Cell 
tab to define the type of data in a cell—overriding Numbers’ automatic 
recognition of data types—controlling how it appears no matter how it 
was entered (Figure 59). 

Figure 59: The Data Format pop-up menu in the Cell tab. 
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The menu offers five categories of data, bookended by an all-purpose 
Automatic default and a roll-your-own option: 

•	 Automatic: Numbers right-aligns numbers, left-aligns text, and 
uses defaults to format dates and times. 

•	 Number: The six number choices control how your numeric 
entries display. Each has a subset of options so you can, for in-
stance, define a specific type of currency. 

•	 Text: This has no built-in data-format options. 

•	 Date & Time: As explained a little further on, date and time are 
inextricably intertwined in Numbers. 

•	 Duration: This is time from another perspective. Choose from 
week, day, hour, minute, second, and, yes, millisecond. 

•	 Input controls: These are the five options that limit data entry to 
a range or to specific items. (See Create Checkboxes, Use Star 
Ratings, Build Pop-Up Menus, and Define Sliders and Steppers.) 

•	 Custom formats: These are covered just ahead in Create a 
Custom Data Format. 

To specify a data type (before or after the data is entered), select the 
cell(s) and choose an option—such as how many decimal places to 
display—from the Data Format pop-up menu (shown in Figure 59, 
above). Data format options, such as those for Currency and Duration, 
change based on choices in the Data Format section. 

When you type something in a data-formatted cell, you won’t see the 
formatting until the data has been entered with ⌘-Return or by 
leaving the cell (Figure 60). When you later work in the cell (double-
click it to make its contents editable), the formatting disappears so you 
can edit the raw data. 

Figure 60: Left: Data as entered. Right: Data formatting applied. 

91 

Click here to buy the full 282-page “Take Control of Numbers” for only $14.99!

https://www.takecontrolbooks.com/cart/?add-to-cart=1186


 

         
            
           

         
          

          
    

 

             
             

         
            

       
     

               
            

         
       

           
             

             
              

         

Use Special Data-Input 
Options 

Numbers has five special cell-formatting options that both speed data 
entry and limit the scope of the data that can be entered (which mini-
mizes mistakes). As a bonus, some of these formats provide at-a-glance 
information—you don’t have to read numbers and compare them 
mentally, for example, when you create checkboxes, Use Star Ratings 
for one-click data entry, or Define Sliders and Steppers or Build Pop-
Up Menus to control data input 

Create Checkboxes
 

Checkboxes are easy to add to a table, and incredibly handy when all 
you need is to indicate whether a certain condition has been met or 
not: registered, passed exam, met quota. They let you enter informa-
tion quickly, and “read” a row or column of data at a glance. 

Note: You can try out checkbox setups in the Numbers templates 

Attendance (in Education) and Recipe (in Personal).
 

To set up checkboxes, select the cells (they can be blank or filled), go to 
the Format inspector’s Cell tab, and choose Checkbox from the Data 
Format pop-up menu. (Data-Checkbox Swaps, a little ahead, describes 
what happens if a cell already contains data.) 

To remove checkbox formatting, select the cells and choose a different 
format from the Cell tab’s Data Format menu. If you choose Text, the 
cells display TRUE and FALSE; choose Number and you get a 1 for 
TRUE and a zero for FALSE. As explained in What Is Truth?, these are 
equivalent values: zeros are false, and non-zero numbers are true. 
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Tip: Check or uncheck a selected checkbox by typing: check it with a 
1 or T (for true), and uncheck it with 0 or F (you don’t need to use 
capital letters). Tip-within-a-tip: Press the spacebar to flip the state 
of a selected cell’s checkbox. 

Touch Bar Tip: Apple considers the checkbox input so handy that it 

shows up on the Touch Bar when cells are selected and you tap 

Format.
 

Manipulate Checkbox Data 
When you check or uncheck a box, Numbers stores the value TRUE in 
the cell for a checked box, and FALSE for an unchecked one—as you 
can see if you Use the Smart-View Strip at the bottom of the window 
when a checkbox cell is selected. (I’m not yelling at you—TRUE and 
FALSE are capitalized in the cell to differentiate them from a plain text 
entry.) These are very important values, since they’re used as the basis 
for decisions when you Construct IF Statements. 

Data-Checkbox Swaps 
You can apply checkbox formatting to already-filled cells. Numbers 
translates the data using simple rules regarding what a checkbox 
represents: a zero is unchecked, or “false,”; non-zero numbers (includ-
ing negatives) are checked, or “true.” Blank cells are unchecked, the 
words true and false are predictably translated, and other text is 
unaffected). 

To translate checkboxes back to “raw” data, select the cells and choose 
either Number or Text from the Data Format pop-up menu on the 
Format inspector’s Cell tab. But don’t expect your original data to 
be there: you get only ones and zeros in cells formatted for numbers, 
and TRUE and FALSE for text cells. Figure 72 shows an error in the 
bottom cell in the rightmost example because the cell’s formula evalu-
ates the cell to its left as to whether it’s true or false, and plain ol’ text is 
neither. 
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Sort Data 
This chapter starts with the basics of how Numbers sorts letters, 
numbers, and blank cells. You’ll see how to quickly Sort with Column 
Menus, and Sort with the Organize Inspector for more-sophisticated 
sorts—including a way to Sort Part of a Table. You’ll learn to Master 
Unsorting, and Deal with Special Sorting Issues such as how sorting 
interacts with headers, footers, merged cells, and hidden rows. 

Learn About Sorting Order
 

If you think sorting order is simple and obvious, then you need more 
variety in your tables. Here’s how Numbers determines sorting order: 

•	 Formula cells: Cells with formulas in them are sorted according 
to their results—that is, what’s displayed in the cell. 

•	 Numeric values: Numbers are always first. Formatting is ignored, 
so $2 comes after 1 and before 3, while 3% comes before 1 (since 
it’s .03). 

•	 Numeric characters: These are numerals that aren’t used as 
numbers, as in a combination like 1-a, or numbers in cells format-
ted to hold text. These numeric characters still sort before alphabet-
ical ones, but they come after actual numbers. 

•	 Alphabetic characters: Alphabetic sorting is case-insensitive: 
capitalization is ignored, so A is the same as a. 

•	 Dates: If some dates are identical, they sort according to their 
hidden time stamps (see Understand Automatic Data Formats). If 
those are identical, the cells remain in their original relative order. 

•	 Punctuation symbols: Standard punctuation symbols—those in 
the ASCII set—are sorted according to their ASCII codes. 
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•	 Boolean values: When sorting cells that contain TRUE or FALSE 
as a result of an IF statement, a checkbox, or direct text entry, 
Numbers sorts FALSE before TRUE. This might be philosophically 
upsetting, but it’s because FALSE is considered zero and TRUE is a 
one (that’s more comforting), so they’re in numerical order. 

•	 Blank cells: Blank cells always end up at the bottom whether you 
do an ascending or a descending sort. 

Note: When it comes to Option characters—those you get by press-
ing Option and another key, with or without Shift—most are inter-
spersed among the punctuation and Roman alphabet characters, with 
the remainder coming after the alphabet. 

Sort with Column Menus
 

Simple sorts are a cinch. To sort according to a column’s content, 
choose Sort Ascending or Sort Descending from its column menu 
(Figure 78). 

Figure 78: Sorting commands are near the top of a column menu. 
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Filter Data 
You may not always want to see all the data in a table. Perhaps you 
want to see only rows with a specific value in column A, or the higher-
than-some-threshold values in column B, or checkmarks in column F. 
You can do this, and more, when you use Quick Filters (described just 
ahead). More-sophisticated options, such as multiple criteria for 
filters, are described in Filter with the Inspector. 

Tip: Remember that you don’t filter out a value, you filter for it. So, 
define filters by what you want left, not by what you want hidden. 

Because this chapter is divided between the use of the Quick Filter 
submenu in a table’s column menus and that of the Organize 
inspector for filtering, I’ll mention here two items here that apply to 
filtered tables in general: 

• You can’t add rows to a filtered table; add commands are dimmed. 

•	 Data in hidden rows, which disappear when a table is filtered, are 
not included in charts unless you check Hidden Data in the Chart 
Options section of the Format inspector’s Chart tab. 

Use Quick Filters
 

When you want a quick look at a subset of the data in rows, use a 
“quick filter,” which hides all rows except those that have a specified 
data item in a specified row. 

To specify a filter value, Control-click a column label for its menu and 
choose from its Quick Filter submenu, which lists all the unique values 
in the column. In Figure 84, the Jack column is filtered for the 
number 1. (Note that the filtered-out values are still included in the 
calculations in the SUM and AVG footers.) 
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Figure 84: Left: The full table. Right: The Jack column filtered for 
the 1 values. The sums and averages still include values in the 
filtered-out rows. 

Values that are hidden when cells are filtered are still used in any 
formula that references them—note that the SUM and AVG values in 
the figure above do not change in the filtered table. 

Tip: To view a sum, average, or other common statistic for the
 

filtered info only, drag across the displayed body cells, and Use the
 

Smart-View Strip.
 

Your other filter-related options are: 

•	 Remove a filter value: Choose it from the Quick Filter submenu 
to uncheck it. 

•	 Add a second filter to a column: Select another item from the 
Quick Filter submenu. In the example above, choosing a 4 as a 
second filter for Jack’s row would leave four rows displayed. 

•	 Filter a second column: Choose from that column’s Quick Filter 
submenu. In our example in Figure 84 above, filtering for a 6 in 
column C (Jill) would leave only one row displayed, since it’s the 
only one that gets through both filters: the value in Jack’s column 
must be 2 or 3, and Jill’s column must contain a 6. 

It’s easier to predict how multiple column filters will interact if you 
imagine one column winnowing the available rows, and the next 
winnowing that group. The filter order doesn’t matter: you can filter 
Jack’s column first, and then Jill’s, or start with Jill’s and then do 
Jack’s, and the result is the same. 
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Analyze Data with 
Categories 

In this very hands-on chapter, after getting acquainted with the con-
cept of categories, you’ll Create a Sample Category Table so you’ll have 
something with which to work. I’ll show you how to Define and View 
Categories and then Add a Summary Function. Finally, there’s a list of 
brief but important facts in More About Categories. 

What are categories? Numbers’ answer to Excel’s pivot tables turns a 
mild-mannered table into a super information engine that reorders 
and groups data, adding subtotals, totals and other statistics—all in a 
format that lets you collapse and expand the groups and sub-groups. 

See the Categories Advantage
 

Say you’re running a school fundraiser and track orders in a table like 
the one in Figure 88. 

Figure 88: The starting point. 

You’d like to analyze the sales to check the popularity of each item, as 
well as the overall numbers for the categories (Cookies vs. Pies)—and 
see if those cute first-graders are outselling their older compatriots. 
With Numbers’ Categories capability, it takes only a selection from 
each of two pop-up menus to go from the full, twenty-row version of 
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the table above to the one below in Figure 89, which shows the 
information divided into two collapsible categories (Pie and Cookies). 

Figure 89: A categories table with the Pie category collapsed.c 

Create a Sample Category Table
 

To experiment with categories, start by making a school fund-raiser 
table like the one in Figure 90. 

Figure 90: The sample table. 

To make the table: 

1.	 Start with a new, empty table. Delete any header column in the 
table, but keep the a header row, and make 20 rows. 
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Handle Formulas and 
Functions 

You may never love building formulas and working with functions, as I 
do, but this chapter should at least remove any stress accompanying 
your dealings with them. It starts with the built-in “quick calculations” 
available from the toolbar’s Insert menu and when you Use the 
Smart-View Strip. After you Learn Formula-Building Basics and how 
to Work in the Formula Editor, I’ll help you Understand Functions and 
Arguments, and then we’ll Explore the Functions Browser. 

Save Time with Quick Calculations
 

All of Numbers’ calculations are quick—very, very quick—but in “quick 
calculations,” quick refers to how quickly you can set up the most 
common spreadsheet calculations, skipping the step of opening the 
formula editor and defining a formula. 

You can access quick calculations in three places: the Insert > Formula 
submenu, the toolbar’s Insert menu, and with the tokens at the bot-
tom of the window (see Use the Smart-View Strip). As a bonus, you’ll 
get to specify which are your most-used calculations. 

These are the functions that are initially included as quick calculations: 

• Average: Averages the numbers. 

•	 Minimum and Maximum: Find the smallest and largest values in 
a range of cells. 

•	 Count/CountA: Count tallies the cells that contain “numerics”: 
numbers, numeric formulas, dates, or times. CountA reports how 
many cells in a range contain something—anything. 

• Product: Multiplies the selected cells using the Product function. 
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•	 Stock Quote: This isn’t included as a smart-view strip token, but is 
on the toolbar’s Insert menu, so I thought I’d mention it here. 
Choose it, and you’re asked to provide a company name or stock 
symbol. The current share price appears in the cell, along with a 
popover that provides lots more information; double-click the share 
price if the popover isn’t visible. (You need an internet connection 
to keep this information current.) 

Use the Insert Button or Menu
 

To use a function from the toolbar’s Insert menu or the Insert > 
Formula submenu, select cells in a column, row, or block, and choose 
from one of the menus. 

The formula is automatically placed on the right of a row selection, or 
at the bottom of a column or a block selection, adding cells to the table 
if necessary to accommodate it. Numbers has done all the work for 
you, but in the end, it has simply constructed a formula with the 
function you chose and the cells you selected, as you can see if you 
check the cell (Figure 94). 

Figure 94: Basic functions in the Insert menu. 
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Master IF Statements and 
Logical Operators 

This chapter starts with the concept of truth, as interpreted by a 
spreadsheet formula, with a quick side trip to Review Comparison 
Operators; after that, we’ll Construct IF Statements. You’ll Learn 
About Logical Operators (AND, OR, and NOT), and then you’ll Put It 
All Together to construct a formula. Finally, you’ll see how to Con-
struct Nested IF Statements, an incredibly convenient and flexible 
calculation tool. 

What Is Truth?
 

What is truth? Surely, a question for the ages. Except in a spreadsheet, 
where the definitions for true and false are straightforward: 

•	 Numbers and expressions that evaluate to numbers: A zero 
is false, and all other numbers are true. So, 42 is true; so are 3÷5, 
and -15, and a reference to cell B7 unless it holds a zero. 

•	 Numeric comparisons: Comparisons are intrinsically true or 
false: 4<3 and 5=7 are false, while 12>10 and 4×3>10 are true. 

•	 Text: While text by itself is “false” (since it’s not a non-zero 
number), it can be used in the truth test of an IF statement. So, 
if the name Bartleby is in B2, the comparison in the statement IF 
B2="Bartleby" is considered true. 

•	 Blank cells: References to blank cells return a false result. 

The importance of “truth” in a spreadsheet is not an issue of accuracy, 
but one of what is entered in a cell based on some condition that you 
can test—the equivalent of If HighestSalesFigure is greater than 
$5000, then put “High Sales Award” in this cell. 
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Note: The words TRUE or FALSE alone in a cell is considered true or 
false in an IF test; they are so special that Numbers puts them in all 
caps if you don’t. When you Create Checkboxes, the cell content is 
TRUE if it’s checked, and FALSE if it’s not. 

Review Comparison Operators
 

While I shouldn’t assume anything at all about you, I wrote 4<3 in the 
previous topic (just above), assuming that you know it means “4 is less 
than 3.” Just as plus, minus, and equals signs are considered mathe-
matical operators, the greater than and less than symbols are compari-
son operators, and they get heavy-duty use in IF statements. 

The other comparison operators are ≥ (greater than or equal to), ≤ 
(less than or equal to), and ≠ (does not equal). These characters are 
available from the keyboard by typing Option-period, Option-comma, 
and Option-equals. But you can simply type the two-character version 
of an operator (>=, <=, or <>) in the formula editor, and Numbers 
replaces it with the single-character version. However, unlike the 
instant transmogrification of * and / into multiplication and division 
symbols when you type them in the formula editor, comparison opera-
tors don’t change to their single-character forms (≥ ≤ ≠) until you’ve 
closed and reopened the editor. 

Construct IF Statements
 

The IF function has a very simple job: judge whether an expression is 
true or false, and return a value based on that evaluation. The value, 
which can be numeric or text, is then displayed in the cell. 

Its syntax is simple: IF(test, if-true, if-false), which translates into 
simply: If this thing is true, then enter this in the cell, otherwise enter 
that. So, IF(A1 ≥ 65,"Pass","Fail") would put Pass into a cell if the 
grade in A1 is 65 or better, and Fail if it is not. 
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Work with Text Functions 
Suppose your friend/brother/boss gives you a spreadsheet of names 
and addresses and says: “I need just a list of names—last name fol-
lowed by a comma and then the first initial. The state abbreviations 
need to be capitalized and the city, state, and zip code columns need to 
be combined—with a comma after the city, and a space between the 
state and zip code. And, oh, can you generate email addresses from the 
last name, the first two letters of the first name, the ‘at’ symbol…”. 

Yes, you can do all these things—and easily, since Numbers lets you 
manipulate text in many ways. In this chapter, after you get acquainted 
with text terminology, you’ll Learn Basic String Manipulations— 
combining and splitting strings of alphanumeric characters to do such 
things as extract the last name from a cell with a full name. After that, 
you’ll Master Other Common Text Tasks, such as changing uppercase 
letters to lowercase, or vice versa, and stripping extraneous spaces out 
of sloppy data. 

When you’ve finished this chapter, you’ll understand this text-manipu-
lation formula, and why you’d want to use it: 

RIGHT(A2,LEN (A2) - FIND(" ",A2,1)) & ", " & LEFT(A2,FIND(" ",A2,1)-1) 

Really. Promise. 

Know Your Text Terminology
 

Here’s a turbo lesson on the terms and concepts we use when manipu-
lating text in a spreadsheet: 

•	 A string is any series of characters—letters, numerals, punctuation, 
and/or symbols. It can be only letters, but doesn’t have to be, and 
it’s often referred to as a “text string” because any numbers in it 
aren’t numbers anymore (they’re just numerals). 

•	 In formulas, strings appear in quotes: “John” or “.edu”. 
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•	 When you compare strings, everything counts: spaces, punctuation, 
and letter case. None of these strings match: A well-done steak; a 
well-done steak; A well done steak. 

•	 An empty string is a pair of quotes with nothing inside: "". It’s 
often used in a formula to delete unwanted characters by replacing 
a character with an empty string—“nothing”. 

•	 You can’t “add” text strings together (how much is “hello” + 
“there”?). But you can concatenate them—join them together—with 
an ampersand. So, while 2+3 equals 5, the concatenation 
"hello"&"there" results in hellothere. You can type a space on 
either side of the ampersand to make the formula easier to read 
("hello" & "there"), but it’s not necessary: spaces outside quotes 
aren’t used in a calculation. When you need a space between words, 
put it in quotation marks in the formula: "hello"&" "&"there" 
results in hello there. 

If you’re paying close attention, you might be thinking that you 
could just use "hello there" with the embedded space, and you’d be 
right. But you’ll be using this technique when referencing cells 
containing text: B2&" "&C2. 

Learn Basic String Manipulations
 

Before I provide specific examples, here’s some general guidance for 
creating your own formulas to handle text strings. When you want to 
manipulate text to create a specific outcome, think about the details 
you need. For instance, for a last name followed by an initial, you need: 

last name + a comma + a space + first letter of the first name 

On a spreadsheet that includes full names in a single cell, it’s easy to 
see what the spreadsheet provides (last name and first name), what 
you must extract (the first letter of the first name), and what you must 
add (a comma and a space). 
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Create Charts 
Charts and graphs are not only a good way, but often the only way, to 
reasonably interpret a pile of data. Numbers provides enough chart 
choices to both represent almost any data you’re wrangling and. And 
you could practically drown in its variety of formatting options, unless 
you stick with straight-vanilla presentations—and who wants that? 

We begin at the beginning, with the variety of charts Numbers offers; 
next you’ll Learn Chart Parts and Terminology and how to Create a 
Chart and Edit Chart Data. And then we move on to Numbers’ speciali-
ties, which let you Design 3D Charts and Make Interactive Charts 

And, because there are so many options for charts when it comes to 
colors, fonts, labels, and more, there’s another whole chapter—Format 
Charts—to cover all that. 

Note: This chapter and the next describe how to create different 

kinds of charts, but don’t cover which chart you should use for what 

purpose. You can find that information in my TidBITS article about 

chart types.
 

Chart Choices
 

Numbers offers an almost overwhelming number of chart choices, with 
the toolbar’s Chart popover providing thirteen (unidentified) chart 
types in three tabs of six pages each (Figure 118). But it’s not the glut 
it appears to be: the thirteen 2D charts in the first tab cover all the 
available types, with some being simple variants of others, while the 
next two tabs show the subsets available for 3D and for interactive 
charts. To peruse the offerings, swipe the popover left or right, or click 
its side arrows. 
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Figure 118: The Chart popover tabs. The 2D tab (far left) covers all 
the chart types; the others offer subsets of those. 

Learn Chart Parts and Terminology
 

Working with charts requires a somewhat specialized vocabulary, as 
you can see in Figure 119, which shows a common bar chart; most of 
the labelled items are also used in other kinds of charts. Notice that in 
addition to their components, charts can also have a color background, 
a title, and a caption 
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Format Charts 
The overabundance of formatting choices for charts can’t all be cov-
ered here. For the most part, their use is obvious: adding and format-
ting labels, choosing colors, and so on. This chapter covers the more 
important, and the less obvious, features in the Format inspector’s 
chart-related tabs. 

After you learn how to select individual chart elements, we explore the 
formatting tabs (The Chart Tab, The Axis Tab, The Series Tab, The 
Style Tab, and The Pie and Donut Tabs), where you can set all the basic 
formatting for a chart, as well as do such things as reposition value 
labels, change the style of the lines in line charts, and explode a pie or 
donut chart or reorder their pieces. I also show you how to Manipulate 
Images for Fills to put pictures in bars, columns, and pie wedges, and 
Tweak Text Elements so that your titles and labels are as clear as your 
data presentation. 

The Format inspector provides formatting options for both the 
overall chart (background color and legend text, for instance) and its 
separate elements (such as bar/line color and data labels). Which tabs 
are available depends on what you’ve selected: a whole chart (and what 
kind) or chart elements (and which ones). The options within each tab 
also vary with the selection. 

Select Chart Elements
 

Some formats affect the entire chart, but others can be applied to 
specific elements. You can, for instance, highlight a single column by 
outlining it in red, or by pulling its value outside of the graphic. 

To format any individual element, first select the chart by clicking any 
part of it, and then click the element. To select a series, click one of the 
lines (or a single bar or column), which selects it and others of its color 
(Figure 129). You can also select a series after you’ve clicked a chart’s 
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Edit Chart Data button by clicking the row or column in the source 
table. 

Figure 129: Left: Clicking any column selects the entire series. 
Right: After formatting the selected series. 

Once a series is selected, you can add another to the selection with a 
⌘-click, or select all of them with Edit > Select All (⌘-A). 

Selecting text elements is covered later in this chapter. 

Tip: To resize a chart, select it and drag a selection handle. Resize 
it more in one direction than the other to change its look—making 
columns taller and thinner or short and fatter, for instance. (Resizing 
has no effect on a chart’s text elements other than moving them so 
they remain associated with the items they identify.) 

The Chart Tab
 

The Chart tab provides myriad options for modifying the overall look 
of a chart; in fact, there are so many that you’ll find that you need to 
scroll the inspector sidebar if you’re on a laptop. The segments avail-
able in the Chart tab vary based on the kind of chart you’ve selected; 
Figure 130 shows the Chart tab for a column chart. Bar charts have 
identical options, and most other charts share many of the same 
choices along with their own unique options. 
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Add Comments 
You can attach a comment to almost anything in Numbers: a table cell 
(but not the table itself), a chart, a text box, specific text inside a 
container, objects such as shapes and images, or the sheet itself. 
You can make notes for yourself or for colleagues sharing the file; 
comments are time- and date-stamped, and color-coded to each user. 
We’ll start with who gets to see your comments, and move on to where 
comments can go (Comments, Comments, Everywhere). Then you’ll 
learn how to Set Comment Options, and to Handle Comments and 
Replies. 

Set Comment Options
 

Comments are small notes that can be attached to almost any object on 
the sheet, and even to the sheet itself. There are three settings in 
regard to comments: color, author name, and text size. Two are set in 
System Preferences, and the third by menu command: 

•	 Color: The comment color setting is used for all comments by a 
specific author in a document, across all its tabs. It is discreetly 
applied to the author’s name and the text buttons for notes attached 
to an object. Freestanding notes on the sheet use the color for the 
note’s background, with a darker shade for its text buttons (Figure 
156). Choose a color from View > Comments > Author Color (you 
don’t have to select a comment note first). 

Figure 156: A comment for a sheet and one for an object. 
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•	 Author name: Go to Numbers > Preferences > General and enter 
an author name. Changes to this, and to text size, are retroactive not 
only for the current document, but for all documents: open one with 
your notes that were a different color, and they’re immediately 
updated. (When a document is shared through iCloud, the “author 
name” is the collaborator’s iCloud name.) 

•	 Text size: Choose from the pop-up menu at the bottom of 
Numbers’ preference pane. 

Note: Changes to color, author name, and text size are applied 

retroactively to previously saved documents when you open them.
 

Solo vs. Swapped vs. Shared
 

There are three basic scenarios in which you’d be using comments: 

•	 In a document for which you’re the only user: Comments are 
handy even when you’re the sole user: make a reminder about 
missing or temporary data, for instance, or use a comment and 
multiple replies to track the history of changes to data. 

•	 In a shared document: You might be simply emailing a docu-
ment back and forth for colleagues to see, edit, or comment upon. 
The author of each comment and reply is identified in the comment. 
Note, however, that there’s nothing that prevents any user from 
deleting notes or even editing others’ comments and replies, be-
cause there’s nothing that identifies a swapped document as having 
originated somewhere other than the current Mac, or having been 
created by anyone other than the current user. 

•	 In a collaborative document in iCloud: When you share a 
document through iCloud, the person who posted it is the owner, 
and has privileges other users do not. 
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Add Audio 
Numbers added a new dimension—sound—to spreadsheets several 
years ago with its voice recordings, which let you create memos for 
yourself or someone sharing the document. 

In this chapter, you’ll learn the basics of making voice recordings and 
Work in the Audio Tab of the Format inspector. 

Create a Voice Recording
 

To make a recording, choose Insert > Record Audio and click the Start 
button in the recording window (Figure 160). Speak your piece 

and then click the Stop button (which reverts to Record so you can 
continue recording). 

Figure 160: The recording window’s basic states: ready to record, 
during recording, and after clicking the Stop button. 

On the sheet, a recording is represented by the standard sound icon. A 
blue ring around it indicates it’s selected, and a thin white inside 
perimeter arc shows how much has been played. (Figure 161). 

Figure 161: The four states of a recording icon. 
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To select the icon without triggering playback, click the black area, not 
any white part. Or, drag from an empty spot on the sheet—you need to 
include only a tiny part of the icon for it to be selected. 

You can’t Use Titles and Captions for sound icons, which is especially 
ridiculous considering their utter sameness. (In the figure above, I 
used individual text boxes for the labels.) 

Note: Want some music on your spreadsheet? Maybe a theme song 
for its tables? Position the Numbers window and the Music app so 
that you can see them both, and drag any song that you own from 
the Music library to the sheet. 

Work in the Audio Tab
 

The Format inspector’s Audio tab (Figure 162), available when a 
recording is selected, provides playback controls, some options that are 
not available elsewhere, and an alternative route to editing a recording. 

Figure 162: The Format inspector’s Audio tab. The control buttons 
are for rewind, play, and fast forward. 
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Work with Shapes and 
Images 

In this chapter, I show you how to Add Shapes to a Sheet. You’ll learn 
Basic Shape Editing, some Advanced Shape Editing, and how to avoid 
recreating special shapes when you Create a Custom Shape or Use 
Shape Styles. Next, it’s All About Arrows, where you’ll learn about 
options for creating arrows (and other line endpoints). Finally, in Use 
Image Galleries, you’ll see how to store, view, and even search a series 
of images that can be viewed by flipping through them or by searching 
for the keywords that you’ve entered. 

Add Shapes to a Sheet
 

Numbers offers so many shapes that it has a toolbar Shape  menu 
that provides a popover (Figure 163) with a scrolling category list, a 
scrolling panel of images for each category, and a search field! 

Figure 163: Two of the categories in the Shape button’s popover. 

Click a category in the popover’s scrolling list and/or scroll through the 
pane, and then click a shape or drag it from the popover to the sheet. 
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But if you just want one of a dozen commonly used shapes, go to 
Insert > Shape for a submenu that lists them. They’re the shapes you 
see in the Basic category in the toolbar’s Shape  popover. 

Note: To use the pen tool (in the top-right corner of the Shape 
menu), click its icon and follow the onscreen directions, which explain 
how and when to click and/or drag to draw a freeform shape. 

Edit Shapes
 

Shapes in Numbers are aren’t static. You can alter the size, color, 
proportions, number of sides, and even curve a straight side. 

Basic Shape Editing 
To edit a shape: 

•	 Change its outline or fill: Select the shape and use the controls 
in Fill and Border sections of the Format inspector’s Style tab. 

•	 Resize it: Select it and then drag any perimeter resize handle. To 
resize the length and width proportionately, press Shift while 
dragging a corner handle; to resize it from its center, press Option. 
(Using Option-Shift does both.) 

•	 Alter its features: Select it and drag a green handle (which 
appear only on shapes that can be specially altered). What happens 
depends on the shape: you can, change the proportion of an arrow-
head to its shaft, a tail to its speech bubble, the angle and number of 
a star’s points, or the number of sides on a polygon (Figure 164). 
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Tackle Text 
A spreadsheet’s main concern is numbers, but it needs text to identify 
what the numbers represent, and also standalone text because some 
types of information must be conveyed with words. I don’t cover basic 
text formatting here, as it’s the same as in other Mac apps. But it’s 
important to know how to handle text in and outside of tables, and the 
latter starts, as does this chapter, with the “text container” concept. 
Next, you’ll learn how to Put Text in Text Boxes and Shapes, and then 
we’ll Tour the Text Tab. 

After that, I show you how to Use Paragraph and Character Styles. 
Finally, you’ll learn how to Search for Text and even Search for and 
Replace Fonts throughout your document (which may not be as handy 
as it sounds). 

What’s a Text Container?
 

In Numbers, text is always in a container. The main containers are text 
boxes and shapes, but elements of an object can be text containers: a 
table’s title and caption, for instance, or a chart’s legends. 

Here’s what you should know about text containers: 

•	 If there’s text on the clipboard and you use the Paste command with 
no container selected, Numbers obligingly creates a text box and 
puts the pasted text in it. 

•	 To paste text into a container, you must first select the container, 
and then click inside it to set the blinking insertion point; otherwise, 
you get a new text box. 

•	 To format all the text in a container, select the container and apply 
the format. To format just some of the text, first select the text. 
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Tip: To quickly deactivate a container’s text but leave the container 
selected to format it or move it with the arrow keys, press ⌘-Return. 

Put Text in Text Boxes and Shapes
 

Numbers has an element specifically devoted to text: the text box. But 
any shape from the toolbar’s Shape menu can be a text container— 
and by “shape,” I mean shape—not the lines that are also in that menu. 
Text boxes and shapes share common capabilities but differ signifi-
cantly when it comes to default formatting and resizing. 

Note: Apple needlessly refers to text boxes and shapes generically as 
two-handle and eight-handle text boxes, for the number of their 
resize handles.You can convert a two-handled text box into an eight-
handled text box by selecting it and choosing Format > Shapes and 
Lines > Reset Text and Object Handles, or by creating columns in the 
text box (using the Format Text tab, on the Layout pane. 

Text Boxes 
A text box is a handy little container, albeit annoying when it comes to 
resizing. To create one, click the Text button on the toolbar; a tiny 
box appears with the blinking insertion point in it, so you can start 
typing immediately. 

Tip: If there’s text on the clipboard, you don’t have to create a text 

box to hold it: just use the Paste command, and Numbers creates a
 

text box filled with the text.
 

A text box never overflows. Create a new one, start typing, and after six 
or seven inches’ worth of horizontal expansion, the text wraps down to 
a second line, increasing the height of the box. Type in an existing text 
box, and it automatically lengthens to accommodate the new text. A 
text box never “underflows” either: delete text and the box shrinks 
vertically, and then horizontally, to wrap tightly around the text. 
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Manipulate Objects 
Tables, with their strict row-and-column structure, can keep even the 
most disorganized user in check. But as you work on a sheet you’re not 
confined to a grid when you add tables, some charts, a few text boxes 
and maybe even images, movies, and recordings. 

Fortunately, Numbers has tools that can keep sheet elements in line 
(literally). In this chapter, after you learn about setting ruler and guide 
preferences and how to Select, Move, and Duplicate Objects, you learn 
how to align, group, and resize selected objects manually when you 
Work on the Sheet, and see how to take a more by-the-numbers 
approach (no pun intended) when you Work on the Arrange Tab. 

Set Ruler and Guide Preferences
 

Before trying to organize things on a sheet, head to Numbers > Prefer-
ences to turn on rulers and guides, since you’ll need them for precise 
object sizing and placement (Figure 184). 

Figure 184: Ruler and alignment preferences. 

Choose a unit of measure for your rulers, and check “Show size and 
position when moving objects” so that you’ll get a readout near the 
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pointer when you move or resize something. Also, set a color for guides 
(which affects both ruler and alignment guides). 

Finally, activate all five “Show guides” options; they are not as intru-
sive as you might assume, and they’re invaluable for neat sheets. I like 
the first four options, but I love the last one, for trackpads: “Use haptic 
feedback when snapping to guides.” That little tap against your finger 
when you’ve dragged something into perfect alignment is just superb. 
Since an object can be aligned at its top, bottom, sides, and vertical and 
horizontal centers with those alignment points on every other object 
on the sheet, as well as with every row and every column of every table, 
you wind up with what seems like a tiny machine gun frantically firing 
at your fingertip as you move something around on a crowded sheet. I 
sorta love that, too. 

Select, Move, and Duplicate Objects 

Select, move, and duplicate objects with the standard Mac methods: 

•	 Select: Click to select something and Shift-click or ⌘-click to add 
an item to, or remove it from, a selection. Drag to select multiple 
items—they don’t have to be completely inside the dragged area. If 
an object is selected, press Tab to select the next object, or Shift-Tab 
for the previous one. 

•	 Move: Drag an object to move it. Constrain the motion vertically or 
horizontally by pressing Shift after you’ve clicked the object. Alter-
natively, use the arrow keys to nudge a selected object, adding Shift 
to move by larger increments. For exact positioning, or objects, use 
the coordinate controls in the Position section of the Format 
inspector’s Arrange tab. 

•	 Duplicate: Create a copy of an object by dragging the item while 
pressing the Option key. You can press the key before or after you’ve 
grabbed the item, but do so before you move it. To Option-drag an 
active table, grab it by the table handle. 
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Import, Export, and Share 
Files 

If there’s anyplace that neither Apple nor Mac users can ignore what’s 
going on in the non-Apple world, it’s in the spreadsheet arena, where 
Excel has worn the laurels for decades. 

This chapter explains how you can exchange files with Excel and 
Import and Export Delimited Files (text files that use punctuation to 
indicate row-and-column breaks), including those that use multiple or 
nonstandard delimiters. And, because sometimes you’ll need to work 
in the other direction, you’ll also see how to Export as a CSV or TSV 
File. Finally, if you want to Share a Numbers Document “live” with 
other users, get started with the information here. 

Exchange Files with Excel
 

Numbers’ and Excel’s interfaces differ so fundamentally that it’s 
amazing they can talk to each other at all. A Numbers sheet is a blank 
canvas that can contain tables, charts, graphics, and standalone text, 
and a Numbers document can contain multiple sheets. An Excel 
worksheet is a vast, window-filling grid; a document can have multiple 
worksheets, and is then referred to as a workbook; its charts, and any 
images you add, float in movable, resizable window-ish frames. 

Note: Because the concept of “sheet” differs in Numbers and Excel,
 
to avoid confusion I’m going to use Excel’s alternative term, work-
sheet, when referring to the Excel environment, as I did above.
 

Import Excel Documents 
The good news is that you can open Excel documents in Numbers, and 
even charts can survive the procedure. The not-as-good news is that 
not everything survives, since Excel offers functions and options that 
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Numbers does not. (Apple’s Document Compatibility with Microsoft 
Office page offers a very extensive list of supported, partially support-
ed, and unsupported Excel features.) And now back to the good news: 
many things import flawlessly or with only minor problems, including 
cell and chart formatting and table-status items such as hidden col-
umns—and even graphic elements. 

Export Excel Documents 
Exporting a Numbers document in Excel format keeps improving; I’m 
amazed at how much of the Numbers document survives intact, 
especially when it comes to various types of charts. 

Here’s what happens in Excel when you open a Numbers document 
exported in Excel format: 

•	 Each sheet in the Numbers document becomes a worksheet in 
Excel, except when components from the Numbers sheet must be 
split across multiple sheets. 

•	 Although an Excel worksheet can look like a blank canvas, it’s not: 
it’s still a giant table grid—with its gridlines turned off. An exported 
Numbers sheet with multiple tables can look exactly the same when 
you see it in an Excel worksheet, but it’s not. The data (along with 
table and cell formatting) of each Numbers table is placed on the 
Excel grid in positions corresponding to those on the Numbers 
sheet, and the worksheet’s grid is turned off. 

•	 A Numbers sheet with tables and charts survives intact: the table 
data goes into the Excel grid, and charts float above the grid as 
Excel’s native charts do. 

•	 Interactive charts ( Make Interactive Charts) are converted to stan-
dard ones: where the Numbers interactive chart displays only one 
data set at a time, the Excel chart shows all of them in a single chart 
that is converted perfectly. 

•	 Titles and captions are converted to text boxes. 

•	 Rounded-corner bars and columns in charts are squared off. 
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Print Spreadsheets 
In Numbers, Apple chose to completely ignore its own interface for 
printing documents (the venerable Print dialog), and the result is a 
limited, non-intuitive, annoying setup. I shall henceforth (except for 
the spoiler alert below) refrain from complaining about what’s not 
available when it comes to printing, and show you how to use, and 
make the most of, the available options, with some special attention 
regarding how to Hone Headers and Footers. 

Spoiler alert: There’s no way to specify page breaks for tables or 
other elements in your document. They happen where they happen. 

The Print Process
 

Numbers has a unique approach to printing, necessitated by the fact 
that a spreadsheet with large tables can easily span multiple sheets of 
paper vertically, horizontally, or in both directions. The setup is not 
pretty, and it’s not particularly intuitive, but neither is it difficult once 
you see how it’s done. 

Note: Print settings are stored with a document, so save it after
 

you’ve set all the printing options.
 

To print a document: 

1. Preview the print version: Choose File > Print. 

Numbers switches to print preview mode, where each sheet in the 
document gets a tab at the top of the window, and the multiple 
pages necessary for a large sheet are shown as (very large) thumb-
nails (Figure 191). Initially, the active sheet is what you were 
working on when you chose Print; its name is highlighted, and its 
pages Click a tab to print a different sheet in the document. 
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Figure 191: The Print Preview thumbnails. 

Most importantly, the sidebar displays Print Setup options (it is no 
longer either the Format or Organize inspector). 

2.	 Set print options: Set the margins, paper size, orientation, and 
other basics in the Print Setup inspector, which shows up when you 
choose the Print command; its options are wonderfully self-ex-
planatory. (For help squeezing things on a page, read Make It Fit, at 
the end of this chapter.) 

3.	 Create headers and footers: Hover over a page thumbnail to see 
its header and footer fields; click a field to add text to it. 

You can set up a header and/or footer with automatic text such as a 
page number or date. For the most part, you add such content to 
headers and footers from the Insert menu; the Page Number, Page 
Count, and Date & Time commands insert smart-field information. 
They’re covered just ahead, in Hone Headers and Footers. 

4.	 Format text: When you are editing a header or footer field, a Text 
tab appears in the sidebar so you can format the text. 
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About This Book 
Thank you for purchasing this Take Control book. We hope you find 
it both useful and enjoyable. We welcome your comments. 

Ebook Extras
 

You can access extras related to this ebook on the web. Once you’re 
on the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
a subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read postings to the ebook’s blog. These may include new informa-
tion and tips, as well as links to author interviews. At the top of the 
blog, you can also see any update plans for the ebook. 

If you bought this ebook from the Take Control website, it has been 
automatically added to your account, where you can download it in 
other formats and access any future updates. 

More Take Control Books 
This is but one of many Take Control titles! We have books that cover 
a wide range of technology topics, with extra emphasis on the Mac 
and other Apple products. 

You can buy Take Control books from the Take Control online catalog 
as well as from venues such as Amazon and the Apple Books Store. 
But it’s a better user experience and our authors earn more when you 
buy directly from us. Just saying… 

Our ebooks are available in three popular formats: PDF, EPUB, and 

the Kindle’s Mobipocket. All are DRM-free.
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kind. Neither alt concepts inc. nor the author shall be liable to any person or entity for any 
special, indirect, incidental, or consequential damages, including without limitation lost 
revenues or lost profits, that may result (or that are alleged to result) from the use of these 
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