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Read Me First 
Welcome to Take Control of Numbers, Second Edition, version 2.2, 
published in June 2019 by alt concepts inc. This book was written by 
Sharon Zardetto and edited by Michael E. Cohen. 

Want to get more out of Apple’s Numbers app? This book’s for you! 
You’ll learn everything from the basic interface to the construction of 
intricate formulas; how to shuffle data around, and sort and filter it 
simply or with complex rules; and how to create tables and charts. 

If you want to share this ebook with a friend, we ask that you do so 
as you would with a physical book: “lend” it for a quick look, but ask 
your friend to buy a copy for careful reading or reference. Discounted 
classroom and Mac user group copies are available. 

Copyright © 2019, Sharon Zardetto. All rights reserved. 

Updates and More
 

You can access extras related to this ebook on the web (use the link 
in Ebook Extras, near the end; it’s available only to purchasers). On 
the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
any subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. You may find new tips or information, as 
well as a link to an author interview. 

If you bought this ebook from the Take Control website, it has been 
added to your account, where you can download it in other formats 
and access any future updates. However, if you bought this ebook 
elsewhere, you can add it to your account manually; see Ebook Extras. 
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What’s New in Version 2.2
 

Sometimes it’s difficult to keep up with Apple’s app updates. Within 
days of the original release of the second edition of this book, for 
instance, Numbers jumped from version 4.3 to 5.0, which we were able 
to accommodate with a swift update (to version 2.1) of this book. Since 
then, there have been several minor Numbers updates for “stability 
and performance improvements,” as well as tweaks to existing features 
and/or the addition of minor but convenient features. Numbers 5.3 
presented a major new feature—Categories (known in the Excel world 
as Pivot Tables)—along with some other tweaks and additions. We 
were in the final editing phase of our update about that when Apple 
polished up a few more things and released Numbers 6.0. In all, a 
wonderful, if frustrating, example of coevolution. As far as I’m con-
cerned, the jump to 6.0 was deserved for the addition of Categories, 
and not for what’s been tweaked since, but it’s now at the version 
number it deserves. 

The major additions to this book since the last version are: 

•	 The Organize inspector: This provides access to the pre-existing 
Sort and Filter tabs, as well as the new Categories capability. I talk 
about the inspectors in general in The Sidebar and Inspectors. 

•	 Categories: Numbers’ answer to Excel’s pivot tables is covered in 
Analyze Data with Categories. 

•	 Import and export improvements: The vastly improved 
importing of CSV and other delimited text files is described in 
Import and Export Delimited Files. Major improvements for im-
porting and exporting Excel files are described in Exchange Files 
with Excel, and Handle Fixed-Width Files is new. 

•	 Voice recordings: Create Voice Recordings on a sheet for your 
own reminders, or for comments or instructions to someone else. 
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Other additions and changes for this version include: 

•	 Chart-tweaking: There’s always more to formatting charts, so you 
can learn how to: use and format leader lines (that’s in a list in The 
Pie and Donut Chart Tabs); tweak your data presentation by adding 
Reference Lines (my favorite new small feature); adjust Value-Label 
Angles; and round the edges of bars and columns (Format Charts). 

•	 Data Redistribution: The procedure I previously described for 
redistributing data in unmerged cells no longer works, so I’ve 
provided a new method, described in Unmerged Data Redistribu-
tion. 

•	 Shapes: Have you ever wondered why those million or so shapes in 
the Shape menu are frequently, but not always, blue, and wished 
you could set a starting-out color for different sheets? Read The 
Color of Shapes. And as if 1000+ built-in shapes weren’t enough, 
you can Save a Custom Shape to the Shape menu. 

What was new in version 2.1 of this book: 

•	 The (then) new chart in town: the donut. Read about it in Choose 
the Right Chart and the renamed and expanded The Pie and Donut 
Chart Tabs. 

•	 A new section in the Import, Export, and Share Files chapter, “Con-
vert Delimited Files,” described Numbers’ new capability of import-
ing more than just the tab- and comma-delimited text files it could 
always handle. (However, that information has been updated again, 
since the capabilities have changed, and the section is now called 
Import and Export Delimited Files.) 

•	 A section on how to Use Image Galleries—little slide shows whose 
images have searchable captions—on your sheets. 

•	 Tabbed Windows (a feature that existed in the previous Numbers 
version, but one I hadn’t covered) explains how to corral multiple 
open documents into one easy-to-manage window. 
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Introduction 
When tax software came out for the Mac, I ignored it for several years. 
And my return was not all that simple, what with self-employed forms 
to be filled out, as well as those for dependent childcare expenses, and 
so on. No, I didn’t like working on paper. Nor did I skip my taxes. 

Instead of canned tax software, I had my spreadsheets. They looked 
like the tax forms, with text on each line, and a cell in the right margin 
to hold the numbers. I enjoyed setting up the interlocking of those 
cells, since a formula could refer to cells elsewhere on the sheet—and 
on other sheets. I could fill out the Business Use of a Home worksheet, 
and its total was reflected in a list of deductions on Schedule C, which 
was used to calculate the annual profit, which was used to figure the 
Social Security tax…. Okay, so I’m sorta geeky. But it led me to explor-
ing the ins and outs of Numbers (in a migration from Excel), which 
eventually led me to sharing the results of my explorations with you. 

Are you new to spreadsheet software, to Numbers in particular, or 
to Numbers 6? Have you had time to only skim the surface of the 
app but want to be more proficient? Are your formula-building skills 
limited to SUM and AVERAGE but you need more from your data? 
Do you wonder if it matters whether you use a line chart or a bar chart 
(it does!), or when a pie chart is the way to go? At the risk of sounding 
like an infomercial: If you answered “yes” to any of these questions, 
this book is for you. If you have other questions, this book is for you. If 
you don’t even know what questions to ask, this book is for you. 

This book is about Numbers 5 on a Mac running Mojave (macOS 
10.14.x). It does not specifically cover Numbers in iCloud (check it out 
by signing in at iCloud.com and clicking the Numbers icon) or on iOS 
devices. Almost all the information in this book, however, is directly 
applicable to Numbers for iCloud because Apple made a concerted 
effort to match the interfaces of the web and Mac versions. The funda-
mentals in this book, such as how to construct formulas, which charts 
to use for what kind of data, and filtering and sorting data, also apply 
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to the iOS version; and you’ll be surprised—I know I was—to see just 
how much of the information here is directly relevant to the iOS 
version. Sometimes you have to simply translate “click” to “tap.” 
Elsewhere, it helps if you’re versed in the iOS interface so that you’re 
comfortable tapping around to find pop-up menus, or working in 
popovers instead of the inspector sidebar. 

P.S.: Yes, I use tax software now. But I work with the forms, not just 
reply to an “interview” and let everything get done behind my back. I 
still like knowing where my numbers go, and putting them there 
myself. 

Just a few more things before we dive in: 

•	 If you’re new to the Mac, you can review basics that might help with 
some of the tasks in this book (such as using Cut, Copy, and Paste, 
and saving documents) in Tonya Engst’s ebook Take Control of Mac 
Basics. 

•	 When I refer to using mouse options or trackpad gestures, I usually 
assume their default settings; yours may be different. They can be 
adjusted in System Preferences > Mouse (or Trackpad). 

•	 The Mac’s shortcut menus disdain the menu bar in favor of almost 
anything else: one might be opened from almost any element in a 
window, or even from the bare desktop. They’re also called contex-
tual menus, a description that pre-dates Apple’s current nomencla-
ture. Their existence is usually totally hidden until you hover near a 
trigger spot, at which point a tiny menu indicator ( ) might appear, 
usually pointing down or to the right; clicking on, or very near, the 
indicator opens the menu. But you don’t need the indicator: a 
Control-click in the area where it would appear opens the menu. 
You can set an alternate shortcut-menu trigger in System Prefer-
ences > Mouse (or Trackpad), where it’s referred to as a secondary 
click. Since a Control-click works no matter your input device or 
preference setting, that’s the term I use throughout this book. 
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Numbers Quick Start 
Beginning at the beginning is not always what a reader needs. Here are 
some areas that you might want to check out first. 

Get started: 
•	 Read in-depth coverage of Numbers’ basics in Learn Terminology 

and the Interface, Work with Sheets and Templates, Review Table 
Basics, and Master Cell Basics. 

•	 If you’re new to spreadsheets in general, also check the Learn the 
Anatomy of a Table, read Cell Referencing 101, and Learn Data 
Entry Basics. 

•	 If you’re new to Numbers, but comfortable with spreadsheets, you’ll 
find these topics especially helpful: Manage Sheets, the Template 
Chooser, and Use Pop-Up and Contextual Table Menus. And you’ll 
love learning how to Analyze Data with Categories. 

Work more efficiently: 
•	 First, Customize Your Environment. 

•	 Keep your frequently used document setups instantly available: Use 
Built-In and Custom Templates. 

•	 Speed Data Entry with Autocomplete, and Type in Shorthand with 
Text Substitution when you can. Speed Data Entry with Autofill, 
and Use Special Data-Input Options: Create Checkboxes, Set Up 
Star Ratings, Build Pop-Up Menus, and Define Sliders and Step-
pers. 

•	 Don’t waste time recreating formatting combinations. Make Custom 
Templates for documents, Use Table Styles, Use Paragraph and 
Character Styles, and even Define a Default Text Box. 
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Work with formulas and functions: 
•	 If you’re new(ish) to spreadsheets, you should Master Cell Basics, 

Learn Formula-Building Basics, Cell References, and Understand 
Functions and Arguments. 

•	 Learn how to Work in the Formula Editor and then Explore the 
Function Browser. 

•	 To enter common formulas quickly, Use Quick Calculation Tokens. 

•	 If you know basic formula and function usage, and want to broaden 
your knowledge, read Nested Functions and Master IF Statements 
and Logical Operators. 

When looks matter: 
•	 A table can look both businesslike and friendly when you know your 

formatting options. See Apply Table Formats, Apply Basic Cell 
Formats, Review Standard Data Formats, and Create Custom Data 
Formats. 

•	 Standardize the look of components in tables and sheets with styles: 
Read Use Table Styles, Use Paragraph and Character Styles, List 
Styles, and the chart style information at the end of the The Chart 
Tab topic. 

•	 Keep things shipshape on a sheet by using Rulers and Ruler Guides 
and learning to Work in the Arrange Tab. 

•	 Add graphical elements to a sheet as described in “Drawing” 
Shapes, and create free-standing labels using Text Boxes. 

•	 Conquer Color Controls for everything from text to cell borders to 
shapes. 

Get more information out of your information: 
•	 Look at your data in a whole new way when you Make Interactive 

Charts. 

•	 Look at your data in a whole new light when you Analyze Data with 
Categories. 
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•	 Add extra statistical data (that doesn’t even appear in your table) to 
a chart with Reference Lines. 

Visualize data with charts: 
•	 Get the basics in Learn Chart Parts and Terminology and Choose 

the Right Chart, and then learn how to Create a Chart. 

•	 Work with the special chart options: Design 3D Charts and Make 
Interactive Charts. 

Work with other people: 
•	 When “other people” are Numbers users, learn to Share and Collab-

orate and Add Comments—and maybe Create Voice Recordings for 
more explicit instructions. When they are not, learn how to Import, 
Export, and Share Files. 
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About Numbers 
This chapter describes how to buy Numbers and stay updated, helps 
you Learn Terminology and the Interface, and explains how to Cus-
tomize Your Environment to suit your particular needs. 

Get Numbers and Stay Up to Date
 

If you don’t already have Numbers, the question is: Why not? It’s been 
a free download since April 2017 (along with Apple’s other productivity 
apps, Pages and Keynote). To download Numbers: 

1. Choose Apple  > App Store and sign in. 

2.	 Type numbers in the Search field. The Numbers app is likely to be the 
first item in the found list. 

3. Click the Get button. 

To update your copy of Numbers, go to the App Store. Click Updates in 
the sidebar or choose Store > Updates ( -7); find Numbers and click 
its Update button. If you have lots of updates waiting, you can use the 
search field to narrow the choices. 

Tip: You can set up automatic updates for your software from within
 

the App Store app. Choose App Store > Preferences, and select 

Automatic Updates, which downloads and installs updates when
 

they’re available. (I much prefer controlling updates on an individual
 
basis and at a time of my choosing.)
 

Learn Terminology and the Interface 

Because an app’s terminology is inseparable from its interface, we take 
a quick look at both in this section. 
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Tables and Sheets 
Numbers is not your [insert ancestor]’s spreadsheet program. Initially, 
a spreadsheet was a document with a grid of rows and columns. Today, 
while Numbers uses “spreadsheet” to refer to the document, that 
document can have multiple sheets, accessed by tabs in the window. 
Each sheet can hold multiple items, including text, charts, and pic-
tures. Want a grid for your numbers? Put a table on your sheet. 

The Sidebar and Inspectors 
The sidebar is a major interface element in Numbers: it’s a panel on 
the right side of the window that displays inspectors, the Function 
Browser, or printing options. It shows a specific inspector when you 
click the Format or Organize button on the toolbar, or when you 
select either from the View > Inspector submenu. The Organize inspec-
tor replaced the previous Sort & Filter inspector in honor of the new 
Categories capability; you can access all three organizational tools— 
Sort, Filter, and Categories—in this conglomerate inspector. 

Tip: Close an inspector with a click on its toolbar button or by select-
ing it again in the View > Inspector submenu (where the active 
inspector has a checkmark). 

Each inspector has multiple tabs that provide setting options that 
change based on the current selection on the sheet. Some tabs have 
further divisions, unnamed by Apple but that I refer to as panes, 
accessed by buttons (Figure 1). 
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Work with Sheets and 
Templates 

You can’t do anything in Numbers without working on a sheet—the 
blank canvas on which you place Numbers’ raison d’être: tables and 
their related charts, as well as fancier elements such as graphics and 
audio recordings. This chapter shows you how to create, name, and 
delete sheets, and how to use their tabs to manipulate multiple sheets 
in a document. Tabbed Windows describes a different kind of tab 
structure, one that makes juggling multiple open windows a thing of 
the past. Zoom In and Out explains how to get anything from a bird’s-
eye view to an extreme closeup of your sheet. Finally, I show you how 
to Use Built-In and Custom Templates. 

Manage Sheets
 

A Numbers document can have more than one sheet; each gets a tab 
immediately beneath the toolbar. Click the tab to display its sheet. 

The tab also provides a menu; open it by pointing to the tab and 
clicking the menu arrow that appears, or with a Control-click anywhere 
on the tab. The menu conveniently lists all the tables and charts on the 
sheet, in order of creation (Figure 5); other objects, such as shapes 
and text boxes, are not listed. Choose an item to select it, and the 
window scrolls if necessary to display it; this works for any sheet, not 
just the current one. 
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Figure 5: A sheet’s pop-up menu lists objects on it, and provides 
several sheet-handling commands. 

Tip: You can access the pop-up menu for any sheet, not just the 
active one. So, for instance, you can delete any sheet at any time. 

Here’s what you can do in the sheet tab area: 

•	 Add a sheet: Click the Add button on the far left. (Alternatively, 
choose Insert > Sheet). 

Note: A new sheet always starts with an empty table, which uses the 
first of the table styles included in the document (see Use Table 
Styles). 

•	 Go to another sheet: Click its tab or choose commands from the 
Window menu to go to the next, previous, first, or last sheet. If you 
prefer the keyboard approach, as I do, use Command-Shift-[ and 
Command-Shift-] to move to the previous and next sheet. 

• Reorder sheets: Drag a tab to a new position. 

•	 Scroll the tabs: Use the arrows at the right of the sheet tabs; 
the arrows appear when the tabs overflow the width of the window. 
On a trackpad, use a two-finger swipe when your pointer is over the 
bar (unless you’ve changed that default in System Preferences). 
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Review Table Basics 
Tables are the sine qua non of spreadsheet applications, so it’s impor-
tant that you understand the basics of table handling, whether you’ve 
never used a spreadsheet app or are accustomed to the Excel or Google 
Sheets approach where table=spreadsheet=table. 

In this chapter, I start with nomenclature for the parts of a table, and 
then cover how to Create and Control Tables. After describing how you 
Use Pop-Up and Contextual Table Menus and Name a Table, I show 
you how to Manipulate Rows and Columns, which covers important 
skills such as inserting, deleting, resizing, and hiding them. 

Note: When it comes to the next (granularly speaking) element in
 

tables, there’s so much to cover that it has its own chapter, Master
 

Cell Basics.
 

Learn the Anatomy of a Table
 

When you choose File > New and open a Blank template, it has one 
sheet (a tab), with a single table on it. The table is surrounded by 
various interface elements; when cells are selected, you see even more. 
Although Apple seems allergic to naming all the interface elements, we 
need names so we can talk about them, so I’ve fabricated some for our 
mutual convenience (Figure 9). 
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Figure 9: I use this terminology to talk about table elements. 
This figure is a composite—not all these controls are available 
at the same time in Real Life. 

Create and Control Tables
 

If you didn’t need tables, you wouldn’t need Numbers. And because 
they are the crux of the work you do in Numbers, you need to know 
how to create, select, move, delete, resize, and name them. But to do 
most of those things, you must be able to recognize a table’s state. 

Learn Table States 
A table can be in one of four states, depending on what you’re doing 
with it. What difference does the state make? Well, for one instance, if 
you press Delete when a table is active, you delete the contents of any 
currently selected cells, while pressing Delete when the table is selected 
deletes the table itself. In addition, there are some things you can do 
only when a table is active, and others only when it’s selected. Figure 
10 shows what the four states look like. 
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Master Cell Basics 
You’ll be spending lots of time selecting cells and moving around in 
tables, so knowing how to select and Move Between Cells and Move 
Within a Block of Cells can save a lot of time. This chapter also covers 
how you can Move a Cell or Its Data and Merge and Unmerge Cells 
(including what happens to the data when you do either). 

Cell Referencing 101 
You’ve probably already realized that a single cell is named, Bingo-
like, for its column and row: B2, E6, and so on. Multiple cells in a 
group (referred to variously as a block, range, array, or collection) 
are named for the top-left and bottom-right cells, with a colon be-
tween: A2:A6 or B5:D10, for instance. (See Cell References). 

Select Cells
 

To select a cell, just click it. (Selecting its contents takes another click: 
read Learn Data Entry Basics). Once selected, a cell’s ready for action: 
type something and it goes in the cell, press Delete and the cell con-
tents disappear. To select more than one cell: 

•	 Drag: Drag across contiguous cells to select them. 

•	 ⌘-click: ⌘-click any cell to add it to, or remove it from, the current 
selection; it doesn’t have to be contiguous with already-selected 
cells. 

•	 Selection handles: Drag a white selection handle to enlarge or 
shrink a selection. 

•	 Shift-click: With some cell(s) selected, Shift-clicking outside the 
selection adds cells, but what you wind up with depends on where 
you started. When you select a block of cells by dragging, everything 
is calculated from the cell that you click first. Drag-select the block 
A1:A3 by starting in A1, then Shift-click in A4, and you wind up with 
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A1:A4 selected, just as you’d expect. But start by selecting A1:A3 with 
a drag upward from A3, then Shift-click in A4, and only A3:A4 is 
selected (as shown in Figure 21), because A3 is the initial cell, and 
the Shift-click selected everything from that cell to the Shift-click 
spot. 

Figure 21: Adding to a selection with a Shift-click in A4. Left: Initial 
selection dragged from A1 to A3. Right: Initial selection dragged from 
A3 to A1. 

•	 Shift-move: Alter a selection by adding Shift to any keyboard 
option that moves you from one cell to another (except for Tab and 
Return, which reverse direction when you add the Shift key). So, 
with the selection A1:A3 made by dragging from A1 to A3: 

‣	 Pressing Shift-down arrow adds A4, the cell beneath the selec-
tion. If you started with a two-column selection, Shift-down 
arrow would add the two cells beneath that selection. 

‣	 Pressing Shift-right arrow adds B1:B3 because it selects cells in 
the next column that are adjacent to the already selected cells. 

‣	 Pressing ⌘-Shift-right arrow selects to the ends of the three 
rows. 

Note that if you selected the original block by dragging in the oppo-
site direction, your results would be different because they would be 
calculated from a different initial cell. 

•	 Entire rows or columns: See Select Rows and Columns. 

Touch Bar Tip: When you select a cells, the Touch Bar displays basic 
text and data formatting options, as well as a few shortcuts (such as 
for inserting formulas). I cover these options in the related topics. 
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Use Table Formats and 
Styles 

Numbers offers many options for table formatting that can make a 
table easy to read—or turn it into an abomination to behold. When 
it comes to avoiding the latter, here’s my advice: Practice restraint! 

I describe table format options, just below, that you can use to stan-
dardize a table’s look, and make its data easy to scan. With formatting 
skills under your belt, you can Use Table Styles to apply your perfect 
combo of formats to other tables, and Reorganize Styles to keep your 
most-used ones readily at hand. 

Apply Table Formats
 

The four formatting choices that affect an entire table—gridlines, the 
table outline, alternating row color, and overall text-size alteration— 
are all accessible in the Format inspector’s Table tab. You can apply 
these to any active or selected table, or to multiple selected tables: 

•	 Gridlines: Almost every table starts with cells delineated by gray 
gridlines. They can be switched on and off separately for body rows 
and columns, row and column headers, and footers (Figure 30). 

Figure 30: The gridline buttons. Left: Horizontal and vertical lines 
for body cells. Right: Header columns, header rows, and footer rows. 
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Tip: If you apply Cell Borders and later remove them, the gridlines 
beneath are likely to be gone, too. Getting them back is easy, but 
non-obvious. Select the area, go to the inspector’s Cell tab, click the 
appropriate gridline pattern from the Border choices, and choose 
Default Style from the Border Styles pop-up menu. 

•	 Table and name outline: In the Table Outline section, choose a 
line style from the pop-up menu, select a color, and set the line 
thickness; add the same outline to the table’s name by checking 
“Outline table name” (Figure 31). (Default Table Style sets the 
outline back to what’s defined in the table’s style.) 

Figure 31: Use the Format inspector’s Table tab to create a custom 
table outline and to turn the table name outline on or off. 

•	 Alternating row color: To make a table more readable, shade 
alternate rows: check Alternating Row Color (near the bottom of the 
Table tab), and then choose from the color well. Shading doesn’t 
have to be subtle shades of gray—other colors can be subtle, too. 
(See the tip on creating subtle shades in Meet the Color Well.) 

•	 Proportional text-size adjustment: If the text in a table in-
cludes more than one font size, you can proportionately enlarge or 
shrink all the text in a selected or active table by clicking the small 
or large Table Font Size button. (If cells in the table are selected, 
the change is still applied to the entire table.) 

In a selected (not active) table, you can use the shortcuts for 
Format > Font > Bigger and Format > Font > Smaller: ⌘-= (be-
cause of the plus sign on that key) and ⌘-- (that’s not a typo—it’s 
the minus sign). 
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Learn About Cell Formats 
“Format” is a nebulous word when it comes to table cells because it can 
refer to different things. A cell’s format defines its look: the back-
ground fill, borders, and text attributes such as font and color. A cell’s 
format also describes how its data should look—whether there are 
dollar signs on the numbers, for instance. 

In this chapter, I cover the details of basic cell formats—background 
fills and borders—and demystify the sometimes puzzling interaction 
between Cell Borders and Gridlines. I also explain one of my (and soon 
to be one of your) favorite features in Create Conditional Highlighting, 
which explains how to apply cell formatting based on its content. 

Apply Basic Cell Formats
 

You can use borders and fills to subtly define areas of your table, or to 
make it look like Times Square at night—which can be a thrill in real 
life, but in a spreadsheet? Not so much. 

Cell Borders 
Most tables start with staid gray gridlines as part of the table style. But 
you can easily highlight areas of the table using cell borders, which 
trump gridlines wherever they are used. Design and apply borders with 
the options on the Format inspector’s Cell tab (Figure 33). 

Figure 33: Border controls on the Cell tab: border patterns, menus 
for border and line styles, a color well, and stroke setting. 
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To apply borders to table cells: 

1.	 Select the target area in the table. 

2.	 In the Format inspector’s cell tab, click a pattern to define which 
lines in the selection you want formatted (Figure 34). 

Figure 34: Border choices and their targets when six cells are 
selected: Outline, All Borders, Inside Borders, and Middle Borders. 
(Middle Borders can be vertical, too, depending on the initial selec-
tion.) 

3.	 Select options from the border and line style menus (Figure 35). 

Figure 35: The menus for border and line styles. 

The Border Style menu has four sections: 

‣	 Recent: This applies the most recently used style, which is 
helpfully displayed in the menu. 

‣	 Selected Styles: This shows borders within the current selec-
tion; if nothing else, the table’s gridlines are an option. 

‣	 Table Styles: Choices here are those in the table styles used in 
the document. 

‣	 Default Style and No Border: Choosing Default Style returns 
selected cells to the gridlines defined in the table’s style. No 
Border removes not only borders you’ve applied, but also the 
underlying gridlines; restore them by choosing Default Style. 
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Control Data Input 
Put data in a cell? Sure, just click in a cell and type—what else is there 
to know? Well, you can start with the many different types of data that 
Numbers recognizes and handles automatically, as described in Under-
stand Automatic Data Formats, and how to Use Text Wrap in Cells 
when your cell runneth over. 

And then there’s letting Numbers do more of the work for you, when 
you Speed Data Entry with Autocomplete and Speed Data Entry with 
Autofill. You can also do more than just a plain ol’ copy and paste: 
Explore Copy and Paste Options shows you how to leave a cell’s for-
matting behind if you want, for instance, to paste only the formatting 
in a new location. 

Learn Data Entry Basics
 

To enter data, select a cell and type. This is convenient—you don’t have 
to click to put the blinking insertion point in the cell after you select it; 
but it can also be dangerous, because if there’s something in the cell, 
typing replaces what’s already there. 

When a cell’s not selected, double-click it to edit the contents. Each cell 
is like a teeny-tiny word processor; when you are editing a cell’s con-
tents, for instance, you can double-click a word to select it or drag 
across characters to select them. 

You have to let Numbers know that you’ve finished typing before 
it can use your input to calculate formulas or do its auto-formatting 
tricks. Navigating to another cell takes care of that, but if you want to 
see formula results or auto-formatting applied before you leave the 
cell, press -Return to deselect the contents. 

To erase all data from a cell, select the cell and press Delete. This works 
for a selected range of cells, too: you can clear multiple cells with a 
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single keypress. Comments are removed as well, but cell formatting, 
including its text formatting, remains “attached” to the cell. 

Graphics Are Not Data 
It seems that you can put an image in a cell: with an image on the 
clipboard and a cell selected, choose Edit > Paste and a tiny version 
of the image winds up in the cell. You can even paste in a video or 
audio file and its associated image shows in the cell. But the image is 
just background fill: the cell’s data appears on top of it. (Now that 
I’ve let that particular cat out of the bag, I’m counting on your not 
overdoing it.) 

The image is no longer an independent entity—you can’t drag or copy 
it out of the cell. That’s because it’s not data any more; it’s just fill 
formatting, like color—which is why your cell data goes on top of it. 

It’s not obvious how to get rid of a background image in a cell— 
unless you remember that it’s just a cell format at that point: select 
the cell and, on the Format inspector’s Cell tab, choose No Fill. 

Understand Automatic Data Formats
 

In cells that have the default Automatic data format set on the Format 
inspector’s Cell tab, Numbers recognizes these data types: 

•	 Number: When you finish entering a number, it’s right-aligned in 
the cell to reassure you that it’s been recognized as such. 

•	 Text: Text is anything that doesn’t qualify as any of the other data 
types, so it includes pure text as well as mixtures of text, numbers, 
and/or symbols. Text is automatically left-aligned in a cell. 

•	 Dates and Times: You can’t have a date without a time, or a time 
without a date; input one, and Numbers includes the other (al-
though it’s not always displayed in the cell): 

‣	 Date: Enter 5/23 and weekday, 5/23/[current year] 12:00:00 AM 
is stored. 

‣	 Time: Enter 12:27, and [current date] 12:27:00 PM is stored. 
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Learn About Data Formats 
Numbers lets you control two kinds of data formatting. There’s the 
data type: an entry of 3:02 could be a time, or a duration of 3 hours 
and 2 minutes, but formatting it specifically as a time or as a duration 
keeps things clear. And then there’s the data’s appearance: you enter 
2, but it could be displayed as 2.0 or 200%; or, a date could show as 
December 10, 2001 or 12/10/01 or the European 10 December 2001. 

In this chapter, I describe the standard data formats that Numbers 
recognizes and then show you how to Create Custom Data Formats, 
including how to use Alternative Formats with Rules to change a cell’s 
formatting based on the data in it. 

Review Standard Data Formats
 

Use the Data Format pop-up menu on the Format inspector’s Cell 
tab to define the type of data in a cell—overriding Numbers’ automatic 
recognition of data types—and to control how it appears no matter how 
it was entered (Figure 51). 

Figure 51: The Data Format pop-up menu in the Cell tab. 

The menu offers five data types, bookended by an all-purpose default 
and a roll-your-own option: 

•	 Automatic: This default lets Numbers identify your input so it can 
right-align numbers, left-align text, and format items such as dates 
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and times. Based on its identification of cell content, Numbers
 
displays appropriate formatting options on the Cell tab.
 

•	 Number formats: The six number choices control how your 
numeric entries display. Each has a subset of options so you can 
tweak things to your satisfaction, such as defining a type of currency 
or the number of digits in a fraction’s denominator. 

•	 Text: The text choice has no built-in data-format options. 

•	 Date & Time: As explained a little further on, date and time are 
inextricably intertwined, not only metaphysically, but in the way 
Numbers stores this information. 

•	 Duration: This is time from another perspective. Choose from 
week, day, hour, minute, second, and, yes, millisecond. 

•	 Input controls: These include special items such as those de-
scribed in Set Up Star Ratings and Build Pop-Up Menus. 

•	 Custom formats: These are covered just ahead in Create Custom 
Data Formats. 

To specify a data type, select the cell(s) and choose an option—such as 
how many decimal places to display—from the Data Format pop-up 
menu (Figure 52). You can do this before or after the data is entered. 

Figure 52: Data format options, such as those for Currency and 
Duration, change based on the data type chosen from the Data 
Format pop-up menu. 

Note: Even the default Automatic menu choice displays options for 
some of the data types Numbers automatically identifies. 
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Use Special Data-Input 
Options 

Numbers has five special cell-formatting options that both limit the 
scope of the that data can be entered (avoiding some mistakes) and 
speed up data entry. As a bonus, some of these formats provide at-a-
glance information—you don’t have to read numbers and compare 
them mentally, for example, when you see a string of stars. First up is 
creating simple but oh-so-handy checkboxes. Then you’ll learn to Set 
Up Star Ratings for one-click data entry, Define Sliders and Steppers to 
limit data to a range of allowed numbers, and, finally, Build Pop-Up 
Menus to control data input. 

Create Checkboxes
 

Checkboxes are easy to add to a table, and incredibly handy when all 
you need is to indicate whether a certain condition has been met or 
not: registered, passed exam, met quota, was present. They let you 
enter information quickly and easily scan a row or column of data. 

Note: You can try out checkbox setups in the Numbers templates 

Attendance (under Education) and Recipe (under Personal).
 

You typically add checkboxes to a column that has a label describing 
what the checkboxes represent. To set up the checkbox format: 

1.	 Select the cells. They can be blank or filled; Data-Checkbox Swaps, a 
little ahead, describes what happens if a cell already contains data. 

2. Go to the Format inspector’s Cell tab and choose Checkbox from 
the Data Format pop-up menu. 

Numbers puts checkboxes in all the cells. To use the checkbox… well, 
you know what to do. 
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Tip: Want to check or uncheck a box without your hands leaving the 
keyboard? With the cell selected, type 1 or T (for True) to check the 
box, and 0 or F (for False) to uncheck it. (The letters don’t need to be 
capitals.) 

Touch Bar Tip: Apple considers the checkbox input so handy that it 
shows up on the Touch Bar when you tap Format for selected cells 
(see Touch Bar Data Formatting). 

Manipulate Checkbox Data 
When you check or uncheck a box, Numbers stores the value TRUE in 
the cell for a checked box, and FALSE for an unchecked one—as you 
can see if you look at the Smart Cell View at the bottom of the window 
when a checkbox cell is selected. (I’m not yelling at you—TRUE and 
FALSE are capitalized in the cell to differentiate them from a plain text 
entry.) These are very important values, since they’re used as the basis 
for decisions when you Construct IF Statements. 

To remove checkbox formatting, select the cell and choose a different 
format from the Data Format pop-up menu on the Cell tab. If you 
choose Text, you see TRUE and FALSE entries in the cells; choose 
Number and you get a one (for TRUE) and a zero (for FALSE). As 
explained in What Is Truth?, these are equivalent values: zeros are 
false, and non-zero numbers are true. 

Data-Checkbox Swaps 
Numbers translates your data into checkboxes according to simple 
rules about what a checkbox represents: a zero is unchecked, or false, 
and any non-zero number (including negative values) is checked, or 
true. Blank cells are unchecked and the words true and false are 
predictably translated; any other text is unaffected (Figure 65). Just 
select the cells and apply checkbox formatting from the Cell tab. 
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Sort Data 
This chapter starts with the basics of how Numbers sorts letters, 
numbers, and blank cells. You’ll see how to quickly Sort with Column 
Menus, and Sort with the Inspector for more-sophisticated sorts— 
including a way to Sort Part of a Table. You’ll learn to Master Unsort-
ing and Unsortables (hint: there are ways to sort the latter), and Deal 
with Special Sorting Issues such as how sorting interacts with headers, 
footers, merged cells, and hidden rows. 

Understand Sorting Order
 

If you think sorting order is simple and obvious, then you need more 
variety in your tables. Here’s how Numbers determines sorting order: 

•	 Numbers: Numbers are always first. Formatting is ignored, so $2 
comes after 1 and before 3, while 3% (since it’s .03) comes before 1. 

•	 Formula cells: Cells with formulas in them are sorted according 
to their results—what’s displayed in the cell. 

•	 Numeric characters: These are numerals that aren’t used as 
numbers, as in a combination like 1-a or numbers in cells formatted 
to hold text. These numeric characters still sort before alphabetical 
ones, but they come after actual numbers. 

•	 Alphabetic characters: Alphabetic sorting is case-insensitive: 
capitalization is ignored, so A is the same as a. 

•	 Dates: If some dates are identical, they are sorted according to 
their “hidden” time stamps (see Understand Automatic Data For-
mats). 

•	 Punctuation symbols: Standard punctuation symbols—those in 
the ASCII set—are sorted according to their codes. 
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•	 Boolean values: When sorting cells that contain TRUE or FALSE 
as a result of an IF statement, a checkbox, or direct text entry, 
Numbers sorts FALSE before TRUE. This might be philosophically 
upsetting, but it’s because FALSE is considered zero and TRUE is a 
one (that’s more comforting), so they’re in numerical order. 

•	 Blank cells: Blank cells always end up at the bottom whether you 
do an ascending or a descending sort. 

Note: When it comes to Option characters—characters you get 

by pressing Option and another key (with or without Shift)—they
 

are mostly interspersed among the punctuation and the alphabetic 

characters, with the remainder coming after the alphabet.
 

Sort with Column Menus
 

Simple sorts are a cinch: choose Sort Ascending or Sort Descending 
from a column menu to sort by that column (Figure 72). 

Figure 72: The column menu’s sort commands. 

Note that I said “sort by” that column. The entire table is sorted 
according to the contents of that column, so rows change position 
within the table. (This can wreak havoc with some formulas, as de-
scribed later in Deal with Special Sorting Issues.) 

You can even subsort with column menus: sort data according to one 
column to group any repeated data there, and then sort the data in the 
next column so that its data is sorted within each of those groups. 
However, while “next” might imply a left-to-right order of column 
sorting, that’s not always the case. 
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Filter Data 
You may not always want to see all the data in a table. Perhaps you 
want to see only rows with a specific value in column A, or the higher-
than-some-threshold values in column B, or checkmarks in column F. 
You can do this, and more, when you use Quick Filters from a table’s 
column menus. More-sophisticated options, such as multiple criteria 
for filters, are described in Filter with the Inspector. 

Because this chapter is divided between the use of Filter menus and 
that of the Organize inspector for filtering, I’ll mention here two 
items that are common to filtered tables in general: 

•	 You can’t add rows to a filtered table; the Add commands are 
dimmed. 

•	 Data in hidden rows—those that disappear when a table is filtered— 
are not included in charts unless you check Hidden Data in the 
Chart Option section of the Format inspector’s Chart tab (see The 
Chart Tab. 

Note: Here’s an important concept to keep in mind: you don’t filter
 

out a value, you filter for a value. So, you define filters by what you
 

want to see, not by what you want hidden.
 

Use Quick Filters
 

When you want a quick look at a subset of the data in your rows, a 
“quick filter” is your best friend. You can apply it instantly using a 
column menu, specifying which values you want to remain visible. 

You can do quick filtering on an active or selected table using column 
menus: 

•	 Specify a filter value: Control-click a column label for its menu 
and choose from the Quick Filter submenu, which lists all the 
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unique values in the column. Figure 77 shows that choosing 2 from 
the column B (Jack) submenu leaves two body rows displayed, since 
only two rows have a 2. The sums and averages in the table are still 
calculated from all the cells that their formulas reference, no matter 
how many of those cells are showing. 

Figure 77: Left: The full table. Center: The Quick Filter submenu for 
Jack’s column. Right: The filtered table shows only two columns, but 
the Sum and Average footers are still calculated for all the cell data. 

Tip: To view a sum, average, or other common statistic for only the 
filtered info, drag across the displayed body cells, and then check the 
tokens in the Smart Cell View. 

•	 Add a second filter to a column: Select another item from the 
same submenu. In the example above, choosing a 3 as the second 
filter would leave four rows displayed, because there are two 2’s and 
two 3’s in Jack’s column. 

•	 Filter a second column: Choose from that column’s Quick Filter 
submenu. In our example, filtering for a 6 in column C (Jill) would 
leave only one row displayed, since it’s the only one that gets 
through both filters: the value in Jack’s column must be 2 or 3, and 
Jill’s column must contain a 6. 

It’s easier to predict how column filters will interact if you imagine 
one column winnowing the available rows, and the other then 
winnowing that group. The filter order doesn’t matter: you can filter 
Jack’s column first, and then Jill’s, or start with Jill’s and then filter 
Jack’s, and the result is the same. 
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Analyze Data with 
Categories 

In this very hands-on chapter, after you get acquainted with the 
concept of categories, you’ll Create a Sample Category Table so you’ll 
have something with which to work. I’ll show you how to Define and 
View Categories and then Add a Summary Function. Finally, there’s a 
list of brief but important information in More About Categories. 

Numbers’ Answer to Pivot Tables 
One of Excel’s premier features is pivot tables, a way of presenting 
table data from a different point of view, as it were, using different 
groupings of data—with or without related subtotals, grand totals and 
other statistics—in a format that lets you collapse and expand the 
groupings. 

Numbers’ take on the pivot-table feature is called Categories, and 
you can do amazing things with it. But to show you examples of what 
Categories can do, I have to send you to examples of what pivot 
tables can do, since they’ve been around much longer. 

Pivot tables were probably invented to track sales data, and most 
examples of the feature use that. But take a look at this one, which 
shows tracking of voter registration info in an Excel table (skip the 
how-to part, and check out the results about two-thirds of the way 
down the page). Also check out this one, in Google Sheets, that does 
use sales but has two text buttons at the bottom of the table that let 
you see two pivot-table views of the data. 

See the Categories Advantage
 

Say you’re tracking a school fundraiser and want to analyze the popu-
larity of cookies versus the frozen pie offerings. So, as you get orders, 
you use a table like the one in Figure 81 to track them. 

138 

Click here to buy the full 318-page “Take Control of Numbers” for only $14.99!

https://www.timeatlas.com/excel-pivot-tables/
https://support.google.com/docs/answer/1272900?co=GENIE
https://www.takecontrolbooks.com/cart?add-to-cart=1186


 

             
           

          

          
                

             
                

            
          

    
 

   

         
       

Figure 81: The starting point. 

You’d like to analyze the sales to check the popularity of each item, as 
well as the overall numbers for the categories (Cookies vs. Pies)—and 
maybe see if those cute first-graders are outselling their older compa-
triots. 

With Numbers’ Categories capability, it takes only four clicks to go 
from the table in the figure just above, to the one in Figure 82: a click 
on a popup menu in the Organize inspector, another on a button there, 
the third in the table to select a cell, and finally one on a pop-up menu 
in the table to add subtotals. (Another click collapsed the Pies category, 
but I’m counting only what it took to make the table.) 

Figure 82: A categories table showing the Pie and Cookies cate-
gories and their sales. 

Create a Sample Category Table
 

To experiment with categories, start by making a sample school fund-
raiser table like the one in Figure 83. 
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Handle Formulas and 
Functions 

Maybe you won’t ever think of formulas and functions as fun, as I do, 
but this chapter should at least remove any stress accompanying your 
dealings with them. It starts with the “quick calculations” available 
from the toolbar’s Insert menu and from tokens in the Smart Cell 
View. 

After you Learn Formula-Building Basics and how to Work in the 
Formula Editor to build formulas, I’ll help you Understand Functions 
and Arguments, and then Explore the Function Browser with you. 

Save Time with Quick Calculations
 

All of Numbers’ calculations are quick—very, very quick—but in the 
phrase quick calculations, “quick” refers to how quickly you can set up 
your table to do the most common spreadsheet calculations, skipping 
the step of opening the formula editor and defining a formula (see 
Work in the Formula Editor). The quick calculations appear in tokens 
in the Smart Cell View at the bottom of the window, on the toolbar’s 
Insert menu, and in the Insert > Formula submenu. As a bonus, 
you even get to specify which are your most-used calculations. 

These are the functions that are initially included in Numbers’ collec-
tion of quick calculations: 

• Average: Averages the numbers. 

•	 Minimum and Maximum: Finds the smallest and largest values 
in a range of cells. 

•	 Count (CountA): This is the problem child in the family. The 
menu lists the Count function, but in fact it’s the CountA function 
that’s used in the cell, as you’ll see if you check the cell’s formula 
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afterward. It’s beyond my imagination why Numbers lists it this 
way, especially as it’s correctly defined as CountA in the Smart Cell 
View. CountA reports how many cells in a range contain some-
thing—anything. Count, on the other hand, counts cells that contain 
numbers, expressions that resolve to numbers, or dates, ignoring 
both blanks and any other kind of data, such as text. 

•	 Product: Multiplies the selected cells together using the Product 
function. 

•	 Stock Quote: This isn’t included as a Smart Cell View token, but is 
included on the toolbar’s Insert menu. When you choose it, 
you are asked to provide a company name or stock symbol. The 
current share price appears in the cell, along with a popover that 
provides lots more information (double-click the share price if the 
popover isn’t visible). Not surprisingly, you need an internet con-
nection to keep the information current. (The STOCK function is 
also available for use in the formula editor, just like other 
functions.) Unlike the other choices on the Insert menu, Stock 
Quote is disabled if you’ve selected more than one cell. 

Use the Insert Button or Menu 
To use a function from the toolbar’s Insert menu or the Insert > 
Formula submenu: 

1.	 Select cells in a column or row, or as a block within the table or one 
that encompasses all the cells of the table. 

2.	 Choose a function from the Insert button’s menu, or from the 
Insert > Formula submenu. 

The formula is automatically placed on the right of a row selection, or 
at the bottom of a column or a block selection, adding cells to the table 
if necessary to accommodate it. 

Numbers has done all the work for you, but in the end, it has simply 
constructed a formula with the function you chose and the cells you 
selected, as you can see if you check the cell (Figure 89). 
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Master IF Statements and 
Logical Operators 

Back in the original Star Trek days, my grandfather made fun of “Dr. 
Spock’s” funny ears, conflating the Enterprise science officer with the 
baby-care expert who had come to fame a decade before. I loved Mr. 
Spock for his adherence to logic above all else (and his cocked-eyebrow 
reaction to Captain Kirk’s lack of same). It’s probably not coincidental 
that when I first encountered computer programming, I was most 
enamored of its use of logical functions, and that affection carried over 
to their use in spreadsheets. 

But, enough history. This chapter first delves into the concept of truth, 
as interpreted by a spreadsheet formula, with a quick side trip to 
Review Comparison Operators; after that, we’ll Construct IF State-
ments. You’ll Learn About Logical Operators (AND, OR, and NOT) and 
see how they expand the usefulness of IF statements, and then you’ll 
Put It All Together to construct a formula. Finally, you’ll see how to 
Construct Nested IF Statements, an incredibly convenient and flexible 
calculation tool. 

Note: Between the time I wrote this intro for the first edition and 

then reviewed its edits, Leonard Nimoy—“Mr. Spock”—died. LLAP
 . 

What Is Truth?
 

What is truth? Surely, a question for the ages. Except in a spreadsheet, 
where the definitions for true and false are straightforward: 

•	 Numbers and expressions that evaluate to numbers: A zero 
is false, and all other numbers are true. So, 42 is true; so are 3÷5, 
and -15, and a reference to cell B7 unless it holds a zero. 
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•	 Numeric comparisons: Comparisons are intrinsically true or 
false: 4<3 and 5=7 are false, while 12>10 and 4×3>10 are true. 

•	 Text: While text by itself is “false” (since it’s not a non-zero 
number), it can be used in the truth test of an IF statement. So, 
if the name Bartleby is in B2, the comparison in the statement IF 
B2="Bartleby" is considered true. 

•	 Blank cells: References to blank cells return a false result. 

The importance of “truth” in a spreadsheet is not an issue of accuracy, 
but one of what is entered in a cell based on some condition that you 
can test—the equivalent of If HighestSalesFigure is greater than 
$5000, then put “High Sales Award” in this cell. 

Note: The word TRUE or FALSE alone in a cell is considered true or 
false in an IF test; they are so special that if you type either in 
lowercase, it’s automatically capitalized. When you Create Checkbox-
es the actual cell content is TRUE if checked, and FALSE if not. 

Review Comparison Operators
 

While I shouldn’t assume anything at all about you, I wrote 4>3 in the 
previous topic (just above), assuming that you know it means “4 is 
greater than 3,” and that 4<3 means “4 is less than 3.” Just as plus, 
minus, and equals signs are considered mathematical operators, the 
greater than and less than symbols are comparison operators, and they 
get heavy-duty use in IF statements. 

The other comparison operators are ≥ (greater than or equal to), ≤ 
(less than or equal to), and ≠ (does not equal). These characters are 
available from the keyboard using the Option key: Option-period, 
Option-comma, and Option-equals). However, you can simply type the 
two-character version of an operator (>=, <=, or <>) in the formula 
editor, and Numbers replaces it with the single-character version. 
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Work with Text Functions 
Say your friend/brother/boss gives you get a spreadsheet of names and 
addresses and says: “I need just a list of names (last name followed by 
a comma and then the first initial); the data came in a little weird and 
the state abbreviations need to be capitalized; the city, state, and zip 
code columns need to be combined with a comma and space inserted 
after the city, and a space between the state and zip code, okay? And, 
oh, can you automatically generate an email address that each person 
will be assigned—it’s just the last name, the first two letters of the first 
name, the ‘at’ symbol…”. 

Yes, you can do all these things—and easily, since Numbers lets you 
manipulate text in many ways. In this chapter, after you get acquainted 
with text terminology, you’ll Learn Basic String Manipulations— 
combining and splitting strings of alphanumeric characters so you 
can do such things as extract the last name from a cell that holds a full 
name. After that, I’ll show you how to Master Other Common Text 
Tasks, such as changing uppercase letters to lowercase, or vice versa, 
and stripping extraneous spaces out of sloppy data. 

Well before you reach the end of this chapter, you’ll understand this 
text-manipulation formula, and why you’d want to use it: 

RIGHT(A2,LEN (A2) - FIND(" ",A2,1)) & ", " & LEFT(A2,FIND(" ",A2,1)-1) 

Really. Promise. 

Know Your Text Terminology
 

Here’s a turbo lesson on the terms and concepts we use when manipu-
lating text in a spreadsheet: 

•	 A string is any series of characters—letters, numerals, punctuation, 
and/or symbols. It can be only letters, but doesn’t have to be, and 
it’s often referred to as a “text string.” 
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•	 In formulas, strings appear in quotes: “John” or “Final:” or “.edu”. 

•	 When strings are being compared, everything counts: spaces, 
punctuation, and letter case. None of these strings matches any of 
the others: A well-done steak; a well-done steak; A well done steak. 

•	 An empty string is a pair of quotes with nothing inside: "". It’s 
often used in a formula to delete unwanted characters (by replacing 
a character with an empty string—nothing). 

•	 You can’t “add” text strings together (how much is “hello” + 
“there”?). But you can concatenate them—join them together—with 
an ampersand. So, while 2+3 equals 5, the concatenation 
"hello"&"there" results in hellothere. You can type a space on 
either side of the ampersand to make the formula easier to read 
("hello" & "there"), but it’s not necessary: spaces outside quotes 
aren’t used in a calculation. When you need a space between words, 
put it in quotation marks in the formula: "hello"&" "&"there" 
results in hello there. 

If you’re paying close attention, you might be thinking that you 
could just use "hello there" with the embedded space, and you’d be 
right. But you’ll be using this technique when referencing cells 
containing text: B2&" "&C2. 

Learn Basic String Manipulations
 

Before I provide specific examples, here’s some general guidance for 
creating your own formulas to handle text strings. 

When you need to manipulate text to create a specific outcome, think 
about the details you need. For instance, for a last name followed by 
an initial, you need: 

last name + a comma + a space + first letter of first name 

With a spreadsheet that includes full names, it’s easy to see what the 
spreadsheet provides (last name and first name), what you have to add 

178 

Click here to buy the full 318-page “Take Control of Numbers” for only $14.99!

https://www.takecontrolbooks.com/cart?add-to-cart=1186


            
         

         
            

          
    

          
             

           
  

    

        
              

             
          

  

Create Charts 
A chart or graph is not only a good way, but often the only way, to 
reasonably interpret a pile of data. Numbers provides enough chart 
choices to both represent almost any data you’re wrangling and poten-
tially confuse you as to which type to use. And you could practically 
suffocate in its variety of formatting options, unless you stick with 
straight-vanilla presentations—and who wants that? 

We begin at the beginning—chart terminology—and then cover how to 
Choose the Right Chart. Next, you’ll see how to Create a Chart and Edit 
Chart Data, and we then move on to Numbers’ specialities with Design 
3D Charts and Make Interactive Charts. 

Learn Chart Parts and Terminology
 

Working with charts requires a somewhat specialized vocabulary, as 
you can see in Figure 113, which shows a bar chart, one of the most 
common chart types. Most of the labelled items are also used in other 
kinds of charts (described just ahead in Choose the Right Chart). 

Figure 113: Elements of a chart. 
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Here’s a brief description of the labels in the figure, along with some 
related terms: 

•	 Chart title: This starts out hidden; turn it on by clicking the Title 
checkbox in the Chart Options section of the Format inspector’s 
Chart tab. 

•	 Axes: The vertical axis of a chart is the Y axis (fifth-grade 
mnemonic: Y goes to the skY); when there are two, they’re referred 
to as Y1 and Y2. The horizontal axis is the X axis. A value axis is one 
that has numeric values; a category axis has text that describes 
groups of data. 

Note: If you visualize the sample chart above as a bar chart (with
 

horizontal bars instead of vertical columns), you’ll realize that the
 

value axis is not always the Y axis, nor are categories always on the
 

X axis.
 

•	 Data series: This is a set of values that make a line, or bars of the 
same color, in a chart. In a scatter chart, they’re the values that 
define either the x-coordinate or y-coordinate data. 

•	 Scale: The scale defines the components of a value axis: its lowest 
and highest values, and the intervals between. 

•	 Value labels: These are optional elements that identify the exact 
value for each data point. The labels can be within or outside the 
bar, column, or pie wedge, and be vertical, horizontal, or diagonal. 

•	 Legend: An optional, but almost always necessary, element that 
identifies the data series (or the pie slices) in the chart. 

•	 Category labels: These typically identify the X axis items, which 
are usually categories rather than numbers; they often identify 
groups of data, as they do in Figure 113, above. 

•	 Background and border: The background is the area behind the 
lines or bars (or pie), not the entire chart with its axes and labels; it 
includes a donut chart’s hole. The border is simply the edge of the 
category axis—the bottom edge in the figure above. 
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Format Charts 
When it comes to charts, the Format inspector provides formatting 
options for both the overall chart (background color and legend text, 
for instance) and its separate elements (such as bar/line color and data 
labels). Which tabs are available depends on what you’ve selected: a 
whole chart (and what kind) or chart elements (and which ones). The 
options within each tab also vary with your selection. There’s an 
overabundance of formatting choices for charts, which can’t all be 
covered here; for the most part, their use is obvious (adding and 
formatting labels, choosing colors, and so on). This chapter covers the 
more important, and the less obvious, features in these tabs. 

After you learn how to select individual chart elements, we explore the 
formatting tabs (The Chart Tab, The Axis Tab, The Series Tab, The 
Style Tab, and The Pie and Donut Chart Tabs), where you can set all 
the basic formatting for a chart as well as do such things as reposition 
value labels, change the style of the lines in line charts, and explode a 
pie or donut chart or reorder their pieces. I also show you how you can 
Manipulate Images for Fills to put pictures in bars, columns, and pie 
wedges, and Tweak Text Elements so that your titles and labels are as 
clear as your data presentation. 

Select Chart Elements
 

While some formats affect the entire chart, others can be applied to 
elements separately. So, you can highlight the columns that represent 
the current year by outlining them with a dotted line, or put values 
inside most of the columns of a chart but call out one series by having 
the value outside the graphic. 

To format any individual element, first select the chart by clicking any 
part of it, and then click the element. To select a series, click one of the 
lines (or a single bar or column), which selects it and others of its 
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color. You can also select a series after you’ve clicked a chart’s Edit 
Chart Data button by clicking the row or column in the source table. 

Once a series is selected, add another to the selection with a ⌘-click, or 
select all of them with Edit > Select All (⌘-A) (Figure 135). 

Figure 135: Left: Clicking any column selects the entire series. 
Right: After formatting the selected series. 

Selecting text elements is covered in Tweak Text Elements. 

Tip: Resize a chart by selecting it and then dragging a selection 
handle. Resize it more in one direction than the other to change its 
look—making columns taller and thinner or short and fatter, for in-
stance. Resizing has no effect on a chart’s text elements other than 
moving them so they remain associated with the items they identify. 

Touch Bar Tip: The Touch Bar provides many shortcuts for chart 
formatting, with choices dependent upon what’s selected. When the 
entire chart is selected, for instance, you get Show/Hide Category 
Labels and Series Values, and the option to enlarge or shrink all the 
text. Selecting a text element provides more granular text-formatting 
choices (see Touch Bar Text and Paragraph Formatting). 

There’s an overabundance of formatting choices for charts, which can’t 
all be covered here. For the most part, their use is obvious: adding and 
formatting labels, choosing colors, and so on. This section covers the 
more important, and the less obvious, features in these tabs. 
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Add Comments 
You can attach a comment to almost anything in Numbers: a table cell 
(although not the table itself), a chart, a text box, specific text inside a 
container, objects such as shapes and images, or the sheet itself. 
You can make notes for yourself, or to colleagues sharing the file; 
comments are time- and date-stamped, and color coded to each user of 
a document. 

This chapter starts with the basics of setting options related to com-
ments; after that, I describe how to Handle Comments and Replies. 

Set Comment Options
 

You can choose a color for your comments, which is applied to the 
notes themselves and also to their markers on objects. If you’re writing 
comments for anyone besides yourself, you should also set your author 
name so other users know who made what comment or reply. These 
settings are not all in the same place: 

•	 Comment color: Choose a color from View > Comments > Author 
Color (you don’t have to select a comment note first). The color is 
used for all comments by a specific author in a document, across all 
its tabs. For notes attached to objects or table cells, the color is 
discreetly applied to the author’s name and the note’s text buttons 
(Reply, Delete, and so on); freestanding notes on the sheet use the 
color for the “paper,” with a darker shade for text buttons (Figure 
164). 

Figure 164: A note for an object and for a sheet. 
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•	 Author name: Go to Numbers > Preferences > General and enter 
an author name. Changes to this setting, and to text size, are 
retroactive not only for the current document, but for all open 
documents and any document you open afterwards. (When a docu-
ment is shared through iCloud, the “author name” is the collabora-
tor’s iCloud name.) 

•	 Text size: Choose from the pop-up menu at the bottom of the 
preference pane. 

Solo vs. Swapped vs. Shared 
There are three basic scenarios in which you’d be using comments: 

✦	 In a document for which you’re the only user: Comments are 
handy even when you’re the sole user of document: make re-
minder notes about missing or temporary data, for instance, or 
use a comment and multiple replies to track the history of changes 
to data or a formula. 

✦ In a shared document: You might be simply emailing a docu-
ment back and forth for colleagues to see, edit, or specifically 
comment on. The author of each comment and reply is identified 
in the comment. Note, however, there’s nothing that prevents any 
user from deleting notes or even editing others’ comments and 
replies, because there’s nothing that identifies a swapped docu-
ment as having originated somewhere other than the current Mac, 
or having been created by anyone other than the current user. 

✦ In a collaborative document in iCloud: When you share a 
document through collaboration in iCloud (read Share and Collabo-
rate), the person who posted it is the owner, and has privileges 
other users do not. 

Handle Comments and Replies
 

It’s not always obvious which elements can hold comments. You can 
attach a comment to: 

•	 A table cell: You can’t add a comment to the table as a whole, but 
you can put one in any cell, and add as many comments as there are 
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Create Voice Recordings 
You can add one or more voice memos to your sheet, for yourself or for 
someone who’s sharing the document. After you make a recording, you 
can Work in the Audio Tab, where there are some special options, and 
learn how to trim a recording and to add or replace its ending in Edit a 
Recording. 

Create a Recording
 

1. Chose Insert > Record Audio and click the Start button in the 
Record Audio window that appears. (You can move this window— 
which I’ll refer to as the “recording window”) within the confines of 
the sheet.) 

2. Speak your piece, and then click the Stop  button. 

You can also use the Stop button to simply pause; it changes to a 
record button so you can continue recording. 

3.	 Add the recording to your sheet by clicking the Insert button (Fig-
ure 168). 

If you want to review the recording first, click the Preview button. 
The audio plays, and an Edit button appears in the corner so you 
can alter it. 

Figure 168: The recording window: Ready to record; during record-
ing; and after clicking the Stop button. 

A recording is represented on the sheet by an icon that changes based 
on the state of the recording. When it’s dormant, the standard sound 
icon is displayed. When you’re playing the recording, the icon toggles 
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between pause and play buttons; it returns to the dormant stage when 
you click another object or the sheet itself (Figure 169). 

Figure 169: The three states of a recording icon: dormant, playing 
(providing a Pause button), and paused (providing a Play button). 
The blue “halo” indicates the recording is selected. 

In the figure above, which shows these states, the blue “halo” around 
an icon indicates it’s selected on the sheet, and the white perimeter arc 
represents how much of the audio has been played. (Oddly, what 
doesn’t change is the size of the icon when you Zoom In and Out.) The 
red title/instructions beneath the icon in the figure is simply a text box 
(see Put Text in Text Boxes and Shapes), added to instruct an unin-
formed user with whom the spreadsheet might be shared. 

Tip: If you lock an audio icon to keep it from being moved, it’s still
 
playable. (Locking and unlocking objects is covered in Work in the
 

Arrange Tab.)
 

Work in the Audio Tab
 

The Format Inspector’s Audio tab, available when a recording is 
selected, provides some playback controls that are not otherwise 
available, and yet another route to editing your recording (covered 
next). 

Go to the Audio tab to: 

•	 Fast forward or backward: Press and hold either button to 
move to a spot in the recording where you want to start editing. 
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Work with Shapes and 
Images 

In this chapter, I show you how to Add Shapes to a Sheet and alter the 
default color offered in the toolbar’s Shape menu in The Color of 
Shapes. You’ll learn Basic Shape Editing, Advanced Shape Editing, and 
how to avoid recreating special shapes when you Save a Custom Shape 
or Use Shape Styles. Next, it’s All About Arrows, where you’ll learn 
about options for creating arrows (and other line endpoints). Finally, 
in Use Image Galleries, you’ll see how to store, view, or search a series 
of images that can be viewed by flipping through them or by searching 
for the key words that you’ve entered. 

Note: Other chapters cover features that also apply to shapes: 
Manipulate Objects, Conquer Color Controls, and most of Tackle Text 
(especially Put Text in Text Boxes and Shapes). 

“Drawing” Shapes
 

You can use shapes—not just what you think of as geometric or 
freeform shapes, but also lines and arrows—to enhance a document 
and make it more cluttered… I mean, understandable. And let that 
be a lesson: it’s easy to slip from understandability to clutter, so don’t 
get carried away. Toward that end, I shall avoid getting carried away 
in my coverage, which is difficult because working with shapes can be 
so creatively satisfying—and even more fun now, since Numbers added 
a plethora of new pre-made shapes. (I wrote that previous sentence in 
a prior update to this book; the latest Numbers update includes even 
more shapes, but how many—and why? There are about 1000 shapes 
now, but I have no answer for the second question.) 
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And why is “drawing” in quotation marks in this section title? Because 
99% of the time instead of drawing you’ll be hammering a pre-made 
shape into… shape. 

Add Shapes to a Sheet
 

Numbers includes so many shapes that it has a toolbar Shape popover 
that includes a scrolling category list and even a search field! 

But before you head there, if you’re looking for one of the dozen most 
frequently used shapes, head to the Insert menu’s Shape submenu, 
which lists what it believes to be those dozen (Figure 172). 

Figure 172: The Insert > Shape submenu. 

Click the Shape button on the toolbar to access the popover. The 
color of the shapes in the popover, as with other toolbar object choices, 
depends on the styles in the current document. To peruse the shapes, 
scroll down in the right pane or click a category in the scrolling pane at 
the left (Figure 173); click the shape you want added to the sheet. 
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Tackle Text 
A spreadsheet’s main concern is numbers, but it also needs text to 
identify what the numbers represent. I don’t cover basic text format-
ting here, as it’s the same as in other Mac apps. But it is important to 
know how to handle text in and outside of tables, and the latter starts 
with the “text container” concept. Then we Tour the Text Tab, learn 
how to Put Text in Text Boxes and Shapes, and Create Bullet and 
Ordered Lists. After that, I show you how to Type in Shorthand with 
Text Substitution and Use Paragraph and Character Styles. Finally, 
you’ll learn how to Search for Text and even Search for and Replace 
Fonts throughout your document (the latter may not be as handy as it 
sounds). 

What’s a Text Container?
 

In Numbers, text is always inside something—a container. Sometimes 
that’s obvious (a text box or a shape), but elements of an object can 
also be text containers: a table’s name and each of its cells, for in-
stance, or a chart’s name, legend, and labels. 

Here’s what you should know about text containers: 

•	 If there’s text on the clipboard and you use the Paste command with 
no container selected, Numbers obligingly creates a text box and 
puts the pasted text in it. 

•	 To paste text into a container, you must first select the container, 
and then click inside it to set the blinking insertion point. (Other-
wise, Numbers creates a new text box for the text.) 

•	 Format all the text in a container by selecting the container and 
applying the format. To format some of the text, first select it and 
then apply the formatting. 
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Tip: If the text in a container is active but you want the container 
itself selected so you can format it or move it with the arrow keys, 
press ⌘-Return. (This is a mite quicker than the alternative: click 
outside the container to inactivate the text, and then click the con-
tainer to select it.) 

Tour the Text Tab
 

Here’s a Cook’s tour of the Format inspector’s Text tab, because 
even ebooks have page-count limits, and we have more important 
things than text formats to cover. The tab, with its Style and Layout 
buttons, is available when you select text or a text container: 

•	 Style: Click the Style button to see general text-formatting choices 
and options for Create Bullet and Ordered Lists. 

• Layout: A click on the Layout button provides these options: 

‣	 Columns: Work here to create text columns within a shape. 
Define the number of columns (type a number or use the arrows 
next to the field), their width, and the width of the gutter—the 
space between the columns. To redefine a column’s width, dou-
ble-click its measurement in the Column column (!) and type the 
new size (Figure 183); if you’ve checked Equal Column Width, 
all the columns change to match. Change the gutter size similar-
ly; multiple gutters can have differing widths. 

Figure 183: Edit column and gutter sizes on the Layout pane. 
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Manipulate Objects 
Tables, with their strict row-and-column structure, can keep even the 
most disorganized user in check. But as you work on a sheet you’re not 
confined to a grid as you add tables, some charts, a few text boxes and 
maybe even images, movies, and recordings. 

Fortunately, Numbers provides tools that can keep sheet elements in 
line (literally). In this chapter, after you attend to the basics of setting 
ruler and guide preferences and reviewing how to Select and Move 
Objects, you learn how to align, group, and resize selected objects 
manually when you Work on the Sheet, and see how to take a more by-
the-numbers approach (no pun intended) when you Work in the 
Arrange Tab. 

Set Ruler and Guide Preferences
 

Before trying to organize things on a sheet, set your preferences for 
rulers and guides, since you need them for precisely sizing and placing 
objects. Go to Numbers > Preferences > Rulers and then: 

•	 Choose a unit of measure for the rulers. 

•	 Check “Show size and position when moving objects” to see a 
readout near the pointer whenever you move or resize something. 

•	 Set a color for guides. This affects both ruler and alignment guides. 

•	 Activate all four “Show guides” options, as they are not as intrusive 
as you might assume, and they’re invaluable for neat sheets. 

•	 If your Mac has a Force Touch trackpad, experiment with the haptic 
feedback option, and then decide if you want to use it. When the 
setting is checked, you get feedback as you drag an object around on 
the sheet: you can feel when it snaps into alignment with another 
object. However, since an object can be aligned at its top, bottom, 
sides, and vertical and horizontal centers with those same align-
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ment points on every other object on the sheet, as well as with every 
row and every column of every table—you wind up with what 
seems like a tiny machine gun frantically firing at your fingertip as 
you move something around on a crowded sheet. 

Select and Move Objects
 

Methods for selecting and moving objects on a sheet are common to 
most apps (and the Finder), so here’s a quick review: 

•	 Select an object: Click to select something; Shift-click or ⌘-click 
to add an item to, or remove it from, a selection. Drag around 
multiple objects to select them—they don’t have to be completely 
inside the dragged area: you can just drag the cursor so that it 
touches each of the items. 

Tip: Once an object is selected on a sheet, pressing Tab selects the 
next object, and Shift-Tab the previous one. The selection order is 
top-down; if two objects’ uppermost parts are at the same spot, their 
order is left-to-right. 

•	 Move an object: Drag it, or use the arrow keys to nudge a selected 
object, adding Shift to an arrow key to move the object by larger 
increments. Add Shift to a drag (press after you’ve started dragging) 
to constrain the motion vertically or horizontally. For exact posi-
tioning, use the coordinate controls in the Position section of the 
Format Inspector’s Arrange tab. 

•	 Copy an object: Press Option when you drag an object to pull out 
a copy. To Option-drag an active table, you must grab it by its name 
or its table handle; anywhere else selects the cells you’ve touched. 
An inactive table can be Option-dragged by its name; if it has no 
name, you must activate it before Option-dragging. 
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Conquer Color Controls 
What a long way we’ve come from the black-and-white world of the 
early Mac and the first spreadsheet program it had from Microsoft… 
Multiplan! (Didn’t see that coming, did you?) 

In fact, we’ve come so far that color options get their own short chap-
ter, since they are myriad, ubiquitous (for tables, cells, charts, lines, 
shapes, and even text), and not always intuitive. 

After a tour of the color well approach for color choice, I show you how 
to Design Gradient Fills and Customize Color Palettes so you don’t 
have to recreate a nonstandard color when you want to use it again. 

Meet the Color Well
 

A color well provides color choices; in a stretched-to-the-limit 
metaphor, you dip into the well for a color. The well displays the color 
of the currently selected item and/or any special characteristics, such 
as a gradient or an opacity level, and also indicates if no color is ap-
plied (Figure 202). The “duplex” version includes a Colors button 
that opens the Colors window for roll-your-own hues. 

Figure 202: The many faces of a color well. Top: Solid, a color with 
a Colors button, no color applied, and multiple colors in a selection. 
Bottom: a gradient fill, a base color and its current opacity level, and 
an image fill. 

A click on a color well opens a popover that shows the colors in the 
document’s palette (which comes from the document’s template). The 
popover changes based on what’s selected on the sheet (Figure 203). 
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Figure 203: Typical color well popovers. Left to right: A basic 
palette; an extended popover with multiple palettes for fills; a six-
color groupings for charts (note the dots on the bottom and side 
arrows that indicate another page of choices). 

Clicking the Colors button on a color well opens the Colors window 
(Figure 204)—also called the “Color Picker”—a standard Mac inter-
face element for picking a color; it provides five approaches to choos-
ing colors through the tabs along its top. 

Figure 204: The Colors window. The sample in the lower-left is the 
current color; the small sample blocks are user-defined. 

Tip: The Crayons tab has 11 shades of gray for quick, easy-to-
replicate pickings; they’re convenient if you can’t print in color. 
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Import, Export, and Share 
Files 

There’s lots of talk, much of it snide, regarding the Apple “ecosystem” 
and its “walled garden” of hardware and software that work together— 
and alone, not always playing well with others. If there’s any place 
Apple and Mac users can’t ignore the outside world, it’s the spread-
sheet arena, where Excel has worn the laurels for decades. 

This chapter explains how you can exchange files with Excel and 
Import and Export Delimited Files (text files that use punctuation and 
paragraph returns to indicate row-and-column data), including those 
that use multiple or nonstandard delimiters. You’ll learn how to Use 
Advanced Import Settings and, because sometimes you’ll need to work 
in the other direction, you’ll also learn how to Export as a CSV File. 
Finally, if you want to Share and Collaborate “live” with other users, 
you can get started with the basics here. 

Exchange Files with Excel
 

Numbers’ and Excel’s interfaces differ so fundamentally that it’s 
amazing they can talk to each other at all. A Numbers sheet is a blank 
canvas that can contain tables, charts, graphics, and standalone text, 
and a Numbers document can contain multiple sheets. An Excel 
worksheet is a vast, window-filling grid; a document can have multiple 
worksheets, and is then referred to as a workbook; its charts, and any 
images you add, float in movable, resizable window-ish frames. 

Note: Because the concept of “sheet” differs in Numbers and Excel, 
I’m going to use Excel’s alternative term, worksheet, when referring 
to the Excel environment to avoid confusion, as I just did in above. 
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Import Excel Documents 
The good news is that you can open Excel documents in Numbers, and 
even charts can survive the procedure. The not-as-good news is that 
not everything survives, since Excel offers functions and options that 
Numbers does not. (This Apple page offers a very extensive list of 
supported, partially supported, and unsupported Excel features.) And 
now back to the good news: many things import flawlessly or with only 
minor problems, including cell and chart formatting and table-status 
items such as hidden columns—and even graphic elements. 

Export Excel Documents 
Exporting a Numbers document in Excel format keeps improving; I’m 
amazed at how much of the Numbers document survives intact, 
especially when it comes to various types of charts. 

Here’s what happens when you open an exported Numbers document 
in Excel: 

•	 Each sheet in the Numbers document becomes a worksheet in 
Excel, except when components from the Numbers sheet must be 
split across multiple sheets. 

•	 Although an Excel worksheet can look like a blank canvas, it’s not: 
it’s still a giant table grid—just one with its gridlines turned off. An 
exported Numbers sheet with multiple tables can look exactly the 
same when you see it in an Excel worksheet, but it’s not. What 
happens is that the data (along with table and cell formatting) of 
each Numbers table is placed on the Excel grid, in positions that 
correspond to their places on the Numbers sheet, and the work-
sheet’s grid is turned off. Very clever—and very useful. 

•	 A Numbers sheet with tables and charts survives intact: the table 
data goes into the Excel grid and the charts float above the grid the 
same way Excel’s native charts do. (Previously, multiple tables 
wound up on separate worksheets and their charts on a worksheet 
of their own.) 

296 

Click here to buy the full 318-page “Take Control of Numbers” for only $14.99!

https://www.apple.com/mac/numbers/compatibility/
https://www.takecontrolbooks.com/cart?add-to-cart=1186


           
           
        

         
             

          
   

             
        

           
            

          

       

          
             

              
      

           
       

           
      

Print Spreadsheets 
In Numbers, Apple chose to completely ignore its own interface for 
printing documents (the venerable Print dialog), and the result is a 
limited, non-intuitive, annoying setup. I shall henceforth (except for 
the spoiler alert below) refrain from complaining about what’s not 
available when it comes to printing, and show you how to use, and 
make the most of, the available options, with some special attention 
regarding how to Hone Headers and Footers. 

Spoiler alert: There’s no way to specify page breaks for tables or other 
elements in your document. They happen where they happen. 

Print Your Sheets
 

The simplicity of printing from Numbers is the very thing that con-
strains you from really controlling your output. Here’s how to print a 
sheet (you must set options separately for each sheet in the document): 

1. Preview the print version: Choose File > Print. 

Numbers switches into a preview mode, where each sheet in your 
document gets a tab at the top of the window’s content area. The 
active tab is the sheet you were working on; its name is white, and 
its pages are shown as (very large) thumbnails. 

The Print Setup options appear in the sidebar, which is scrollable if 
you’re working on a smaller screen (Figure 217). 

Note: To cancel preview mode at any time, click the Done button at 

the bottom of the Print Setup sidebar or press Esc.
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Figure 217: A multi-page sheet in preview mode for printing. The 
tabs along the top are for other sheets in the document. 

2.	 Set print options: Set the margins, paper size, orientation, and 
other basics on the sidebar’s Print Setup tab; these options are 
wonderfully self explanatory. (For help squeezing things on a page, 
read the sidebar Make It Fit, just ahead.) 

3.	 Create headers and footers: Hover over a page thumbnail to see 
its header and footer fields; click a field to add text to it. You can set 
up a header and/or footer with automatic text such as a page num-
ber or date; for the most part, you can add such content to headers 
and footers from the Insert menu—the Page Number, Page Count, 
and Date & Time commands insert smart-field information and are 
covered ahead, in Hone Headers and Footers. 

When you are editing a header or footer field, a Text tab appears in 
the sidebar so you can format the text. 

4.	 Specify sheet printing: Click either This Sheet or All Sheets at 
the bottom of the sidebar to specify whether you want to print the 
current sheet, or all sheets in the document. (To print some, but not 
all, sheets, you must print each one separately.) 

5.	 Click Print: Click the Print button at the bottom of the sidebar, or 
choose File > Print again. 
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About This Book 
Thank you for purchasing this Take Control book. We hope you find 
it both useful and enjoyable to read. We welcome your comments. 

Ebook Extras
 

You can access extras related to this ebook on the web. Once you’re 
on the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
a subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read postings to the ebook’s blog. These may include new informa-
tion and tips, as well as links to author interviews. At the top of the 
blog, you can also see any update plans for the ebook. 

If you bought this ebook from the Take Control website, it has been 
automatically added to your account, where you can download it in 
other formats and access any future updates. However, if you bought 
this ebook elsewhere, you can add it to your account manually: 

•	 If you already have a Take Control account, log in to your account, 
and then click the “access extras…” link above. 

•	 If you don’t have a Take Control account, first make one by follow-
ing the directions that appear when you click the “access extras…” 
link above. Then, once you are logged in to your new account, add 
your ebook by clicking the “access extras…” link a second time. 

Note: If you try these directions and find that your device is incom-
patible with the Take Control website, contact us.
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Why Take Control? We designed Take Control electronic books to help readers regain 
a measure of control in an oftentimes out-of-control universe. With Take Control, we also 
work to streamline the publication process so that information about quickly changing 
technical topics can be published while it’s still relevant and accurate. 

Our books are DRM-free: This ebook doesn’t use digital rights management in any 
way because DRM makes life harder for everyone. So we ask a favor of our readers. If you 
want to share your copy of this ebook with a friend, please do so as you would a physical 
book, meaning that if your friend uses it regularly, they should buy a copy. Your support 
makes it possible for future Take Control ebooks to hit the internet long before you’d find 
the same information in a printed book. Plus, if you buy the ebook, you’re entitled to any 
free updates that become available. 

Remember the trees! You have our permission to make a single print copy of this 
ebook for personal use, if you must. Please reference this page if a print service refuses 
to print the ebook for copyright reasons. 

Caveat lector: Although the author and alt concepts inc. have made a reasonable effort 
to ensure the accuracy of the information herein, they assume no responsibility for errors 
or omissions. The information in this book is distributed “As Is,” without warranty of any 
kind. Neither alt concepts inc. nor the author shall be liable to any person or entity for any 
special, indirect, incidental, or consequential damages, including without limitation lost 
revenues or lost profits, that may result (or that are alleged to result) from the use of these 
materials. In other words, use this information at your own risk. 

It’s just a name: Many of the designations in this ebook used to distinguish products 
and services are claimed as trademarks or service marks. Any trademarks, service marks, 
product names, or named features that appear in this title are assumed to be the property 
of their respective owners. All product names and services are used in an editorial fashion 
only, with no intention of infringement. No such use, or the use of any trade name, is 
meant to convey endorsement or other affiliation with this title. 

We aren’t Apple: This title is an independent publication and has not been authorized, 
sponsored, or otherwise approved by Apple Inc. Because of the nature of this title, it uses 
terms that are registered trademarks or service marks of Apple Inc. If you’re into that sort 
of thing, you can view a complete list of Apple Inc.’s registered trademarks and service 
marks. 
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