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Read Me First 
Welcome to Take Control of Keynote, version 1.0, published in 
July 2015 by TidBITS Publishing Inc. This book was written by Joe 
Kissell and edited by Dan Moren. 

This book helps you create smarter, more attractive presentations 
using Apple’s Keynote app. It includes planning, organizing, and laying 
out slides; adding animation and other special effects; and customizing 
themes. It also offers guidance in rehearsing and delivering your 
presentation. 

If you want to share this ebook with a friend, we ask that you do so 
as you would with a physical book: “lend” it for a quick look, but ask 
your friend to buy a copy for careful reading or reference. 

Copyright © 2015, alt concepts inc. All rights reserved. 

Updates and More
 

You can access extras related to this ebook on the Web (use the link 
in Ebook Extras, near the end; it’s available only to purchasers). On 
the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
any subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. You may find new tips or information, as 
well as a link to an author interview. 

If you bought this ebook from the Take Control Web site, it has been 
added to your account, where you can download it in other formats 
and access any future updates. However, if you bought this ebook 
elsewhere, you can add it to your account manually; see Ebook Extras. 
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Basics
 

To review background information that might help you understand 
this book better, such as finding System Preferences and working with 
files in the Finder, read Tonya Engst’s free ebook Read Me First: A 
Take Control Crash Course, available for free on the Web or as a 
standalone ebook in PDF, EPUB, and the Kindle’s Mobipocket format. 
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Introduction 
Among people who create presentations frequently, Microsoft’s 
PowerPoint has long been so dominant that the name has become 
a generic term—I often hear people say things like “she showed a 
PowerPoint” rather than “she showed a presentation” or “she showed 
a slide deck.” But with all due respect to PowerPoint, which is in fact 
a fine app, Keynote is what the cool kids use these days. 

Keynote, like PowerPoint, is a tool for creating sequences of visual 
elements, typically used as supporting material for live presentations 
such as speeches, training programs, comedy routines, and sermons. 
But because the format is so flexible, it’s often used for other things 
too—everything from self-playing presentations that run on museum 
kiosks to mockups of apps and Web pages (somewhat in the style of 
HyperCard, for those who remember it). 

Presentations can include extremely fancy animations and visual 
effects, spreadsheet-like tables, interactive charts, audio and video 
elements, and much more. Sadly, though, most of the Keynote (and 
PowerPoint) presentations I see are boring—slide after slide of dense, 
static, bulleted lists, read nearly verbatim by the presenter. Conversely, 
I’ve seen far too many presentations that overdo special effects to the 
point that they distract the audience from the content (as though visual 
pizazz can substitute for a well-constructed performance). 

In this book, I’d like to help you solve both of those problems by 
showing you how to use Keynote as effectively as possible. Part of what 
I’ll discuss is figuring out what you want to say, how best to support 
your ideas visually, and how to use Keynote’s live presentation features 
(where applicable) to their best advantage. The other part, however, 
is explaining the mechanics of Keynote—how to go about constructing, 
arranging, and beautifying your presentations, making use of a sur-
prisingly large and diverse set of capabilities. 

This is not intended as a comprehensive reference. I ignore some 
features completely, and I mention others only in passing. For 
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example, you don’t need me to spell out how to make text bold, how 
to save a file, or how to copy and paste, because Keynote does these 
things the same way as most other Mac apps. 

In addition, for some details I’ll refer you elsewhere—for example, the 
formulas and calculations available in Keynote’s tables would require 
many pages to document completely, but they’re nearly the same as 
what Numbers offers, and Take Control has a terrific book on Numbers 
already (Sharon Zardetto’s Take Control of Numbers). 

But if you’re curious about a feature that I’ve omitted, don’t forget that 
Keynote has pretty good built-in help—choose Help > Keynote Help to 
view it. Although it’s a bit dry and not nearly as detailed as this book in 
most respects, it’s not half bad. 

This book covers Keynote 6 (the latest update, as of publication date, 
is 6.5.3), which requires OS X 10.9 Mavericks or later. Although the 
iOS and Web versions of Keynote are accessible from other operating 
systems, I don’t describe them in detail, but I do give an overview of 
how they compare to the Mac version in Appendix A: iOS and Web 
Versions of Keynote. 
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Keynote Quick Start 
As you work with Keynote, you can refer to the topics in this book 
in any order to get help with particular features or tasks. However, I 
recommend that everyone read the first two chapters (Learn Keynote 
Basics and Plan Your Presentation) before jumping in, as they will 
inform the decisions you make throughout each presentation. 

Get ready: 
•	 Take a quick tour of Keynote’s main window and learn about key 

concepts and terms. See Learn Keynote Basics. 

•	 Before you start constructing slides, make sure your goals are clear. 
See Plan Your Presentation. 

Design your presentation: 
•	 Choose a theme, add some blank slides, and arrange them to fit the 

outline you want to follow. See Create a Presentation. 

•	 Arrange the elements on a slide, and add presenter notes. See Lay 
Out a Slide. 

•	 Learn about the special features for pictures, video, music, and 
shapes in your presentation. See Work with Media Objects. 

•	 Format your text, including font, sizes, styles, bulleted and num-
bered lists, and multiple columns. See Work with Text. 

Enhance your presentation: 
•	 Spice up dull numerical data with a visual component. See Add 

Tables and Charts. 

•	 Save effort with user-defined styles that let you quickly format (and 
reformat) text, graphics, and more. See Define and Use Styles. 

•	 Add motion and sparkle to your slides. See Work with Animation. 

•	 Edit master slides and even create entirely new themes to give your 
presentations a custom look and feel. See Customize a Theme. 
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Deliver your presentation: 
•	 Set up your monitor(s), rehearse and fine-tune your talk, and use 

Keynote’s numerous playback features in person or remotely. See 
Deliver a Live Presentation. 

•	 Not all presentations have a live presenter. If yours is designed 
to stand on its own—especially if it will play automatically with 
a prerecorded soundtrack—you’ll need to follow some extra steps. 
See Create a Canned Presentation. 

Deal with other odds and ends: 
•	 Learn about local and cloud storage options, using passwords, 

sharing presentations, printing, exporting, and other housekeeping 
tasks in Manage Document Details. 

•	 Learn what’s different in the iOS and Web versions of Keynote. See 
Appendix A: iOS and Web Versions of Keynote. 
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Learn Keynote Basics 
Even if you’re a beginner, you’ve probably dabbled in Keynote at least 
a bit, so much of what I explain in the next few pages will probably 
be review. But I want to make sure we’re all on the same page (or slide, 
if you will) before getting into the details. So please indulge me for a 
moment and follow along as I walk you through some of the basic 
features, concepts, and terms you’ll need to know. 

Begin by opening Keynote (in /Applications). When you do so, the 
Theme Chooser appears (Figure 1); if Keynote is already open, choose 
File > New to display it (I’ll say more about the Theme Chooser in 
Master Slides and Themes). 

Figure 1: Select a theme to provide an overall visual appearance for 
your presentation in the Theme Chooser. 

Now select a theme and click Choose. For the purposes of this chapter, 
it doesn’t matter which one you choose, but I’ll use Gradient for my 
examples (the third one in the top row); I like it because it’s the one 
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Apple uses for all its keynote presentations. Once you do that, the main 
document window (Figure 2) appears. 

Figure 2: The main Keynote window, which shows the Navigator 
on the left, the current slide in the middle, and an inspector on the 
right. 

Almost everything you do in Keynote happens in this single window. 
(We’ll talk about a few exceptions later.) For now, simply notice the 
overall layout. The toolbar is at the top, as in most Mac apps. On the 
left is a sidebar showing the Navigator (a scrollable column containing 
thumbnails of all your slides—right now, there’s just one). In the 
middle is your first slide, with some placeholder text. And on the right 
is another sidebar containing a set of controls called an inspector. In 
the remainder of this chapter, I’ll explain these controls in more detail. 

Views
 

By default, Keynote displays its Navigator in the left-hand sidebar 
(Figure 3). As you add slides, they’ll appear in this list. (Feel free to 
try that now a few times by clicking Add Slide and selecting any 
of the master slides shown in the popover.) You can click any thumb-
nail to jump to that slide, and rearrange slides using drag-and-drop 
(more on this in Organize Slides). 
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Plan Your Presentation 
The first and most important step in creating any Keynote presentation 
is to quit Keynote. 

Wait, what? 

You read that right. If you’re going to bake cookies, you first need to 
know the recipe and gather all the ingredients—making it up as you go 
along is unlikely to produce the results you want. Likewise, you need to 
have blueprints before starting to build a house and a syllabus before 
teaching a college class. In much the same way, you should plan out 
your presentation before even opening Keynote, because that will save 
you time and effort and yield a better outcome than just diving in. 

Planning may mean different things to different people. For some, it’s 
a sketch on a whiteboard or legal pad. For others, it could be an outline 
developed in Word or OmniOutliner. Still other people may just need 
15 minutes of reflection during a walk in the park to mentally plot out 
their goals. However you approach the task, make sure you have at 
least a rough outline of your presentation’s overall structure before you 
start. 

Your goal in doing all this—apart from making the process more 
efficient—is to end up with a presentation that is not boring. Presenta-
tions that are well thought out in advance are nearly always more 
interesting and engaging than those that are cobbled together on the 
fly (believe me, I’ve delivered plenty of the latter—and it showed). 

What happens in Keynote—the actual visual (and sometimes audio) 
elements that will appear on the screen—is secondary to the ideas 
you’re conveying. If those ideas are clear before you begin, your pre-
sentation will be more successful regardless of what you do in Keynote. 

Start by deciding on an overall approach, which will depend on how 
your presentation will be delivered and what the audience expects. I 
lay out your options just ahead, in Use the Right Format for the Job. 
Next, plot out the contents of your presentation—what ideas you want 
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to convey, and in what order. For some, that might mean writing out 
every word you’ll say; for others, it might be merely a quick bullet list. I 
say more about that in Figure Out What to Say. Finally, before creating 
your first slide, give some thought to what sorts of things you want 
your audience to see (for example, whether their attention should be 
mainly on you or mainly on the screen). That will help you Decide on a 
Visual Approach. 

Use the Right Format for the Job
 

The most boring presentations I’ve seen are those in which the slides 
consist largely of bulleted lists, and the speaker basically reads what’s 
on the screen. Yuck! Please don’t do that. 

But… 

There’s nothing inherently wrong with bulleted lists, and in fact they’re 
ideal for conveying certain kinds of information. Furthermore, in some 
situations you must have all the essential text on the slides, perhaps 
because you, the one designing the presentation, will not be delivering 
it in person. 

In still other situations, a text-heavy approach is mandatory—even if 
you are delivering the presentation in person—because your audience 
demands it. For example, if you’re delivering the quarterly sales results 
to your company’s vice presidents, pictures and animations aren’t 
going to make points. They’re going to expect to see numbers and 
facts—maybe a few charts—and that’s it. 

To oversimplify greatly, I’d like to suggest that most Keynote presenta-
tions will use one of four (broad and overlapping) formats: 

•	 Conventional: Whether you’re delivering a TED talk, a motiva-
tional speech, or a product launch, a conventional presentation 
relies primarily on your words, tone, body language, and enthusi-
asm to make its points; everything on the screen merely supports or 
elucidates what you say. The presentations should normally be light 
on text, consisting mainly of images, videos, short phrases (includ-
ing questions and quotes), tables, charts, and tasteful animation. 
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Create a Presentation 
If you followed the steps in the preceding chapter to Plan Your Presen-
tation, this is the point when you reopen Keynote and recreate the 
structure of your written, typed, or sketched outline in a series of 
slides. With or without a plan, in this chapter you’ll create the shell of 
your presentation—the slides themselves, arranged in a meaningful 
order—perhaps with just enough text to help you find your way 
around. You’ll learn about various tools to organize your slides, too. 

You don’t have to do all these steps up front; you can build your 
presentation one slide at a time, if you prefer. But you’ll have to skip 
ahead to future chapters (such as the next one, Lay Out a Slide) to 
learn about arranging elements on a slide and making your presenta-
tion more visually appealing. 

At any time as you work on your presentation, you might choose to 
rearrange, add, delete, or hide slides, so you may want to return to this 
chapter from time to time. 

Choose a Theme
 

When you first open Keynote—or when you choose File > New— 
Keynote displays the Theme Chooser (shown back on the first page 
of Learn Keynote Basics). This is your starting point for all new presen-
tations, wherein you select a theme—a set of master slides that share 
the same general look, including background, fonts, and other features. 
Apple supplies 30 different prebuilt themes; you can also modify these, 
add your own, or add themes designed by third parties (see Customize 
a Theme). 

All of Apple’s themes come in two aspect ratios. The Standard view 
shows themes at 1024 by 768 pixels (4:3 aspect ratio), while the Wide 
view shows themes at 1980 by 1080 (16:9 aspect ratio). (Custom 
themes that you make or modify can have any desired dimensions.) 
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Ideally, you’ll choose the aspect ratio that matches the projector or 
display you’ll be using to deliver your presentation. Pick the wrong 
one, and you’ll either find your slides letterboxed with black bars, 
or squished or stretched to fit the screen. Neither of these alterations 
looks great. 

You might not know, at this point, what sort of display you’ll have. 
You can and should ask, but don’t count on your contact to provide 
the correct answer. In my experience, 1024 by 768 is still the most 
common aspect ratio for projectors used in business settings; for 
home theater projectors and flat-screen displays, 1920 by 1080 is 
more common. If you have sufficient time, you can create two versions 
of your presentation, one for each aspect ratio, but if you have to pick 
just one, I’d suggest going with Standard. 

Tip: If you plan to create two versions of a presentation, start with 
Standard. Then duplicate it, switch to the corresponding Wide theme, 
and rearrange or enlarge the elements on your slides as needed. 

What’s the best theme for your presentation? It depends. As you can 
tell, some are more subdued, suitable for business settings; others are 
geared toward photo-based presentations, interior design, weddings, 
and so on. You may need to try a few to find the one you like best. Just 
remember that you can change your mind later—it won’t necessarily 
be painless, but it’s certainly possible. As I mentioned earlier, the 
Gradient theme is the one Apple uses for its keynote presentations— 
it’s elegant and uncomplicated, and a good choice if you can’t decide. 

Select a theme and click Choose to open a new Keynote presentation. 

Add Slides
 

To add a new slide, you can do any of the following: 

•	 Click Add Slide on the toolbar and then click a master slide in 
the popover that appears. 

•	 Choose Slide > New Slide (Command-Shift-N). This creates a slide 
using the same master slide as the one currently selected. 
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Lay Out a Slide 
If you’re following along, so far, all you’ve done is add some blank 
slides with just enough text on each one to remind you of its purpose, 
and arrange them in some preliminary logical order. The next step is to 
add real content. As you do this, you’ll need to arrange the elements on 
each slide, which entails dealing with things like resizing, alignment, 
grouping, and front-to-back layering. This chapter explains those 
central tasks, which apply to every type of object that might appear on 
your slides. 

Note: In later chapters, I’ll look at more of the details of particular
 

object types—see, for example, Work with Media Objects, Work with
 

Text, and Add Tables and Charts.
 

Besides the elements on your slides that the audience will see, you may 
want to include notes that only you, the presenter, will see as you give 
your presentation. I discuss those in Add Presenter Notes. I then turn 
to comments (see Add Comments), which are especially useful when 
you’re collaborating on a presentation and you need to share your 
thoughts about a slide or element with another Keynote user. 

Fill In Placeholders
 

When you add a slide to a presentation, it usually contains one or more 
text boxes or images that function as placeholders. (The exception is 
the Blank master slide, which has only a background.) Placeholder text 
and images don’t appear when you play a presentation, but they show 
where you can insert your own content as you’re editing it. 

Note: To learn about creating your own placeholders on master
 

slides, see Modify Master Slides.
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You can fill in text boxes in either of two ways: 

•	 Double-click the box (as the placeholder text says to do) and start 
typing. 

•	 Select the box (by clicking it once) and start typing. 

Tip: If a text box is selected (as shown by selection handles on the 
outside), you can press Tab to select the next text box. 

You can fill in image placeholders in any of these ways: 

•	 Drag an image file (such as a JPEG or PNG graphic) from the 
Finder and drop it onto the placeholder graphic. 

•	 Click the Media button on the toolbar, click Photos, navigate to 
a photo, and click it. 

•	 Choose Insert > Choose, navigate to an image file, select it, and click 
Insert. 

Later in this chapter I talk about resizing, aligning, and grouping 
images; for more ways in which you can alter an image (such as adding 
a mask, border, shadow, or transparency, or changing a photo’s expo-
sure), flip ahead to Modify Images. 

Add More Objects
 

If your slide needs only the elements for which the master slide pro-
vides placeholders, you can skip this topic. But many slides—especially 
those you’re building from scratch using a Blank master slide—require 
additional objects. Now is a fine time to begin adding them. 

The middle portion of the toolbar (or, if you prefer, the Insert menu) 
has controls to add all the objects you may need—click Table , 
Chart , Text , Shape , or Media to display a popover with 
additional options (such as table format and media type). Navigate to 
the object you want and click it to insert the object on your slide. 
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Work with Media Objects 
The most interesting and effective presentations usually employ 
audiovisual elements of some kind to help focus the audience’s atten-
tion and add nuance that words alone don’t supply. In this chapter, 
I look at how to add and manipulate many such elements, including 
photos, music, movies, and shapes. I also look at the various uses of 
links within a presentation, both for navigation and to open external 
resources. 

Add Media
 

Apple uses the term “media” in Keynote to refer only to photos, music, 
and movies. One way to insert such an item is to click the Media 
button on the toolbar; click Photos, Music, or Movies in the popover 
that appears (Figure 17); navigate to the item you want; and click it. 

Figure 17: The media browser lets you insert photos, music, 
and movies into your presentation. 
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The three views of the media browser popover show you the following: 

•	 Photos: The contents of your Photos, iPhoto, or Aperture library 
(including regular albums and smart albums) 

•	 Music: The contents of your iTunes library (including regular 
playlists and smart playlists) 

•	 Movies: The contents of your ~/Movies folder and its subfolders 

Note: Each view of the Media browser popover can be extremely 
slow to load the first time you use it in any session, especially if your 
photo or iTunes library is quite large. 

To search for an item in one of these collections, click the Search 
icon and enter a title, keyword, rating, or other common search term. 

If you want to add media that isn’t in one of those places—or if you 
have difficulty finding it within Keynote—you can also drag in files 
from the Finder, or drag photos, movies, or sounds from almost any 
app (including Photos, iTunes, and Safari). 

Finding Images 
If you don’t happen to have just the right photograph for your pre-
sentation, you might try checking this little place called the Internet, 
which apparently has photos of anything and everything. One good 
place to start is Google Images, which has a truly vast repository of 
photos, drawings, paintings, and other images. 

Don’t assume that any image you find on the Web is fair game for 
your presentation, though. If an image is copyrighted, you may need 
to obtain permission from the owner to “publish” it by displaying it in 
a public place; this becomes especially important if your presentation 
will be recorded, broadcast, streamed, or made available for down-
load. One nice feature of Google Images is that it lets you search by 
license. After performing a search, go to Search Tools > Image Rights 
and choose a license (such as “labeled for reuse”) to display only 
images the owner has expressly granted a public license for. 

If Google Images doesn’t have what you want, do a Web search for
 

“stock photos.” You’ll find a few hundred million such sites!
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Work with Text 
A Keynote slide shouldn’t contain much text, because it needs to be 
legible from quite a distance, at a much lower resolution than your 
Mac’s display, and possibly in unfavorable lighting conditions. Never-
theless, titles, bullets, quotes, callouts, and other chunks of text are 
important components of almost every presentation. Keynote offers a 
wide variety of tools to format text to your liking. I discuss them in this 
chapter, with special emphasis on lists (which have some interesting 
idiosyncrasies). 

Note: All text in Keynote needs a container of some kind (either
 

a text box or a shape). Many master slides include text boxes for
 

elements like Title and Body, but you can add your own custom
 

text boxes too. See Add a Text Box.
 

Understand Text Formatting Scope
 

The first thing you should know about text in Keynote is that you can 
work with it on any of three levels, depending on what’s selected at the 
moment: 

•	 Object: You can apply formatting to an entire text box (or shape), 
affecting all the text within. You might do this, for example, to 
change the font or color of everything in the box. 

•	 Paragraph: Each paragraph (including list items) can have its 
own formatting, which typically includes attributes like indentation, 
tabs, and vertical space before and after. 

•	 Character: You can also alter the style of any selected character(s). 

All character-level formatting (like font, size, and color) can be applied 
at the paragraph and object level too; all paragraph-level formatting 
can also be applied at the object level. But lower-level formatting 
modifies higher-level formatting. For example, if you format a text box 
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a certain way, you can override any given paragraph within it; and you 
can later override a single word in that paragraph with character styles. 

Furthermore, you can adjust text formatting manually (affecting only 
the text box, paragraph(s), or character(s) currently selected); or, you 
can use styles to apply a collection of formatting attributes at once and 
then, if you like, update all the text in your presentation that uses that 
style simply by modifying the style definition. 

Note: This chapter is only about the text formatting options them-
selves; to learn about styles, see Use Object Styles and Use Text 

Styles.
 

In the remainder of this chapter, I describe where to find various 
formatting controls and what they do. With a few exceptions, I don’t 
go into much detail—you know what “bold,” “centered,” and “double-
spaced” mean (the same as in every word processor and page layout 
app), so unless I think something is particularly confusing or notewor-
thy, I just give it a quick mention. 

Equations in Keynote 
If you want to include nicely formatted complex equations in
 

Keynote, you’ll need a third-party equation editor called MathType. 


If MathType is installed, you can choose Insert > MathType Equation. 
When you do this, MathType opens. Compose your equation, and 
then choose File > Close and Return to Keynote (Command-W). In 
the Save Changes dialog, click Yes. 

Keynote inserts the equation as a PDF image. You can then move 
or resize it; if you want to make any other changes, double-click the 
equation to reopen it in MathType. 

Modify Text Formatting
 

On the Text tab of the Format inspector (Figure 32), you’ll find all the 
controls for modifying the appearance of the selected paragraphs and 
characters (or, if an entire object is selected, all the text within it). 
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Add Tables and Charts 
Tables and charts can spice up a presentation, making it more visually 
interesting and displaying data in a friendly, easily digestible way. 
Keynote lets you add either type of element to a slide and format it in 
almost any imaginable way. 

In Keynote, a table isn’t merely a table; it’s a full-blown spreadsheet, 
with all the formulas Numbers offers. In fact, Keynote’s tables and 
charts have nearly all the features Numbers offers—in most respects, 
the calculation and formatting options are identical. 

Numbers does have additional features, of course. It offers a bigger 
workspace; multiple sheets; more sorting and filtering options; tem-
plates; spreadsheet import and export features; and commands to 
freeze, hide, and transpose rows and columns. But that’s about it! 
Virtually everything else Numbers can do, Keynote can do too. 

In fact, Keynote’s table and chart capabilities are so extensive that it 
would take (at a rough guess) about 300 pages to document them all. 
I base this on the fact that Sharon Zardetto’s excellent book Take 
Control of Numbers clocks in at 330 pages! Because you’re likely to 
have relatively few (and relatively simple) tables and charts in your 
Keynote presentations, and because I would prefer this chapter not be 
300 pages long, I’m going to present only a quick summary of how to 
use those elements. If you’d like to know even more about tables and 
charts, I’ll refer you to Sharon’s book instead. 

Add a Table
 

To add a table to a slide, click the Table button on the toolbar and 
click a table type (Figure 34) in the popover; or, choose a table type 
from the Insert > Table submenu. Either way, you can choose from 
among four initial table types: Headers (with row and column 
headers), Basic (with column headers only), Plain (with no headers), 
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and Sums (with column and row headers, plus a sum row at the bot-
tom). In the popover, you can also swipe left or right with two fingers 
on a trackpad, or click the left or right arrow, to insert versions of these 
table types with different visual styling. No matter what you choose, 
you can always restyle your table later with whatever headers, borders, 
colors, or other features you like. 

Figure 34: Click a table style in this popover to insert that type 
of table. They are Headers (top left), Basic (top right), Plain (bottom 
left), and Sums (bottom right). 

Once you choose a table, it appears on your slide as in Figure 35. In 
addition, the Format inspector changes to show controls for working 
with your table—more on that in Format a Table, ahead. 

86 

Click here to buy the full 168-page “Take Control of Keynote” for only $15!

https://www.takecontrolbooks.com/cart?add-to-cart=1195


             
            

          
            

              
            

       

            
         

      
        

           
            

   

            
         

            
            

             
         

       

          
            

             
             

          
   

Define and Use Styles 
If you’ve ever used styles in a word processor or page layout program, 
you know they can save tremendous amounts of time and effort while 
keeping a document’s appearance consistent. For example, if you apply 
the style “Heading 1” to each of the first-level headings in a document, 
they’ll all have the same font, size, style, color, and so on—and if you 
later change the appearance of that style, all the Heading 1 paragraphs 
in the document will automagically update to match. 

Keynote uses styles in much the same way. You can apply styles to 
objects (such as text boxes, images, movies, shapes, tables, and 
charts—collectively, “object styles”) and to text (paragraphs, 
characters, and lists—collectively “text styles”). For each of these 
elements, you can choose from several predefined styles, alter any of 
those styles to meet your needs, or create your own styles from scratch. 

Understand How Styles Work
 

A style is a collection of attributes, all of which can be adjusted some-
where in the Format inspector. Which specific attributes are included 
depends on the style type. For example, shape styles can include the 
formatting not only for the shape itself (border, fill, shadow, and so on) 
but also for any text inside it (font, size, alignment, spacing, and the 
like), whereas character styles include only character attributes (font 
family, typeface, size, color, and advanced character formatting). 

For each type of element to which styles can apply, Keynote offers 
predefined styles. You can select one of these to apply that entire 
bundle of attributes to the selected element. At any time, you can pick 
a different style to change all those attributes at once. You can also 
define your own styles, or modify any style (predefined or user-
created) to have different attributes. 
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When you modify a text style, all the text elements using that style 
update themselves to reflect your modifications. With object styles, 
you have a choice—you can either apply your changes to all the existing 
objects that use that style, or disconnect those objects from the style, 
in which case your changes apply only to objects you add in the future. 
(I explain more about this behavior ahead, in Modify an Object Style.) 

Regardless of what styles you apply, you’re always free to make manual 
changes to any attribute; these changes override the style definition. 

Style Hierarchies 
A single element on your slide might have more than one style type 
applied to it. Indeed, a single style can include other sub-styles. For 
example, shape styles can include paragraph styles, and paragraph 
styles can include character styles. With all these intertwingled styles, 
you might wonder which one takes precedence in which situation. 

The easiest way to think about this overlap is that lower-level styles 
always override higher-level styles. For example, suppose you have a 
text box in Shape Style A, containing a paragraph in Paragraph Style 
B, containing a word in Character Style C. If you change the shape 
style, the paragraph style and character style remain unchanged; 
if you change the paragraph style, the character style remains un-
changed. (List styles, by the way, fall between paragraph and charac-
ter styles in the hierarchy but affect only indentation and lead-in 
bullets, numbers, or images; see Bullets & Lists.) 

Most of the time, style changes “just work” and do exactly what you
 

expect them to do, but if they don’t, the most likely reason is that a
 

lower-level style is taking precedence over a higher-level style.
 

Use Object Styles
 

As the name suggests, object styles affect the entire selected object. 
The attributes they affect depend on the object type: 

•	 Shapes and text boxes: Shape styles, which apply to text boxes 
as well, include border, fill, shadow, reflection, and opacity—plus 
text formatting (that is, paragraph, list, and character formatting). 
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Work with Animation 
In Keynote, the word animation means something slightly different 
from what you might expect. It doesn’t refer to cartoon characters 
walking and talking, and it doesn’t necessarily even imply motion as 
such. Rather, animation refers to any type of visual change that occurs 
during your presentation, such as bullet points or graphics appearing 
or disappearing, objects changing in size or style, and visual effects 
that accompany the transition from one slide to the next. 

You can make a complete Keynote presentation without any animation 
whatsoever. It’ll be a standard slideshow—when you press a key or 
click your mouse, whatever’s on the first slide will disappear and be 
replaced with whatever’s on the second slide; lather, rinse, repeat. And 
in some cases, that’s perfectly fine. If you’re doing a quick daily update 
for your staff and you just need to show them half a dozen charts, 
there’s no point in getting fancy. 

However, animations aren’t merely window dressing. They also serve 
numerous functional purposes, such as allowing you to progressively 
disclose information on a slide, highlight or deemphasize objects or 
text as you speak, and call attention to a major change of topic. 

Broadly speaking, animation in Keynote falls into two categories: 
transitions (what happens when one slide disappears and the next one 
appears) and build effects (what happens to elements on a given slide). 
Builds are further divided into three subcategories: a build in makes an 
element appear; a build out makes it disappear; and an action effect 
moves or changes an element in some way. 

Add Slide Transitions
 

Keynote offers dozens of transitions that add zip and sparkle to the 
switch from one slide to the next. In a moment I’ll show you how to use 
them, but first, let me plead with you to use these effects sparingly—if 
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at all. As visually impressive as they may be, they can make an other-
wise professional-looking presentation seem cutesy and cheap. My 
recommendation is to use transitions (especially the flashier ones) 
sparingly, only when you want special emphasis. If you do feel it 
necessary to include transitions for every single slide, choose some-
thing fairly subtle, and be consistent—a different wacky transition 
on every single slide serves no purpose other than to make your audi-
ence wonder what you were thinking. 

To add a transition, start with the slide you’re transitioning from. 
Make sure nothing is selected on the slide (which you can do by click-
ing the slide’s thumbnail in the Navigator). Then go to the Animate 
inspector (Figure 43) and click Add an Effect. 

Figure 43: The Animate inspector for slides shows these controls 
for transitions between slides; after you add a transition, more 
options may become available. 

In the popover that appears, you can click a transition to apply it—or 
hover over the transition name and click Preview to see what it will 
look like first. Transitions are grouped into the following categories: 

•	 None: No transition—just the plain ol’ this-slide-disappears-and-
the-next-one-appears routine. 

•	 Recent Effects: Up to five effects you’ve used most recently 
(which also appear elsewhere on the list). 
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Customize a Theme 
Keynote’s 30 built-in themes (with about a dozen master slides each) 
are attractive, professionally designed, and highly functional. If you 
need to put a presentation together quickly, you’re bound to find a 
theme that will be close enough to what you’re looking for to meet your 
needs. 

As you work on your slides, however, you may find that some elements 
aren’t quite right. Maybe you want all your bullet points to use a larger 
font or a different color. Maybe you get tired of the background color 
or pattern, or want a placeholder graphic to be in a different spot. You 
might frequently need a layout that isn’t like any that Apple provides. 
Or perhaps you want to brand every slide with your company’s logo. In 
all these cases, you could make the relevant changes manually on each 
individual slide, but you’ll save tons of time and aggravation by making 
them just once—on the master slides—and letting them propagate to 
the rest of your presentation. 

In this chapter, I discuss how to customize a theme by modifying any 
or all of its master slides (and under what circumstances those changes 
apply to your individual slides). Although you can do this for just a 
single presentation, if you want to reuse those modified master slides 
for other presentations, you can save your own custom themes. 

Modify Master Slides
 

To modify any of the master slides in your current presentation, 
choose View > Edit Master Slides (Command-Option-E), choose Edit 
Master Slides from the pop-up View menu on the toolbar, or 
click Edit Master Slide on the Format toolbar when a single slide is 
selected. The Navigator is replaced with thumbnails for each of the 
master slides in your theme (Figure 52), each with a descriptive name 
underneath. 
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Figure 52: In Keynote’s Edit Master Slides mode, thumbnails of 
the current theme’s master slides appear in the sidebar on the left. 

At this point, there’s no particular magic—you just select a master 
slide, make any modifications you like (by adding objects or using 
the Format or Document inspectors), just as though you were working 
on an individual slide. When you’re done, those changes will apply 
to all slides in the current presentation using that master slide. (An 
exception: when you’ve modified a master slide element on an individ-
ual slide, you’ll need to manually reapply the master to that slide; see 
Reapply Master Slides.) Most objects you add to master slides aren’t 
editable on individual slides; to make an object an editable 
placeholder, see Add Placeholder Objects, ahead. 
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Deliver a Live Presentation 
All your slides and animations have been honed to perfection, and 
you’re (almost) ready to deliver your presentation before a live audi-
ence. (If it won’t be delivered live, skip ahead to Create a Canned 
Presentation.) You could just click Play and hope for the best, but 
you’ll have much better results if you follow the steps in this chapter 
to customize the presenter display, rehearse your presentation, and 
set up your Mac to work with whatever display(s) you’ll be using. 

This chapter also covers the mechanics of playing a presentation— 
things like how to go forward and backward, how to black out the 
screen, how to skip to an arbitrary slide, how to pop out of Keynote 
temporarily to demonstrate software or show a Web page, and so on. 
Finally, I say a few words about showing a live Keynote presentation 
to a remote audience using Skype, Google Hangouts, or other tools. 

Customize the Presenter Display
 

When it comes time to give your presentation, your Mac’s screen 
doesn’t necessarily have to show the same thing the audience is seeing. 
Assuming you’re connecting to an external display or projector of some 
kind, your Mac can show something much more helpful: a fully cus-
tomizable presenter display that lets you see things the audience can’t. 
Those things include a preview of your next slide or build, your presen-
ter notes, and a timer, among other things. 

To tell Keynote what you want to appear on your presenter display 
and how you want things to be arranged, choose Play > Customize 
Presenter Display. Your screen changes to look like Figure 55—that 
is, it looks like your presenter display, with the addition of a floating 
window (Figure 56) that enables you to choose which elements 
should appear on it. Check the boxes corresponding to whichever items 
you want to see, and select Elapsed or Remaining for the timer. (Don’t 
click OK yet!) 
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Figure 55: Customizing the presenter display means arranging 
elements to your liking and setting preferences in the dialog shown 
at the bottom (enlarged just ahead). 

Figure 56: In this dialog, select which options you want to see on 
your presenter display. 

You can then move or resize any item on the screen to meet your 
needs. Want a tiny view of your current slide, a big preview of the next 
one, and your presenter notes at the top rather than the bottom? No 
problem. Go crazy. If at any time you want to return to the default 
layout for the selected items, click Use Auto Layout. 
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Create a Canned 
Presentation 

Not all presentations are delivered before a live audience. Sometimes 
you may want to create a presentation that will stand entirely on its 
own. Such a presentation may go on a kiosk where visitors can either 
watch it autoplay or step through slides manually. Or your goal may 
be to export a self-contained movie—perhaps with a soundtrack and 
narration—that you can share on YouTube or embed on a Web page. 
In these and numerous other cases, you’ll need to take extra steps 
to package your presentation in a way your audience will find useful 
without your live participation. 

For the purposes of this chapter, I divide standalone presentations into 
three categories (which can overlap somewhat): 

•	 Links-only: Unlike a normal presentation, in which you click a 
button or press a key to advance to the next build or slide, a links-
only presentation advances only when the user explicitly clicks or 
taps a link. See Create a Links-only Presentation. 

•	 Self-playing: A self-playing presentation is just what it sounds 
like: one in which the builds and slides advance on their own 
(according to a preset schedule), without any intervention at all. 
See Create a Self-playing Presentation. 

•	 Narrated: In a narrated presentation, you (the creator) record 
yourself giving the presentation. Both your voice and the timing 
of builds are recorded, and all of that can be played back automati-
cally. See Record a Slideshow with Narration. 

This chapter also covers adding a musical soundtrack (see Add a 
Soundtrack), which plays as the presentation progresses and can be 
used whether your presentation is canned or not. 
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Create a Links-only Presentation
 

Whether you create a game, a quiz, or an educational tool, a links-only 
presentation gives you something vaguely resembling a HyperCard 
stack: a slideshow in which the viewer moves from slide to slide only 
by clicking (or tapping) an object or text that’s linked to another slide. 
(To review the process for creating links, flip back to Add Links (for 
objects) and the Add Text Links sidebar.) 

If this is the sort of presentation you have in mind, the most important 
consideration is that it contain all the necessary links! Unfortunately, 
there’s no good way to automate the process—it might require keeping 
a manual list, or simply enduring some trial and error. But you must 
do at least the following three things: 

•	 Make sure every slide contains at least one link to another slide 
(so viewers never get stuck on a slide). 

•	 Make sure every slide in your presentation is linked to from at least 
one other slide. 

•	 Call attention to links in some clear visual way. For example, make 
all the linked objects the same color, or give them the same border. 
Viewers should not have to guess what part of the screen they can 
tap. 

Any given slide can contain multiple links, and any slide can be linked 
to from multiple places. You don’t have to make your presentation 
linear, restricting yourself to “Next Slide” and “Previous Slide” links. 

However, now that I’ve mentioned “Previous Slide,” it’s always a good 
idea to offer a way back, not just forward. And when you get to the end 
(if there is an end), be sure to include a link back to the beginning. 

Once you’ve created and tested all your links to make sure viewers 
always have a clear path through your presentation, the final step is 
to visit the Document tab of the Document inspector (Figure 63) 
and choose Links Only from the pop-up Presentation Type menu. 
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Manage Document Details 
So far I’ve said almost nothing about the Keynote document itself— 
the file that contains the presentation you’ve just made. Because your 
Keynote file is so important, you should be aware of a few details about 
how it can be stored, used, and shared. 

In this chapter, I discuss the implications of storing a Keynote presen-
tation locally on your Mac versus on iCloud Drive, why and how to 
password-protect a presentation, and various ways of sharing your 
presentation with others (in either read-write or read-only form). I 
say a few words about printing (starting with “please don’t!”) and then 
wrap up with details on various ways of exporting your presentation 
(for example, in PowerPoint or PDF format). 

Choose Local or iCloud Storage
 

When you save a new presentation, you can store it either in iCloud 
Drive or anywhere on your Mac. To use iCloud Drive, you can either 
choose Keynote — iCloud from the Where pop-up menu in the Save 
dialog; or, if the sidebar is visible, select Keynote at the top of the 
sidebar under iCloud. 

Using iCloud Drive requires an iCloud account (of course); the chief 
advantage is that files stored there automatically sync across all other 
Macs and iOS devices that are signed in to the same iCloud account. 
If you’re using Keynote on more than one device, this is the most 
convenient way to ensure that your presentations are everywhere you 
need them to be. (For more on working with iCloud Drive, see Navigate 
iCloud Drive, a free chapter from Scholle McFarland’s Yosemite: A 
Take Control Crash Course; or my book Take Control of iCloud.) 

On the other hand, local storage is often cheaper, gives you more 
flexibility, and may be more reliable (sorry to say, but iCloud is fre-
quently flaky). If at any time you want to change where the current 
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Keynote presentation is stored, hover over the title in the sidebar and 
click the tiny downward arrow to the right of the title. Then choose a 
different location from the Where pop-up menu. 

Set a Password
 

If you want to make sure that only authorized people can play a pre-
sentation, you can add a password, which encrypts the file using the 
AES-128 standard. To do this, go to the Document tab of the Docu-
ment inspector, check Require Password to Open, enter and verify a 
password, and click Set Password. (To remove the password, uncheck 
the box and enter the password.) 

Note: Password protection is specific to a single presentation. But 
you can also require a password to exit any presentation running 
on your Mac, which may be useful when the Mac is used for a kiosk 
display. To do this, go to Keynote > Preferences > Slideshow, check 
Require Password to Exit Slideshows, enter and verify a password, 
and click Set Password. 

Share a Presentation
 

To share your presentation, click the Share button on the toolbar 
and choose one of the standard options: 

•	 Share Link via iCloud: Assuming the document is stored in 
iCloud Drive, these commands send a link to the Web version of 
the document via the app or service of your choice (such as Mail, 
Messages, or Twitter). Initially, all links support editing, but you 
can change that instantly with the next command in this list. 

•	 View Share Settings: See and copy the URL to the shared pre-
sentation, change its permissions if you like (you can choose Allow 
Editing or View Only), add a password, or stop sharing. 

•	 Send a Copy: This command prompts you to choose a delivery 
method (such as Mail, Messages, or Facebook) and then pick a 
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Appendix A: iOS and Web 
Versions of Keynote 

This book is all about the Mac version of Keynote. I’ve mentioned the 
iOS version in passing (and in a slightly more involved way in Use 
Keynote Remote), and I’ve acknowledged the existence of a Web 
version—but that’s about it. I wish I could say that Keynote has the 
same features and interface on every platform, but that would be a fib. 
Although the three versions of Keynote share a great deal in common, 
there are enough exceptions and gotchas that you’ll want to know what 
you’re getting yourself into. 

In this brief appendix, I provide a quick overview of how Keynote on 
these other platforms differs from Keynote on the Mac, and describe 
a few important capabilities you may need to know about when using 
Keynote on multiple devices. 

Keynote for iOS
 

Keynote for iOS contains the vast majority of the features in Keynote 
for OS X. The user interface is a bit different—for example, there’s no 
room for an inspector pane on such small screens, so there are a lot 
more popovers and such—and it’s downright cramped on an iPhone. 
Nevertheless, most of the basic functionality is there. Impressively, 
that includes all the transitions (even Magic Move), build in, and build 
out effects; Instant Alpha and masking; presenter notes; internal and 
external links; and most self-playing options. 

Because it uses iCloud Drive for storage, any presentation you create 
in Keynote for iOS is automatically available on your Mac (and at 
iCloud.com) too, and vice-versa, so it’s no problem to start working 
on a presentation on one platform and continue it on another. 
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Nevertheless, some features are missing. Here are some of the most 
significant things you won’t find in Keynote for iOS: 

•	 Outline and grid views: You get a Navigator (which you can turn 
off for a single-slide view), and that’s it. 

•	 Action builds: Although you can’t create or edit action builds, 
Keynote for iOS does play action builds that you created in OS X. 

•	 Custom themes: If you create a presentation on OS X using a 
custom theme, that theme will appear in iOS. However, you can’t 
add new, blank custom themes directly to Keynote for iOS. 

•	 Editable master slides: You’re stuck with the master slides in 
the prebuilt themes (or presentations you added in OS X); you can’t 
make any changes to the master slides in iOS. 

•	 List and character styles: Although the formatting itself carries 
over from a presentation created in OS X, you can’t directly apply 
or modify list or character styles. That also means you can’t change 
bullet or number characters, spacing, and the like. 

•	 User-defined paragraph styles: You can apply any existing 
paragraph styles, including custom styles you created in OS X, but 
you can’t modify paragraph styles or create your own in iOS. 

•	 Narration: Although you can add a soundtrack (see below), you 
can’t record a live narration to use as part of a self-playing presenta-
tion, as you can in OS X. 

In addition, several features are present, but different or limited in a 
significant way. For example: 

•	 Alignment: Basic alignment controls (and automatic guides) exist. 
But because you can’t select multiple objects at once, you can’t 
group or ungroup them, and there are no commands to align or 
distribute a group of objects. 

•	 Ruler: A ruler appears when you’re moving an object, but can’t be 
made to appear all the time—and never appears while editing text 
(which also means you can’t edit indents or tab stops). 
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About This Book 
Thank you for purchasing this Take Control book. We hope you find 
it both useful and enjoyable to read. We welcome your comments. 

Ebook Extras
 

You can access extras related to this ebook on the Web. Once you’re 
on the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
a subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. You may find new tips or information, as 
well as a link to an author interview. 

•	 Find out if we have any update plans for the ebook. 

If you bought this ebook from the Take Control Web site, it has been 
automatically added to your account, where you can download it in 
other formats and access any future updates. However, if you bought 
this ebook elsewhere, you can add it to your account manually: 

•	 If you already have a Take Control account, log in to your account, 
and then click the “access extras…” link above. 

•	 If you don’t have a Take Control account, first make one by follow-
ing the directions that appear when you click the “access extras…” 
link above. Then, once you are logged in to your new account, add 
your ebook by clicking the “access extras…” link a second time. 

Note: If you try these directions and find that your device is incom-
patible with the Take Control Web site, contact us.
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About the Author
 

Joe Kissell is the author of more than 50 books about technology, 
including Take Control of iCloud and Take Control of Your Online 
Privacy. He is also a Contributing Editor to TidBITS and a Senior 
Contributor to Macworld, and he has appeared on the MacTech 25 
list (the 25 people voted most influential in the Macintosh community) 
since 2007. 

When not writing, Joe likes to travel, walk, cook, eat, and practice t’ai 
chi. He lives in San Diego with his wife, Morgen Jahnke; their sons, 
Soren and Devin; and their cat, Zora. To contact Joe about this book, 
send him email and please include Take Control of Keynote in the 
subject of your message. 

Shameless Plug 
On my site Joe On Tech, I write about how people can improve their 
relationship with technology. I’d be delighted if you stopped by for a 
visit! You can also sign up for joeMail, my free, low-volume, no-spam 
mailing list, or follow me on Twitter (@joekissell). To learn more about 
me personally, visit JoeKissell.com. 
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About the Publisher
 

TidBITS Publishing Inc., publisher of the Take Control ebook series, 
was incorporated in 2007 by co-founders Adam and Tonya Engst. 
Adam and Tonya have been creating Apple-related content since they 
started the online newsletter TidBITS in 1990. In TidBITS, you can 
find the latest Apple news, plus read reviews, opinions, and more. 

Credits 
• Publisher: Adam Engst 

• Editor in Chief: Tonya Engst 

• Editor: Dan Moren 

• Production Assistants: Oliver Habicht 

• Cover design: Sam Schick of Neversink 

• Logo design: Geoff Allen of FUN is OK 

More Take Control Books 
This is but one of many Take Control titles! Most of our books focus 
on the Mac and OS X, but we also publish titles that cover iOS, along 
with general technology topics. 

You can buy Take Control books from the Take Control online catalog 
as well as from venues such as Amazon and the iBooks Store. But it’s 
a better user experience and our authors earn more when you buy 
directly from us. Our ebooks are available in three popular formats: 
PDF, EPUB, and the Kindle’s Mobipocket. All are DRM-free. 
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Copyright and Fine Print 
Take Control of Keynote 

ISBN: 978-1-61542-457-3
 

Copyright © 2015, alt concepts inc. All rights reserved.
 

TidBITS Publishing Inc. 50 Hickory Road, Ithaca NY 14850, USA 

Why Take Control? We designed Take Control electronic books to help readers regain 

a measure of control in an oftentimes out-of-control universe. With Take Control, we also 

work to streamline the publication process so that information about quickly changing 

technical topics can be published while it’s still relevant and accurate. 

Our books are DRM-free: This ebook doesn’t use digital rights management in any 

way because DRM makes life harder for everyone. So we ask a favor of our readers. If you 

want to share your copy of this ebook with a friend, please do so as you would a physical 

book, meaning that if your friend uses it regularly, he or she should buy a copy. Your 

support makes it possible for future Take Control ebooks to hit the Internet long before 

you’d find the same information in a printed book. Plus, if you buy the ebook, you’re 

entitled to any free updates that become available. 

Remember the trees! You have our permission to make a single print copy of this 

ebook for personal use, if you must. Please reference this page if a print service refuses 

to print the ebook for copyright reasons. 

Caveat lector: Although the author and TidBITS Publishing Inc. have made a reasonable 

effort to ensure the accuracy of the information herein, they assume no responsibility for 

errors or omissions. The information in this book is distributed “As Is,” without warranty 

of any kind. Neither TidBITS Publishing Inc. nor the author shall be liable to any person 

or entity for any special, indirect, incidental, or consequential damages, including without 

limitation lost revenues or lost profits, that may result (or that are alleged to result) from 

the use of these materials. In other words, use this information at your own risk. 

It’s just a name: Many of the designations in this ebook used to distinguish products 

and services are claimed as trademarks or service marks. Any trademarks, service marks, 

product names, or named features that appear in this title are assumed to be the property 

of their respective owners. All product names and services are used in an editorial fashion 

only, with no intention of infringement. No such use, or the use of any trade name, is 

meant to convey endorsement or other affiliation with this title. 

We aren’t Apple: This title is an independent publication and has not been authorized, 

sponsored, or otherwise approved by Apple Inc. Because of the nature of this title, it uses 

terms that are registered trademarks or service marks of Apple Inc. If you’re into that sort 

of thing, you can view a complete list of Apple Inc.’s registered trademarks and service 

marks. 
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