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Read Me First
Welcome to Take Control of Exploring & Customizing Snow Leopard,
version 1.0, published in August 2009 by TidBITS Publishing Inc. This
book was written by Matt Neuburg and edited by Tonya Engst.
Every couple of years, Apple plunges its excited users into a new
world with a major revision of Mac OS X. This time, it’s Snow Leopard
(Mac OS X 10.6). So, what’s new in Snow Leopard? What’s all the
fuss about? This book gives you a hands-on guided tour, while pointing out the adjustments, tweaks, and customizations you can and
should make in the System, the Finder, and more.
Copyright © 2009, Matt Neuburg. All rights reserved.
If you have the PDF version of this title, please note that if you want
to share it with a friend, we ask that you do so as you would a physical
book: “lend” it for a quick look, but ask your friend to buy a new copy
to read it more carefully or to keep it for reference. You can click here
to give your friend a discount coupon. Discounted classroom and Mac
user group copies are also available.

UPDATES
We may offer free minor updates to this book. To read any available new
information, click the Check for Updates link on the cover, or click here.
On the resulting Web page, you can also sign up to be notified of major
updates via email. If you own only the print version of the book or have
some other version where the Check for Updates link doesn’t work, contact us at tc-comments@tidbits.com to obtain the PDF.

BASICS
In reading this book, you may get stuck if you don’t understand Take
Control syntax for things like working with menus, preferences, and
windows, or for finding items in the Finder.
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Please note the following:
• Menus: When I describe choosing a command from a menu in
the menu bar, I use an abbreviated description. For example, the
abbreviated description for the menu command that creates a new
default window in the Finder is “File > New Finder Window.”
• Contextual menus: In the old days, I would have said that a
contextual menu appears after you Control-click something that
has a contextual menu, such as an item in the Finder. Now, however,
there are many ways to open a contextual menu on a Mac. You can
still Control-click, but you can also right-click if you have a two-button
mouse, or you can invoke it from the trackpad of a reasonably new
laptop. (Configure your laptop in the Trackpad System Preferences
pane.) So, whenever you read “Control-click” or “right-click,” use
whichever method you like to open a contextual menu.
• Preferences: When I say “preference pane,” especially when I
speak of “the so-and-so preference pane,” I’m referring to the System
Preferences application. To start System Preferences, choose System
Preferences from the  menu (or click its icon in the Dock, if it’s
there). You access a particular preference pane by way of its icon, or
the View menu. For example, to see “the Displays preference pane,”
you would launch System Preferences and then click the Displays icon
or choose View > Displays.
On the other hand, talk of preferences in relation to a particular
application has to do with the window you see when you choose
AppName > Preferences (where AppName is the name of the application). So, for example, when I say, “set Terminal to emulate a vt100
or vt102 in its preference window,” I’m telling you to start Terminal,
and then choose Terminal > Preferences and do something in the
window that appears.
• Panes and views: Window content in Mac OS X can be dynamic.
What’s in a window can change depending on what button you press.
So there needs to be terminology describing the changeable portion
of a window. I call the highest region of changeability in a window
(often the entire content of the window) a “pane”; smaller areas within
a pane that can change, I call a “view.”
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For example, as I just mentioned, when you start System Preferences,
you can then click an icon or choose from the View menu to see a
particular preference pane, such as Displays or Energy Saver. Those,
then, are panes. Similarly, in the Finder preferences window, you can
click a toolbar item, such as General or Labels, to change the entire
content of the window; so I’ll speak of “the General pane” or “the
Labels pane.”
Smaller regions whose content changes when you click a button—the
sort of area that often used to be called “tabs”—are what I call “views”
in this book. So, for example, to see “the Color view of the Displays
preference pane,” you would launch System Preferences and then click
the Displays icon to switch to the Displays pane, and then click Color
to see the Color view within the Displays pane.
• Path syntax: I occasionally use a path to show the location of a file
or folder in your file system. Path text is formatted in a colorful typewriter font. For example, Snow Leopard stores most utilities, such
as Disk Utility, in the Utilities folder; the path to Disk Utility is
/Applications/Utilities/Disk Utility.
The slash at the start of the path tells you to start from the root (top)
level of the disk. You will also encounter paths that begin with~ (tilde),
which is a shortcut for any user’s home folder. For example, if someone with the user name joe wants to install fonts that only he can
access, he would install them in his ~/Library/Fonts folder, which
is just another way of writing /Users/joe/Library/Fonts.
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Introduction
Perhaps you stood in line to obtain one of the first copies of Mac OS X
version 10.6 Snow Leopard at your local computer store. Perhaps you
had pre-ordered it online, and it arrived all shiny and shrink-wrapped at
your door. Or perhaps you were more cautious and waited until you felt
Apple had straightened out the initial kinks inevitable in a new operating
system release. One way or another, you wound up with a copy of Snow
Leopard.
You stayed up late installing it on your Macintosh; then you fell asleep
exhausted. You woke up the next morning excited as a child on Christmas. But now what do you do? You know things must be different—
otherwise this wouldn’t be a new system release—but what things?
Where should you look, to see what’s snowy about Snow Leopard? Even
more important, what changes have implications for the way you work?
What options, settings, choices do you need to tackle, what new techniques and possibilities do you need to know about, in order to start
using Snow Leopard comfortably and efficiently, so you can stop gaping
at your newly upgraded computer and get back to using it?
This book covers the day-after-Christmas reality of exploring and
tweaking Snow Leopard so that you can use it to its full potential—and
to your full potential. It introduces you to Snow Leopard by shining an
exploratory flashlight into its dark corners, revealing what’s new, what’s
different, and what might call for a customization in Snow Leopard’s
behavior—or in your behavior—so that you can get on smoothly with
your regular computer life.
This book is your guide to Snow Leopard’s unique essence and to what
you should know about Snow Leopard to get the most out of it. I’m not
writing for Unix experts, so I don’t generally talk about clever technical
hacks; the customizations pointed out here are primarily those that Snow
Leopard wants and expects you to perform directly in its normal interface.
I do, however, point out areas where Snow Leopard might need a little
help from third-party utilities in order for you to work most comfortably
and efficiently.
Now let’s meet Snow Leopard and make it change its spots!
8
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Snow Leopard Quick Start
This book describes many areas of Snow Leopard worth exploring and
customizing, some of which will be more important to you than others.
Naturally, I think that sooner or later you should take the time to read
this book from start to finish, but I also understand that you’re eager to
get working with Snow Leopard and that you might want to know what’s
most important to do right now, and come back to the rest of the book
later. So, I suggest a three-stage approach:
1. Right away, perform the customizations that will immediately
improve your Desktop and interface experience.
2. Learn about Snow Leopard’s new features, so that you can get the
most out of them in your work.
3. Catch up on the remaining customizations whenever you have time.
Here, then, is how I suggest you customize and learn about Snow
Leopard with the help of this book:
Do these things right away:
• If you were already using Leopard and would like to prepare yourself
mentally to change your work habits to fit the new Snow Leopard
environment, read Know What’s New (p. 11).
• Check that you installed Snow Leopard correctly, in accordance with
what you want it to do for you; read Install Intelligently (p. 13).
• Prevent Snow Leopard from engaging in certain background activities
when you first boot up into it; read Block the Big Bang (p. 18).
• Make your computer safer, thanks to Time Machine, a feature that
makes backups easy as pie; read Preserve the Past with Time Machine
(p. 23).
• Set up the overall workspace; read Dominate the Dock (p. 37) and
Straighten Out Your System Preferences (p. 42).

9

Click here to buy the full 165-page “Take Control of Exploring & Customizing Snow Leopard” for only $15!

• Customize your Finder windows so that you can navigate easily to
important areas of your disks; see Handle the Hierarchy (p. 44) (and
possibly Appendix A: Place the Finder’s Default Window, p. 159).
• Make the pointer—Apple calls it the cursor in this context—easier
to see, the screen easier to read, and generally clear the decks so
you have a good view of what you’re doing; read Ease Your Eyeballs
(p. 119) and Make the Menu Bar Opaque (p. 156).
Explore new aspects of Snow Leopard:
• Find out about Exposé’s new appearance and behavior; read Explore
Exposé (p. 83).
• Experiment with the new, studlier text engine, and discover a great
new way to switch keyboard layouts; read Tackle Your Text (p. 135).
• Find out about the new importance and usability of services; read
Survey Your Services (p. 114).
Do these things as needed and when time permits:
• Consider how you’ll use Spaces, Dashboard, and third-party window
management; read Wash Your Windows (p. 82).
• Tweak keyboard shortcuts and keyboard behavior to match your
needs and habits, and learn about the many ways to customize
mousing; read Control the Keyboard, Master the Mouse (p. 102).
• Simplify your font access and make Snow Leopard run leaner and
meaner; read Fix Your Fonts (p. 126).
• Make effective use of the icons at the right end of your menu bar; read
Customize Status Menus (p. 148).
• Make various additional small customizations; read Perform
Miscellaneous Configurations (p. 152).
• Be ready to continue exploring customizations; read Find Other
Customizations (p. 158).
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Know What’s New
If you’re familiar with Mac OS X 10.5 Leopard, Snow Leopard presents
interesting changes that you may want to take account of as you adjust
your work habits to fit the new environment. This section lists some of
the most important ones (with reference, where appropriate, to later
sections of this book).

Here are the main points of what’s new in Snow Leopard:
• New Exposé options: Exposé is a handy system for quickly moving
between open windows on your Mac. Exposé’s All Windows and
Application Windows modes have been revamped to make them
clearer and more useful. Windows are labeled, and minimized windows are displayed. There are new ways to enter Application Windows
mode, from the Command-Tab application switcher and from the
Dock (which can be used in All Windows mode). So you’ll be able to
switch not only to the application you want but to the window you
want, with greater ease and speed. You can even drag-and-drop from
one window to another by passing through the Dock and Exposé!
Read Explore Exposé (p. 83).
• New system-wide text features: The built-in text system has been
upgraded with features like smart quotes and smart copy-and-paste.
Even more important, the text system can now perform automatic
substitutions: you type one thing, and the text system substitutes
another, and you can define these substitutions at a global level. You
can even have your spelling corrected as you type! See Set Up Text
Behavior (p. 135).
• Revamped Services: Services are features provided by one program
that appear in another program. Services have taken on a whole new
importance and a whole new interface. Services can be enabled and
disabled, and their keyboard shortcuts assigned, in a new preference
pane. Instead of a huge Services menu, only services applicable to
the current context appear. Moreover, the contextual menu plug-in
architecture has been withdrawn; instead, services are the new contextual menus, and they too are more intelligent about when they
11
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Install Intelligently
If you’ve already installed Snow Leopard, it may seem too late to speak
of customizing the installation. Nevertheless, customization of Snow
Leopard does begin with installation. When you originally run the
installer, you pass through a series of several screens leading to the
actual installation:
1. The Language screen
2. The Welcome screen
3. The License Agreement screen
4. The Install Summary screen
The last screen, Install Summary, is where you can perform some
customizations.
Relax! You don’t have to reinstall if you missed any customizations
in Install Summary. You have a working installation of Snow Leopard,
and that’s the important thing. If you omitted installing a system component listed in the Install Summary screen, such as Rosetta or a set
of printer drivers, you can install it later by double-clicking the file
Optional Installs.mpkg; it’s inside the Optional Installs folder on the
install disk. In fact, as I’ll explain in a moment, if you later need a
system component that you didn’t install originally, your Mac may
automatically offer to download and install it for you!

INSTALL SUMMARY
The Install Summary screen contains a Customize button at the lower
left. Click it to see a dialog where you may select which elements of the
system should be installed. Let’s run through the options:
• Printer Support: Unlike previous system installers, the Snow
Leopard installer simplifies your printer driver installation choices.
(That’s a polite way of saying you don’t get much choice!) You can
choose Printers Used by This Mac, Nearby and Popular Printers, or
13
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Block the Big Bang
The “Big Bang” is scientists’ name for the initial instants after the
creation of the universe, when things were changing fast and the laws
of physics were wacky. Well, Snow Leopard has its own Big Bang!
When you first start up into your newly installed system, Snow
Leopard may try to do some things automatically—things that can
slow down your computer and make your life unpleasant. So the first
customizations you should make are to forestall the “Big Bang.”
If you’ve already installed Snow Leopard and started it up, it’s probably too late: you’ve already experienced the “Big Bang.” But if you’re
reading this book before installing Snow Leopard, forewarned is
forearmed—the moment your computer starts up in Snow Leopard for
the first time, that’s the moment to Stop Spotlight and Take Your Time
With Time Machine. You should also consider whether you want to
Arrest Automatic Updates.

STOP SPOTLIGHT
When Snow Leopard starts up for the first time, the Spotlight indexer
may start re-indexing your boot volume and any other writable disks that
are attached to your computer. In the long run, this is a good thing; as I’ll
explain later (Understand Spotlight), you definitely do want Spotlight to
build these indexes, so that subsequently you can locate files and text on
your computer with amazing speed.
But the initial construction of Spotlight’s indexes is time-consuming,
requiring a great deal of reading from and writing to disk, along with
a significant proportion of your computer’s CPU (its brain). While
Spotlight indexing is going on, your computer’s fans might ramp up,
and the computer might feel sluggish. The solution is simple. Don’t let
Spotlight index your computer now; tell it to index your computer later,
when you’re not using it (during your lunch break, for example).
Unfortunately, Apple provides no simple interface for turning off
Spotlight indexing temporarily. Instead, use this trick:
1. Open the Spotlight preference pane, and switch to the Privacy view.
18
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Preserve the Past
with Time Machine
Snow Leopard includes a built-in method of backing up your computer’s data and restoring past versions of your files with ease and
transparency. This is the appropriately named Time Machine, a simple
device for making sure you can recover the past when you need to.
The lack of a backup copy of something causes a major proportion
of computer frustrations (“Argh, I accidentally deleted / changed /
corrupted / misplaced my Very Important File”); with Time Machine,
you have no excuse for finding yourself in that position.
In this section, I explain how to use and customize Time Machine, and
I look at a few third-party utilities that can help you get the most out of
managing your Time Machine backups.

PREPARE FOR TIME MACHINE
Time Machine requires that you have a spare volume to back up to. This
will typically be an external hard drive. You cannot use Time Machine
to back up the volume that is holding your backup archives. So plan
accordingly.
Partition? A Time Machine backup archive needn’t occupy an entire
disk; you can partition a disk and dedicate one partition to Time
Machine backup archives.
The simplest way to be ready for Time Machine is thus to have on hand
an external hard drive to back up to. The only requirements are that it
be formatted as Mac OS Extended (Journaled) and have more free space
than the amount of material to be backed up. (You can reformat using
Disk Utility if needed.) In a day and age when a 1 TB external USB hard
disk is available for less than $100, those aren’t onerous requirements.
You needn’t keep the external drive connected to your Mac all the
time. You can use the same volume to hold archives backed up from
23
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Dominate the Dock
The Dock is one of the most controversial elements of the Mac OS X
interface. Some users feel they couldn’t manage without it; others find
it poorly implemented and misconceived. Also, when the Dock is at the
bottom of the screen, it appears as a highly reflective “shelf,” and the
icons sitting on it occupy more of your screen real estate than seems
necessary.
Using a computer whose Dock is in your way, or in some other sense
isn’t how you want it, is annoying. You can customize the Dock’s position, size, and behavior to some extent, and you can’t comfortably get
any other work done until you do; so it makes sense to take a moment,
early on, to set up the Dock according to your tastes (which is why this
section appears so early in this book).

Before you customize anything, you should learn your way around the
Dock. The Dock displays (reading roughly from left to right):
• Application icons: These may be running applications (which
appear automatically) or pointers to application files.
• A divider: Drag this to resize the Dock. Control-clicking the divider
brings up a contextual menu with quick access to some of the settings
in the Dock preference pane and a command for opening the Dock
preference pane.
• Files and folders: These are all pointers. By default, the
Applications, Documents, and Downloads folders appear initially.
• Minimized windows: These represent open windows of running
applications, which you’ve “hidden” by choosing Window > Minimize
(or by clicking the middle button at the top left of the window); quitting an application obviously removes its minimized windows from
the Dock.
• The Trash: It’s, like, the Trash!
To open whatever is represented by a Dock icon, click the icon once.
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Straighten Out Your
System Preferences
The vast majority of Snow Leopard customizations are performed
through the System Preferences application. Therefore, one of the first
things to customize after you’ve installed and started up Snow Leopard
for the first time is System Preferences itself.
In this section, I explain how to customize and use System Preferences
to find the preference pane you’re after easily.

The default arrangement of preference pane icons in the main System
Preferences window is by category (Personal, Hardware, Internet &
Wireless, and System). Perhaps this arrangement is to your taste, but
it certainly isn’t to mine, because what I know isn’t a preference pane’s
category, but its name! Therefore, I like to see these icons arranged
alphabetically by the name of the preference pane. To obtain that
arrangement (Figure 14), start up System Preferences and choose
View > Organize Alphabetically.

Figure 14: The main pane of System Preferences, with its icons
arranged alphabetically.
42
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Handle the Hierarchy
Your hard disk is full of things, such as applications you want to use,
or documents you want to read or edit. They live somewhere on your
hard disk—but where? To get anything done at all, you must be able
to locate your files. The better you understand how to locate files, and
the more you customize that process to suit your own preferences and
needs, the more comfortable and productive you’ll be.
There are two main ways of locating files on your computer, which you
can think of as polar opposites of one another:
• The folder hierarchy: Every file is in a folder, every folder is in
a folder, and so on, upward, until we reach the top level, called a
volume: this is usually your hard disk, or a partition of your hard
disk. So, to reach any file or folder, you can traverse that same path
downward: starting at some high level, such a volume or your
Home folder, you enter a folder, then a folder within that, and
so forth, until you reach whatever you’re after.
• Jumping: Navigating the folder hierarchy can be tedious, and
besides, the hierarchy itself can be a terrible mode of organization;
it works like a filing cabinet, but your mind doesn’t, and to locate
something this way, you must know beforehand the entire sequence
of folders containing it, which is not always the case. You need ways
to slice through the hierarchy and reach your stuff, no matter where
it is. You want to jump directly to the file or folder you have in
mind—so let’s call this way of locating things jumping.
You can customize your Snow Leopard environment—in particular,
the Finder and Spotlight, as well as your Open and Save dialogs—so
that you can both navigate the hierarchy and jump directly to your
stuff, comfortably and easily. In this section, I explain how.
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Wash Your Windows
Here’s a news flash from the Department of Unintended Consequences: windows are great, but they’re also a problem. As soon as
you have more than a few windows open at once, it’s clear that those
windows are like automobiles, and your monitor is like a Los Angeles
freeway—it’s overcrowded, and no matter how much you widen it,
it’s still going to be overcrowded. This is particularly a problem on
an operating system like Mac OS X, where the windows of different
applications can become intermingled. Finding the window you
want can be like searching, amid the distracting red herrings, for
the Purloined Letter: you might not be able to see it even if it’s in
plain sight.
To ease the window traffic on your monitor, Apple has provided
various devices for helping you see the windows you want to see:
• Exposé: In 2003, in Mac OS X 10.3 Panther, Apple introduced
Exposé as a way of letting you switch quickly among all your
open windows (or get them all out of the way so you can see your
Desktop). Read Explore Exposé (next page) and discover its new
Snow Leopard behavior.
• Spaces: In Mac OS X 10.5 Leopard, Apple introduced Spaces, a
true virtual desktops implementation letting you switch between
entire sets of windows at once. Your task is to decide whether you
want to use Spaces, and if so, to Set Up Spaces (p. 90) with triggers
that you’ll use readily.
• Dashboard: Also in this section, we will Dominate Dashboard
(p. 96). Dashboard qualifies as a form of window management
because it presents certain miniature applications in a special
window layer that’s visible only when you want to use it.
• Third-Party Alternatives: Finally, if all that isn’t enough, we’ll
Consider Third-Party Window Management (p. 100). A third-party
application might make windows work in a nicer way for you.
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Control the Keyboard,
Master the Mouse
Advanced as it is, Snow Leopard can’t read your mind. So, with the
possible exception of some valiant pioneers who are making use of
speech recognition or other innovations, the main way to get anything
done on your Mac is still by pressing keys and manipulating the
mouse. Therefore you owe it to yourself to give a little thought to what
the keyboard and the mouse do.
You can make a number of customizations regarding how the Mac
responds to your keypresses and mouse clicks. Individually, each of
these customizations may seem small, but considering how much time
you’ll spend mousing and typing, they can add up to the difference
between annoyance (or even wrist pain) and nimbleness.

MODIFY YOUR MODIFIERS
The modifier keys are Shift, Control, Option, Command, and Caps Lock.
Some users don’t like the placement of these keys; perhaps they are
accustomed to a different layout. Snow Leopard lets you change their
placement (except for that of the Shift key, which is always the Shift key).
To make such a change, go to the Keyboard preference pane, switch to
the Keyboard view, and click the Modifier Keys button.
This might seem rather an arcane setting; but it can be practical.
Consider, for example, the Caps Lock key. It’s an anachronistic holdover
from the typewriter. Do you sometimes accidentally turn on Caps Lock,
and then your passwords don’t work or you’re suddenly typing capital
letters by mistake? Do you just wish you could rip it off the keyboard?
Well, you can: In the Caps Lock Key pop-up menu, choose No Action.
Presto, the Caps Lock key is completely disabled. Alternatively, you can
re-map the Caps Lock key so that it acts as some other modifier key; you
might, for example, make it into an extra Control key.
You can use this feature to swap modifier key functionality in other
ways. You can even rearrange modifier key functionality differently for
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Ease Your Eyeballs
A common complaint about using computers is an inability to see
comfortably. You sit at the computer for long stretches of time; you
read text on the screen; you peer at minute details. You deserve as
pleasant a viewing experience as you can possibly get. Snow Leopard
gives you many ways to improve the way your monitor portrays the
computer’s world.

CALIBRATE YOUR SCREEN
When you first install Snow Leopard, the default screen calibration may
give your screen a pale, washed-out appearance, making icons difficult to
distinguish and text difficult to read.
If you don’t like, or have doubts about, the way your screen looks, go
to the Color view of the Displays system preference pane and pick a
different display profile, if there is one. If that doesn’t help, you can
calibrate the display manually. Follow these steps:
1. Wait until a time of day, and be in a location and under lighting
conditions, where you commonly use your computer. Your perception
of the screen is greatly affected by the incident and ambient light.
Position yourself where the screen is at its best viewing angle. Many
screens give false colors or reduced visibility if seen from too high or
low or from one side.
2. Prepare your monitor: In the Display view of the Displays preference
pane (or using whatever control is supplied by your monitor), set the
screen’s brightness to maximum. In the Seeing view of the Universal
Access preference pane, set the contrast to normal (and if your monitor has a contrast control, set it to maximum).
3. It may be useful to have some windows open in the background that
can serve as a reference point. I like to open TextEdit, because the
background of an empty window works as a standard white point
reference. Also, in Text Edit, I like to summon the Open dialog and
display it in List view, because the blue and white stripes are quite
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Fix Your Fonts
Font management has always been a problem on the Mac, and fonts
remain an extraordinarily rocky area of Mac OS X. Once you have
more than a few fonts, the mere act of choosing a font in an application becomes a trial, because the list of available fonts is so long. Font
versioning, especially when different fonts have the same name, is a
troublesome business. And a surprisingly high percentage of crashes
and other strange phenomena experienced by Mac OS X users are due
to font problems, such as conflicts between fonts, or fonts that are in
some way badly structured.
For these reasons, it’s important to take control of your fonts on Mac
OS X. Read this section to implement some font management that will
make your Mac quicker and nimbler by putting unneeded fonts out of
sight—until you do need them.

KNOW WHY FONT MANAGEMENT IS NEEDED
The biggest problem with fonts in Mac OS X is that they are literally all
over the place. There isn’t just one Fonts folder you can peek into and say
“These are my fonts.” Fonts load automatically into the system and they
become available for use in applications, if they are in any of (at least)
three places:
• /System/Library/Fonts
• /Library/Fonts
• ~/Library/Fonts
So just seeing what fonts you have is a pain in the Finder. And even when
you know a font file’s name, that doesn’t mean you know all about it:
• A font file is like an image file: its name is just a label; what you want
to know is what a font face looks like.
• A single font file can contain multiple font faces or, just the opposite,
multiple font files can make up a single family of related font faces.
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Tackle Your Text
Unless you use your Mac primarily for surfing the Web or creating
graphics, sooner or later you’re going to press a key on your keyboard,
and a text character is going to appear on your screen. It sounds simple, but behind the scenes a lot of incredibly sophisticated stuff is
happening as the mighty Mac OS X text engine swings into action.
In Snow Leopard, the Mac OS X text engine has been heavily
upgraded, providing many new features, including smart quotes,
automatic correction of misspellings as you type, and text substitutions where you type one thing and something else is entered for you.
Naturally, that calls for some customization, so the first thing we’ll do
is examine the new text engine and Set Up Text Behavior. Then we’ll
make sure you Understand the Input Menu so that you can enter
interesting text characters.

SET UP TEXT BEHAVIOR
To explore the new features of Snow Leopard’s text engine, you need
to work in two places at once. First, bring up the Language & Text
preference pane, and switch to the (new in Snow Leopard) Text view.
Second, launch TextEdit, because unlike many other word processors
and text processors it’s a kind of unmediated showcase for Snow
Leopard’s built-in text engine features.
So, you’ll customize system-level settings in the Text view of the
Language & Text preference pane, and you’ll experiment with the text
engine in action in TextEdit.

Text Substitutions
In the Text view of the Language & Text preference pane, the Symbol and
Text Substitution table is a list of changes that the text engine can make
for you automatically as you type. For example, you type (c) and the text
engine can automatically change it to the copyright symbol ©.
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Customize Status Menus
Status menus (also called status items, status icons, menu extras,
or menu bar extras) are the icons that appear at the right end of your
menu bar. (This area is technically called the system status bar.)
Status menus can be a convenience or a waste of valuable menu bar
space, depending on your needs, your monitor size, and what you had
for breakfast. In any case, controlling which status menus appear is
a customization you can and should perform.
Unfortunately, the tools for status menu management are scattered all
over your computer. This section will help you find most of them.

SHOW STATUS MENUS
How do status menus come into being? There are various ways. Some
status menus are there by virtue of being enabled in System Preferences.
Some status menus are put there by some application, either through its
preferences or because the application is running.

The system status bar shown above has three groups of icons:
• Starting from the left, the first two status menus come from thirdparty utilities—respectively, the preference pane PTHPasteboard and
the application FastScripts.
• Then come status menus placed by various built-in System Preference
panes—Universal Access, Spaces, Network (AirPort), Sound, Language
& Text (Input menu), Energy Saver, Date & Time, and Accounts (Fast
User Switching).
• At the far right is the Spotlight menu, which is not really a status
menu.
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Perform Miscellaneous
Configurations
This section points out some miscellaneous customizations that
you should not neglect in your eagerness to get on with using Snow
Leopard. I’ve collected them here at the end, not because they’re less
important than those that have preceded, but because they couldn’t
be categorized into an earlier section.

SET UP LOGIN ITEMS
Your login items are applications that launch automatically when you
log in to your user account. These are typically applications that you like
to be always active; because of Mac OS X’s virtual memory model and
non-polling event loop architecture, there is usually no penalty for having
numerous applications running, except that when you start up your Mac,
you must wait for them to all launch before you can get much done.
To set up applications as login items:
1. Open the Accounts preference pane.
2. Select your user name in the list on the left, and click the Login Items
button to show the Login Items view.
3. Locate a desired application in the Finder and drag it from the Finder
into the Login Items list. Or, click the
button and navigate to the
application in the Open dialog.
Tip: You can make any application in the Dock a login item, without

using the Accounts preference pane. To do so, Control-click the
application’s Dock icon and choose Options > Open at Login from
the pop-up menu.

152

Click here to buy the full 165-page “Take Control of Exploring & Customizing Snow Leopard” for only $15!

Find Other Customizations
On the one hand, a systematic discussion of every pane of System
Preferences, and every option in every application’s Preferences
window, one by one, would bore most readers to tears. On the other
hand, you can (and should) make important customizations in these
locations. So here’s a compromise—a final word of advice.

This book has pointed out Snow Leopard customizations that are
particularly important or difficult to find, but many others remain,
and you should still search out those other customizations and tweak
Snow Leopard so that it’s the way you like it. For example, this book
hasn’t talked about setting your computer’s sound volume, or specifying
its Beep sound.
So take some time, after the excitement of meeting Snow Leopard
has subsided, to march through every view of every pane of System
Preferences. Look at your options, and make sure things are set up
the way you like them.
Similarly, as you start up an application, take a moment to examine
its preferences and see what customizations are available to you. For
example, in Safari, do you like tabbed browsing? When you click a link
to open a page in a new tab, do you want holding the Shift key to mean
“open the page in the background” or “open the page and switch to that
tab right now”? This book hasn’t talked about how you set up Safari’s
preferences. But those are still things you should do.
Finally, if you think a particularly important customization has been
omitted from this book, email us and let us know. Maybe we’ll include
it in a future update. Many of our ideas about what customizations our
readers find significant have come from our readers themselves.

158

Click here to buy the full 165-page “Take Control of Exploring & Customizing Snow Leopard” for only $15!

Appendix A: Place the
Finder’s Default Window
A computer is to program, and sometimes a customization requires
just that little bit of programming to make things the way you really
want them. In this appendix—which is intended for all readers of this
ebook, even those who normally would shy away from programming—
we’ll solve a problem I mentioned earlier, in Set Up the Default Finder
Window. The problem is that when you ask the Finder for a default
Finder window (File > New Finder Window) you can never be sure
where on the screen this window will appear.
We’ll write a little program that makes a default Finder window and
puts it in the same place, always. Then we’ll see how you can run this
program with a convenient keyboard shortcut.

First we’ll write the program:
1. Launch AppleScript Editor (it’s in the Utilities folder) and type this
program into its script window (or click here to paste it in automatically, since a normal copy and paste from this ebook might not work):
tell application "Finder" to activate
tell application "System Events"
tell application process "Finder"
tell menu bar item 3 of menu bar 1
click menu item 1 of menu 1
end tell
end tell
end tell
tell application "Finder"
set position of Finder window 1 to {10, 60}
end tell

2. Choose Script > Run (or press the Run button in the toolbar).
This shows you what the program does; it summons a default Finder
window and then moves it to a fixed position near the top left corner
of the screen. (Sorry about the flash as the window moves; I couldn’t
do anything about that.)
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SHAMELESS PLUG
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Macintosh is with AppleScript, a system-level language
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Now that you’ve seen this book, you know that Take Control books
have an easy-to-read layout, clickable links if you read onscreen, and
real-world info that puts you in control. Click any book title below or
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collection!
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