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Read Me First
This ebook was published in December 2017 by alt concepts inc. It was written by
Jason Snell and edited by Scholle McFarland.
This book helps you get started with Apple’s Photos app (for macOS and iOS). It
focuses on importing libraries from older apps, managing your media inside Photos,
and using Photos to edit and share your media with friends, relatives, and the world
at large.
Photos: A Take Control Crash Course, version 1.1
Copyright © 2017, The Incomparable Inc. All rights reserved.

Formats and Updates
• Use the link in Ebook Extras, near
the end, to download the latest
version of the ebook in PDF, EPUB,
or Mobipocket format.
• If you downloaded this ebook from
the Take Control website, it has been
added to your account. If you
bought it elsewhere, you can add
it to your account; see Registering
Your Ebook.
Tip: You can read about putting Take
Control ebooks on various devices and
computers on our Device Advice page.
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Introduction
In 2002, Apple introduced iPhoto as a way for us to save our photos on our Macs
inside a “digital shoebox.” At the time, I’d owned a digital camera for three months,
and had only a few hundred digital images. Over the years, as my photo library grew,
Apple revised iPhoto, always trying to stay in front of the onslaught of thousands of
digital photos accumulated over a lifetime—at least the lifetime of my two children.
By 2014, enough was more than enough. Apple decided it needed to start from
scratch and ditch both iPhoto and the professional-level photo tool it had introduced
in 2005, Aperture. It chose to replace them both with a single application, which
would be called—in the prosaic style favored by Apple for its iOS apps—Photos. This
would allow Apple to unify (more or less) the photography apps it was creating for
both macOS and iOS.
In this book, I’ll describe how to perform most of the tasks you’ll want to do with
Photos—in both macOS and iOS. One of the most exciting features of Photos is its
embrace of cloud services. You can choose to keep your entire photo library in the
cloud rather than on your drive, making those images instantly available on any
device signed in to your account. (It’s up to you to decide whether you want to
embrace the cloud to that degree.)
My daughter, born late in 2001, is now a high-school student. Her entire life has been
chronicled with digital photos—tens of thousands of them at this point. I originally
used iPhoto to catalog her childhood. Now that catalog resides in Photos, and in
iCloud Photo Library. Photography is how we preserve the images of our lives; it’s
important that we understand the software that allows us to organize, view, and share
those images. That’s what this book is for.
The version of the book you are reading has been updated to reﬂect the changes in
Photos for macOS version 3.0, which was released along with macOS 10.13 High
Sierra in September 2017. You can ﬁnd an overview of the changes by reading
What’s New in Photos.
Thanks for joining me on this journey. Let’s get started!
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Photos Quick Start
This book explores Apple’s Photos app (in macOS and iOS) by walking you through
the most essential photo-management and editing tasks. You can read the chapters
in any order. Click any link to jump to a topic.

Find What’s New

Get Organized

• Latest updates: If you used Photos in
Sierra or in iOS 10, ﬁnd out what’s
new in Photos in 10.13 High Sierra
and iOS 11 in What’s New in Photos.

• Embrace search: Apple includes machine-learning technology to Photos
that allows it to identify objects, animals, and faces. Read Use Search to
Find Your Photos to take advantage
of this exciting feature.

• For upgraders: For those who’ve
previously used iPhoto or Aperture, I
provide some explanation of what’s
different in Photos vs. iPhoto and
Aperture.

• Add metadata: No one knows your
photos better than you do. Make
them easier to ﬁnd later by applying
keywords and marking Favorites.
Read Add Info about Your Photos
and Use the Info Window.

• Migrating your library: If you’re upgrading from iPhoto, check out Import from iPhoto into Photos.

• Build albums: Photos organizes your
library by date. If you have other
ideas, create your own albums. See
Make Albums in Photos.

• Aperture issues: If you’re upgrading
from Aperture, see From Aperture to
Adobe? as well as From Aperture to
Photos.

• Create smart albums: Want to quickly round up all the photos of your
kids taken with your DSLR within the
last year? Take advantage of your
valuable metadata in Deﬁne Smart
Albums in Photos.

Import and Manage Photos
• From ﬁles and devices: Photos for
macOS and iOS can import ﬁles directly from your camera or memory
card. Read Import Your Files into
Photos.

• Hide or trash: Not every photo is
meant to be shared or is a keeper.
See Hiding Photos and Deleting
Photos.

• From multiple libraries: You can
easily switch between libraries to
keep different collections separate.
See Use Multiple Photos Libraries.

Perfect Your Photos
• Quick-ﬁx options: Give photos a little extra “pop” in macOS or iOS by
cropping, applying ﬁlters, and ﬁxing
red-eye and rotation problems. See
Make Quick Photo Fixes.

Find Your Bearings
• Use the sidebar: Learn the meaning
of everything in the sidebar. See
Navigate the Photos Interface.
• Decode icons: Understand (and turn
off or on) the small icons that may
overlay your photos. Read the sidebar Metadata Mania.

• Advanced editing: Learn how to
Make Adjustments to Your Photos by
removing unwanted details and applying adjustments, as well as editing
with external apps like Photoshop if
you prefer. You can now also Edit
Live Photos.

• Control Live Photos: Learn how to
view—or disable—Live Photos taken
with a newer iPhone.
5
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Explore Your Collection

Show Oﬀ Your Photos

• Memories: Remember Christmas
3 years ago? Photos does. Peruse
Photos-generated collections of your
photos, including a map of locations,
associated people, and (in Photos for
iOS) a customizable movie. Check
out Use Memories to Unearth Old
Photos for much more.

• Social media: Don’t let your photos
stay locked up on your Mac. Learn
the easiest ways to Share Your Photos on Facebook, Twitter, Flickr, and
more.
• Export: If your desired method of
sharing your photos involves getting
them out of Photos, try Exporting
and Resizing Images.

• People: Get a handle on how Apple
automatically identiﬁes the people in
your photos, and how to put names
to faces in Add Names to People.

• Slideshows: Turn a special event’s
photos into a beautiful movie with
its own soundtrack. See Make
Slideshows in Photos.

• Summaries: This view of a Collection
shows a slideshow on the Mac and
lets you view and customize a video
summary on iOS. See View a Summary of a Grouping and View a Custom-made Video.

• Printed projects: For all the convenience of digital photos, there’s still
nothing quite like holding an image
of loved ones in your hands. Discover how to Make Books, Calendars,
and Cards and Make Photographic
Prints.

Connect with Other Devices
• iCloud Photo Library: Thanks to the
cloud, you can access your entire
Photos library from any device you
own. But you’ll need to change the
way you think about managing your
photos. Read Sync with iCloud Using
Photos.
• Apple TV: Admire your favorite photos on your big-screen TV when you
View Photos on an Apple TV.
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What’s New in Photos
In macOS High Sierra and iOS 11, Photos has some huge new features. Here are the
highlights of the biggest changes in the new versions of Photos.
sions, Curves and Selective Color have
been added to give you more control
over color and contrast. Learn all about
these tools in Make Adjustments to
Your Photos.

Redesigned Interface
In previous versions of Photos for Mac,
you could choose to navigate either via
tabs at the top of the screen or an
iPhoto-like sidebar on the left side.
With High Sierra, the sidebar has won
and is the primary way you navigate.
For an overview, see Navigate the Photos Interface.

The Filters tab has also been overhauled, adding nine new effects (really,
three new effects, each with three variations). See Make Quick Photo Fixes.

The sidebar has been reorganized into
four groups, Library, Shared, Albums
and Projects. Library contains links to all
photos, Memories, Favorites, People,
Places, Imports, and Recently Deleted
items (see Focus on the Sidebar). Albums is divided into two folders. Media
Types features automatically generated
albums of a speciﬁc media type (for
example, all Panoramas). My Albums is
for all the albums you create yourself,
including Smart Albums. (See Look
Through Albums.)

External Editor Support
If you like to store your images inside
Photos and iCloud Photo Library, but
edit them in another app like Photoshop or Acorn, rejoice! With a couple
of clicks you can edit your photos in an
external editing app, and once you
save them, they’re automatically
brought back into Photos and synced
with iCloud. See Edit Outside of
Photos.

Live Photos Improvements

That new Imports item in the Library
section features an entire history on all
the ﬁle imports you’ve made to your
library. This can be helpful when you
want to access a batch of photos that
wouldn’t necessarily sort together by
date, location, or other means—but are
connected because you imported them
all in one sitting. (See Import Your Files
into Photos.)

You can do more with Live Photos in
High Sierra than in previous versions.
Set Live Photos to loop, bounce, or behave like a single long photographic
exposure (which is amazing for shots of
waterfalls). Change the key image that
represents the Live Photo, in case you
just missed the perfect shot. You can
also crop, enhance, trim, and mute Live
Photos. (See Edit Live Photos.)

The top right corner of the Photos list
offers feedback on the current selection
and a quick ﬁlter view that lets you ﬁlter
the image list by type or keyword.

Smarter People Feature
The People feature is improved, with a
clearer interface, more intelligence
about which faces tend to be seen with
other faces, and training that syncs via
iCloud to make face detection easier
on other devices. (See Add Names to
People.)

Editing Improvements
The editing window has been radically
changed, with a new three-tab view
that rolls most detailed editing tools
into the Adjust tab. In addition to the
adjustments offered in previous ver7
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Photos vs. iPhoto and Aperture
When you compare features, it’s easy to see that, in most ways, Photos is a reincarnation of Apple’s venerable photography app, iPhoto. A few organizational features
have been lost, the interface is more reﬁned, deep connections to iCloud have been
added, and the entire app feels faster.
Not long after introducing Photos, Apple announced that it also was ceasing development of its professional photography app, Aperture ①. Photo hobbyists who used
Aperture despite not needing most of its features might not mind the omissions, but
professional users should consider other options.

① iPhoto and Aperture have been discontinued. Apple intends Photos to be their replacement.

Coming from iPhoto

From Aperture to Adobe?

If you’re used to iPhoto, Photos won’t
be that jarring. Photos can import your
iPhoto library (see Import from iPhoto
into Photos) and retains many (but not
all) of the features of iPhoto. Star
ratings have been demoted to keyword
status, ﬂagged items are now Favorites,
and iPhoto Events are now just another
kind of photo album. (Rob Grifﬁths
wrote a great round-up of the pros and
cons of moving to Photos for High
Sierra that’s worth reading.)

If you loved Aperture and just don’t ﬁnd
Photos to be a suitable replacement—
and that’s not an unreasonable sentiment at all!—the app you should probably consider is Adobe CC Lightroom
CC.
Lightroom CC (both the new and Classic
versions) is tightly integrated with Photoshop and available as part of Adobe’s
Photography bundle, which as of this
writing costs $120 per year, and offers
cloud features of its own. You can download a free 30-day trial to give it a spin.

Photos also offers numerous improvements to iPhoto, including expanded
editing tools and direct integration with
iCloud. With a little time, iPhoto users
should be able to settle in comfortably.

While some people have a problem with
the idea of paying an annual fee to access software, for my money (and yes,
I’m a paying subscriber) the Lightroom
CC/Photoshop bundle is one of the best
deals in the software world today.
(For much more on Lightroom, check
out Jeff Carlson’s book Take Control of
Lightroom CC.)
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Import from iPhoto into Photos
If Photos is the spiritual successor to iPhoto, it’s only right that Photos can import your
iPhoto library, and do so while keeping it intact—more or less ①. Because the features
of Photos don’t align precisely with those in iPhoto, some information from iPhoto
ends up in unexpected locations.

① An iPhoto library (left) migrates to Photos (right).

You’ll need to get used to the changes in Photos—and be prepared to change your
approach to organizing your media—but Apple has worked to make the migration
process as painless as possible.144

First Time’s the Charm

Don’t Use iCloud (Yet!)

The ﬁrst time you launch Photos, it
searches your system for iPhoto and
Aperture libraries. If only one library
ﬁts the bill, it imports that library. Otherwise, it opens the Choose Library dialog (see Use Multiple Photos Libraries).
Choose a library from the list, and Photos prepares the library for import.

On ﬁrst launch, Photos asks if you’d like
to use iCloud Photo Library. I recommend that you decline for now, and
read the Sync with iCloud Using Photos
chapter before committing.
Don’t worry—it’s quite easy to turn on
iCloud Photo Library at any time.

In some cases, macOS may import your
iPhoto library before you ever open
Photos. Don’t worry—iPhoto will warn
you if this has happened, and you can
delete that unedited Photos library and
re-import from iPhoto at any time without penalty.

Import Any Time
Hold down Option when you launch
Photos to bring up the Choose Library
dialog. From that dialog, you can select
to import any iPhoto or Aperture library.

9
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Import Your Files into Photos
While iCloud can add all the photos you take on your iOS devices to Photos on the
Mac automatically (see Sync with iCloud Using Photos), the traditional way of adding
items to a Photos library is by connecting a device or memory card directly ①. (For
information about importing an entire library into Photos, see Import from iPhoto into
Photos.)

① When you attach a camera or insert a memory card, Photos displays its contents in the Import pane.

Most of this chapter is about importing into Photos on a Mac, but see Importing to
iOS if you want to move your images directly onto an iOS device.

Decide on a Workﬂow

View All Your Image Imports

You’ll need to decide whether to import photos directly into Photos from
your camera (either via USB or by inserting a memory card) or ﬁrst import
them using Apple’s Image Capture
app and then add them to Photos.
If you plan to modify your images in
some way before Photos ingests them,
or if you’d prefer to manually manage
where your ﬁles are stored, you should
use the second approach.

Starting in High Sierra, Photos now
keeps track of your past photo-importing sessions and lets you review all the
photos that were imported at a speciﬁc
time. To view this list, click the Imports
entry in the Library section of the Photos
sidebar. You’ll be able to scroll back
through your photo library, organized
by when the particular photos were imported into the library.
This list doesn’t display photos synced
from iCloud Photo library, just images
that were brought in to your library via
import from a device or a ﬁle on disk.
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Use Multiple Photos Libraries
Most people will probably use a single library with Photos. But if you want to keep
strict separation between different media collections, it’s easy to create multiple
libraries in Photos on the Mac and switch between them ①.

① Two different Photos libraries, with entirely different sets of media.288

Adding a New Library
1. Hold down the Option key as you
open Photos.
2. In the Choose Library dialog that
appears ②, click the Create New
button.
Photos asks you to choose where on
your Mac’s drive you want to save the
new library ﬁle.
② Hold down Option while opening Photos to
see the Choose Library dialog.

Switching Libraries
Hold down the Option key as you open
Photos. In the Choose Library dialog:

Reasons to Have Many Libraries

• If one of the listed libraries is the one
you want to open, select it and click
the Choose Library button.

✦

✦

• To open a Photos library that isn’t
listed, click Other Library.

✦

Note: The Choose Library dialog lists
any importable library it can ﬁnd—the
app actually searches your Mac for
any Photos libraries as well as not-yetimported Aperture and iPhoto libraries.

✦

Create one for each client, if you’re a
freelance photographer.
Keep your work photos separate from
the family stuff.
Let your kids mess with their photos
without trashing your library.
Separate the ﬁles you want to sync to
iCloud from ones you don’t.
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Navigate the Photos Interface
The macOS Photos interface ① is a study in minimalism: most of the action takes
place in a single window, which you navigate through by clicking on items in the
sidebar. (Of course, that approach doesn’t quite translate to the iOS version—see
Navigate Photos for iOS.)

① The main Photos interface features a sidebar on the left; clicking in the Photos view brings up a tab
bar at the top of the window.

Focus on the Sidebar

A Quick View of Selections

In previous versions of Photos, you
could choose to navigate the main interface via a sidebar or a series of tabs
at the top of the screen. Beginning with
High Sierra, the sidebar is mandatory.
Tabs only appear at the top of the
screen in speciﬁc contexts, such as
when Photos is selected in the sidebar,
or when you’re editing an image.

In the top right corner of the Photos window, you’ll see text indicating how many
items are currently selected. You can
drag the thumbnail image to the right of
the text as a proxy of the entire
selection, whether it’s into a different
app or just into a photo album.
Just below the selection indicator is a
ﬁlter interface; click on the text next to
Showing and you can quickly ﬁlter the
view to show only favorites, edited images, photos, or videos.
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Add Info about Your Photos
Apple knows most of us don’t have a lot of time to organize our photo libraries. Even
though Photos deeply analyzes each image to ﬁgure out its contents, it still can’t
divine everything about a photo—at least, not yet. That’s why Photos also contains a
set of simple organizational tools that let you embed additional meaning into the
images you’ve captured ①.

① If I had a favorite view of my photos, it would probably be quite similar to the Favorites view.

Play Favorites
Some of us like to precisely quantify
things. I knew a kid in high school who
actually rated every movie he watched
on a ﬁve-star system. (He grew up to
be a movie critic—true story!) But most
of us can’t be bothered with complex
ratings systems, so Photos uses a simpler approach: Favorites.
In thumbnail views, all your Favorites
appear with little white hearts in their
bottom-left corner ②. Awwww. (There’s
even a subtle drop shadow, so if that
corner of your photo is entirely white,
you can still see the heart.)

② Find the fave: it’s the one with the white
heart in the bottom-left corner.

Instafave!

A view of all your favorite photos appears in the Favorites section of the
Library section of the sidebar. Click Favorites and you’ll see just your very best
shots, as judged by you!421

To make a photo a Favorite on the Mac:
✦

Click the heart
icon located toward the right side of the toolbar ③.

③ Show your love with the heart icon.

Note: If your iPhone uses iCloud Photo
Library, your Favorites will be synced
with the Photos app on the Apple Watch
by default.

✦
✦

✦

✦

Select it and press the Period (.) key.
Hover your pointer over the image
and click the heart.
Select it and choose Image > Add to
Favorites.
In the Info window (press Commandin the upper-right
I), click the heart
corner.
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Add Names to People
Photos performs 11 billion computations on every photo to analyze its contents for
faces, scenes, and objects. But while Photos is good at recognizing faces, it’s terrible
at putting names to those faces. Unless you’ve been diligent about adding everyone
whose picture you take to the Contacts app (complete with a picture that Photos can
use to identify them), you’ll need to do some work in the People view ① (located in
the Library section of the sidebar) to teach Photos who’s who.

① The People view is a catalog of familiar faces, and it’s where you teach Photos who is who.

Find All Photos for a Person

Fix Your Face

The People view contains all the faces
Photos has identiﬁed and connected to
a name. If you want to ﬁnd photos of a
speciﬁc person, this is the place to go—
just double-click an item to see all the
photos that Photos has matched to that
face.

If you don’t like the picture that represents you (or someone else) in the People view, you can ﬁx that:
1. Double-click the face.
2. Scroll down and ﬁnd a better picture.
3. Control-click the image and choose
Make Key Photo.

Having your photos tagged based on
who’s in them is a great organizational
tool. For example, when it’s time to
ﬁnd photos of my family for our holiday
cards and annual calendars, I use a
smart album that displays photos containing all four of our faces (see Deﬁne
Smart Albums in Photos). It’s sobering
to discover that in a full year, you were
photographed with your family fewer
than ten times.

Photos reassigns the default image.
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Use Search to Find Your Photos
All the images in your Photos libraries are scanned millions of times with machinelearning algorithms to identify faces, as well as more than 4000 different scenes or
objects (see Add Names to People for more on face-detection). This makes the
Search feature in Photos incredibly powerful. Want to ﬁnd a photo featuring a dog?
Just type Dog in the search box. The automatically generated Dog category will
provide you with possibilities ①. And that’s just the beginning.

① Photos can do tricks like identify dogs in photos. (Nobody’s perfect, though—it also found a cat.)

The Search Box Is Your Pal

Quickly Jump to Dates

Some people use search boxes habitually. Others see them as a last resort. If
you’re in the latter camp, you need to
break from tradition when you use Photos. The Search feature in Photos is terriﬁc. You can quickly search keywords
②, titles, or descriptions. Enter a year,
or a month and a year, and you see all
the photos taken during that time.

Type a month and year combination
to quickly see all photos taken on that
date. So, for example, I enter August
2004 to see all the images from the
month my son was born.

I rely on the Search feature for navigating my library of more than 70,000 photos, and I highly recommend it. When
in doubt, use the search box!
On the Mac, if you don’t see the search
box in the upper-right corner, back out
to a broader viewing level, such as the
main level of an album.

② Type the name of a location (here, the island
of Kauai) to see all the pictures you took there.

In iOS, if you don’t see the search box,
make sure you are in the main level of
Photos, Memories, or Albums and tap
the Search icon.
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Use Memories to Unearth Old Photos
The Memories view ① builds collections of photos and videos based on a time, place,
or theme, so you don’t have to do the work to gather everything together.

① The Memories pane shows collections of images and videos that Photos thinks you might like.

Located under Library in the sidebar (or
in its own tab on iOS), the Memories
view contains a scrollable list of
rectangles labeled with what they
contain. Memories are organized
automatically by Photos based on a few
different concepts: the recent past
(“Best of Last Month”), this same time in
a previous year (“On This Day”),
locations (“Kauai”), and even themes
(“In Nature”). It may seem a bit
scattershot, but the idea is to help
rediscover photos that you’d never
otherwise revisit.
To begin reliving a Memory, doubleclick any item in the Memories pane.

Take Control of Memories
You can’t edit Memories themselves, but
you can mark them as Favorites.
In macOS, select a Memory and choose
Image > Add to Favorite Memories to
add it to the Favorite Memories tab. To
remove a Memory from the Favorite
Memories tab, select it there and press
the Delete key.
In iOS, scroll down to the bottom of the
Memory to tap Add to Favorite Memories or Remove from Favorite Memories.
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Make Albums in Photos
Just because Apple has put effort into automatically organizing your photos doesn’t
mean you can’t do it yourself if you prefer. After all, there’s only so much nuance a
computer can bring to organizing our photo libraries. You can create your own
collections of items in the Albums section ①.

① Click on the Media Types or My Albums folders for a view of all the items contained inside.

This chapter begins by looking at albums in macOS, and ends with a discussion of
Albums in Photos for iOS.

Find Your Albums

Sorting Your Albums

At the top of the Albums section, you’ll
ﬁnd a folder called Media Types, which
ﬁlters all your items down into media
with special attributes, such as selﬁes,
panoramas, portrait mode, live photos,
videos, screenshots, GIFs, and bursts.
There’s also a My Albums folder, where
you’ll ﬁnd all the albums you’ve
created, manually or via smart albums
(see Deﬁne Smart Albums in Photos).

You can organize your albums by clicking on My Albums and then dragging
Albums around, or by dragging them
around in the sidebar. You can sort
them choosing an option from the
View > Sort submenu. You can sort
them by name or date.
You can also sort the photos contained
in albums; see the sidebar Sorting Photos in Albums, later in this chapter.

Make a New Album
To create a new album, choose File >
New Album (Command-N). If nothing’s
selected, the album will be empty. Otherwise, you’ll get a new album made
from the photos you’ve selected.
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Deﬁne Smart Albums in Photos
Smart albums are a great way to collect items based on their attributes, whether
they’re inherent to the item itself (such as what camera took the picture) or based
on information that you’ve added (such as keywords). Smart albums, which are
available only in the macOS version of Photos, let you slice your library in endlessly
interesting ways ①.

① This smart album displays only images containing the faces of me, my wife, and our kids, as
recognized by Photos. We are really terrible about taking group pictures.

Create a New Smart Album
1. Choose File > New Smart Album
(Command-Option-N).

② The basic Smart Album dialog.

2. In the dialog that appears ②,
name your smart album.

Editing Smart Album Settings

3. Deﬁne the rules of your album as
described ahead in this chapter.

You can always edit the settings of your
smart album later to change or ﬁne-tune
what it searches for:

4. Click OK.

✦

Note: In the Albums pane and the
Albums section of the sidebar, a smart
album always stands out: a small gear
icon appears next to its name or over
its preview thumbnail.

✦

Select a smart album and choose
File > Edit Smart Album.
Control-click the album itself, and
choose Edit Smart Album.
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Sync with iCloud Using Photos
While Photos works ﬁne as a standalone image library, it’s built to connect with
Apple’s online service, iCloud. With iCloud Photo Library, all your devices can view
items stored in a single online library—and add new items to it, giving you access to
every item in your media collection from any device ①.

① Check the iCloud Photo Library box in Photos > Preferences > iCloud to sync with iCloud.

Uploading your library to iCloud adds convenience and a measure of safety to your
photo collection, but there are numerous complications to this process, too.768

Set a System Photo Library

The Cost of Cloud Storage

iCloud syncing will work only with a
single library on your Mac, which Apple
refers to as the System Photo Library.
It’s generally the ﬁrst library that you
opened when you started Photos. You
can have as many libraries as you like
(see Use Multiple Photos Libraries), but
only one can sync to iCloud.

As of this writing, every Apple ID comes
with 5 GB of storage for free. 50 GB of
iCloud space (including not just your
photos but your iOS backups and
iCloud Drive ﬁles) costs $0.99 per
month, 200 GB costs $2.99 per month,
and 2 TB costs $9.99 per month (To
check the latest pricing, see Apple’s
iCloud storage plans and pricing page.)

To change the System Photo Library:

At the high end, that’s a better deal than
Google Drive or Dropbox, which charge
$9.99 and $8.25 respectively per month
for 1 TB. But Amazon now offers unlimited photo storage free for Prime members, and Google Photos offers free unlimited storage space—so long as your
photos are limited to 16 megapixels and
your video ﬁles to 1080p.

1. Hold down the Option key and
launch Photos.
2. Select the library that you want to
sync via iCloud, and click Choose
Library.
3. Choose Photos > Preferences >
General.
4. Click the Use as System Photo
Library button ②.

Turn On iCloud Syncing
iCloud syncing is an all-or-nothing
proposition. To turn it on, choose
Photos > Preferences > iCloud and
select the checkbox next to iCloud
Photo Library. Photos immediately
begins uploading the entire contents
of your library to iCloud.

② Click Use as System Photo Library to make
your currently open library iCloud eligible.
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Make Quick Photo Fixes
Photos has a bunch of simple tools that can improve your images quickly and without
a lot of fuss. Just select an image and press Return (or if you’re viewing a single
image, click the Edit button in the top right) to access the editing tools ①. You can
move between photos with the arrow keys, and click Done to exit the view. (Or, if
you’re working in iOS, see Processing Photos in iOS, at the end of this chapter.)

① The Edit pane consists of a large image preview, tabs, and a strip of controls down the right side.

In this chapter, I focus on the “quick-ﬁx” options. For more advanced editing, see
the next chapter, Make Adjustments to Your Photos.833

Auto Enhance
The ﬁrst thing you should try when
touching up a photo is to click the
icon. You don’t even need
Enhance
to be in Edit mode to click it! Photos
analyzes your image and makes
guesses about the proper levels, color,
and more.

② The Enhance feature tries to improve your
photo (the right one is better than the left), but
it doesn’t overdo it.

Since it’s operated by a computer and
not a human, the Enhance icon won’t
solve every problem. Sometimes it will
make your photo look worse, and other
times it can be a bit too timid ②. But it’s
always worth a try if you’re not conﬁdent using the more advanced features
under the Adjust
icon.

Edit without Fear
You can always go back to your original
image: click the Revert to Original button in the toolbar or choose Image >
Revert to Original. This feature is also
available in the Edit pane. Photos always
stores a copy of your original image.
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Make Adjustments to Your Photos
Basic adjustments of the kind I described in the previous chapter, Make Quick Photo
Fixes, are often all you need to make your photos come to life. But sometimes
you need to take total control over the situation.
Select an image and press Return (or if you’re viewing a single image, click the Edit
button in the top right) to enter the Edit pane, then click to switch to the Adjust
tab. Along the right side you’ll see numerous tools you can use to make your images
look their best ①.

① Exterminate all your images’ ﬂaws with the Adjust tab of the Edit view.

If you’ll be editing in iOS, read this entire chapter to learn the lay of the land and see
Add Adjustments in iOS and Extensions for iOS for iOS-speciﬁc details.

Adjust Your Photos
Down the right side of the Photos window you’ll see 13 different adjustment
controls. When you hover over them,
you’ll see that many of them offer an
Auto button to automatically apply basic adjustments, and an undo arrow
to go back. Click the disclosure triangle
to the left of any item to see the controls that live underneath ②.
② Many adjustment options have a primary
control (visible once you click the disclosure
triangle) made up of component options you
can display by clicking another triangle.
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Share Your Photos
What good are photos if you can’t share them with friends? Traditionally, sharing
photos meant sending prints or binding photos in albums and showing them to other
people. You can still do that, of course—see Make Books, Calendars, and Cards and
Make Photographic Prints—but sometimes you want sharing to be more immediate.
Fortunately, Photos makes it easy to share images quickly over the internet, too ①.

① Sharing an image via Twitter couldn’t be faster or easier. It’ll even suggest usernames for you.

Whether you’re sharing a single photo (see below) or Sharing Multiple Photos with
social media, Photos connects with a variety of third-party services. You can also try
iCloud Photo Sharing, which lets you share an entire album that others can update
and comment on (see Sharing Using iCloud). And, if your desired sharing method
requires that you get your photos out of Photos, you can do that too (see Exporting
and Resizing Images). At the end of the chapter, I discuss Sharing from iOS.

Photo Sharing Methods
• Select a photo, and then choose
File > Share.
• Control-click an image and choose
Share ② from the contextual menu.
• Select a photo, and then click the
Share icon in the toolbar.
In each case, you’ll need to pick how
you want to convey your photos, from
social-networking and photo-sharing
services to more direct transfers.

② You can access the Share menu by Controlclicking a single photo.
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View Photos on an Apple TV
Your living room is a natural place to share photos, and your big high-deﬁnition TV
set can be an excellent canvas for those photos. If you have a fourth-generation
Apple TV or Apple TV 4K connected to your set, you can view your iCloud Photo
Library, as well as Albums and Memories in the Apple TV Photos app ①.

① The Apple TV Photos app gives you access to your iCloud Photo Library, Memories, and albums.1094

Scroll Through Photos
The Photos app on the Apple TV is designed to show off your photos and
videos, not make any edits. The Photos
pane displays the entire contents of
your iCloud Photo Library separated
into Moments, with the newest on top.
To view an image full screen, select the
photo with the Siri Remote and click.
From this view, you can swipe left and
right to move to the next and previous
photos in your library.

② Swipe up on a selected photo to see the
date and time the photo was taken.

Don’t Use iCloud Photo Library?

You can also swipe up to display the
date and time the photo was taken ②.
(For a live photo, it will also play back
the video version of the photo.) Swipe
back down to zoom back to full size.

Photos for Apple TV is really designed
for iCloud Photo Library. If you just want
to share photos from your Mac to your
Apple TV, you can use Home Sharing on
your Mac and the Computers app on
your Apple TV. (See Photos on an Older
Apple TV for info on Home Sharing.)
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Make Slideshows in Photos
I can’t go to a school function without seeing at least one slideshow. Photos provides
seven different slideshow themes ①, and if you’re the type who wants your
slideshows just so, you have a lot of power to control exactly how yours behave.

① The Vintage Prints theme may be my favorite of the Photos slideshow themes.

This chapter begins by talking about the slideshow options in Photos for macOS; for
iOS information, read Make Slideshows in iOS, at the end of the chapter.

Create a Slideshow

Direct Ken Burns

1. Select a group of images, and
choose File > Create > Slideshow.

Some slideshow themes aren’t particularly customizable, beyond the order
of the images and the text. But the Ken
Burns theme, which slowly pans and
zooms across a still image, is.

2. Give your slideshow a name, and
click OK. A new entry appears in
the Projects section of the sidebar.

When Ken Burns is selected in the
icon
Theme Picker, a Ken Burns Effect
appears in the lower-left corner of every
image. Click it and two more buttons
appear:

3. In the slideshow editor that opens,
you can organize the images,
choose a theme and music, and
determine how long your
slideshow lasts, as I describe next.

✦

Choose a Theme

Click the Theme Picker
icon at
the right and then click a theme name.
You can re-order the images in all
themes, but some themes are even
more editable.

✦

Use the In-Point
icon to set how
you’d like your photo to look when
it ﬁrst appears on screen.
Use the Out-Point
icon to set the
appearance of the photos when the
slideshow is about to transition to the
next photo. (Photos will set a default
movement if you don’t customize a
photo’s zoom and pan.)
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Make Books, Calendars, and Cards
On the Mac, Photos lets you create designs with your photos, upload those designs
to Apple’s servers, and then take delivery of custom-printed objects in a few days’
time. My family creates annual calendars, makes souvenir books after trips and other
important life events ①, and, of course, every year there are holiday cards. These
physical products are great ways to keep our photos in view throughout the year,
even when we’re not staring at a device.

① When my father passed away, we scanned in photos from throughout his life and created books to
give to my mother and all of his children. It was a perfect way to honor him.

Create a New Project

Creating Projects Without Apple

Choose File > Create > Book, File >
Create > Calendar, or File > Create >
Card.

Beginning with High Sierra, Apple has
allowed third-party apps to tie right into
Photos for the purposes of making
books, prints, web galleries, and more.

If you have images selected when you
issue that command, they’ll automatically be added to your project. If not,
no worries. You can add photos from
within a project by clicking the Add
Photos button, or by dragging a photo
into a project’s name in the Projects
section of the sidebar.

To use one of these apps, you’ll need to
download them from the Mac App
Store. Choose File > Create > More… to
be taken to these apps in the store.
Once a compatible app has been installed, it will show up in the File > Create list, just beneath the native Photos
options.
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Make Photographic Prints
We lost something when we all converted from ﬁlm to digital photography. Though
viewing photos on our iPhones and TVs is great, for many of us the physical print still
has a lot of power. And let’s not forget that posters are just enormous prints! Photos
hasn’t forgotten the power of prints ①—you can make them at home, using a photo
printer, or order them online and have them shipped to you.

① Apple makes it easy to order prints from Photos, even for nonstandard sizes like panoramas.

Order from Apple

Using Third-Party Services

Apple lets your order prints directly
from within Photos on the Mac. Choose
File > Create > Prints. In addition to
traditional print sizes, it offers square
prints and “auto-sized” prints, which
conform to the aspect ratio of your
image and can be very long—making
them perfect for printing panoramas.
Apple also sells poster prints in two
sizes: 16-by-20 and 20-by-30 inches.

As I mentioned in Creating Projects
Without Apple, you can now use thirdparty services like Shutterﬂy, Whitewall,
and Wix to make books, prints, and
more from within Photos ②.

Once you’ve selected a size, a preview
window shows you what portion of your
image will be printed. If your image’s
aspect ratio doesn’t match that of the
print size, part of it will be cropped.

② The Whitewall extension lets you order a
large-format print with frame from right
within Photos.

You can slide your image around to
get the right crop. If you want to zoom
or add effects, click the Show Options
icon and use the controls in the
Options window.

Now for the bad news. These app extensions don’t provide interfaces that are
up to Apple’s standard. I’d much rather
build a book in Photos than the Shutterﬂy Photo Books app, to be honest. But
at least they’re there if you want to give
them a try.

Note: You can also pinch on your trackpad to change the zoom and crop on
your image.

When you are ready to order, click
Order Prints.
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About This Book
We hope that you found this book both useful and enjoyable to read. We welcome
your comments and questions in individual chapters. You can also send us email.

Ebook Extras
You can access extras related to this
ebook on the web ①.
Once you’re on the ebook’s Take Control Extras page, you can:
• Download any available new version
of the ebook for free, or buy any subsequent edition at a discount.

① After clicking “access extras…,” if you aren’t
logged in to the Take Control site, you’ll see
this dialog. Click the close button in the upperright corner to view Ebook Extras, or log in or
create an account.

• Find out if we have any update plans
for the ebook.
• Read postings to the ebook’s blog.
These may include new information
and tips, as well as links to author
interviews.
• Download various formats, including
PDF, EPUB, and Mobipocket ②.
(Learn about reading on mobile devices on our Device Advice page.)

Registering Your Ebook
If you bought this ebook from the Take
Control website, it has been automatically added to your account, where you
can download it in other formats and
access any future updates.
If you bought this ebook elsewhere,
you can add it to your account:

② Tap a download button (circled in red here)
to get your book in a different format—or to get
a free update, if one is available.

• If you already have a Take Control
account, log in to your account, and
then click the “access extras…” link
in the previous bulleted list.

Note: If you try these directions and ﬁnd
that your device is incompatible with the
Take Control website, contact us.

• If you don’t have a Take Control account, ﬁrst make one by following
the directions that appear when you
click the “access extras…” link above.
Then, once you are logged in to your
new account, add your ebook by
clicking the “access extras…” link a
second time.

71

Click here to buy the full 74-page “Photos: A Take Control Crash Course” for only $10!

About the Author

Jason Snell has been writing about
Apple since it was doomed—1994, to
be exact—and was the lead editor for
Macworld for more than a decade. He
also oversaw editorial operations for
PCWorld, TechHive, and Greenbot.

Acknowledgments
Special thanks to:
✦

He currently writes about technology
at sixcolors.com, and is a columnist for
Macworld. He hosts many podcasts on
the Incomparable and Relay FM
networks, including the award-winning
The Incomparable, Upgrade,
Download, Liftoff, Free Agents, Robot
Or Not, and TV Talk Machine.

✦

✦

Lauren, Jamie, and Julian for putting
up with my extra time working on this
project in the garage.
Kelly, Scholle, Tonya, Adam and Joe
for their hard work in putting the
many editions of this book together.
All the TidBITS, Six Colors, and
podcast readers/listeners for their
thoughtful comments and questions
about Photos that helped shape the
contents of the book.

Jason lives with his wife and two
children in Mill Valley, California.

72

Click here to buy the full 74-page “Photos: A Take Control Crash Course” for only $10!

About the Publisher
alt concepts inc., publisher of Take Control Books, is operated by Joe Kissell and
Morgen Jahnke, who acquired the ebook series from TidBITS Publishing Inc.’s
owners, Adam and Tonya Engst, in May 2017. Joe brings his decades of tech writing
experience to his role as Publisher. Morgen’s professional background is in development work for nonproﬁt organizations, and she employs those skills as Director of
Marketing and Publicity.

More Take Control Books

Credits

This is but one of many Take Control
titles! Most of our books focus on the
Mac, but we also publish titles about iOS,
along with general technology topics.
You can buy Take Control books from the
Take Control online catalog as well as
from venues such as Amazon and the
iBooks Store. But it’s a better user experience and our authors earn more when
you buy directly from us. Just saying…

✦

Publisher: Joe Kissell

✦

Editor: Scholle McFarland

✦

Editor, original editions: Kelly Turner

✦

Cover design: Sam Schick, Neversink

✦

Logo design: Geoff Allen, FUN is OK

Our ebooks are available in three popular
formats: PDF, EPUB, and the Kindle’s
Mobipocket. All are DRM-free.

73

Click here to buy the full 74-page “Photos: A Take Control Crash Course” for only $10!

Copyright and Fine Print
Photos: A Take Control Crash Course
ISBN: 978-1-61542-478-8
Copyright © 2017, The Incomparable Inc. All rights reserved.
alt concepts inc. 4142 Adams Ave. #103-619, San Diego CA 92116, USA
Why Take Control? We designed Take Control electronic books to help readers regain
a measure of control in an oftentimes out-of-control universe. With Take Control, we also
work to streamline the publication process so that information about quickly changing
technical topics can be published while it’s still relevant and accurate.
Our books are DRM-free: This ebook doesn’t use digital rights management in any way
because DRM makes life harder for everyone. So we ask a favor of our readers. If you want to
share your copy of this ebook with a friend, please do so as you would a physical book,
meaning that if your friend uses it regularly, they should buy a copy. Your support makes it
possible for future Take Control ebooks to hit the internet long before you’d ﬁnd the same
information in a printed book. Plus, if you buy the ebook, you’re entitled to any free updates
that become available.
Remember the trees! You have our permission to make a single print copy of this ebook for
personal use, if you must. Please reference this page if a print service refuses to print the
ebook for copyright reasons.
Caveat lector: Although the author and alt concepts inc. have made a reasonable effort
to ensure the accuracy of the information herein, they assume no responsibility for errors or
omissions. The information in this book is distributed “As Is,” without warranty of any kind.
Neither alt concepts inc. nor the author shall be liable to any person or entity for any special,
indirect, incidental, or consequential damages, including without limitation lost revenues or
lost proﬁts, that may result (or that are alleged to result) from the use of these materials. In
other words, use this information at your own risk.
It’s just a name: Many of the designations in this ebook used to distinguish products and
services are claimed as trademarks or service marks. Any trademarks, service marks, product
names, or named features that appear in this title are assumed to be the property of their
respective owners. All product names and services are used in an editorial fashion only, with
no intention of infringement. No such use, or the use of any trade name, is meant to convey
endorsement or other afﬁliation with this title.
We aren’t Apple: This title is an independent publication and has not been authorized,
sponsored, or otherwise approved by Apple Inc. Because of the nature of this title, it uses
terms that are registered trademarks or service marks of Apple Inc. If you’re into that sort of
thing, you can view a complete list of Apple Inc.’s registered trademarks and service marks.

74

Click here to buy the full 74-page “Photos: A Take Control Crash Course” for only $10!

