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Read Me First

Welcome to Take Control of iWeb ‘09, version 1.1, published in
March 2011 by TidBITS Publishing Inc. This book was written by
Steve Sande, edited by Karen Anderson, and published by TidBITS
Publishing Inc.

This book puts you in control of creating and publishing
professional-looking Web sites using iWeb, Web design software
from Apple Inc. It discusses iWeb 3, the version of iWeb that goes
with Apple’s iLife ’'09 and iLife 11 software suites.

Copyright © 2011 Steve Sande. All rights reserved.

If you have an ebook version of this title, please note that if you
want to share it with a friend, we ask that you do so as you would a
physical book: “lend” it for a quick look, but ask your friend to buy
a new copy to read it more carefully or to keep it for reference.

Discounted classroom and Mac user group copies are also available.

Updates and More

You can access extras related to this book on the Web (use the link
in Ebook Extras, near the end of the book; it’s available only to
purchasers). On the ebook’s Take Control Extras page, you can:

» Download any available new version of the ebook for free, or
purchase any subsequent edition at a discount.

* Download various formats, including PDF and—usually—EPUB and
Mobipocket. (Learn about reading this ebook on handheld devices
at http://www.takecontrolbooks.com/device-advice.)

* Read postings to the ebook’s blog. These may include new
information and tips, as well as links to author interviews. At the
top of the blog, you can also see any update plans for the ebook.

* Get a discount when you order a print copy of the ebook.
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iWeb Version '09 vs. Version 3

You’ll see under iWeb > About iWeb that this program is called
iWeb ‘09 in general, and that the latest version number (as of
this writing) is 3.0.3. For the sake of brevity, I refer to it as
“iWeb 3” when I'm talking about this version and call it simply
“iWeb” the rest of the time.

Basics

In reading this book, you may get stuck if you don’t know certain basic
facts about iWeb or if you don’t understand Take Control syntax for
things like working with menus or finding items in the Finder.

Please note the following:

« Path syntax: I occasionally use a path to show the location of a
file or folder in your file system. For example, iLife installs its
component applications, such as iWeb, in the Applications folder.
The path to iWeb is: /Applications/iWeb.

The slash at the start of the path tells you to start from the root level
of the disk. You will also see paths that begin with ~ (tilde), which is
a shortcut for any user’s home directory. For example, if a person
with the user name andrea wants to find her iWeb Domain file, she
would look in the ~/Library/Application Support/iWeb folder,
which is another way of writing /Users/andrea/Library/Application
Support/iWeb.

* Menus: When I describe choosing a command from a menu in
the menu bar, I use an abbreviated description. For example, the
abbreviated description for the menu command that saves a file
from iWeb is “File > Save.”

* Toolbar: I refer to the iWeb toolbar throughout this book. You can
find it at the bottom of the iWeb window, or—if you prefer to use
menus or keyboard shortcuts, check out Table 1, next, which maps
toolbar buttons to menu commands and keyboard shortcuts.
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Table 1: Menu and Keyboard Equivalents for the Toolbar

Toolbar Icon Menu Equivalent Keyboard Equivalent
rl File > New Site Shift-Command-N
Thesie.

v— Insert > Text Box None
Text Box
| —
- Insert > Shape > [list of None
s, shapes]
Shapes
—
B T Format > Unmask / Mask | Shift-Command-M
=
Unmask

Arrange > Rotate Counter | Command-R
) Clockwise
Rotate

View > Show / Hide Media | None

View > Show / Hide Adjust | None

Image

Adjust
—
View > Show / Hide Option-Command-I
0 Inspector
Inspectoe
T —
Q‘ View > Show / Hide Colors | Shift-Command-C
Colors
——
Format > Font > Show / Command-T
A Hide Fonts
Fonts
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What'’s New in Version 1.1

Take Control of iWeb ‘09 version 1.1 was inspired by a desire to clarify
that users of iLife '11 can use this ebook, since the version of iWeb in
both iLife 09 and iLife ’11 is the same. While creating the update, I also
added a few tips to give you more control of this powerful software:

» Finding More Templates lists additional sources for iWeb
templates.

» In Editing One Site on Two Macs, I explain how Dropbox makes it
easier to share a single iWeb domain file between multiple
computers or users.

» Publish to Dropbox shows you how to take advantage of Dropbox
for free or low-cost hosting of iWeb sites.

* In Money, Maps & More I've added information on how to:
» Embed a Keynote Presentation into an iWeb page.

» Localize Your iWeb Site so international visitors can read it in
their native languages.

» Include a Google Calendar on an iWeb page.

» Design for Mobile Devices like the iPhone, iPod touch, and iPad.
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Introduction

In this book, I take you on a journey of discovery. I briefly explore the
past so you can see what a powerful tool iWeb is, and then you can
follow along as I build a Web site step by step using iWeb. You can visit
my iWeb site at http://www.tcoiwebog.com/ and then read about how
I used iWeb to create what you’re viewing.

If you've never made a Web site before, you’ll be thrilled with how
easily you can organize your words and images and have iWeb turn
them into a beautiful work of art. Experienced Web designers will be
happy with the ways iWeb works with the rest of the iLife suite to
create vibrant Web sites full of text, sound, video, and photography.

In iWeb 3—also known as iWeb ’'09—Apple had made significant
improvements in the application to address earlier shortcomings and
make iWeb an even more powerful Web site design and publishing
tool.

In previous editions of this book, I had described a number of
workarounds that allow publishing of your iWeb site to hosts other
than MobileMe. Thanks to a new FTP (file transfer protocol) capability
built into iWeb 3, these workarounds are no longer needed. Similarly,
several other processes I detailed in earlier editions have been
eliminated or streamlined, as Apple has added new or improved
functions.

Although iWeb was left untouched during the release of iLife '11, the
world of iWeb is still moving ahead. In this updated version I provide
you with more hints, tips, and ideas to make iWeb work for you.

Let’s get started!

9
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IVWeb Quick Start

Although you can read this book sequentially, you may wish to take
a custom path through the topics that I cover. You can click the blue
links to jump quickly to a particular topic.

Learn what’s new in iWeb 3:

* Find out how the changes in iWeb 3 help you create Web sites that
are more compelling and powerful that those you could create in
iWeb 2; see What’s New in iWeb 3.

Start your site:

» For historical context, read A Brief History of Making Web Sites.
Then, if you haven’t already, Install iWeb.

» Start a new site! Learn how to Create Your First Site.
* Get the scoop on Editing One Site on Two Macs.

» Ready to take your site live? In Publish Your Site, you’ll find out
how to publish to MobileMe and to other servers, including
Dropbox. Appendix A: Web Hosting provides more detail about
hosting your site on a server that is not MobileMe.

Add links:

* Learn about making links in Create Web Hyperlinks and Create
Other Link Types.

« If image-based links are more your fancy, find more info in Create
Picture Hyperlinks and Make an Image Map.

* Link to content from other Web sites with Add an RSS Feed.
* Get social with your iWeb site. Read Add a Twitter Feed.

Add media:
* Turn your thoughts into bits with Publish a Blog.

» Take your radio or TV show online with Publish a Podcast.

» Add Photos to your site, and learn how to use the iSight Photo
widget, Photo pages, My Albums pages, and MobileMe galleries.

10
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* UseiWeb to Create an Online Movie Theater and add videos from
iMovie and YouTube.

Create special effects:
* Add Special Elements to count visitors and provide an email link.

* Learn how to Make Text Sparkle and discover the fabulous effects
you can create with Shapes, Layers & Masks.

* See Enhance Photos to add cool effects—like Instant Alpha—to your
photos.

» Looking for extra income? Add Google AdSense Ads, get ideas for
how to Run an Online Store, and Increase Traffic to your site.

» Add Google Maps or Include a Google Calendar.

* Add a Form to your site in order to capture information from
visitors.

11
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What’s New in iWeb 3

For those of you who have been using earlier versions of iWeb, here’s a
quick rundown of what’s new or different in iWeb 3:

Publishing improvements: Apple drastically improved the
process for uploading to Web hosts other than MobileMe by adding
FTP capabilities to iWeb. See Use a Third-Party Web Host.

Updated user interface: An improved Media Browser, accessed
on the right side of the iWeb window or via the double-chevron
button at the right side of the toolbar, provides instant access to
your audio, photos, movies, and a larger collection of widgets.

iSight Movie widget: You can make a video podcast with the
iSight Movie widget, assuming you have an iSight camera handy.
See Add an Episode with the iSight Movie Widget.

iSight Photo widget: Would you like to instantly add a picture of
yourself to an iWeb site? You can Use the iSight Photo Widget to do
so without opening any other applications on your Mac.

More new widgets: You can add a Countdown Timer to place a
constantly updating countdown clock on your Web page, while the
new RSS Feed widget adds updates from other Web sites, including
your Twitter feed (read Add an RSS Feed).

Integration with Facebook: You can use integration with
Facebook that lets your Facebook buddies know when you've
updated your iWeb site. To set this up, look for the Facebook option
when you configure the Site Publishing Settings.

Advanced gradient fills: When adding a gradient fill to the
background of a page or object, you have more control over the
type, direction, angle, and color of the fill with the Advanced
Gradient Fill. See Background Fill for details.

Easier layering: If you like to stack items as though you were
piling them up on the Web page, you’ll be pleased with the Bring
to Front and Send to Back commands. To learn more and see
examples, skip to Text Layering and Layers.
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A Brief History of
Making Web Sites

To appreciate just how powerful a Web site development tool iWeb
is, it’s helpful to know a little about what it used to take to create and
publish a Web site.

Beginning in 1991, the World Wide Web made the Internet vastly more
useful and exciting for many people. Anyone with access to a Web
server could put Web pages on the Internet, and anyone with a Web
browser could look at them. Unlike earlier Internet applications, the
Web wasn’t just straight text—Web pages could have colors, pictures,
and other visual elements.

The language of the Web is HTML (Hypertext Markup Language).
Created by Tim Berners-Lee as part of his original specification for the
World Wide Web, HTML is a set of text instructions designed to tell a
Web browser, like Safari or Firefox, where to place text, pictures, links,
and other features on a Web page. (Find out more about Tim Berners-
Lee at http://en.wikipedia.org/wiki/Tim_berners-lee.)

I was so excited by the invention of the Web and HTML, that I quickly
downloaded the original NCSA Mosaic Web browser, visited the few
sites that were available, and made my own Web site. What tool did I
use to set up my original site? SimpleText. That’s right—the same tool
we still use to read those ubiquitous Read Me files that seem to come
with every new piece of software, although it’s now called TextEdit.

SimpleText was a good tool for developing Web sites in those days.
Most sites consisted of a lot of text, hyperlinks to other sites, and had
only a few graphics since most of us were using slow, dial-up modems
to access the Internet. We would type the HTML into a text document
and then view the more graphical result in a Web browser.

Here’s a simplified example of the HTML behind a basic Web page:

<html>
<title>This is an example Web page</title>
<p><b>Welcome to my example Web page.</b><br />
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Install iIWeb

To install iLife ’11, including iWeb, your Macintosh must meet or
exceed the following minimum requirements:

« A Mac with an Intel processor and at least 1 GB of memory
« DVD drive.
« A display with at least 1280-by-768 pixel resolution.

At least 5 GB of available disk space if you want to install all of
iLife ’11. To install only iWeb, 750 MB should be sufficient.

« Mac OS X Leopard 10.6.3 or later.

If your Mac meets the requirements, grab your iLife "11 disc and
follow the directions in this chapter to install the software, make
sure you have the latest version, and launch the software.

Using the iLife ‘09 DVD? The process to install the software from
an iLife ‘09 disc is similar to what is described in the next section.
Although some of the other iLife applications are now available in the
Mac App Store, iWeb is not. Whether that situation might change in
the future or not is unknown.

Run the Installer

Before you install iWeb (or any software), I recommend that you quit
any applications that are already running. I also suggest that you
disable antivirus software, if you have it installed, to avoid possible
conflicts with the installer. Remember to turn it back on once the
installation is completed.

If you've installed other Mac software, you already know how to install
iLife ‘11: Open the box, remove the installation DVD, and place it in the
SuperDrive inside of or attached to your Macintosh. Soon the drive

begins to whir and the DVD contents appear on the screen (Figure 2).

Double-click the iLife ’11 icon to launch the installer.
17
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Create Your First Site

In this chapter, I walk you through the basic steps for doing Web
publishing in iWeb. You can follow along as I create a site, which
I've put on the Web—at http://www.tcoiwebog.com/—so you can
see it in action. You may wish to create a similar sample site, so you
can get some practice. Alternately, you can skim this chapter to
quickly find information about a particular topic.

Create a New Site

The first time you launch iWeb, it either creates a new blank site for
you or opens your existing iWeb Domain file (the file in which your
iWeb sites are saved). Let’s look at both of these scenarios:

» First launch ever: iWeb creates a new blank site for you and
greets you with a Welcome to iWeb 09 dialog (Figure 4).

p—
i
- A
Welcome to iWeb 09

B
The Best way 50 9ot 50 Anow Web 09 is to see & in action { )' l%
. ’ ' . . ds-on Mels

an

‘.’ ul ‘i’[m‘

Ihre P el @bes WY et ot ~

Figure 4: The Welcome to iWeb ‘09 dialog has an introductory video
and links to video tutorials on the Apple Web site. I recommend the
tutorials as a supplement to this book.

Allow iWeb to access your keychain? You may be asked
whether to allow iWeb to use confidential information in your
keychain. If this message appears, click the Allow button.
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Publish Your Site

In this chapter, I help you figure out where to publish your site
(MobileMe or somewhere else) and give you the necessary steps.

Decide Where to Publish

A Web site is nothing if the rest of the world can’t see it. To publish
your site so others can view it, you must copy its files to a Web server,
a computer running Web-serving software that knows how to
communicate with Web browsers. Usually, a Web server has an
always-on connection to the Internet and—ideally—it is situated in

a place where power outages, drive failures, and other problems are
unlikely to occur. A service that provides you with space on a Web
server, and takes care of all the maintenance and technical details of
running a Web server is called a Web host.

From the perspective of an iWeb user, you have three main choices for
your Web host, which I present next in what I consider the most likely
option to the least likely.

Use MobileMe

Apple has made Web publishing easy by integrating iWeb with the
MobileMe service. A site published to MobileMe can be open for the
world to see, or it can be password protected for privacy. The URL to
your Web site can either begin with www.mac.com, or you can host a
personal domain (a registered domain name that you control) on
MobileMe (see Set Up a Personal Domain on MobileMe, later in this
chapter). A downside of publishing to MobileMe is that Apple doesn’t
allow commercial activity on Web sites hosted there (see the Warning
in Run an Online Store to read the rules about commercial activity).

Available for $99 per year, MobileMe provides 20 GB of storage, an
email address, and many other features. If you would like to join, visit
your local Apple Store or see http://www.me.com/. (Joe Kissell’s Take
Control of MobileMe is a valuable source of information on how to
make the most of MobileMe.)
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Work with Text

Even if you include fancy graphics or podcasts on your Web site, the
text is the heart of your site and is worthy of your attention. In this
chapter, I cover a grab bag of techniques that all relate to working
with text: improving its look, avoiding issues with high-ASCII
characters, and creating hyperlinks.

Make Text Sparkle

iWeb’s professionally developed templates are nice, but you may want
to customize the look of your text, perhaps in order to make your page
stand out more. Although I don’t want to overdo it, I'd like to add
pizzazz to my example pages by modifying text colors and styles, and
applying effects such as opacity and rotation.

Fonts

If you have a special headline that needs to stand out, consider using

a different font. Yes, I know I told you earlier not to use too many
different fonts, and that basic rule still applies. However, judicious use
of a special font can definitely change the way your Web page looks. As
an example, I decided to change the text “Steve Sande” on the About
Me page to make it stand out a bit. I selected the text by double-
clicking it, and then clicked the Fonts button on the toolbar. Changing
from the default Helvetica Neue font to plain Helvetica gave me the
slightly bolder look I wanted.

Size

Size matters when it comes to text on Web pages. Headlines and titles
should be larger than body text. To change text size without using the
Font panel, select the text and press Command-Minus to make the text
smaller or Command-Plus to make the text larger. There’s also a slider
in the Font panel you can use to resize text on the fly.
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Shapes, Layers & Masks

In this chapter, I talk about three powerful iWeb features—Shapes,
Layers, and Masks. I touched on the topic of layers with respect to
text objects in Work with Text, but there’s more to the story.

Shapes

In iWeb, shapes are exactly what the name implies, pre-drawn shapes
that you use to add excitement to your Web site. These include lines,
arrows, circles, stars, rectangles, polygons, and even comic speech
balloons. Shapes can behave in three different ways on your page:

» Inline: If you insert a shape just after clicking in a text block when
a text cursor is flashing, the shape goes in the text as an inline
graphic, meaning it behaves just like a regular character.

* Wrapped: You can change an inline graphic so that text in its
paragraph wraps around it.

» Fixed-object: You can drag the object around freely on the page
and place it where you like. Text does not wrap around it.

I discuss each of these options ahead, and I talk about Changing a
Shape (for instance, adding more points to a star) and about Adding
Text to the inside of a shape.

Inline & Wrapped Shapes

Follow along with me as I add an inline shape: First, I set the insertion
point by clicking in the text where I want the shape to go. Next, I
choose a circle from the Shapes pop-up menu on the toolbar. A circle
surrounded by handles appears (Figure 43).
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Publish a Blog

Blog is a contraction of Web log, describing a Web site on which a
writer, or group of writers, posts items on a regular basis focusing
on a specific subject. The items typically include text, images, and
links to other Web sites or Internet resources. Blogs display content
in reverse chronological order, with the latest entries at the top of
the page.

Although we didn’t call them blogs in the early days, blogs have
been on the Web all along. Blogging took off in 2001 with the
emergence of Blogger and other free Web-based blogging services
that made it easy to add new blog entries and keep old entries
organized. Blogging has become a popular means of communication
and has been adopted by the mainstream media, although it is
primarily known as an alternative media capable of affecting
worldwide opinion.

In this chapter, I show you how to be an iWeb blogger.

What's on an iWeb Blog Page?

iWeb’s Blog page type provides most of the elements of a classic blog:

» An overview page, with excerpts of the most recent posts listed in
reverse chronological order

» Detailed blog entries on their own pages
* An archive of past entries that your readers can visit

» Comments with attachments (when the Web site is published to
MobileMe)

* Atool for searching iWeb blogs (MobileMe only)
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Publish a Podcast

What'’s the fastest-growing new media on the planet? Podcasts.
Podcasts, online radio or video shows, are consumed whenever,
wherever, and however the listener desires. A typical podcast has
three features:

« It has a number of episodes, all dealing with a particular subject.

- Listeners can subscribe to a podcast with podcatcher software,
such as iTunes or Juice, to get the latest episode automatically.

- Listeners can enjoy a podcast on a mobile device, such as an
iPod, iPhone, or other MP3 player.

Hundreds of thousands of podcasts are available today on almost
any conceivable topic from “A Bluegrass and Old Time Radio Show”
to “Zolfo Springs, Florida Weather.”

Video podcasts won’t necessarily appeal to people who like to listen
while they do something else, but they do have advantages:

 It’s easier to demonstrate devices or processes when you can
show what you're talking about instead of describing it.

« The combination of sight and sound is much more engaging than
audio alone. Would you rather see bright blue water, sparkling
sand, and swaying palm trees in a travel podcast, or only hear the
podcaster describing them?

In this chapter, I explain how to set up a podcast section on your
iWeb site, and how to add content from GarageBand, the iSight
Movie widget, iMovie, and the Finder. I also include directions for
how to Add an RSS Feed and Add a Twitter Feed.
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Add Photos

Digital photos are great! It’s so easy to take pictures with your
digital camera and transfer them to your Mac, then retouch and
categorize them in iPhoto. With iWeb, it’s straightforward to add a
gallery to your Web site so visitors can read about a vacation trip
and then view pictures from the trip in an animated slideshow.

Here’s a summary of your options:

Insert a single photo: If you just want to add a single photo,
you can do so via the Media Browser or the Finder, but don’t
miss trying the new iSight Photo widget to quickly add a photo
of yourself (I cover the iSight Photo widget ahead shortly).

Photo pages: You can Create a Photo Page to display as many
as 300 photos on the page and offer a nice slideshow option.

My Album pages: These Web pages organize multiple iPhoto
albums on a single page. Once you Set Up a My Albums Page,
viewers of the page can click an iPhoto album’s thumbnail-style
cover image to open a Photo page showing its contents.

MobileMe galleries: You can Work with MobileMe Galleries
in iPhoto and publish them to your MobileMe account. Web
galleries have several nice features for fun and easy viewing of
photos, and you can put an animated, clickable, thumbnail-style
image leading to a gallery on any page in iWeb.

(For advice on enhancing the appearance of your photos using tools
in iWeb, or for details on making them into clickable links, see the
next chapter, Enhance Photos.)

Use the iSight Photo Widget

As you’ve seen earlier in this book, adding photos to an iWeb page is
as easy as dragging one from the Media Browser or Finder, and then
dropping it on the page or a placeholder. But did you know you can
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Enhance Photos

iWeb gives you the power to do more with your online photos. In
this chapter, I describe how to create interesting effects, frames, and
shadows, and even how to use my favorite tool—Instant Alpha—to
eliminate cluttered backgrounds in photos. I also cover how to turn
almost any picture into a clickable hyperlink, in Create Picture
Hyperlinks, and how to Make an Image Map.

The Fine Points of Photo Formatting

Here are my favorite tips for formatting photos in iWeb:

* Removing, adding, or changing reflections: Some iWeb
templates automatically place a reflection under large pictures on
certain pages. You can add, remove, or change reflections on almost
any picture: select the picture, open the Graphic Inspector, and
configure the “Reflection” checkbox and slider. Reflections cannot
be added to photos that represent iPhoto Web galleries.

Reflections aren’t always appropriate. I like them under large single
photos on a page, but they seem distracting and unnecessary on
pages with a lot of text or multiple photos. I tried reflections under
the photos on the Examples page of my Web site and didn’t like
them (Figure 73).

come, readers!

Welcome, readers!| | We
Figure 73: Photos on a Web page without (left) and with (right) a
reflection. Should you use a reflection? You make the call. In this
case, I found the reflection distracting so I removed it.
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Create an Online
Movie Theater

Digital video is becoming much easier to produce, thanks to better
camcorders and software like iMovie. You can share your digital
videos with your Web site visitors by converting the videos to a
Web-friendly, low-bandwidth format, then exporting them to iWeb.
The process is extremely easy, once you've created the digital video.
You can also Add a YouTube Video to your Web page using the
YouTube widget. I discuss both options in this chapter.

(For information about video podcasting, flip back to the Publish a
Podcast chapter, and especially check out the topics relating to
iMovie and to the iSight Movie widget.)

Import from the Finder? You needn’t have a movie in iMovie or
YouTube to include it on an iMovie page. For example, you can drag a
QuickTime movie into an iWeb page from the Finder.

Add an iMovie Video

Once you've shared a movie from iMovie to Apple’s Media Browser,
you can easily import it into other applications that use the Media
Browser, including iWeb.

Here’s how to put your movie in the Media Browser and include it on
an iWeb page:

1. With your edited movie selected in iMovie, choose Share > Media
Browser.

A dialog appears, asking you to select the format(s) for exporting
your movies (Figure 78).
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Money, Maps & More

A Web site can be a drain on your wallet, especially if it grows

so popular that you're charged for bandwidth and space usage
overages. Wouldn't it be nice if you could at least recoup part of
the cost of running your Web site? Perhaps you have a great new
product or service that you want to sell online. With iWeb and a
little ingenuity, you can start selling your goods to the world.

Perhaps you’d like to add a form to your site, either to gather names
or to conduct a survey. Or, maybe you’d like to add a map? I cover
these options and more in this chapter.

Add Google AdSense Ads

Google AdSense is the most prevalent example of an affiliate program.
Affiliate programs provide advertising content to your Web site and
provide a way to make ad revenue for your site. Apple and Google are
close partners, and they’ve worked together to create an easy way for
you to add Google AdSense ads to your iWeb pages.

Here’s how to sign up to show AdSense ads on your iWeb site:
1. Choose File > Set Up Google AdSense.

2. In the resulting dialog (Figure 82), enter your email address and
click Submit. (Or click the I Already Have an Account button.)
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Learn More & Do More

Continue your journey with iWeb by learning more about
MobileMe, podcasting, and Web design. The publications and Web
sites listed here are some of my favorites.

Take Control ebooks:

» Take Control of MobileMe, by Joe Kissell (TidBITS Publishing, $10)

» Take Control of Podcasting on the Mac, by Andy Affleck (TidBITS
Publishing, $10)

Books:

» The Non-Designers Web Book, by Robin Williams & John Tollett,
(Peachpit Press, $39.99)

» Learning Web Design: A Beginner’s Guide to HTML, Graphics, and
Beyond, by Jennifer Niederst Robbins (O’Reilly, $39.95)

* Web Design Garage, by Marc Campbell (Prentice Hall, $34.99)
Web sites:

» Apple’s iWeb Forum
http://discussions.apple.com/forum.jspa?forumID=1309

* Vincent Flanders’s Web Pages That Suck
http://www.webpagesthatsuck.com/
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Appendix A: Web Hosting

The topic of hosting an iWeb site on a server that isn’t run by
MobileMe could rightfully fill another book. However, it wouldn’t
be fair to you to talk about setting up your own Web site without at
least touching on the subject, so this appendix gives an overview of
how to obtain a domain name for your Web site and find a Web host
for it elsewhere than MobileMe.

To get a domain name and host your Web site elsewhere than
MobileMe, follow these steps:

1. Decide at which Web location your site will be reachable. Web-
hosting companies typically offer you one or more of the following
choices for the start of a URL:

» A special path at the hosting company from a domain
they control: This is common for sites provided by your
Internet Hosting Provider. The pattern is usually http://
www.example.com/username/ or http://www.example.com/
“username/.

» A subdomain at the hosting company: A subdomain
prepends a name to the front of a domain name; for instance,
I host Web sites on my Podbus.com hosting service with URLs
like http://mytestsite.podbus.com/.

If you go with either of the above two options, skip to Step 1in
the next set of steps.

» Your own domain: Many hosting companies are happy to
create a virtual Web server for you at a domain name you choose
and register through them or a third party. This virtual Web
server resides on the same computer as dozens or even tens of
thousands of other Web sites, but only responds when its name
is “called” by a browser. For example, my Podbus.com servers
host a number of Web sites, including the one used for the
examples for this book. This type of hosting is usually slightly
more expensive than using a path or a subdomain.
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About This Book

Thank you for purchasing this Take Control book. We hope you find
it both useful and enjoyable to read. We welcome your comments at
tc-comments@tidbits.com.

Ebook Extras

You can access extras related to this ebook on the Web. Once you’re on
the ebook’s Take Control Extras page, you can:

» Download any available new version of the ebook for free, or buy a
subsequent edition at a discount.

» Download various formats, including PDF and—usually—EPUB and
Mobipocket. (Learn about reading this ebook on handheld devices
at http://www.takecontrolbooks.com/device-advice.)

* Read postings to the ebook’s blog. These may include new
information and tips, as well as links to author interviews. At the
top of the blog, you can also see any update plans for the ebook.

* Get a discount when you order a print copy of the ebook.

About the Author

Steve Sande embraces change. After gathering his Bachelor of Science
in Civil Engineering and MBA from the University of Colorado, he
worked as an engineer until falling in love with the Mac in late 1984.
He started a new life as an IT manager and unofficial Mac evangelist,
at one point managing a team supporting over 1,200 Macs.

In 2004, Steve embarked on a new career as a certified Mac
consultant. When he’s not haunting the local Apple Stores, working
with clients, or writing ebooks, he loves to cook, go geocaching, sing,
ride his recumbent bicycle, collect and create art, and attend classical
music concerts. Since 2008, he’s been reporting Apple news on The
Unofficial Apple Weblog (http://www.tuaw.com/), and hosts the
weekly TUAW TV Live streaming video show (http://ustream.tv/
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tuaw/). You can follow Steve on Twitter (http://www.twitter.com/
stevensande/).

Steve lives in Highlands Ranch, Colorado, with Barb—his wife, who
really is a rocket scientist—and his tortoiseshell cat, Ruby.

A
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Author’s Acknowledgments

I'd like to thank several people for their support during the creation of
this book:

» Barb Sande, my wonderful wife, for putting up with me typing
away on my computer at all hours of the day.

* Tonya Engst, for being such an unbelievably patient, hard
working, and understanding editor-in-chief.

« Karen Anderson, for taking on the daunting task of editing this
book and being patient with a person who is notoriously slow at
creating updates.

« Doug McLean, for his sharp eyes and unfailing logic in pointing
out sections of the book that needed work.

About the Publisher

Publishers Adam and Tonya Engst have been creating Apple-related
content since they started the online newsletter TidBITS, in 1990. In
TidBITS, you can find the latest Apple news, plus read reviews,
opinions, and more (http://www.tidbits.com/). Adam and Tonya are
known in the Apple world as writers, editors, and speakers. They are
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also parents to Tristan, who thinks ebooks about clipper ships and
castles would be cool.
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Take Control electronic books help readers regain a measure of control in an oftentimes
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www.apple.com/legal/trademark/appletmlist.html.
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Featured Titles

Click any book title below or visit our Web catalog to add more
ebooks to your Take Control collection!

Take Control of Easy Mac Backups (Joe Kissell): Devise a rock-solid
backup strategy so you can restore quickly and completely, no matter
what the catastrophe. $10

Take Control of Maintaining Your Mac (Joe Kissell): Find a
commonsense approach to avoiding problems and ensuring that your
Mac runs at peak performance. $10

Take Control of Passwords in Mac OS X (Joe Kissell): Create and
manage strong passwords that keep your data safe without taxing your
memory! $10

Take Control of Users & Accounts in Snow Leopard (Kirk McElhearn):
Find straightforward explanations of how to create, manage, and work
with—and among—user accounts. $10

Take Control of Safari 5 (Sharon Zardetto): Make the most of Apple's
Safari, a Mac Web browser with many hidden and under-appreciated
talents! $10

Take Control of iTunes 10: The FAQ (Kirk McElhearn): This FAQ-style
ebook helps you wrap iTunes around your little finger and enjoy your
media more. $10

Take Control of Screen Sharing in Snow Leopard (Glenn Fleishman).
Figure out which type of screen sharing to use when and how to get the
most out of screen sharing. $10

Take Control of Your Paperless Office (Joe Kissell): With your Mac,
scanner, and this ebook in hand, you’ll finally clear the chaos of an
office overflowing with paper. $10

Take Control of MobileMe (Joe Kissell): This ebook helps you make
the most of the oodles of features provided by a $99-per-year
MobileMe subscription. $10
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