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Read Me First 
 
Welcome to Take Control of Safari 4, version 1.0, published in June 
2009 by TidBITS Publishing Inc. This book was written by Sharon 
Zardetto and edited by Tonya Engst. 

This book shows you how to make the most of Safari, a deceptively 
powerful Web browser with features you may have never even tried. 
Although it focuses on Safari 4, well over 80 percent of its informa-
tion applies to Safari 3, too. 

Copyright © 2009, Sharon Zardetto. All rights reserved. 

If you have the ebook version of this title, please note that if you 
want to share it with a friend, we ask that you do so as you would a 
physical book: “lend” it for a quick look, but ask your friend to buy 
a new copy to read it more carefully or to keep it for reference. You 
can click here to give your friend a discount coupon. Discounted 
classroom and Mac user group copies are also available. 

UPDATES 
We may offer free minor updates to this book. To read any available 
new information, click the Check for Updates link on the cover, or click 
here. On the resulting Web page, you can also sign up to be notified of 
major updates via email. If you own only the print version of the book 
or have some other version where the Check for Updates link doesn’t 
work, contact us at tc-comments@tidbits.com to obtain the PDF. 

BASICS 
There are only a few basic items you need to know to make your 
“reading experience” smoother: 

• Menu references: The general “shorthand” description to refer 
to choosing something from a menu is, for instance, File > Open. 
Occasionally a command’s name changes partially to match its 
context; I describe these commands with an obvious placeholder 
such as File > Sync TheDevice. 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!
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• Path names: The route you take to a file on your hard drive, 
whether by looking through columns in a window or by double-
clicking your way through folders, is the file’s path, and there’s 
a standard “syntax” for referring to these paths. 

The disk’s name is always the first thing in a path; we assume the 
disk is always there, so we don’t include its name, but we preserve 
the slash that would separate it from the next item. So, HardDrive/ 
System/Library becomes /System/Library. 

A path to something in a user’s home directory starts with the 
drive’s name, followed by Users and then the user’s name. The con-
vention, however, is to replace those first three items with ~ (tilde), 
so HardDrive/Users/Miriam/Library becomes simply ~/Library. 
(You’ve probably noticed by now that path text is formatted in 
special type.) 

• System Preferences: To work with System Preferences, choose 
System Preferences from the  menu and in the window that opens, 
click the icon for the settings you want to adjust. I describe this pro-
cedure simply as, for instance, “Open the Parental Controls prefer-
ence pane” or “In System Preferences, open Parental Controls.” 

• Safari Preferences: Applications have their own preferences, 
separate from System Preferences. In Safari, choose Safari > 
Preferences (Command-Comma), then access a specific group of 
preferences—such as General, Bookmarks, or RSS—by clicking its 
icon at the top of the preferences window. 

• Contextual menus: When I refer to accessing a contextual menu, 
I usually write “Control-click on [whatever] for the contextual 
menu…”. This is a little ironic since I never Control-click—my main 
computer is a laptop, and I use a two-finger tap for a contextual 
menu. You might do the same, or you may be using a mouse that’s 
programmed to open a contextual menu with a right-click. When-
ever you read “Control-click” or “right-click,” use whatever method 
you like to open a contextual menu. 

Tip: After you click a link to jump to a different spot in this book, 
you can return to where you were by using Go > Back (Command-
[) in Preview, or View > Go To > Previous Page (Command-Left 
arrow) in Acrobat. 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!
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Introduction 
 

 
Why do you need a book about Safari? You’ve been using Safari for 
seeming eons, and you’re doing just fine. 

But you don’t have to settle for “fine.” In all likelihood, Safari does 
more than you’ve been asking it to, and those things you have been 
doing with it can be done more quickly, elegantly, and efficiently when 
you know Safari’s ins and outs. I can vouch for that because when 
Safari 4’s beta version was released, I vowed to finally, finally, explore 
Safari thoroughly, in order to find the best way to organize bookmarks, 
give it another chance as an RSS reader, learn about tab options 
instead of using them in the most obvious way—oh, and deal with the 
pesky issue of having dismissed the offer to save a password for a site 
and never again being asked to do so. 

The fact that Safari 4 offered some new features was both the impetus 
for the exploration and the icing on the cake: the nifty Top Sites view, 
“smart” address and search fields, searching the content of history and 
other bookmarked pages—this time I planned to get ahead of the curve 
by learning how to make the most of Safari. 

And, now that I’ve devoted all that time to it, you don’t have to! You 
won’t have to learn bits and pieces from various sources, experiment 
on your own, or click your way through the not-exceptionally-helpful 
Help system to put together disconnected tidbits of information. 

Whether you have been using Safari 4 or are about to upgrade to it, 
this book is for you. If you plan to stay in Safari 3 for quite some time, 
this book is still for you: at least 80-85 percent of what’s covered here 
also exists in Safari 3. (Check What’s New in Safari 4 to find out what 
doesn’t apply its predecessor.) 

No matter how you use Safari now—for lightweight general surfing, or 
middleweight targeted browsing with a pile (probably a disorganized 
pile) of bookmarks, this book will take you to the heavyweight division, 
with toned tabs, a buffed bookmarks bar, total control over RSS feeds, 
and more. 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!
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Safari 4 Quick Start 
 
The material in this book is the least linear of any Mac book I’ve 
ever written: there are few interdependencies among the topics, 
so you can start with any one that piques your interest or is likely to 
answer the burning questions you have about using Safari—whether 
they’re of longstanding duration or specifically about Safari 4. 
Luckily, ebook links lend themselves to just that sort of approach! 

On the other hand, if you don’t want to accidentally miss anything, 
just follow the advice given to Alice: “Just start at the beginning, and 
when you get to the end… stop.” 

 

Download and install Safari 4: 
• If you haven’t moved to Safari 4 yet, Appendix B: Update to Safari 4 

(p. 85) shows you how easy it is to do so, and discusses the system 
requirements for the upgrade. 

Check out Safari 4’s new features: 
• If you want to hit the highlights of new features, use the links in 

What’s New in Safari 4 (p. 9). 

Customize your experience: 
• From top (the toolbar) to bottom (the status bar), you can tweak 

Safari’s looks and behavior. See Customize Your Safari Environ-
ment (p. 10) and Organize the Bookmarks Bar (p. 47).  

• Set your Safari preferences. Its various preference panes are 
covered in their topic areas, such as Know Your Link-Opening 
Options (p. 28), Turn on AutoFill Sources (p. 64), Set the Download 
Preferences (p. 70), and Set Your RSS Preferences (p. 73). 

Learn key browsing techniques: 
• You know the basics, but learn their details in Navigate to and 

within Web Sites (p. 17), Track Your Downloads (p. 70), Use 
AutoFill for Forms and Passwords (p. 64), and Scan Site Highlights 
with RSS Feeds (p. 73). 

• Juggle multiple sites with finesse by learning how to Handle 
Multiple Pages with Window Tabs (p. 28).  

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!
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• Read about the differences in the ways your previously visited Web 
sites are stored automatically or manually in Go Back to Where 
You’ve Been (p. 19). Explore the details for each of the methods 
in Manage Your Top Sites (p. 24), Set Up and Use Bookmarks 
(p. 34), and Retrace Your Steps through History (p. 52). 

• Protect your privacy: Store and Edit Your Passwords (p. 66), and 
learn about Stealth Browsing (p. 54) and how to Erase All Your 
Tracks (p. 55). 

• Optimize your search techniques in various areas with Use the 
Google Search Field (p. 56), Search within a Page (p. 59), and 
Search Your History and Bookmarks (p. 61). 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!
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What’s New in Safari 4 
 
Many of Safari 4’s new features are background improvements—
such as increased page-loading speed and support for the CSS 
Effects standard—that can enhance your browsing experience but 
don’t require any action (or learning) on your part. 

From a user’s point of view, Safari 4 is so similar to its predecessor 
that you can transition to it with neither fuss nor muss. Yet it does 
offer new features that, if not revolutionary, are evolutionary in 
Safari’s development. 

 
The new features: 

• The flashiest new feature, Top Sites—which turns out to be some 
steak as well as sizzle—is covered in Manage Your Top Sites (p. 24). 
On the opposite end of the flash spectrum is the extremely useful 
new full-page zoom described in Supersize Me (p. 16). 

• “Smart…field” is a Safari 4 buzz phrase. Use the Address Field 
(p. 17) covers the smart address field, while Use the Google Search 
Field (p. 56) describes the smart search field and The Search 
Snapback (p. 57). 

• “Full…search” is another buzz phrase. The Finder’s iTunes-inspired 
Cover Flow view has spread to Safari for reviewing your bookmarks 
and history (Figure 12, p. 36; Figure 18, p. 53). Both can now 
be searched not just by URLs or page titles, but also by the page 
content. Search Your History and Bookmarks (p. 61) covers this 
incredibly convenient improvement. 

• Safari 4’s tab bar has a few subtle changes, covered in Take the Tab 
Tour (p. 30). 

 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!
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Customize Your  
Safari Environment 
 
From top (the toolbar and bookmarks bar) to bottom (the status 
bar), and several things in between (such as starting pages), you 
have some choices as to how Safari’s window looks and behaves. 
In this section, I walk you through the most important basic cus-
tomizations that you should do when you start using Safari. I cover 
many other customization options throughout this ebook. 

DO BASIC SETUP FOR THE “BARS” 
The top of the Safari window has, of course, the title bar, and it also 
accommodates tabs, the toolbar, and the bookmarks bar; at the bottom 
is the lowly status bar.  

Except for the title bar, you can make the bars come and go as you 
please: use the Hide/Show commands in the View menu. On a big 
screen, there’s no reason to turn them off; on a laptop, however, you 
can get an extra 4–6 lines of text in the window when you turn off all 
of them. 

Toolbar 
The Safari 4 toolbar has nearly twice as many customization options 
as did its predecessor, but add them sparingly because a too-crowded 
toolbar cuts down on the size of the address and search fields, especi-
ally when you work with less-than-full-width windows. (Truth be told, 
the buttons aren’t all that handy; most have convenient keyboard and 
menu equivalents, as shown in Table 1, next page.)  

To change the toolbar: 

1. Choose View > Customize Toolbar to open the Customize dialog. 

2. With the Customize dialog open, drag items onto or off the toolbar. 

3. Reorder items as desired by dragging them to new spots. (You can’t 
separate the address and search fields; buttons must go to their 
combined left or right.) 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!
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Navigate to and  
within Web Sites 
 
In life, the journey may be the reward, but when you’re surfing the 
Web, it’s the destination that counts. In this section I explain how to 
get there quickly and move among various “theres” with a minimum 
of effort. 

USE THE ADDRESS FIELD 
Typing a URL (Universal Resource Locator, a Web site’s “address”) 
into Safari’s address field and pressing Enter takes you directly to that 
page. It’s not necessarily a quick route, depending on your typing 
skills, but it’s direct. 

Tip: To activate the address field from the keyboard—since you’re 
going to type anyway—use Command-L, the shortcut for File > 
Open Location. (So that’s what that command means!) 

If Safari recognizes what you’re typing, it lists the most likely matches 
(Figure 4); to go to a suggested site, click on one, or use the Up and 
Down arrow keys to select one and then press Enter. Safari also pro-
poses destinations based on your bookmarks. 

 
Figure 4: Typing in the address field (only app was typed for this 
picture) fills in the rest of the address that Safari thinks you want, 
which is also identified as the Top Hit. 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!
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Manage Your Top Sites 
 
Safari 4 is Big Brother-ish in a good way: it keeps track of where 
you’ve been, and how often and how recently you’ve been there, and 
cleverly calculates a Top Sites list stripped of such distractions as 
sign-in pages and multiple pages from the same site. 

The presentation of Top Sites can be deceiving: more than just eye 
candy, it provides a way to scan multiple, identifiable thumbnails in 
an instant—you’ll wish you could view your bookmarks and history 
in the same way. 

TOP SITES BASICS 
Go to your Top Sites by choosing View > Top Sites (Command-Shift-1) 
or by clicking the Top Sites button ( ) in the bookmarks bar. The 
sites are displayed in a curved gallery of thumbnails; pages whose 
content has changed since you last visited are flagged with a can’t-miss 
white star on a blue background (Figure 6). Go to a page by clicking 
on its thumbnail; it expands to fill the screen, but is slightly dimmed 
until it’s updated from the site. 

No Top Sites button? Add the button to the bookmarks bar through 
Safari’s Bookmark preference pane; check Include Top Sites.  

Tip: The search field in Top Sites searches through your History, 
not just the Top Sites, but it’s better to start elsewhere for that 
search; see Search Your History and Bookmarks. 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!
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Handle Multiple  
Pages with Tabs 
 
I’m always surprised at the number of users who disdain to use tabs 
because they assume the feature is a useless add-on. But window 
tabs are possibly the best thing since sliced bread; come to think of 
it, they’re sort of like sliced window. 

Tabs let you keep multiple Web pages open in a single window; this 
is especially useful on a laptop with limited screen real estate, but it 
keeps window juggling to a minimum on any screen. And they pro-
vide a convenient organizational tool: you can, for instance, have 
several windows open, each with a subset of related Web pages in 
tabs, when you’re researching a topic—whether the topic is global 
warming or which wireless, Bluetooth speaker you should order 
from Amazon.com. 

KNOW YOUR LINK-OPENING OPTIONS 
Before browser-window tabs were invented, a Command-click on a 
link opened it into a new window, as an alternative to the plain click 
that changed the current window’s contents. Power users, and lots of 
normal people, loved this feature; now, however, with the ubiquitous 
availability of tabs, Command-clicking a link opens it in a new tab. 

But Safari’s Tabs preferences let you set the Command-click shortcut 
to open a link in a new window or a new tab. You can also change the 
default of new tabs and windows opening in the background instead 
of as the active page. I suggest you leave all the default settings, but 
no matter which you choose, learn the keyboard modifiers that let 
you temporarily override the defaults: 

• Use Option to change the window/tab default: If Command-
click opens a tab, Command-Option-click opens a window, and vice 
versa. 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!
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Set Up and Use Bookmarks 
 
Bookmarks are, at heart, simple things: pointers to pages you 
want to revisit. But their flexibility—the different ways you can 
store and access them, how they interact with tabs—make them 
far from simple tools.  

I used to keep very few bookmarks on my bookmarks bar, and 
most of the rest in what amounted to a big pile (nothing in folders 
or subfolders), with little or no renaming of my bookmarks from 
their default, often long-winded, titles. I bookmarked a lot of sites, 
yet rarely used the bookmarks to go back to them because the lack 
of organization made it too much of a bother. 

Once I started exploring bookmark options and discovered their 
versatility and power, however, I was converted—and now I’m pros-
elytizing. Knowing how convenient bookmarks make my browsing 
has encouraged me to become, and stay, organized—a philosophy 
I have yet to apply to my closets. Naming a bookmark and putting 
it in a certain folder when I first save it has become second nature 
in a very short time. (I still have a catch-all bookmark folder for 
when I’m in a hurry or don’t know exactly where something should 
go—just like I have a junk drawer in the kitchen. And in the dining 
room. And in almost every other room.) 

FLAG FAVORITES WITH BOOKMARKS 
No matter how you want to access a bookmarked page later, you start 
the same way: 

1. While on the page you want bookmarked, choose Bookmarks > Add 
Bookmark (Command-D), or click the Add Bookmark button ( ) in 
front of the address field. 

2. Name the bookmark in the slide-out dialog (Figure 11). 

The default name is that of the page; it’s often too generic and too 
long to be useful as the bookmark title. Keep bookmark names short 
but clear, and extra-short if you’re putting them on the bookmarks 
bar (“WikiP” for Wikipedia, for instance). 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!
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Retrace Your Steps 
through History 
 
Even if you don’t recall where you’ve been on the Web, Safari does, 
and it provides a myriad of ways for you to return to any site you’ve 
seen in… well, up to almost forever, although that can make for a 
ridiculously large, and therefore largely useless, list of visited pages. 

A BRIEF HISTORY LESSON 
Your surfing history is tracked by a series of bookmarks—one for every 
page you view (yes, every page, not every site!). These history book-
marks are divided into subsets for each day and are available from: 

• The History menu: A generous handful of “Today’s” recent sites 
are listed individually for convenience, with the rest stuffed into an 
Earlier Today submenu. The menu includes additional submenus 
for previous days. 

• The Bookmarks window: The History collection shows a single 
subcollection for the current day, and one for every previous day up 
to the limit you’ve set in Safari Preferences (Figure 18). You can 
delete individual bookmarks or entire folders from the History 
collection, but you can’t reorganize or rename them as you can 
other bookmarks and folders.  

Open the Bookmarks window by choosing either History > Show All 
History (inconveniently situated way at the bottom of the menu, 
without a keyboard shortcut) or Bookmarks > Show All Bookmarks 
(at the top of the menu, and with a Command-Option-B shortcut). 
The only, very small, price you pay for the latter option is having to 
click on the History collection when the bookmarks list opens. 

Set the limit for the number of days included in your history in the 
General pane of Safari Preferences, with the Remove History Items 
menu. (The “Manual” option means Safari won’t ever erase a history 
bookmark, but if you choose a time limit you can still get rid of selected 
bookmarks manually.) 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!

http://store.eSellerate.net/s.asp?s=STR5625274989&Cmd=BUY&SKURefnum=SKU39016495850&PT=TRK-0083-SAMPLE


56 

Know Your Search Options 
 
Safari offers three distinct types of searching: across the vast Web, 
within the currently displayed Web page, and through the titles and 
content of your browsing history and bookmarks. 

USE THE GOOGLE SEARCH FIELD 
At its core, the Google search field hasn’t changed between Safari 3 and 
4: you can use it the same way you always have—with, perhaps, some 
honed techniques you’ll learn here. But Safari 4 has added two new 
features: the drop-down list and the SnapBack button. 

The Drop-Down List 
Start typing in the Google field in the Safari toolbar, and a drop-down 
menu appears, with ten suggested completions (Figure 19).  

 
Figure 19: The Google drop-down menu (shortened in this picture) 
provides ten suggestions that change as you continue typing in the 
field, and a list of your last ten search terms. If your search term 
appears on the current Web page, the bottom of the menu lets you 
know how many occurrences there are; selecting this Find command 
opens the Find banner (see Search within a Page). 

Tip: Clear the contents of the search field quickly so you can start 
again by clicking the Cancel button ( ), or by pressing Esc or 
Command-Period. 
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Use AutoFill for  
Forms and Passwords 
 
Safari’s AutoFill feature helps fill in the blanks on Web pages—for 
forms and even user name and password information. It uses infor-
mation from the sources you’ve allowed, and it can fill in fields on a 
Web page one at a time or in one fell swoop. 

TURN ON AUTOFILL SOURCES 
Safari can gather form-filling information from three sources, but you 
have to tell it which ones it’s allowed to use: 

1. Open Safari Preferences and click AutoFill (Figure 23). 

 
Figure 23: The Edit buttons in AutoFill are somewhat misleading: 
only the first lets you edit information, by opening your card in 
Address Book. The other two open lists for which your only editing 
option is deleting entries. 

2. For the most complete AutoFill behavior, check all the choices: 

• Using info from my Address Book card: Your “me” card in 
Address Book can store the frequently asked-for basics of name, 
address, phone, and email. 

This card should have been automatically created as part of your 
Mac OS X setup. Look in Address Book (it’s in your Applications 
folder) for a card with your name on it, and a small white-on-
gray “me” stamp in the lower left corner of your account icon at 
the top of the card. If there’s no “me” card, make a new card, fill 
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Track Your Downloads 
 
Most of us don’t give a second thought to downloads: click a link, 
download, perhaps have it auto-open, and move on. A little atten-
tion to the details, however, never hurts—and might help. 

SET THE DOWNLOAD PREFERENCES 
There are three download-related items in the General pane of Safari 
Preferences (Figure 25). 

 
Figure 25: Default (and also recommended) settings for download-
related items in Safari Preferences. 

These options are best left at their defaults: 

• Save downloaded files to: The default Downloads folder is the 
logical place; the only reason to change the download location is to 
prevent the commingling of Web downloads and email attachments 
from Apple Mail, both of which use this folder as a default—but I 
recommend changing Mail’s download folder instead. (Do you think 
of email attachments as “downloads”?) 

Tip: Keep your Downloads folder in the Dock: it bounces once 
when a download is complete—a nice little alert—and you can 
use the Grid view to see downloaded items conveniently sorted 
by Date Added. (Control-click on the Downloads Dock icon for 
its contextual menu, and choose Grid; open the contextual menu 
again, and choose Date Added.) 
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Scan Site Highlights  
with RSS Feeds 
 
An RSS (“Really Simple Syndication”) feed lets you check out a Web 
site’s contents the way you might scan newspaper headlines, quickly 
deciding which information you want to read in depth—if the site’s 
designer has included RSS capabilities. 

Most RSS feeds offer the first few lines or a hand-tooled synopsis 
of an item, with a MORE link to get you to the full version; some 
include the full text of each article. In both cases, however, you get 
a series of text-based information without the rest of the Web site—
with its graphics, buttons, and links (and ads). 

In Safari, you can view RSS feeds whenever you’re on a site that 
offers them, or store your favorite sources as bookmarks so you can 
return to them for frequent updates. 

SET YOUR RSS PREFERENCES 
Safari offers quite a few preferences in regard to how RSS feeds are 
handled, so start with a visit to the RSS options in Safari > Preferences: 

• Default RSS reader: If you’re new to reading RSS feeds, leave 
Safari as the default in this menu until you get your bearings (and 
perhaps even afterward, when your RSS reading habits are more 
easily identified). If you Use Mail as Your RSS Reader, choose it 
from this menu; for Other RSS Readers, choose Other and then 
select your reader. 

Your choice of a default reader affects Safari’s response when you 
access an RSS feed, whether you click a button in the address field 
or select one from a folder you’ve placed on the bookmarks bar. 

This book defaults to Safari! The information throughout this 
“Scan Site Highlights with RSS Feeds” section assumes you’ve set 
Safari as your default RSS reader—with the exception, of course, 
of “Use Mail as Your RSS Reader.” 
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Appendix A:  
Create a Web-Clip Widget 
 
If you use Dashboard a lot, you’ll find it convenient to have a Web 
page snippet, or “clip,” as a widget for quick reference, whether it’s 
tomorrow’s weather, today’s stocks, or something like a joke-of-the-
day. (Don’t use Dashboard? Don’t know what it is? It’s an 
application, on your Dock by default but also in your Applications 
folder, that displays a bunch of tiny applications, called widgets, 
that do everything from tracking the weather to checking what’s in 
your local movie theaters to—of course—letting you play games.) 

 
To create a widget from part of a Web page: 

1. Go to the Web page you want to clip. 

2. Choose File > Open in Dashboard, or click the Open in Dashboard 
button if it’s on your toolbar.  

The Web page dims and a large bright patch follows your cursor 
around (Figure 36). 

3. Move the cursor to the spot on the page that you want to clip; the 
bright rectangle resizes to fit each article as you pass over it. 

Not everything can be clipped: “Clippability” depends on the 
Web page design; the rectangle resizes itself only over clippable 
articles or graphics. 

4. Click on the article to select it. 

5. Resize the clipped area if necessary to make it larger or smaller 
(Figure 37). 

6. Click the Add button at the right of the purple bar that appeared at 
the top of the window when the page dimmed. Dashboard opens 
with the clipped area of the page as a standalone widget. 

7. Move the cursor to the bottom right of the new clip widget to make 
the Info button ( ) appear, and click it. 

Click here to buy the full 92-page “Take Control of Safari 4” for only $10!

http://store.eSellerate.net/s.asp?s=STR5625274989&Cmd=BUY&SKURefnum=SKU39016495850&PT=TRK-0083-SAMPLE


85 

Appendix B:  
Update to Safari 4 
 
Updating from Safari 3 to Safari 4 is a cinch, but you can’t use 
Safari 4 unless you also have the correct version of Tiger (Mac OS X 
10.4.x) or Leopard (Mac OS X 10.5.x). The Mac’s built-in Software 
Update feature can take care of everything for you. 

Automatic software updating is controlled by the Software Update 
preference pane, where you can set how often the Mac checks for 
updates and whether downloading them happens automatically or 
waits for your approval. So, depending on your settings, your Mac 
may have already guided you through the download, and even the 
installation, of your required system updates and Safari 4. 

If your settings are such that you manually check for and download 
updates (and you’ve avoided some of them), this section tells you 
how you to upgrade to Safari 4. 

SYSTEM REQUIREMENTS 
The Mac won’t install Safari 4 unless your system software is updated 
to accommodate it. There are minimum Mac OS X requirements as 
well as a Security Update requirement if you’re still running Tiger: 

• Mac OS X versions: For Leopard (systems beginning with 10.5), 
you need at least 10.5.7; for Tiger (systems beginning with 10.4), 
you need 10.4.11, the last official Tiger release. 

• Security Update 2009-002: This system-software update 
is required for Tiger systems.  

If you’re behind the curve on your version of Mac OS X, set aside a 
goodly chunk of time for updating: the combination of download time, 
installation, restarting—and then perhaps needing to update other 
software to get along with the system update—can take several hours. 
If all you need is the Tiger Security Update, the time you need is 
minimal, though dependent on your connection speed. 
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About This Book 
 
Thank you for purchasing this Take Control book. We hope you find 
it both useful and enjoyable to read. We welcome your comments at 
tc-comments@tidbits.com. Keep reading in this section to learn 
more about the author, the Take Control series, and the publisher. 

ABOUT THE AUTHOR 
It’s hard to believe that I’ve been writing about computers since before 
the Mac was born. There were personal computers before the Mac? Ah, 
yes, my first: the Timex-Sinclair with its 2K of RAM (that’s not a typo, 
and it was a thrill when the 16K RAM pack became available) and 
cassette-tape storage. Good old days? Not by a long shot! 

But I’ve been writing about the Mac since it arrived on the scene—
hundreds of print articles, twenty or so (paper) books, and now 
electronic-based dissemination of Mac info—and haven’t tired of it 
yet (and I tend to become bored rather easily).  

In addition to a university-professor husband whose Macophilia rivals 
my own, I have two grown sons currently temporarily back in the all-
too-briefly emptied nest—although I’m not sure how they coordinated 
moving back the exact same week. We live in New Jersey, just a few 
miles outside of Manhattan (a statement I add for the comfort of my 
New-York-born-and-raised husband). 

AUTHOR’S ACKNOWLEDGMENTS 
The usual thanks to the Control Freaks and Irregulars for reading 
through and commenting on the beta manuscript. In addition, thanks 
to Rich Wolfson, who’s been beta-reading my stuff for nigh unto 20 
years now; to Jerry Szubin; and especially to Jerry’s partner, Andrew 
Bagge, who finally switched from the Dark Side to a Mac and was 
therefore an especially handy guinea pig—I mean, reader—for the 
initial version of this book. 
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Thanks also to Adam Engst in general, but to Tonya Engst in particular 
as editor of this book; she’s always a pleasure to work with. 

SHAMELESS PLUG 
My other Take Control books are Take Control of Fonts in Leopard, 
Take Control of Font Problems in Leopard, and Take Control: The 
Mac OS X Lexicon. When it comes to ebooks, the topics I want to write 
about that don’t fit in the Take Control line go to my one-woman show 
at http://33thingsbooks.com/; odds and ends wind up in my blog at 
http://mactipster.wordpress.com/, and what little is left of my life can 
be followed on Twitter, where I’m cleverly named SharonZardetto. 

ABOUT THE PUBLISHER 
Publishers Adam and Tonya Engst have been 
creating Macintosh-related content since they 
started the online newsletter TidBITS, in 1990. 
In TidBITS, you can find the latest Macintosh 
news, plus read reviews, opinions, and more 
(http://www.tidbits.com/). 

Adam and Tonya are known in the Mac world 
as writers, editors, and speakers. They are also 
parents to Tristan, who thinks ebooks about 
clipper ships and castles would be cool. 

PRODUCTION CREDITS 
Take Control logo: Jeff Tolbert 

Cover design: Jon Hersh 

Editor in Chief and template master: Tonya Engst 

Publisher and grep automation master: Adam Engst 

Thanks to Sharon for her enthusiasm, detailed research, and excellent 
writing! 
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Copyright and Fine Print 
 

 
Take Control of Safari 4 

ISBN: 978-1-933671-66-6 
Copyright © Sharon Zardetto, 2009. All rights reserved. 

 

TidBITS Publishing Inc. 
50 Hickory Road 

Ithaca, NY 14850 USA 
http://www.takecontrolbooks.com/ 

 

Take Control electronic books help readers regain a measure of control in an oftentimes 
out-of-control universe. Take Control ebooks also streamline the publication process so 
that information about quickly changing technical topics can be published while it’s still 
relevant and accurate. 

This electronic book doesn’t use copy protection because copy protection makes life harder 
for everyone. So we ask a favor of our readers. If you want to share your copy of this ebook 
with a friend, please do so as you would a physical book, meaning that if your friend uses it 
regularly, he or she should buy a copy. Your support makes it possible for future Take 
Control ebooks to hit the Internet long before you’d find the same information in a printed 
book. Plus, if you buy the ebook, you’re entitled to any free updates that become available. 

Although the author and TidBITS Publishing Inc. have made a reasonable effort to ensure 
the accuracy of the information herein, they assume no responsibility for errors or 
omissions. The information in this ebook is distributed “As Is,” without warranty of any 
kind. Neither TidBITS Publishing Inc. nor the author shall be liable to any person or entity 
for any special, indirect, incidental, or consequential damages, including without 
limitation lost revenues or lost profits, that may result (or that are alleged to result) from 
the use of these materials. In other words, use this information at your own risk. 

Many of the designations used to distinguish products and services are claimed 
as trademarks or service marks. Any trademarks, service marks, product names, or named 
features that appear in this title are assumed to be the property of their respective owners. 
All product names and services are used in an editorial fashion only, with no intention of 
infringement of the trademark. No such use, or the use of any trade name, is meant to 
convey endorsement or other affiliation with this title. 

This title is an independent publication and has not been authorized, sponsored, 
or otherwise approved by Apple Inc. Because of the nature of this title, it uses terms that 
are trademarks or registered trademarks of Apple Inc.; to view a complete list of 
the trademarks and the registered trademarks of Apple Inc., you can visit 
http://www.apple.com/legal/trademark/appletmlist.html. 
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Featured Titles 
 
Now that you’ve seen this book, you know that Take Control books 
have an easy-to-read layout, clickable links if you read onscreen, 
and real-world info that puts you in control. Click any book title 
below or visit our Web catalog to add more ebooks to your Take 
Control collection! 

 
Take Control of Apple Mail in Leopard (Joe Kissell): Go under the 
hood with the new (and old) features in Apple Mail 3. Joe gets you 
going and helps you get the most out of Mail. $10 

Take Control of Easy Backups in Leopard (Joe Kissell): Devise a rock-
solid backup strategy so you can restore quickly and completely, no 
matter what the catastrophe. $10 

Take Control of Font Problems in Leopard (Sharon Zardetto): If you’re 
having mysterious font problems in Leopard, help is at hand! $10 

Take Control of Fonts in Leopard (Sharon Zardetto): Install, organize, 
and use fonts with ease in Leopard! $15 

Take Control of iWeb ’09 (Steve Sande): Learn how to work effectively 
and creatively in iWeb, and get help with using third-party hosts and 
custom domain names. $10 

Take Control of Passwords in Mac OS X (Joe Kissell): Create and 
manage strong passwords that keep your data safe without taxing your 
memory! $10 

Take Control: The Mac OS X Lexicon (Andy Baird and Sharon 
Zardetto): In this definitive guide, you’ll find over 500 of the most 
important Macintosh- and Internet-related terms. $15 

Take Control of the Mac Command Line with Terminal (Joe Kissell): 
Learn the basics of the Unix command line that underlies Mac OS X, 
and get comfortable and confident when working in Terminal. $10 
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