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Take Control ebooks help readers regain some measure of control in an oftentimes
out-of-control universe. Take Control ebooks also streamline the publication
process so information about quickly changing technical topics can be published
while it’s still relevant and accurate. Send comments about this, or any, Take
Control ebook to te-comments@tidbits.com.

This ebook does not use copy protection because copy protection makes life harder
for everyone. So we ask two favors of our readers. If you want to share your copy of
this ebook with a friend, please do so as you would a physical book, meaning that if
your friend uses it regularly, he or she should buy another copy. Or if someone has
given you a copy you find useful, please buy your own copy at
http://www.tidbits.com/takecontrol/—your support makes it possible for future
Take Control ebooks to hit the Internet long before you’d find the same
information in a printed book. Plus, if you buy the book, we will contact you should
we make a free update available.

Although the author and TidBITS Electronic Publishing have made a reasonable
effort to ensure the accuracy of the information herein, they assume no
responsibility for errors or omissions. The information in this ebook is distributed
“As Is,” without warranty of any kind. Neither TidBITS Electronic Publishing nor
the author shall be liable to any person or entity for any special, indirect,
incidental, or consequential damages, including without limitation lost revenues or
lost profits, that may result (or that are alleged to result) from the use of these
materials. In other words, use this information at your own risk.

Any trademarks, service marks, product names or named features that appear in
this ebook are assumed to be the property of their respective owners.
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Version 1.1 Changes

Version 1.0 of this ebook appeared one day after Panther itself went
public. The book was thus very timely, but the rush to publication
limited the depth of coverage that it could provide. Since then, lots of
folks (including myself) have had a chance to dive deeper into Panther
and gain more wisdom about the ways in which you can and should
customize Panther. This version 1.1 update of Take Control of
Customizing Panther draws upon that increased wisdom to help you
better direct your customization efforts. Here are the major changes:

« Updated and improved the Reading and Printing Tips section.
« Enhanced suggestions for how to customize Finder windows.
« Occasional changes in the Customize Exposé section.

« Modified the discussion of using Font Book to customize font menus
to provide more depth and a more task-focused approach.

« New sections about third-party utilities, display profiles, Internet
helper applications, the Classic menu, Services, Safari, and
Terminal.

« Occasional changes in the sections about the Keyboard Viewer and
about setting custom keyboard shortcuts.

« A new final section, written by Tonya Engst, lists customizations you
can make in System Preferences and Finder Preferences.

Note

If you printed the 1.0 edition of this ebook and now want to reprint
only significantly changed pages, we suggest you reprint the entire
book, omitting pages 7—9 (but note new info about Epson printer
drivers on page 8) and omitting page 50 to the end.

Future
Updates

TidBITS Electronic Publishing may publish minor updates to this
ebook to account for errata, software updates, new information, or
other reasons. Such updates will be offered at no extra charge; notifi-
cation will go to the email address you gave at the time of purchase.
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Reading and Printing Tips

We designed this ebook to be read online or printed. Here are a few
tips to help you get the most out of your reading experience.

Online reading tips:

(We're still learning the tricks for Panther’s Preview application, so
these are for Adobe Acrobat and Adobe Reader):

« In Adobe Acrobat 5, the Take Control default settings on the View
menu are Fit in Window and Continuous. For most people with
larger monitors, those should be fine. To focus only on reading, in
Acrobat 5, choose View > Full Screen, or in Acrobat 6, choose
Window > Full Screen View. (Press Esc to leave full screen mode.)

« Increase the size of the text by clicking the window’s Zoom button to
make the window as wide as possible, then choose View > Fit Width.

« To scroll using keyboard shortcuts, you must click in the main text
area before they will work. The Page Up and Page Down keys may be
the easiest (and they scroll by screen when you view less than a full
page). The Left and Right arrow keys scroll to the previous and next
page starts.

 Blue text indicates links. You can click any item in the Table of
Contents to jump to that section. Cross-references are also links, as
are URLs and email addresses.

« Work with the Bookmarks tab showing so you can always see and
jump to any main topic by clicking the associated bookmark.

Printing tips:

« In the unlikely even that Adobe Acrobat or Adobe Reader cannot
successfully print this PDF, try Apple’s Preview utility; several
readers have solved printing problems by trying Preview.

« When printing, if you prefer a tighter layout that uses fewer pages,
check your printer options for a 2-up feature that places two ebook
pages on one printed page. For instance, your Print dialog may have
an unlabeled pop-up menu that offers Layout as a choice. After you
choose Layout, choose 2 from the Pages per Sheet pop-up menu.
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Introduction

Perhaps on the evening of Friday, October 24, 2003, you stood in line
to obtain one of the first copies of Mac OS X version 10.3 Panther at
your local computer store. Or perhaps you were more cautious and
waited until you felt the inevitable initial kinks had been straightened
out. One way or another, you wound up with a copy of Panther. You
stayed up late installing it on your computer; then you fell asleep
exhausted. You woke up the next morning excited as a child on
Christmas. You rushed to the computer and gasped with delight at the
interesting Desktop icons, the weird Finder windows, the slick Exposé
animations, and the super-fast Help Viewer. You squealed with
amazement when you saw what Command-Tab did.

Now it’s the second day. You're finished playing and want to work.
You'd like to Take Control. And, in particular, you’d like to take control
of how your computer looks and behaves. But where to start? What, in
this brave new world, is up to you? What is it that needs customization,
so that things will go smoothly henceforward?

This ebook covers these second-day-of-Panther sorts of things. In
particular, it details ways you can customize your computer that were
impossible in previous versions of Mac OS X, and that might not be
obvious from a casual inspection.

Some customizations, of course, are fairly obvious to the experienced
user, especially if you examine the panes of System Preferences (panes
which, you’ll discover, have been renamed, rearranged, and
recombined in some rather startling ways). As you would expect, you
can choose a system beep sound, a Desktop background, a favorite
screensaver, a highlight color, and all the other simple furniture that
makes computer life feel more cozy and familiar and pleasing. This
book doesn’t delve into those deeply, but do consult Set Finder and
System Preferences for an extensive list of common customizations.

This is not a book intended to satisfy the Unix mavens. I don’t talk
about magic incantations you can perform in the Terminal or tricks
that require editing arcane config files. So, for instance, I don’t tell you
how to move your swapfiles to a different partition; that involves Unix
wizardry, and the way you do it hasn’t changed from earlier systems.
This ebook is about straightforward customizations that Panther allows
and expects you to perform.
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Customizing Panther Quick Start

This ebook mentions many customizations, not all of which you need
employ. To use this ebook effectively, I suggest you use a systematic
approach that differentiates between things you must customize before
you can work comfortably in Panther at all and things you can
customize later. Here is an overview of how I recommend you
customize your Panther installation:

Do these things right away:

Check that you customized your installation correctly for what you
want Panther to do for you; see Customize Your Installation.

Customize your Finder windows so you can navigate easily in the
Finder and in Open and Save dialogs to important areas of your
hard disk; see Customize Finder Windows.

Learn and configure Exposé, a new and exciting way to deal with
window overload; see Customize Exposé.

Customize which fonts appear in Font menus and Font palettes; see
Customize the Font Palette and Menu.

Update third-party utilities (such as DragThing or Default Folder X)
that you can’t live without. Also, use TinkerTool to set up double-
headed scroll arrows. See Restore (or Install) Third-Party Utilities.

Do these things as time permits or when the need arises:

Set up your display profile; see Configure Your Display Profile.

Configure your Internet helper applications so you can easily open
Web links in email, email links from your Web browser, and so on;
see Set Up Internet Helper Applications.

If you use Classic (that is, Mac OS 9 from within Mac OS X), turn on
and customize your Classic menu; see Set Up the Classic Menu.

Make the new Keyboard Viewer available from your menu bar; see
Enable Keyboard Viewer.

Create custom keyboard shortcuts for global actions like taking
screenshots and program-specific menu items; see Customize
Keyboard Shortcuts.

Perform other customizations, as described in this ebook: there’s
information about customizing Services, Open and Save dialogs,
Safari, Terminal, and the many Finder and system preferences.
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Customize Finder Windows

The Finder is arguably the single most important application on your
computer, because through its windows you see all your files and
folders. Customizing your Finder windows is therefore key to working
enjoyably and efficiently in Panther. Furthermore, the way you
customize your Finder windows has a profound effect on how your
Open and Save dialog boxes look, because the Open and Save dialog
boxes share the sidebar with the Finder (as you see in the next section,
Sidebar Basics).

Set Up the Default Finder Window

Let’s start with the simple matter of the size, position, and style of your
Finder windows. As in previous versions of Mac OS X, the way to set
the default appearance of your Finder windows is to make a new
window, arrange it as you like it, and then close it without doing
anything else.

Tip Open a default Finder window, as a basis for navigating your hard

disk, by choosing File > New Finder Window (Command-N).

Here’s how to proceed with customizing your Finder windows:
1. Open a default Finder window, as explained in the tip just above.

2. Adjust the window size by dragging its lower right corner. I prefer a
width just slightly narrower than the width of the monitor. The
reason I like this width is that my preferred view is column view,
and I want as many columns as I can get without sacrificing
legibility. I like the height to be less than half the height of my
monitor, so that I can open two Finder windows and see them both
at once without changing the height of either one.

3. Adjust the window’s position by dragging the title bar at the top. I
like it to occupy roughly the upper half of my monitor, so that if
open a second window I can just drag it down to the lower half in
order to see both at once.

4. Set the view (icons, list, or columns). If you choose column view,
then you should also set the width of the columns. To do so, Option-
drag the size widget at the bottom of a column. That’s important,
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Customize the Font Palette and Menu

Font management has always been a problem on the Mac, which is why
there have always been third-party font management utilities. The
main problem is that once you have more than a few fonts, Font menus
become long and unwieldy. Mac OS X aggravates the difficulty by
placing over two dozen fonts in the /System/Library/Fonts folder
that you’re not supposed to remove. Also, on Mac OS X, fonts can be
installed in any of four different places, which makes them hard to
keep track of.

If you suffer from too-long Font menus, or related font management
problems, you may wish to use Font Book, a new utility available in
Panther. You’ll find it in the Applications folder.

Font Book lets you customize what appears in your Font palette and
Font menu. Thus, you can keep lots of fonts installed for occasional use
without having them appear every day. Furthermore, Font Book lets
you clump your fonts into “collections”; these collections can be
enabled and disabled as a whole, and they appear in the Cocoa Font
palette, as way of accessing more quickly the fonts that they contain.
You can see in Figure 4 that I have lots of fonts, but only a few of
them, scattered sparsely through the list, are enabled. You can also see
that I've created several collections that categorize my fonts, and only a
few of these collections are enabled.

Figure 4 re ala) Font Book |
Qearh
Collection Font ] lF't :!
p ‘A All Fonts p Helvetica . |4 It .
: | ABCDEFGHIJKLM
o gl - or . NOPQRSTUVWXYZ
= Lioe i m abcdefghijkim
i iHDeHer lText . “ nopq rStUVWXYZ
e 1234567890
b Lucida Grande : {i)
LLEJ |E | Disable ] 77 Fonts Helvetica Meue R;zgular. 28.1 pt. %

Font Book, as customized on my machine.
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About the Author

Matt Neuburg is a former Classics professor. One of his students, to
whom he tried to teach the fine art of composing Greek sentences, was
Adam Engst, who later went on to publish TidBITS. Matt eventually
left academe and became a TidBITS Contributing Editor, writing
reviews of software such as outliners and databases.

He is also a consultant and programmer, and has written three books
for O’Reilly & Associates: Frontier: The Definitive Guide, REALbasic:
The Definitive Guide, and AppleScript: The Definitive Guide. He lives
in the village of Ojai, California, which he regards as all but
indistinguishable from Paradise.

Matt’s home page: hitp://www.tidbits.com/matt/
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Take Control of Panther: The Series

Take control of computing with the Take Control series of highly
practical, tightly focused electronic books! Written by leading
Macintosh authors, edited by TidBITS Electronic Publishing, and
delivered to your electronic doorstep within moments of “going to
press,” Take Control ebooks provide the technical help you need.
http://www.tidbits.com/takecontrol/

Other available Take Control ebooks:

Take Control of Upgrading to Panther, by Joe Kissell
http://www.tidbits.com/takecontrol/panther/upgrading.html

Additional ebooks planned for release in 2003 include:
Take Control of Users & Accounts in Panther

Take Control of Sharing Files in Panther

Take Control of .Mac

With your support, we plan to publish a number of additional ebooks
in early 2004.
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Shameless Plug

One extremely powerful way to customize
your computer is with AppleScript, a r=r-
system-level language that can make : .
applications do things programmatically. PISEHP
Instead of your doing something with the P Y
mouse, then reading the screen, then
thinking about what this means and what
you should do next, and so forth, the
computer does the doing, the reading, and
the thinking. This means that your hands
and eyes and brain are freed from having to
perform repetitive or tiresome activities
better suited to the computer itself. Lengthy operations can be reduced
to a single step, and applications can be made to work together. You
can also use AppleScript to customize such things as what happens
when a file is placed into a certain folder in the Finder, or what your
computer does when a music CD is inserted.

TidBITS Electronic Publishing will probably publish one or more Take
Control ebooks about AppleScript in the future, but for the full story
you might wish to obtain my new book, AppleScript: The Definitive
Guide, from O’Reilly & Associates.
http://www.oreilly.com/catalog/applescpttdg/
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About TidBITS Electronic Publishing

Take Control ebooks are a project of TidBITS Electronic Publishing.
TidBITS Electronic Publishing has been publishing online since 1990
when publishers Adam and Tonya Engst first created their online
newsletter, TidBITS, about Macintosh and Internet-related topics.
TidBITS has been in continuous, weekly production since then, and it
is the leading online Macintosh newsletter.

To stay up to date on Mac OS X 10.3 Panther and other Macintosh
topics, be sure to read TidBITS each week. At the TidBITS Web site you
can subscribe to TidBITS for free, participate in TidBITS Talk
discussions, or search 13 years of news, reviews, and editorial analysis.

Adam and Tonya are well-known in the Macintosh world as writers,
editors, and speakers, and they have written innumerable online and
print publications. They are also parents to Tristan, who is almost five
and thinks ebooks about trains, clipper ships, and dinosaurs would be
cool.

| [ BITS it

TidBITS Web site: hitp://www.tidbits.com/

Adam’s home page: http://www.tidbits.com/adam/

Tonya’s home page: hitp://www.tidbits.com/tonya/
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