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Read Me First 
This ebook was published in May 2015 by TidBITS Publishing Inc. It was written by
Jason Snell and edited by Kelly Turner. 
This book helps you get started with Apple’s Photos app, introduced in 2015 to
replace iPhoto and Aperture. It focuses on importing libraries from older apps, 
managing your media inside Photos, and using Photos to edit and share your media
with friends, relatives, and the world at large. 
Photos for Mac: A Take Control Crash Course, version 1.1 
Copyright © 2015, The Incomparable Inc. All rights reserved. 

Formats and Updates
• Use the link in Ebook Extras, near

the end, to download the latest 
version of the ebook in PDF, EPUB,
or Mobipocket format. 

• If you downloaded this ebook from
the Take Control Web site, it has
been added to your account. If you
bought it elsewhere, you can add
it to your account; see Registering
Your Ebook. 

Tip: You can read about putting Take
Control ebooks on various devices and 
computers on our Device Advice page. 

About the Links 
Some links in this ebook, like the
“Device Advice” link just above, take
you to a Web page. Other links, such 
as “Ebook Extras” higher up, jump you 
to a different part of the book. 
If you click a link that takes you to a dif-
ferent part of the book, you can return
quickly to your previous spot if your
ebook reader offers a “back” feature. 
For example, if you use iBooks to read
the EPUB version of this book, click
the “Back to” link at the lower left. Or, 
if you use Preview on the Mac to read 
the PDF version, choose Go > Back or 
press ⌘-[. 

Sharing a Chapter 
✦ We encourage you to share any chap-

ter with someone who would benefit 
from the info—sharing is entirely free. 

✦ Each chapter ends with special link
buttons for sharing via Twitter, Face-
book, Google+, LinkedIn, and email. 

✦ Click the desired button to share a 
Web link to that chapter. For Twitter
and LinkedIn, the suggested text
includes a useful tip. 

Commenting on a Chapter 
✦ Click the Disqus icon at the end of 

a chapter to view the Web version and
enter your comment or question. 

✦ You can read and reply to other com-
ments there as well. 

✦ The author may not reply to every
comment or question, but we will
read everything and use the com-
ments to identify areas of confusion.
If a chapter worked especially well 
for you, let us know about that, too. 

✦ Unhelpful comments will be deleted. 

Note: For help with menus, paths, and
other basic topics, check out Read Me 
First: A Take Control Crash Course, 
available for free on the Web or as a 
standalone ebook in PDF, EPUB, and
the Kindle’s Mobipocket format. 
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Introduction
In 2002, Apple introduced iPhoto as a way for us to save our photos on our Macs 
inside a “digital shoebox.” At the time, I’d owned a digital camera for three months, 
and had only a few hundred digital images. Over the years, as my photo library grew, 
Apple revised iPhoto, always trying to stay in front of the onslaught of thousands of 
digital photos accumulated over a lifetime—at least the lifetime of my two children.

By 2014, enough was more than enough. Apple decided it needed to start from 
scratch and ditch both iPhoto and the professional-level photo tool it had introduced 
in 2005, Aperture. It chose to replace them both with a single application, which 
would be called—in the prosaic style favored by Apple for its iOS apps—Photos.

This book is about Photos for Mac, but the ghosts of iPhoto and Aperture hang over 
it. Mac users have spent years in those programs, cataloging priceless collections of 
images and videos accumulated over decades. Photos looks quite different from 
iPhoto, although its approach resembles its predecessor in many ways. And both are 
miles away—in both looks and capabilities—from Aperture.

In this book, I’ll describe how to perform most of the tasks you’ll want to do with 
Photos. No previous knowledge of iPhoto or Aperture is required, though I will walk 
you through the migration process from both apps and show you where the stuff in 
those programs ends up—if anywhere—in Photos.

One of the most exciting features of Photos is its embrace of cloud services. For 
the first time, you can keep your entire photo library in the cloud rather than on 
your drive. (It’s up to you to decide whether you want to embrace the cloud to that 
degree.) The connection between iOS and the Mac has also never been stronger.

But of course, there are also some changes that won’t be as welcome. Some features 
many people came to rely on in iPhoto and Aperture are gone. I hope some of them 
will come back one day—after all, this first version of Photos is just the beginning.

My daughter, born late in 2001, is about to enter high school. Her entire life has been 
chronicled with digital photos—tens of thousands of them at this point. I used iPhoto 
to catalog her childhood. Now that catalog resides in Photos. Photography is how we 
preserve the images of our lives; it’s important that we understand the software that 
allows us to organize, view, and share those images. That’s what this book is for.

The version of the book you have in your hands is an update to the 1.0 version, which 
was short and meant to be just enough to get you started with Photos for Mac. Now, 
with version 1.1, I’ve written a complete book with the early chapters refreshed with 
post-beta info and the later chapters added. Thank you to the many 1.0 readers who 
offered valuable feedback and helped shape this book.

Thanks for joining me on this journey. Let’s get started!
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Photos Quick Start 
This book explores Apple’s new Photos app by walking you though the most
essential photo-management and editing tasks. You can read the chapters in any
order. Click any link to jump to a topic. 

Know Your Options
The new Photos app will feel familiar to
iPhoto users. Aperture users, however,
will likely feel less at home. See how
Photos stacks up to both programs in
Photos vs. iPhoto and Aperture. 

Import Photos
•	 From iPhoto: Make a smooth transi-

tion to Photos and discover the 
beauty of hard links in Import from
iPhoto into Photos. 

•	 From Aperture: See which features 
make the move and which get left
behind when you Import from Aper-
ture into Photos. 

• From your Mac: Photos can import
files directly from your camera, but
if you need to edit the files before 
handing them off to Photos, it may
make sense to use Image Capture
instead. Read Import Your Files into
Photos. 

•	 From multiple libraries: You can 
easily switch between libraries to
keep different collections separate.
See Use Multiple Photos Libraries. 

Find Your Bearings
• Learn to quickly navigate a Photos

library with the button bar. Or open
the sidebar for a more iPhoto-like 
view. See Navigate the Photos
Interface. 

• Appreciate how important the
Search field is for finding photos
based on keyword, location, and
more in the sidebar Search: Use It!. 

• Understand (and turn off or on) the
small icons that may overlay your
photos. Read the sidebar Metadata 
Mania. 

Get Organized
•	 Add metadata: No one knows your

photos better than you do. Make
them easier to find later by applying
keywords, identifying faces, and
marking Favorites. Read Add Info 
about Your Photos. 

•	 Build albums: Photos organizes your
library by date. If you have other
ideas, you can create collections in
the Albums pane. See Make Albums 
in Photos. 

•	 Create smart albums: Want to quick-
ly round up all the photos of your
kids taken with your DSLR within the
last year? No problem. Learn how to
take advantage of all your valuable
metadata in Define Smart Albums in 
Photos. 

Perfect Your Photos 
•	 Quick-fix options: Give photos a lit-

tle extra “pop” by cropping, applying
filters, and fixing red-eye and rota-
tion problems. See Process Your 
Photos. 

•	 Advanced editing: For more serious 
image problems, learn how Edit 
Your Photos by removing blemishes
and other unwanted details and ap-
plying adjustments. 

• For a pointer on editing raw images,
read Raw vs. JPEG, in “The Photos
Grab Bag” chapter. 
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Connect with Other Devices 
•	 iCloud Photo Library: Thanks to the 

cloud, you can access your entire
Photos library from any device you
own. But you’ll need to change the
way you think about managing your
photos. Read Sync with iCloud Using
Photos. 

•	 iOS devices: Whether you use the
cloud or a sync cable, you can Work 
with Photos in iOS. 

•	 Apple TV: Admire your favorite pho-
tos on your big-screen TV when you
View Photos on Apple TV. 

Show Off Your Photos 
•	 Social media: Don’t let your photos

stay locked up on your Mac. Learn
the easiest ways to Share Your Pho-
tos on Facebook, Twitter, Flickr, and 
more. 

•	 Export: If your desired method of
sharing your photos involves getting
them out of Photos, you can Export
and Resize Images. 

•	 Slideshows: Turn a special event’s
photos into a beautiful movie with
its own soundtrack. See Make 
Slideshows in Photos. 

•	 Printed projects: For all the conve-
nience of digital photos, there’s still
nothing quite like holding an image
of loved ones in your hands. Discov-
er how to Make Books, Calendars,
and Cards and Make Photographic
Prints. 
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Photos vs. iPhoto and Aperture 
When you compare the features of Photos to those of iPhoto, it’s easy to see that,
in most ways, Photos is a reincarnation of iPhoto. A few organizational features have 
been lost, the interface is more refined, deep connections to iCloud have been
added, and the entire app feels faster. 
But not long after introducing Photos, Apple announced that it also was ceasing
development of its professional photography app, Aperture, and that Photos would
be a suitable replacement ① (see my Macworld article). Based on the initial version
of Photos, however, this doesn’t seem to be the case. Photo hobbyists who used 
Aperture despite not needing most of its features might not mind the omissions, but
professional users should probably start considering other options, such as Adobe’s
Lightroom. 

If you’re used to iPhoto, Photos won’t
be that jarring. Photos can import your
iPhoto library (see Import from iPhoto
into Photos) and retains most, but not
all, of the features of iPhoto. Star ratings
have been demoted to keyword status,
flagged items are now Favorites, and
iPhoto Events are now just another kind
of photo album. But with the optional
sidebar displayed in Photos, you’d
think you were using a slick new version
of iPhoto. 
There are new features, to be sure, in-
cluding modified and expanded edit-
ing tools and more direct integration
with iCloud, but with a little time, iPhoto
users should be able to settle in com-
fortably. 

① iPhoto and Aperture have been discontinued. Apple intends Photos to be their replacement. 

Coming from iPhoto A Farewell to Apps 
Apple’s announcement specified that
iPhoto and Aperture would both be
updated for compatibility with OS X
Yosemite, but that’s it. 
Not to be a negative nelly, but you
shouldn’t hold out hope that Apple will
reconsider its decision. Both apps will
probably still work for a while yet, but
updates are extremely unlikely. 
If Photos doesn’t float your boat and
you’re an Aperture user, you might con-
sider Adobe’s Lightroom. It’s tightly inte-
grated with Photoshop and available
as part of Adobe’s Photography bundle,
which as of this writing costs $120 per
year, and offers cloud features of its 
own. You can download a free 30-day
trial to give it a spin. 
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Coming from Aperture
I'm not much of an Aperture user. I
use it mostly to capture images on the 
fly directly from my Canon DSLR . I’ve
built an entire workflow around shoot-
ing Apple events: resizing the images
to Web resolutions, applying a water-
mark, and saving the result out as
JPEGs to be uploaded to a server. 
Could I do that same task in Photos? 
It doesn’t support tethered shooting, 
exporting multiple versions with differ-
ent image-quality levels, or watermarks.
And the differences certainly don’t end
there. Photos doesn’t support the con-
cept of separate projects inside a single
library. And star ratings and color labels
are imported as keywords. 
Photos also doesn’t support plug-ins
or editing in an external editor—both 
key features of Aperture. And Photos’
editing features, while solid, don’t
match Aperture’s. For example, Photos
doesn’t offer an adjustment brush to
selectively apply an edit to the image. 
If you use Aperture because it’s more
than iPhoto, but haven’t availed your-
self of most of its features, you may find
Photos sufficient (see Import from
Aperture into Photos). But if you rely
on any Aperture features that Photos 
doesn’t support, prepare for disap-
pointment. 
Now the good news: Some Aperture
features (like the Split view, which I use
all the time) are available in Photos ②. 
And Photos will import your Aperture
libraries, though your projects will turn
into folders in the Albums section. 
If you try Photos and decide it’s not for
you, your Aperture libraries will still be
there, unharmed. So there’s no risk in
giving Photos a spin. 

The Optimistic View 
Apple has a habit of killing its apps and
replacing them with new ones that re-
semble the old only in passing. Perhaps
most controversial was the radical re-
design of Final Cut Pro X. 
At the time, Final Cut Pro users were 
furious that the new version didn’t offer 
numerous features that they relied on.
Apple’s response was to say that the old
Final Cut Pro would continue to work for 
quite some time, and in the meantime
the company would try to add as many
of those features to Final Cut Pro X as 
possible. 
Today, even the most ardent Final Cut
Pro X critic would have to admit that 
Apple has added back a large number
of key features that weren’t present in
the first version. 
When Apple announced Photos, it
strongly indicated that it would be able
to serve Aperture users, too. Does that
mean future updates will add Aperture
features? There are no guarantees, but
at least there’s hope. 

② Split view in Photos is similar to what you’d
see in Aperture, but not quite the same. 

Share this tip and chapter on 
“Unfortunately, Photos for Mac has no selective-editing features in the

style of Aperture’s adjustment brush.” 

Discuss “Photos vs. iPhoto and Aperture” via 
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Import Your Files into Photos 
While iCloud can add all the photos you take on your iOS devices to Photos automati-
cally (see Sync with iCloud Using Photos), the most traditional way of adding items to
a Photos library is by connecting a camera directly ①. If you want to exert ultimate
control over your media collection, you can also manually import photos from your
drive—an approach that offers a lot more flexibility. (If you’re looking for information
about importing an entire library into Photos, see Import from iPhoto into Photos and 
Import from Aperture into Photos.) 

① When you attach a camera or insert a memory card, Photos displays its contents in the Import pane. 

Decide on a Workflow 
You’ll need to decide whether to im-
port photos directly into Photos from
your camera (usually via USB) or first
import them using Apple’s Image Cap-
ture app and then add them to Photos. 
If you plan to modify your images in 
some way before Photos ingests them,
or if you’d prefer to manually manage
where your files are stored, you should
use the second approach. (For reasons
why you’d want to modify your images
before importing them, read Importing
from Disk, later in this chapter.) 

Using Image Capture 
The Image Capture app is a great alter-
native to importing your files directly
into Photos. Once the files are imported,
you can modify and arrange them, and
then add them to Photos using the
File > Import command in Photos. 
To make Image Capture the default app
for a device or memory card, open Im-
age Capture, select the card or device
under Devices, and click the disclosure
triangle at the bottom left. Choose 
Image Capture from the Connecting
This Device Opens menu. 
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Importing from a Camera
If you’re shooting photos (or capturing
video) with a standalone camera, or
with an iOS device that isn’t syncing
with iCloud, you’ll get your files into
Photos by attaching the device or its
memory card to your Mac. 
The process is automatic. When you
attach a device that your Mac registers
as one containing photos and/or
videos, the Import pane (or Import sec-
tion of the sidebar) appears, ready to
gobble your media files. 

Photos Eliminates Redundancy
When you attach a device, Photos scans
its contents and compares them to its
current library. If Photos finds the same
images in both places, it collects these
items at the very top of the Import
pane, marked as Already Imported ②. 
Below that, it shows photos that aren’t
yet in the library, labeled as New Items. 

Select Photos to Import
In most cases, you’ll want to click Im-
port All New Items. But to import only
certain items, you can click to select
those items—your selections are indicat-
ed by a dimmed image with a blue
checkbox in the lower-right corner ③— 
and import them by clicking the Import
Number Selected button ④. 
Photos can automatically delete what
you’ve just imported and free up space
on your memory card or device. Select
the Delete Items after Import checkbox
in the Import pane. This saves you a
step, but adds some risk in the case of
a corrupted import. (I haven’t seen one 
of those in years, though.) 

Tip: Select Open Photos for This Device
if you want Photos to open every time
you attach that particular device;
uncheck it if you’re annoyed by the app
launching when you plug in the device. 

② Photos doesn’t want to waste your time with
items you’ve already imported into its library. 

③ Items selected for import are dimmed and
sport blue checkboxes. 

④ Click the button on the left to import only
selected images. 

Synchronize Watches… Go! 
You can batch-adjust the date and time
of images you’ve imported into Photos
by choosing Image > Adjust Date and
Time. If you have images from cameras
whose clocks weren’t quite synchro-
nized, this tool can help put the images
back in proper order. 
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Importing from Disk
To add files to the Photos library that
are already on your Mac, drag them
directly into the Photos pane or choose
File > Import. 
If you’ve set the sidebar to be visible
by choosing View > Show Sidebar, you 
can see the results of your file import
by selecting Last Import in the Albums 
section of the sidebar. 

Editing before Importing
If you want to edit photos using a
separate app, such as Photoshop, it’s
easier if you do it before importing
it into Photos. Photos lets you copy and 
paste adjustments only one at a time,
so if you want to apply a specific effect
to a whole bunch of images, you may 
prefer to use an external tool. 

Adding Location Data
Photos lacks support for editing the
EXIF data that rides along with every
image you take, detailing the camera
settings and where an image was taken. 
If you shoot photos with a digital
camera that doesn’t have GPS features,
those images won’t have location data
attached to them—and while Photos can 
display location data, it won’t let you 
add it in after the fact. 

Tip: Many Mac and iOS apps let you
geotag photos after the fact and even
use your iPhone as a GPS logger. Check 
out Geotag Photos and HoudahGeo, or
search the Mac App Store. 

Manage Files Yourself 
By default, Photos imports all your files
inside the Photos Library, essentially
outside of your control. 
If you don’t like the idea of submitting to
Photos and letting it control everything
for you, you can manage your media the
old fashioned way—in the Finder. 
To do this, choose Photos >
Preferences > General, and uncheck 
the “Copy items to the Photos library” 
option. If you leave this option turned
off, Photos will respect your location
preferences. 
Photos marks images imported by this
means with a small icon—of an arrow 
coming out of a box—in the bottom left 
corner ⑤. 

⑤ A user-managed image (left) has a white
box and an arrow in the bottom-left corner. 
If Photos can’t find that file, the white box 
turns into a yellow alert symbol (right). 

All edits you make to the photo will be
stored inside the Photos library, but if
you delete the original file in the Finder,
Photos won’t let you edit that file again.
So all the responsibility for managing
your files is up to you. 
User-managed files also won’t sync to
iCloud. You can copy selected files into
the Photos library by choosing File > 
Consolidate. 

Share this tip and chapter on 
“If you’re adding location data to photos from a digital camera, do that

before importing them into Photos for Mac.” 

Discuss “Import Your Files into Photos” via 
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About This Book 
We hope that you found this book both useful and enjoyable to read. We welcome 
your comments and questions in individual chapters. You can also send us email. 

Ebook Extras 
You can access extras related to this 
ebook on the Web. Once you’re on the 
ebook’s Take Control Extras page, you 
can: 
• Download any available new version

of the ebook for free, or buy a subse-
quent edition at a discount. 

• Download various formats, including
PDF, EPUB, and Mobipocket. (Learn
about reading on mobile devices on 
our Device Advice page.) 

• Read postings to the ebook’s blog.
These may include new information
and tips, as well as links to author
interviews. At the top of the blog,
you can also see any update plans
for the ebook. 

Registering Your Ebook
If you bought this ebook from the Take
Control Web site, it has been automati-
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